ARTICULATE STORYLINE®
Working with States, Triggers, and Layers ................................................................. 351
  Adding and Editing States ......................................................................................... 352
  Adding and Editing Triggers ...................................................................................... 361
  Adding and Editing Slide Layers .............................................................................. 367
Applying Animations and Slide Transitions ............................................................ 375
  Adding Entrance and Exit Animations to an Object ................................................. 376
  Syncing Animations .................................................................................................. 379
  Adding Transitions to Slides and Slide Layers ........................................................ 384
Customizing Your Project Design .......................................................................... 386
  Using Themes ........................................................................................................... 387
    Working with Theme Colors .................................................................................. 390
    Working with Theme Fonts ................................................................................... 397
  Applying a Background Design .............................................................................. 403
  Using Slide Masters .................................................................................................. 407
  Using Feedback Masters ......................................................................................... 418
Working with Variables ........................................................................................... 430
  Adding True/False Variables .................................................................................... 432
  Adding Text Variables ............................................................................................... 435
  Adding Number Variables ......................................................................................... 439
  Building a Simple Counter ....................................................................................... 448
  Evaluating Text Variables ....................................................................................... 452
Inserting and Customizing Quiz Slides .................................................................... 456
  Adding Graded Questions and Survey Questions .................................................. 457
  Adding Freeform Quiz Questions ............................................................................. 466
    Drag and Drop ....................................................................................................... 467
    Pick One ................................................................................................................ 480
    Pick Many ............................................................................................................. 490
    Text Entry .............................................................................................................. 500
    Hotspot ................................................................................................................. 509
    Shortcut Key ......................................................................................................... 521
  Using Question Banks ............................................................................................. 528
    Creating and Editing Question Banks .................................................................. 529
    Drawing from Question Banks ............................................................................. 540
  Adding Result Slides ............................................................................................... 548
    Limiting Quiz Attempts ......................................................................................... 555
    Submitting Answers All at Once .......................................................................... 558
    Confirming That Users Are Ready to Submit Their Answers ................................ 562
Importing Content from Other Sources .................................................................. 564
  Importing from PowerPoint ...................................................................................... 565
  Importing from Articulate Quizmaker .................................................................... 569
Articulate Storyline

Welcome to Articulate Storyline! Storyline is a powerful standalone tool with unparalleled interactivity features that will help you build dynamic, engaging content—including simulations, screen recordings, drag-and-drop interactions, click-and-reveal activities, quizzes and assessments, and much more.

If you're new to Storyline, we recommend beginning with the section of tutorials called Getting Started with Articulate Storyline.

For a deeper dive into a specific feature or topic, check out the other Articulate Storyline tutorials in the following categories:

- Beginning a New Storyline Project
- Inserting and Customizing Slide Content
- Inserting and Customizing Media
- Inserting and Customizing Screen Recordings
- Inserting and Customizing Interactivity
- Working with States, Triggers, and Layers
- Applying Animations and Slide Transitions
- Customizing Your Project Design
- Working with Variables
- Inserting and Customizing Quiz Slides
- Importing Content from Other Sources
- Customizing the Storyline Player
- Previewing and Publishing Your Project
- Helpful Storyline Tools and Options

If you've got questions that aren't answered here in the tutorials, no worries—you can always tap into the superpowers of the Articulate community by asking your question in the community forums. You'll find thousands of other Articulate users and staff there who can help you out.
Getting Started with Articulate Storyline

To help you get started using Articulate Storyline we created a series of beginner tutorials that will walk you through creating your first slide and then using many of the most common features. They'll help you get up and running quickly. They're not exhaustive tutorials, but they do cover the basics.

- Overview of Storyline to become familiar with the interface
- **Create your first slide & add some content to it**
- **Learn to build interactive content by creating a simple scenario and drag & drop interaction**
- **Build and edit quiz questions and learn to create a result slide to track quiz results**
- **Record screencasts and create interactive software simulations**
- **Customize the Storyline player using the player editor**
- **Publish your courses to Flash, HTML5, and for the iPad**

Each tutorial includes a video screencast and some practice activities for you to follow along. If you want more specific detail, then visit the other tutorial categories listed on the previous page. If you have a question, feel free to jump into the community forums and ask. We're eager to help you get started!

**Overview of Articulate Storyline**

Watch the video below for a quick overview of Articulate Storyline. You'll become familiar with the layout and how to locate common features. When you're ready to build that first slide, click on one of the tutorial links above.

![ARTICULATE STORYLINE](image)

You can always get more detail about Storyline and its features in the product tutorials on the previous page. For now, if you're ready to get started, check out this tutorial on **how to create your first slide and add content to it**.
Add Content to Your Slides

Building courses in Storyline is a combination of adding content to the slide and then creating interactive elements. In the previous tutorial we did a quick overview of the Storyline interface. In this section we'll go through three simple tutorials where we'll add content to the screen, synchronize animations to audio, and import a PowerPoint file.

These three tutorials will expose you to some of the types of tasks you'll do when you first get started. You'll learn to use many of the core features.

Here's a folder with some practice files (13MB) that you can use with the tutorials.

• Create Your First Slide
• Sync Animations with Audio
• Import PowerPoint Slides
Create Your First Slide

In this tutorial we'll look at how to add content to your slides and you'll get to practice using some of the other common features.

Most of your work in Storyline will happen at the Insert tab. As you can see in the image below, you can insert slides; static content like pictures, videos, and text; and you can insert interactive elements.

In this series of tutorials we'll focus on the non-interactive elements. We'll look at interactive content in the next tutorial.
Watch the video first and then follow the steps below to practice.

Practice Activity
Here's a folder with some practice files for you to download.

We'll get started by building a simple slide that includes some text, pictures and shapes. You'll build a screen like the one you see below.
• Insert a new slide and select the blank slide layout from the Basic Layouts tab.
• Go to the Insert Tab. Add a picture to the slide.
• Use the text box to add a title: New Hire Orientation
• Use the text box to add some body text. **NOTE:** You can add placeholder text by typing =lorem()

We’ll assume that this is the starting screen of a course with three sections.

• Add a shape for each section.
• Add some text to each shape: Section 1, Section 2, and Section 3.
• Select the first shape. Increase the font size and apply a gradient shape style under the Format tab.
• Go to the Home tab. Use the Format Painter to apply the same format from the first shape to the other two.

![Apply format using Format Painter](image)

• Go to the Design tab. Apply a design theme to the slide. Add a new theme color.

![Apply design theme & colors](image)

• Review the timeline and add titles to the objects on the timeline so that they're easy to identify.
At this point the slide you built is fairly simple. But in the process you learned to insert and edit some of the basic content. You also learned to use the format painter and to apply design themes.

In the next tutorial we’ll learn to use the timeline to sync animations to the audio.
Sync Animations with Audio

In the previous tutorial we learned how to create a slide and add some basic content like text and shapes. We'll build on that in this tutorial.

We’ll again start with a blank slide. This lets you practice a little of what we learned in the first tutorial. We’ll add a picture and create projection screen with some text on it. Then we’ll add animations to the text. After that, we’ll record some audio and learn to sync it to the animated text.

Ready to get started?

Watch the video first and then follow the steps below to practice.

Practice Activity

Download the practice file here.

Create the slide and add a character.

- Insert a new slide. Select the blank layout.
- Go to the Design tab. Apply a new design theme. Use one of the gradient backgrounds.
- Go to the Home tab. Add a rectangle to the screen to create a horizon line.
- Right-click the rectangle and select Format Shape.
• Fill: set to 50% transparent.
• Line color: select no line color.
• Add a photographic character that's pointing to the screen.

Create the white board and text.

• Add a rectangle to the slide to create a whiteboard.
• Apply a white background quick style to the rectangle.
• You should have a screen that looks kind of like the one below.
Review the timeline.
Look at the timeline and notice the objects on the timeline. You can slide them left or right to change when they come in and out. You can also change the layering position by moving them up and down.

We’re going to record an audio track and then we’ll add some animation to the text box. After that we can sync the audio to the animated text.

- Add some placeholder text by typing \lorem(). The placeholder text should consist of three paragraphs.
- Let’s add a fly-in animation to the text. Select the text box.
- On the Animations tab, select Entrance Animations, Fly In (by first level paragraph). This will set the paragraphs to animate in individually.
- Go to the timeline, the text box now has a little arrow next to it. When you click the arrow, it expands the title box and shows each individual paragraph of text.
- Slide the individual paragraphs to different points on the timeline to control when they animate in and then Preview.

Record audio narration.
We’ll record some quick audio and then sync the three paragraphs to the audio.

- Go to Insert tab. Select Sound and then select Record Mic. Record something simple like this text: "This is paragraph one. It is very interesting. This is paragraph two. It is shorter. This is paragraph three."
- You should see the audio track on the timeline.
Add Cue Points to the timeline.
Now we’ll add some **Cue Points** to the timeline so it’s easy to sync the animations to the audio.

- Play the audio and set a Cue Point at the beginning of each sentence. You do this by **pressing the C key** where you want a Cue Point. Don’t worry about being perfect because you can always move them around later. Each time you hit the C key, you’ll see a Cue Point added to the timeline.
- Now we’ll move the paragraphs along the timeline to the individual Cue Points. You can slide them to the cues, or right click and **Align to Cue Point**.
- When you’re done, preview the slide. You should hear the audio and see the text animate in on cue.

That's basically it when it comes to syncing animations to your audio. Any objects you add to the screen can be moved along the timeline to create an entrance and exit point. And from the animation tab you can add entrance and exit animations.

Again, this was a simple demo. But in this exercise you learned to add and edit content like text, shapes and photo characters. You also learned to use the timeline and how to sync animations to audio on the timeline using the Cue Points. Now go ahead and practice animating objects on and off the screen.

In the next tutorial, we’ll **import a PowerPoint file**.
Import PowerPoint Slides

Odds are that you already have some content that was created in PowerPoint. Importing those slides into Storyline is super simple. And then once they’re in your project you can work with them the same you would any other slides.

In this tutorial we’ll import a few PowerPoint slides and then we’ll make some edits to the slides. In this case, the starting PowerPoint file has a video and web object from a previous Articulate Studio course.

Watch the video first and then follow the steps below to practice.

Practice Activity

Ok...let’s get started. Here are some assets you can download to follow along and practice.

- Create a new Storyline project.
- Add a New Slide and select the Import tab. Select PowerPoint and locate the practice PowerPoint file. Import the three slides from the practice PowerPoint file.
- Review what was imported.
  - You’ll notice that after you import the slides the objects on the screen are editable. Text boxes in PowerPoint slides become text boxes in Storyline. And the same happens to shapes and pictures. That means they’re all editable just like they would be if you inserted them on slide without importing from PowerPoint.
  - The slides with video and web object also work as they should. NOTE: web objects won’t display until published.
  - If you look at the slide layouts and the option available in the Design tab, you’ll see that the master template design from PowerPoint was added. What was once PowerPoint is now all Storyline.
In the Notes tab, you'll see that the slide notes are there. And when you go the slides that had video and a web object, those are also available to you.

As you can see, the import of the PowerPoint content was pretty seamless. Go ahead and edit some of the content:

- Change the text size and color.
- Change the shape and color.
- Move things around.

**What to watch out for when importing PowerPoint slides.**

The import process for PowerPoint is simple and straightforward. However they are two different applications and there are some things to consider when importing PowerPoint. Here are a few items based on the practice file:

- Review the navigation for imported slides to make sure they behave the way you want.
- PowerPoint is linear so it will import a "Jump to next side" trigger. You'll need to remove that or edit it.

PowerPoint's hyperlinks come in with the objects. But you may want to convert the hyperlink shape to a button. Here's how:

- Go to the Insert tab and insert a button. Apply a format to it.
- Go to the Home tab and double-click the format painter.
- Apply the button format to the PowerPoint shapes with hyperlinks. That's a simple way to convert the PowerPoint shapes that have hyperlinks to buttons.

You can review these tutorials and knowledge base articles for more information on importing PowerPoint slides.

To sum it up, we started with a PowerPoint file that included three slides with video and a web object. After importing we were able to edit the slide contents and quickly convert the hyperlink objects to interactive buttons.

That's it for this series on adding content to your slides. Now it’s up to you to get started. Practice by building on what we started here. And you’ll be on your way to becoming a Storyline guru.

In the next tutorial we'll look at [building interactive content in Storyline](https://www.learntorun.com/).
Create Interactive Slides

In the previous tutorials we looked at how to add simple content like pictures, text, and video to the slides. And we learned how to synchronize animations to an audio track.

In this tutorial we'll practice creating interactive content in Articulate Storyline.

Storyline comes with some pre-built interactive elements like the buttons and markers. It allows all sorts of custom interactivity like drag & drops, mouse overs and the use of variables. Since this is a getting started tutorial, we'll keep it kind of simple.

We'll explore the essential authoring process in Storyline that lets you build interactive content. Once we cover that, we'll practice using the authoring features to:

- **Build an Interactive Scenario**
- **Label an Image with Interactive Markers**
- **Create a Drag & Drop Interaction**

These are all basic demos but they'll help you get started and are easy enough to practice on your own. Download this folder to use when you practice these activities.

**Understanding States, Slide Layers, and Triggers**

To build interactive content requires that you understand the essential authoring process in Storyline; and that all happens with the States, Layers, and Triggers.

**What you need to know about States:**

Any object you put on the slide can have multiple states. To change states from one to the other requires an action that triggers it.
For example, buttons typically have a normal state. And when you hover the mouse over the button the state changes to look different. And then when you click on the button it changes again. In this example, you have three states:

- **Normal** - what it looks like before you do anything
- **Hover** - what it looks like when you move your mouse over it
- **Down** - what it looks like when you click on it

The states are changed based on a triggered action like hovering your mouse over or clicking on a button. The power of Storyline is that you’re not limited to interactive buttons. Any object you put on the slide can have multiple states that can be triggered by a user action.

![States tab](image)

This object has four states that can be triggered by an action.
What you need to know about Slide Layers:
Slide Layers sit on top of the slide and then you use triggered actions to show or hide them. For example, you may have a button that when clicked shows a slide layer.

![Image showing Slide Layers]

This slide has two layers

Base layer

What you need to know about Triggers:
Triggers are the actions that drive interactivity in Storyline. When someone clicks a button you want something to happen. That requires a trigger. When you roll the mouse over some text and you want it to change colors, that requires a trigger. When someone drags and drops a picture and you want it to provide some feedback, that requires a trigger.

Triggers are written to be very simple. It’s always: What do you want to happen; and when do you want to it to happen. Example: I want to change the state of the character when I click the button.

![Image showing Trigger Wizard]

The action is to change the state

When the user clicks

That's the essence of building interactive content in Storyline—each object can have multiple states and slides can have layers. And then triggers let you create actions like state changes and showing or hiding layers.
Of course, triggers can do much more than state changes and show/hide layers. It really just depends on what you want to do. For now, we'll keep it simple. Once you get a handle on a few simple things, feel free to practice doing more with triggers.

Let's create a simple interaction using state changes, slide layers, and triggers. We'll also take a peek at how Storyline's built-in characters work.
Create an Interactive Scenario

In this series of tutorials we'll practice using the states, layers, and triggers that we discussed earlier.

We'll assume this is a customer call center interaction where a customer calls to report an issue. The employee has to make a decision. One choice will be positive and the other will be negative.

The practice slide already has some content in it. There's a customer and a situation that requires a decision. We'll add an employee and create a simple interaction where we provide feedback by changing the character's expression and showing new slide layers.

Here's the download file for you to follow along.
Watch the video first and then follow the steps below to practice.
Practice Activity: Create feedback with state changes.

- Open the starting scenario file from the practice folder.
- Go to the Insert tab. Insert a new character to be your call center employee. Select an expression and the headset pose.
- Crop the desk out of the image.
- Now we’ll add a feedback button that will change the state of the two characters when clicked.
- Insert a button. This we’ll title Choice 1. In this scenario, choice 1 is not the best choice and the customer will become angry. So let’s add a trigger to the button that changes the state of the customer to angry. Remember, triggers are always: What should happen and when should it happen? In this case we want to change the state of the customer to angry when the button is clicked.

  ![Trigger Wizard](image)

  **What needs to happen?** Change the state of the character...

  **When does it need to happen?** ...when the learner clicks the button.

  ![Trigger Wizard](image)

- On the Triggers panel, select the button's trigger. Then set the action to change the state on the customer to angry (a built-in expression) when the button is clicked.
- Preview the slide.

  You built your first simple interaction! Now let’s add a trigger to change the call center employee’s expression, too.

- Select the Choice 1 button and then add a new trigger from the triggers panel.
- Change the state of the call center employee to surprised. And then preview.

  There you have it. In just a few simple steps you built a quick elearning interaction. We’re going to build on that in the next tutorial. Make sure to save the changes on the slide so we can use them for the next tutorial.
Watch the video first and then follow the steps below to practice.

Practice Activity: Create feedback showing slide layers.

In the previous tutorial we added feedback using state changes and triggers. In this tutorial we’ll add feedback to the interactive scenario with Slide Layers.

Let’s review what we’ve done so far. We created a Choice 1 button that when clicked changes the expressions of the customer and employee. This is a great way to provide some visual feedback in your courses. Now we’re going to add a feedback Slide Layer to the button. And then we’ll add another button for Choice 2.

- Open the previous file.
- In the Layers panel, add a slide layer and title it “Choice 1.” Notice how the base slide is viewable on the slide layer? This makes it easy to align your content. We’re going to add a customer response in the same place where we have the original customer statement. Let’s hide the customer comment so it’s not visible when we show this layer.
- On the timeline you’ll see the Base Layer Objects. Click on the arrow to expand the timeline. Then click to the eye icon to hide the text box on the base layer.
- Add a text box to the slide layer for the customer response. Add some text to show the customer is not happy.
- Click on the base layer. Now let’s add a trigger to the Choice 1 button that will show the Choice 1 layer.
- Select the Choice 1 button. Add a trigger to "show the layer Choice 1 when clicked".
- Preview the slide. You should see the character state changes and the text from the Choice 1 layer.
Create a new slide layer.

- Now we’ll duplicate the layer and button for our second choice.
- Select the Choice 1 layer and then duplicate it by clicking the duplicate layer button.
- Title the new layer “Choice 2” and then change the text in it to make it positive feedback.

Create a new button.

- Copy the Choice 1 button. Hold SHIFT+CTRL and drag the button to the right.
- Copying the button also copies the triggers. This means you don’t have to do much to change the interaction.
- On the Choice 2 button triggers, change the link from Angry to Happy for the Customer.
- Change the link from Worried to Happy for the Employee.
- And change the layer link from Choice 1 to Choice 2.
- Preview the slide.

In just a few clicks you created an interactive decision-making scenario using Storyline’s States, Layers, and Triggers. And that’s the essence of creating interactive content in Storyline. Of course, there’s a lot more that you can do but at this point it’s just a matter of practicing the basics and then building from there.

Here’s a good practice exercise: how would you build a tabs interaction like the image below? Each tab should reveal a different layer. Give it a try.

![Image of a tabs interaction](image)

In the next tutorial, we’ll take a quick look at the interactive markers and learn how easy it is to add them to your slides.
Add an Interactive Marker to an Image

In this tutorial we’ll add a couple of interactive markers to a map of Washington DC, and then we’ll make some edits to the markers.

Start by downloading the practice folder.

*Watch the video first and then follow the steps below to practice.*

**Practice Activity**

Create a marker.

- Open the *WashingtonDC.story*. We’re going to add two markers to it.
- Go to the Insert tab and locate **Markers**. Select a marker and add it to the Capitol Building.
- Position the **Marker Label**. If you click and grab the label you can drag it around the marker to change where it displays. Use the side anchors on the label to change its size.

Add content to the maker.

- Add a title and description. You can copy from the placeholder.txt in the practice folder.
- Format the text just like you would with any other text.
- Preview the marker.
Edit the marker.

- Let’s make some edits to the marker. Notice the swirl animation and how the box comes in and out on a mouse click? We can change that.

![Modify the marker](image)

- Double click on the marker to open the Marker Tools. Look at some of the options and explore what you can do to the markers like changing the icons, animations, colors of the markers and label styles.
- Change the animation on the marker and move the label so it doesn’t open on top of the Capitol Building.
- Preview the slide.

**Create a second marker with video.**
Now we’ll add a second marker to be placed by the Washington Monument. For this one, we’ll add a video to the label instead of text.

- Add a new marker to the Washington Monument.
- Double click on the marker to open the Marker Tools. Under Marker Options, click on the media icon. Here you can insert pictures and videos. We’ll insert a video.
- Select the video from the practice folder. Once the video’s inside the marker you can click on it to scale it.
- Preview the slide.

As you can see, adding interactive markers is pretty simple. And then editing them is as easy as editing any other shape in Storyline. Find an image and practice adding your own markers.

In the next tutorial we’ll take a quick look at creating a drag and drop interaction.
Create a Drag-and-Drop Interaction

In the previous tutorials, we learned to use the States, Layers, and Triggers to build an interactive scenario. Then we practiced adding interactive markers to an image. In this tutorial, we'll look at how to create a quick drag & drop interaction.

Drag & Drop Basics

Here's a quick overview of how drag and drops work. First, you need an item that can be dragged. And you need a place to drop it. We call that the target. When you create drag and drop interactions in Storyline, you'll select the draggable item and then the drop target using a simple form.

Watch the video first and then follow the steps below to practice.

Practice Activity: Create a Drag & Drop Sorting Interaction

Let's build a quick drag and drop sorting activity where we will sort colored squares to a garbage can or file cabinet. To get started, download the practice folder.

- Open the drag-drop.story file. At this point the slide just contains some objects. There are two sets of colored squares (yellow and blue) and two images, a garbage can and a file cabinet. You’ll also notice that there are no Slide Layers. We’re going to convert this slide to a freeform question.
- From the Insert tab, select Convert to Freeform. And then choose Drag and Drop.
• This opens a form where you can choose your Drag Items and Drop Targets. The form also contains all of the default programming required to grade the interaction and provide feedback. As you can see there are a few options. For now, we'll just go with the defaults.
• Under the Drag Items column, select all of the yellow and blue squares. That makes them all draggable.
• Under the Drop Target column, select the garbage can for the yellow squares and the file cabinet for the blue squares. We'll keep all of the default settings.
• Click on Save & Close.
• Preview the drag & drop interaction. Pretty cool, huh?

This process converted the slide objects into a gradeable drag & drop interaction. Now look at the Slide Layers. You'll notice that Storyline created the Incorrect and Correct feedback layers. They can be edited just like any other layer.

If you want to edit the interaction, go to the Edit Drag and Drop button in the top right corner. We'll stick with defaults, but feel free to look at your options and see what they do.

As you can see, building drag & drop interactions is pretty easy. The key point is that anything you put on the slide can be converted to a drag & drop interaction in minutes. That's going to give you all sorts of opportunities for interactive elearning.

Create a sorting activity on your own. See if you can figure out how to get the items to return to their starting spot when not dropped on the right target.
Watch the video first and then follow the steps below to practice.

**Practice Activity: Convert to Freeform**

While we’re at it, let’s create another freeform question. We use the same process as the drag & drop, but in this demo we’ll use the **Pick One** option.

Let’s see how well you do on your own.

- Start with the `drag-drop.story` file and select the slide with the three characters on it.
- Convert it to a **Pick One** freeform question and make one of the characters selectable.
- Preview the slide.

As you can see, Storyline makes it easy to convert a slide and its objects to a freeform interaction. There’s obviously a lot more you can do to build interactive content in Articulate Storyline. But this is a good start. The best thing is to practice building a few of your own interactions. If you get stuck, feel free to ask someone in the community or check out some of the other Storyline tutorials.

In the next tutorial, we’ll look at how to [create quiz questions in Storyline](#).
Build Quizzes and Result Slides

No doubt you’ll need to add some quizzes and knowledge checks to your elearning courses. Articulate Storyline makes it very easy to do so; and there’s so much flexibility that you can make your quizzes as simple or advanced as you like.

Since this is a getting started tutorial, we’ll keep it pretty simple. However, be sure to check out all of the quizzing product tutorials for more detailed information.

In this series of quick tutorials we’ll:

- Create a simple form-based quiz question
- Convert any slide to a freeform question
- Quickly create a results slide to track & grade
Create a Form-Based Quiz Question

Articulate Storyline offers a few options when it comes to quiz questions:

- You can insert standard quiz and survey questions.
- Build your own using freeform options.
- Draw questions from a bank of questions.

For this demo we’ll add a simple multiple choice question.

*Watch the video first and then follow the steps below to practice.*
Practice Activity

- To create a quiz question, click on the New Slide icon.
- Select the Quizzing tab.
- Select Multiple Choice from the Graded tab.
- This opens a question form where you can add your content.

**Quiz form**

- Add a question: Who was the first US president?
- Add some choices: Washington, Adam, and Jefferson
- Select the correct answer: Washington
- Stick with the generic feedback and close the form.
- Preview the slide.

You can always modify how the quiz content is laid out on the slide. At this point you can move it around like you would any other object in Storyline. If you want to edit the quiz question, do so right from the screen or click on the Edit Multiple Choice button in the top right corner. That brings you back to the form.

Now it’s your turn. Create a couple of questions and then practice editing them.
Create a Freeform Question

In a previous tutorial we looked at the freeform feature to create a quick drag & drop interaction. In this tutorial we’ll use the Convert to Freeform feature to convert a slide’s content to an interactive quiz question.

Watch the video first and then follow the steps below to practice.

To convert a slide to a freeform question you’ll need a slide with some content on it. In this case, we’ll start with a blank slide and add some shapes to it. And then we'll convert the slide to a freeform question.

Practice Activity

- Add two of each shape to your slide: triangle, circle, and square.
- Add a text box with directions to select the triangle shapes.
- Now we need to convert the slide to a freeform question.
- Go to the Insert tab and select the Convert to Freeform icon.
- Select Pick Many so that we can select more than one choice.
• This opens a form. We’ll need to **add all of the objects that are potential choices**. In this case, they are the shapes.

![Convert to freeform](image)

• Once the shapes are added, **select the correct answers** which are all triangles.
• We’ll keep the default feedback.
• Select **Save & Close** in the top left corner.

That’s it. You converted a slide and its objects to a freeform question. You’ll notice that there are now incorrect and correct slide layers for feedback. Look at the states for the shapes. Notice how Storyline added additional states?

Go ahead and **preview the question**. Notice how you can select the objects on the screen? Let’s do a quick edit of the slide.

• Add a new triangle to the screen.
• Select the **Edit Pick Many** button on the top left.
• Add the new triangle choice and mark it correct.
• Right now the objects are all in their original positions. Let’s make them shuffle. On the top ribbon, under **Shuffle**, select **Answer**.
• Now **Preview** the question. **Replay** the preview a few times. Notice how the shapes are shuffled and not in their original position? That’s because we’re shuffling the answers.

There’s a lot more you can do with the freeform conversion. Go ahead and practice building a few of your own questions and see how it works.
Create a Result Slide

Chances are that you’ll have multiple quiz and freeform questions spread throughout your elearning course. Some of them you may want to track and some you may not.

When you go to publish a course you can choose to track by slides viewed or you can track by the results of the graded quiz questions. In this tutorial we’ll learn to create a result slide that pulls questions from multiple quizzes.

*Watch the video first and then follow the steps below to practice.*

![Image of Storyline interface]

**Practice Activity**

Download and open the [big-quiz.story file](#). The project file is loaded with three scenes and a few quiz questions so you can practice creating results slides. Although this project is a little simpler than the one shown in the screencast above, the principles for creating a result slide are the same.
Use these steps to get some practice using result slides:

- On the **Insert** tab, choose **New Slide**.
- Select the **Quizzing** tab.

![Select result slide]

- Then select the **Results Slides** tab. For this tutorial we’ll select the **Graded Results** Slide. Then click **Insert**.

![Choose type of result slide]

- This opens the Result Slide Properties window, which displays all of the gradable questions in your course. Select the ones you wish to track and then choose the passing score.
• Click on the Options tab on the left side of the Result Slide Properties window, and you’ll see that you can choose what to display and whether or not to let the learner review the quiz or try again.

• Click OK to add the result slide to your course. Depending on what slide or scene was currently selected at the time you inserted the Result slide, you might find that the result slide ends up in a place other than where you want it. You can click and drag the slide thumbnail to the place where you want it to appear. To drag it into a different scene, you’ll need to be in Story View. (If you’re not, just click the Story View tab at the upper-left of your workspace.)

• When you’re ready to Publish, if you choose to publish for LMS you’ll notice that under the tracking options you can choose a result slide to track.

Articulate Storyline provides many options for assessing understanding. You can build a number of standard quiz questions or create your own using the freeform conversion feature. In either case, the sky’s the limit. And when you’re ready to publish, create a results slide and then select the questions you want to grade and track. It’s as easy as that.

Of course, there’s a lot more power to Storyline, but this should be enough to get you started.

You might also want to explore:

Adding Result Slides
Create Screencasts and Software Simulations

In Storyline it’s easy to create both screencast videos and interactive software simulations. In this tutorial we’ll take a quick look at how to build software training, make edits, and enhance your instruction using the zoom screen feature.

Screencasting Basics

Before we get started let’s review some screen recording basics. There are two ways to provide software training:

1. Video screencasts
2. Interactive simulations

Video Screencasts

Video screencasts are videos that show your recorded computer screen. They capture all of your mouse movements and any audio narration. The final output is a single video file. They’re great for “how-to” videos, but not very interactive.

Interactive Simulations

Interactive simulations simulate using the software. Instead of a video, you get single screens with linked hotspots and various help instructions. That means you can simulate much of the software’s interactions by having the learners click on the right areas or enter text just as they would with the real software.

There are three ways to show interactive simulations:

1. **View mode**: you walk through the process and the learner views what you’re doing
2. **Try mode**: the learner tries to walk through the process & you provide visual hints and captions
3. **Test mode**: the learner can demonstrate the ability to complete a task through a simulated test where they do all of the required actions

Articulate Storyline offers both types of screen recordings. You start by recording a video and from there you can choose to insert the video or an interactive simulation using one of the three modes.
Check out the tutorials to learn more:

- [Screencast Video](#)
- [Interactive Simulation](#)
Record a Screencast Video
In this tutorial you’ll learn to record a screencast video and add it to your slide.

Watch the video first and then follow the steps below to practice.

Practice Activity
To keep it simple, we’ll record how to add a shape to a PowerPoint slide and then apply an animation. That's easy enough for you to replicate on your own.

• Open PowerPoint so that the screen is ready to be recorded.
• In Storyline, click the Record Screen button. That will hide the Storyline screen and open up a recording frame.
• NOTE: By default the frame is the same size at the course slide dimensions. This will give you the best screen quality. You can either resize the software to fit in the default frame, or grab one of the frame's corners and resize the recording window to fit the software. You'll notice that the recording frame's aspect ratio remains the same. That's so it will fit perfectly on the slide.
• When you're ready to record, hit the red Record button. You'll get a count down and then you can begin to record the screencast. If you have a mic connected, you'll record your audio and all mouse movements.
• For this tutorial, we'll insert a shape onto a PowerPoint slide and animate it. You can watch the tutorial above to see the exact steps.
• Once you’re done recording, click on the Done button. That will process the video and open a box where you can title the video and choose what you want to insert.

Let’s add a title: PowerPoint demo
• Select insert the video on a single slide and then press Insert.
• At this point the video is added to the slide. Look at the timeline. You can see it’s an object on the timeline just like anything else you’d add to the Storyline slide.
• Save the file so that we can use it later in the interactive simulations tutorial.

As you can see recording a video screencast is fairly simple. If you want to add one to your slide, it’s just a mouse click away. At this point you can add shapes, text, or anything else you would normally do in Storyline. In the video tutorial above, I added a help button that opened a help layer. See if you can figure out how to do that on your own.

• Insert a help button.
• Create a help layer.
• Add a trigger to the help button to show the help layer.

Click here if you want to learn how to edit the video. Otherwise, in the next tutorial we’ll look at how to create an interactive simulation.
Edit Screencast Videos

Once you record a screencast video you may want to make some changes and edits to the video. In this brief tutorial, I'll show a few common edits that you can make.

*Watch the video first and then follow the steps below to practice.*

Quick tips:

- The master video is always available to you from the **Insert** tab via **Recording Screen**.
- Control when a video starts by choosing **Play Video** from the **Video Options**.
- Add video controls via the **Video Options** or by customizing the player via the **Slide Properties**.
- Crop & trim the video by selecting **Edit Video** in the **Video Options**.

There are more things you can do, but this is a good start. Watch the tutorial above to become familiar with the features. Then record a video and test out the features to see what happens.

In the next tutorial, we'll look at how to **create an interactive simulation** using the same video.
Create an Interactive Simulation

As we noted earlier, after recording a video screencast you have the option of inserting the video as a screencast tutorial which will play on a single slide. Or you can insert the video as a series of interactive slides that simulate the software.

In this tutorial we'll explore how to insert interactive simulations.

Watch the video first and then follow the steps below to practice.
**Practice Activity**

Once you have a recorded video you can reinsert it as a simulation. So we'll just reinsert the PowerPoint video we recorded earlier. But instead of adding it as a video, we’ll add it as an interactive simulation.

- On the **Insert** tab, click the drop down arrow on the **Record** button. That will display all recorded videos.
- Select the **PowerPoint video** we recorded earlier.

![Insert as video tutorial](image)

- Then select the **Step-by-step** option. You can see that we have three options. For this demo, we'll select **Try mode** steps.
- Click on **Insert**. That will insert a series of slides with hotspots that link to the next slide. The hotspots are the mouse clicks that were recorded during the video recording.
- **Review the slides.** Take a look at the feedback layers in the Slide Layer panel. Notice the feedback layers? Storyline generated captions with text instructions. Notice the hotspots on the slides? Look at the Triggers panel and review how the hotspots are triggered to the next slide.
- **Preview** the scene and test the interactive simulation. What happens when you click in the wrong area?

Once the content is on the slide you can edit it like any other slide—add characters, shapes, text, interactive buttons, etc.

That's basically it. Record your computer screen and then make the choice of either inserting a video clip of the entire screencast or a series of interactive screens to simulate the software. In the next tutorial, we’ll look at [how to edit the interactive simulations](#).
Edit Interactive Simulations

One thing you’ll notice when moving your mouse around a software interface is that the software provides all sorts of visual cues. For example, there may be a rollover effect for clickable tabs; or perhaps the icons change colors. Sometimes you’ll get some help text.

This is great for live software, but it’s not always great for software simulations. If you’re testing someone on a sequence of steps you don’t want the screen to give away where to click. But when you create the software simulation, Storyline doesn’t always know which screens you want. Often you’ll capture rollover effects or help text that you don’t want in your simulation.

These artifacts need to be edited out of the interactive simulation. And in Storyline it’s really easy to do. Because we create the slides from the recorded video, all we need to do is go back to the video to find a frame where the artifact doesn’t appear.

Watch the video first and then follow the steps below to practice.
**Practice Activity**

Editing the simulation screens is very easy.

- **Locate a slide** where you need to make an edit.
- Right click on the slide and select **Action Fine Tuning**. This opens the video panel.
- Use the **Previous Frame** or **Next Frame** buttons to locate a frame where the artifact doesn't appear. You can also click and drag frame markers on the video timeline.
- Once you find a frame you like, hit the **OK button**.

That's how simple it is. Use Action Fine Tuning to select the frame you want, and you're all done. Now it's up to you to practice. Record a simple tutorial like the PowerPoint example above and then practice editing out artifacts and visual cues.
Customize the Player

Articulate Storyline’s player is very flexible. You can enable and disable all sorts of features which will allow you to build the types of courses you want.

In these getting started tutorials we'll:

- **Explore how to customize the course player via the slide properties window.**
- **Learn to make slide-level customization to the player.**

Review the tutorials and then practice making some modifications to the course player using the practice files included here.
Customize the Course Player

Out of the box, the Articulate Storyline player features a standard left sidebar menu and slide content area. However, you’re not limited to the default look. In fact, the Storyline player offers all sorts of opportunities for customization…and all within a few clicks.

In this getting started tutorial we’ll quickly look at how to customize the course player.

*Watch the video first and then follow the steps below to practice.*
**Practice Activity**

The video above provides a very good overview of what you can do with the player. Download the practice files so that you can follow along with the tutorial and then do the practice activities.

Use the practice file to practice these tasks:

- Move the menu to the top left.
- Add a glossary to the top right.
- Add two glossary terms & definitions.
- Add a seekbar to the player.
- Change the title of scene 2.
- Add a PowerPoint file to the resources.
- Add a URL to the resources.
- Create a custom color scheme.
- Save the color scheme.

**Bonus:**

- Scene 3 doesn't appear in the menu list. Figure out how to insert the missing scene 3.

As you can see, modifying the player in Storyline is straightforward. Practice making a few modifications so that you’re familiar with your options. Then when you need a custom player you’ll know where to start.
Customize the Player at the Slide Level

In the previous tutorial we explored how to customize the Storyline player via the player properties window. Those changes are applied to all slides. However, there may be times when you need to customize the player for specific slides only.

For example, the slide contains a video and you want to include a seekbar but you don’t want the seekbar visible on all slides.

Watch the video first and then follow the steps below to practice.
**Practice Activity**

Here are a few practice activities to help you learn to customize the slide player.

- Go to a slide and open the slide properties from the base layer in the Layers panel.
- Disable the previous and next buttons on the slide.
- Preview the slide.
- Restore the buttons and enable the seekbar.

Making modifications to specific slides is relatively simple. Keep in mind that the changes you make at the slide level override the settings made in the course player. That means if you make changes to the course player they may not impact the custom changes you made at the slide level.
How to Publish Your Course

Publishing your course in Storyline is very simple. Click the publish button, choose your options, and then publish.

Watch the tutorial for a quick overview.
By default Storyline publishes to Flash. But you can choose to publish for mobile using the HTML5 and iPad options. Select what you want and it's a one-time publish.

How it works:

When you launch a course from the URL it will look for the Flash player. If the device doesn't play Flash then it will load the HTML5 version of the course.

If you're launching the URL from the iPad then it will try to load via the Articulate Mobile Player which can be downloaded for free from iTunes. Without the Articulate Mobile Player, the content can be viewed on the iPad using Mobile Safari and the HTML5 output. The mobile player is ideal as it will give you the best playback. Currently the Mobile Safari browser has some limitations playing media and interactive content.

You can learn more about publishing your courses in the product tutorial section.
Beginning a New Storyline Project

There are several ways to begin a new Storyline project from scratch:

- Click the Articulate button in the upper-left corner and choose New.

- Or, on the Storyline launch screen, click New project.

- Or, open Storyline and press Ctrl+N on your keyboard.

Storyline will begin a brand-new story, containing just a single empty slide. Initially, you'll see the slide in Story View. If you want to switch to Normal View, where you can add and customize your slide content, just double-click the slide thumbnail.
**About your project's story size**

When you begin a new project, its size will default to 720 pixels wide by 540 pixels high. You can change that if you like, and now's the best time to do it—before you add anything to your slides. Otherwise, when you change the size, objects on your slides might need to be rearranged or resized in order to look right with the new size.

To find out how to change your project's story size, check out the tutorial called [Choosing a Story Size](#).

**What if you want to start a project by recording a screencast, or by importing from PowerPoint, Quizmaker, or a Storyline template?**

You can do any of those things! On the Storyline launch screen, you can choose any of the following:

- [Record screen](#)
- [Import PowerPoint](#)
- [Import Quizmaker](#)
- [From project template](#)

The links above will guide you through the steps for each option.
Choosing a Story Size

When you first begin a new project, the content area of your course (the slide stage) defaults to 720 pixels wide and 540 pixels high. You can easily choose a different size by using the Story Size option on the Design tab of the Storyline ribbon.

If you want to change the story size, it's always best to do it before you add any content to your slides. Otherwise, when you change the size, objects on your slides might need to be rearranged or resized in order to look right with the new size.

Keep in mind that when you publish, the total size of your published output will be slightly larger than the dimensions you choose for the Story Size. That's because Storyline adds a little bit of height and width for the course player. Depending on the player features and controls you include, the player might add up to 260 pixels in width, and up to 118 pixels in height. For more details on customizing your player, check out this tutorial.
Here's how to change your story size:

1. Click the Design tab on the Storyline ribbon.
2. Choose Story Size.

3. The following window appears. In the Story Size selector, choose one of the preset sizes, or choose Custom. If you choose Custom, you can set the exact pixel width and height for your slide stage by entering numbers in the Width and Height fields, or by clicking the arrows to change these settings.

4. In the section called If new size is larger, choose one of the following:

   - Scale To Fit
   - Fill Background

   If you choose Fill Background, you can select a Fill Color from the drop-down menu and choose a Fill Transparency.

Leave the Lock aspect ratio box selected if you want to keep the current proportions. That way, if you change the width or height, the other setting will change proportionately.
- **Scale To Fit**: This scales the contents of your slides to fit proportionately within the new size.
- **Fill Background**: This retains the current slide background and applies it to the new size, but it doesn't resize your slide content. If you choose this, you'll also need to use the **Story Position** selector to choose where on the slide you want your existing content to appear.

5. In the section called **If new size is smaller**, choose one of the following:

- **Scale To Fit**: This scales the contents of your slides to fit proportionately within the new size.
- **Crop**: This crops your content to fit within the new size. Click **Next** to use the cropping tool to choose the crop area of each slide.

   - Move the box to indicate the part of your content that you want to appear on the slide. Then either click **Apply to All Slides**, or use the green arrows or the **Slide** field to view and crop additional slides until you’re finished. Click **OK** when you’re satisfied with the cropping on all your slides.

6. Click **OK** to go back to your slide content.
**Story View** gives you a big-picture view of all the content in your course.

In this view, you can view and arrange your slides in groups, called **Scenes**. The starting scene (which is what learners see when they first launch your course) has a small green flag next to its title, and it'll always be the leftmost scene in Story View.

Lines and arrows indicate the relationship between slides and scenes. If you're building a non-linear course, you can use **triggers** to customize how users proceed through your course's slides and scenes.
**How to get to Story View**

If you’re in a view other than Story View, you can quickly switch to Story View by clicking the Story View icon at the bottom of your screen. It's near the zoom controls in the lower right:

Or, you can click the **View** tab on the Storyline ribbon and select **Story View**:
Or, if you're in Normal View, you can also click the **Story View** tab just below the Storyline ribbon:

### Choosing the starting scene

To change which scene the learner sees first when your course launches, select the scene in Story View and click **Set as Starting Scene** on the **Home** tab. (Or, right-click the scene and choose **Starting Scene**.) The starting scene is marked with a green flag and appears in the leftmost part of the Story View workspace.
**Adding new scenes**

To add a new scene in Story View, click the **Home** tab and choose **New Scene**. Or, right-click anywhere in the Story View workspace and choose **New Scene**.

The new scene will contain a single blank slide. You can double-click the slide to switch to Normal View, where you can add content to the slide.

Another way to add new scenes is to create a duplicate of an existing scene. Just right-click a scene and choose **Duplicate**.

**Adding new slides**

To add a new slide, you can click **New Slide** on either the **Insert** tab or the **Home** tab. You can also right-click in the Story View workspace and choose **New Slide**.

The **Insert Slides** window appears, where you'll have several choices for the kind of slide you want to insert. If you need help choosing from the options available, check out the tutorials [here](#).
Adding or renaming titles on scenes and slides

Each scene and slide has a title. Scene titles appear at the top of the scene. Slide titles appear below each slide.

Slide Titles
A slide's title defaults to whatever title text is already on that slide, if there is any. If not, Storyline inserts "Untitled Slide" as the title. You can double-click the title to change it, or right-click the title and choose Rename. (If you do rename a slide title, it won't change any actual title text that you've already added on the slide itself.)

The slide title you see below each slide will be what Storyline uses as the default text in your course's menu, if you choose to include a menu in your player. But you can change the wording on your player menu, if you like, without affecting the title text that appears for each slide and scene here in Story View. Check out the tutorials on Customizing the Storyline Player for more details.

Scene Titles
For scene titles, Storyline inserts "Untitled Scene" as the default name at the top of each scene. You can double-click the scene title to change it, or right-click the scene name and choose Rename. The scene titles will be what Storyline
uses as the default text in your course's menu, if you choose to include a menu on your player—but you can change the wording on your player menu, if you like, without affecting the title text that appears here in Story View. Check out the tutorials on **customizing your player** for more details.

**Rearranging slides**

To rearrange slides, just click and drag a slide to the place you want it to be. When you drag a slide to a different place, a small blue arrow will appear to show where it'll be inserted. Release your mouse button to drop the slide into place.

A blue arrow indicates the place the slide will land if you drop it

You can even use **Shift-Click** or **Ctrl-Click** to select multiple slides at the same time, and move them as a group. You can move slides within the same scene or into different scenes.
**Collapsing and expanding scenes**

Sometimes it's helpful to collapse a scene in order to get a better view of what's in your course. You can click the minus sign in the upper-right of any scene to collapse it. Click the plus sign to expand it again.

You can also collapse or expand all your scenes at the same time by right-clicking in the Story View workspace and choosing **Collapse all scenes** or **Expand all scenes**.
Controlling the presentation order

By default, slides and scenes follow a linear order, but you can create non-linear learning paths by changing the triggers on any slide. Just select a slide and, in the Triggers panel, edit the trigger for the Next button (or any other trigger on the slide).

![Image of triggers panel](image)

Need a quick overview of triggers and how they work? Find out here.

Zooming in and out

There are a few ways to change the zoom in Story View:

- **Ctrl-mouse wheel**: This is probably the easiest and quickest way to zoom in and out. Hold down your Ctrl key and scroll your mouse wheel. Scroll forward to zoom in, or backward to zoom out.
- **Zoom slider**: In the lower-right corner of your screen, you'll see a zoom slider. Drag to the right to zoom in, or to the left to zoom out.
• **Zoom percentage:** Next to the zoom slider in the lower-right corner of your screen, you’ll see a zoom percentage. You can click the percentage to bring up the zoom window, where you can change the zoom to whatever you like. You can also access this window by clicking the View tab and choosing the Zoom button.

![Zoom window](image)

• **Fit to window:** To the right of the zoom slider in the lower-right corner of your screen, you'll see a small rectangular button with arrows. Click that to make everything fit in the viewable area of your Storyline window.

![Fit to window button](image)

Click the rectangular icon to fit your content within the window's current size.

Or, click the View tab and select Fit to Window.

![Fit to Window button](image)
Editing slides while in story view

Generally, you'll want to switch to Normal View in order to make changes to individual slides. But there are some edits you can make directly while in Story View. Here's a summary of what you can do:

- **Switch a slide's layout**: You can right-click any slide and choose **Layout** to assign a different master layout to that slide. Or, with one or more slides selected, click the **Layout** option on the **Home** tab and choose from the slide layouts available. You can also choose **Reset Slide** if you've modified some of the layout elements on the slide and want to revert back to the master layout's original properties. Need help customizing slide layouts? Find out more [here](#).

- **Change a slide's background**: Right-click a slide and choose **Format Background** to add a different fill to the slide's background. Or, click the **Design** tab and right-click one of the **Background Styles** to apply a new background to the selected slide or all slides. If you need some guidance on using the Format Background options, check out the tutorial [here](#).

- **Switch to a different design theme**: Design themes allow you to quickly change the background, colors, and fonts used on a specific slide or on all slides in your course. You can use the **Design** tab to switch to a different theme, or modify the theme colors or theme fonts. [Here's a tutorial](#) with more details about design themes.

- **Change a slide's transition**: Select a slide and click the **Animations** tab to choose a different transition for that slide. [More on transitions](#).

- **Add or edit triggers**: Triggers tell Storyline how to respond when learners interact with your course. Select a slide and use the **Triggers** panel to add, edit, or delete triggers. Find out more about using triggers [here](#).

- **Change slide properties**: You can adjust the properties of any slide by selecting the slide and using the **Properties** panel. You can change the slide-advance behavior, the player controls available on that slide, and more. If you use Shift+Click or Ctrl+Click to select multiple slides in Story View, you can even change the properties for all selected slides at once. For help with choosing the slide properties, check out the tutorial [here](#).

- **Duplicate, rename, or delete slides**: To duplicate a slide, select it and click the **Duplicate** option on the **Home** tab. Or, right-click any slide and choose **Duplicate**. You can also use the right-click menu to **Rename** or **Delete** a slide.

Adding a screen recording

You can click the **Record Screen** button on the **Home** or **Insert** tab to create a movie or interactive screencast to insert in your course. If you've already created a screen recording in this project, you can click the small arrow on the **Record Screen** button and select from a list of screencasts available for inserting. For more information on screen recordings, see [this tutorial](#).
**Adding content from a Question Bank**

The **Question Bank** button on Story View's **Home** tab allows you to insert quiz slides from a bank of questions, or to manage your question banks.

When you click **Question Bank**, you'll be able to choose from several options. For more details on setting up and using question banks, see this tutorial. Keep in mind, you don't have to use question banks to insert quiz slides—if you prefer, you can add quiz questions one at a time to your course. For help with that, check out the tutorials called **Adding Graded Questions and Survey Questions**, and **Adding Freeform Quiz Questions**.
Using Normal View

Think of Normal View as the place where you build and customize each slide’s content. Here, you can edit anything about a specific slide—including the slide design, objects on the slide, their timing and animations, states, triggers, and more. You can also create and customize layers for your slide, and use triggers to control when the layers should appear.
**How to get to Normal View**

If you're in a view other than Normal View, you can quickly switch to Normal View by clicking the slide icon at the bottom of your screen. It's near the zoom controls in the lower right.

Or, you can click the **View** tab on the Storyline ribbon and select **Normal View**.

Or, if you're in Story View, you can double-click on any slide thumbnail to see that slide in Normal View.
Switching to different slides or scenes

Normal View allows you to view any slide within a given scene in your course. To jump to a different slide within the same scene, use the column to the left of your slide to select the slide you want to work with. If you'd like to view slides from a different scene, use the Scenes selector in the upper-left to choose a scene.
**Keeping multiple slides open in Normal View**

Sometimes it’s helpful to keep several slides easily accessible for editing. For example, in the following picture, see how I have several tabs along the top edge of my Normal View workspace? Each takes me to a slide I’m currently working on. This way I can quickly switch without always having to scroll to a different slide or open a different scene.

To open multiple slides like this, click the **Story View** tab, then double-click the thumbnail of any slide you want to open. It'll be added as a tab in your Normal View. To remove it from view, you can just click the X in the upper-right of the tab. (This won't delete the slide; it just removes it from view until you open it back up again.)

**For more help with adding or customizing content:**

Check out the following Storyline tutorials if you need some guidance on how to build or customize your slide content:

- Inserting and Customizing Slide Content
- Using the Timeline
- Working with States, Triggers, and Layers
- Inserting and Customizing Media
- Inserting and Customizing Screen Recordings
- Inserting and Customizing Interactivity
- Applying Animations and Slide Transitions
- Customizing Your Project Design
- Controlling a Slide's Advance Behavior and Other Slide Properties
- Inserting and Customizing Quiz Slides
Inserting and Customizing Slide Content

Storyline's intuitive authoring environment makes it super quick and easy to create compelling e-learning content. In the following tutorials, you'll learn how to insert and customize your slides and the objects they contain:

- Adding Pictures
- Adding Screenshots
- Adding Characters
- Adjusting Properties for Pictures, Screenshots, and Characters
- Drawing Shapes
- Adding Captions, Chat Clouds, and Thought Clouds
- Adding Text Boxes
- Adjusting Properties for Shapes, Captions, and Text Boxes
- Using the Format Shape or Format Picture Window
- Ordering, Grouping, Sizing, and Positioning Your Objects
- Applying Quick Styles
- Creating a Zoom or Pan Effect
- Inserting Slide Notes
- Using the Storyline Clipboard
- Inserting New Slides
- Controlling a Slide's Advance Behavior and Other Slide Properties
- Using the Timeline

You might also want to explore:

Inserting and Customizing Interactivity
Adding Pictures

It's easy to enhance the content of your course with images to help reinforce learning or provide your learners with important visual information. You can insert images onto any slide or slide layer, or onto any slide master layouts or feedback master layouts. Here's how:

1. While viewing any slide, slide layer, or slide master, click the **Insert** tab, and choose **Picture**.

2. Navigate to the image you want to use. The following image formats are supported:

   - BMP
   - EMF
   - GIF
   - GFA
   - JFIF
   - JPE
   - JPG
   - JPEG
   - PNG
   - TIF
• TIFF
• WMF

3. To insert a single image, double-click it, or select the image and then click **Open**. To select more than one image at a time, click and drag to choose multiple files, or use **Shift-Click** or **Ctrl-Click**, and then click **Open**. **TIP:** If you have Windows Explorer open, you can also select one or more files from your Windows Explorer Window and drag them onto your Storyline slide.

Once you've inserted an image, you can move, resize, or format the image(s) however you like.

**You might also want to explore:**

*Adjusting Properties for Pictures, Screenshots, and Characters*
Adding Screenshots

Storyline’s screenshot tool provides a quick and easy way of adding screenshots to your course without having to open up a separate screenshot tool. Here’s how to add a screenshot to any slide:

1. While viewing a slide, a slide layer, or a slide master, click the **Insert** tab, and choose **Screenshot**. A dropdown list of thumbnails will appear. Each one represents an open application or browser window. Minimized applications won’t appear in the list.
2. Do either of the following:

- Hover over any thumbnail in the list to see the application or window name, and click one to insert a screenshot of that item onto the current slide.
- Or, if you prefer to take a screenshot of just part of your screen (rather than an entire open window), choose **Screen Clipping** from the bottom of the list.
3. If you chose **Screen Clipping**, your screen will dim and your Storyline window will disappear temporarily. Click and drag on your screen to select the area you want to capture. The selected area will appear non-dimmed. When you release your mouse button, the Storyline window will return, with your screen clipping on the current slide.

![Screen Clipping Example](image)

If you choose Screen Clipping, your screen dims except for the area you select. When you release the mouse button, the selected area appears as a screenshot on your slide.

4. Once you insert a screenshot, it behaves like any other image. You can move it, resize it, crop it, animate it, or apply any other image effects that you like.

**You might also want to explore:**

*Adjusting the Properties for Pictures, Screenshots, and Characters*
Adding Characters

The character packs in Storyline provide all sorts of great options for adding life to your course. You can choose from illustrated or photographic character packs, each of which contains both male and female characters in a variety of different hairstyles, clothing, poses, and expressions.

Storyline comes with a several illustrated characters and one photographic character. You can purchase more characters in the Articulate Store.

Here’s how to add a character to your course:

1. From any slide or slide master, click the Insert tab and choose Character.
2. Choose the character pack you’d like to use: **Illustrated** or **Photographic**.

3. When the character window appears, use the buttons at the top and the lower-right of the window to customize your character. As you make your selections, the character preview in the right-hand side of this window changes to reflect your choices.
4. Click **Insert** to add your character to the current slide.

Once the character is inserted, you can manipulate or modify it just like you would any other image. You can move it, resize it, crop it, animate it, or apply any other image effects that you like. You can also add States to your character to show different expressions or poses, and use triggers to control when those different States appear.

**You might also want to explore:**

- Adjusting Properties for Pictures, Screenshots, and Characters
- Changing the Style of a Character You've Inserted
- Adding and Editing States
- Adding and Editing Triggers
- Create an Interactive Scenario
Changing the Style of a Character You’ve Inserted

Once you've inserted a character in your course, you can use the Character Tools to quickly and easily make adjustments without having to reinsert the character from scratch.

This is especially helpful if you've applied animations, image effects, or other customizations to the character. You can easily swap to a different character, expression, pose, or perspective without losing your work.

Here's how to make adjustments to a character you've inserted:

1. Select a character on a slide or slide master.
2. Click the **Design** tab in the **Character Tools** section of the ribbon:
3. Use the buttons in the **Styles** area of the toolbar to make your changes. The options here will be different depending on whether you're working with an illustrated character or photographic character:

- For illustrated characters, you can change to a different **Character, Expression, Pose, or Perspective**.

![Illustrated Character Options](image1)

- For photographic characters, you can change to a different **Pose or Crop**.

![Photographic Character Options](image2)

4. You can also make additional adjustments in the **Arrange** section of the ribbon:

- **Bring Forward**: Click this option to bring the character forward one layer on your slide. Or, to send the character to the very front layer, click the small arrow next to **Bring Forward** and then choose **Bring to Front**.

- **Send Backward**: Click this option to send the character back one layer on your slide. Or, to send the character to the very back layer, click the small arrow next to **Send Backward** and then choose **Send to Back**.

  (Tip: In addition to the above two options, another way to change the layer order of objects is to use the timeline. Click the **Timeline** tab below your slide workspace. All the elements on your slide will be listed in
the timeline, in the same order in which they're layered on your slide—in other words, the topmost items in
the list are the items that are closest to the front, or top, layer of the slide. To change the layering order, just
select an item on the timeline and drag it up or down in the list.)

- **Align**: Use this option to align characters with one another or with other objects, or to align characters with
  the slide itself. Click **Align** and choose either **Align to Slide** or **Align to Selected Objects**. (If you've
  selected just one object rather than multiple, only **Align to Slide** will be available.) Next, click **Align** again
  and choose one of the alignment options (left, center, right, top, middle, or bottom). Or, to space multiple
  items evenly, choose **Distribute Horizontally** or **Distribute Vertically**.

- **Group**: Grouping is a handy feature that allows you to move, resize, rotate, flip, or change other attributes
  of several objects all at the same time—as if they were a single object. To group objects, use **Shift-Click** to
  select two or more objects, and then choose **Group** to group them. If you later wish to ungroup them, you
  can select the group and choose **Group > Ungroup**. To regroup items that were previously part of a group,
  choose **Group > Regroup**.

- **Rotate**: Click this option to rotate your selected object(s). Choose one of the options listed, or choose **More
  Rotation Options** to enter a specific rotation value. If you choose **More Rotation Options**, you’ll see a
  window where you can enter a specific value in the **Rotation** field, or specify a degree value.
  Click **Close** when you’re done.

5. In the **Size** section of the ribbon, you can use the **Crop** button to customize the cropping boundaries of the
character, in the same way you can with other images. When you click this button, handles appear on your
character, and you can drag them to crop. Or, you can use one of these alternative methods to crop:

- With the **Crop** button selected, click and drag the character within the cropping window. Then click
  elsewhere on the slide to apply the crop.
- Or, just type specific dimensions for the height and width in the fields next to the **Crop** button, and
  press **Enter** to apply the new dimensions.

**You might also want to explore:**

*Adjusting Properties for Pictures, Screenshots, and Characters*
Adjusting Properties for Pictures, Screenshots, and Characters

Once you've inserted a picture onto a slide in Storyline, there are several Picture Tools you can use to customize it. You can use these same tools to also customize any screenshots or Storyline characters you've inserted, since these behave just like images once you insert them.

Here's how to access and use Storyline's Picture Tools:

1. Select the image, screenshot, or character you want to customize.
2. On the Storyline ribbon, select the **Format** tab.

![Image of Storyline ribbon with Format tab highlighted]

3. Here's what you can do with the **Adjust** section of the ribbon:

   - **Brightness**: Click this option and select one of the brightness choices listed, or select **Picture Correction Options** to see all the picture formatting options available.
   - **Contrast**: Click this option and select one of the contrast options listed, or select **Picture Correction Options** to see all the picture formatting options available.
   - **Recolor**: Click this option and choose a new color. If you don't see the color you want, choose **More Variations** so that you can choose from additional theme colors or define your own custom color. You can also choose **Set Transparent Color** if you want to make any part of your image transparent, based on its color. (If you choose this option and then click on the picture, everything of that color will turn transparent.)
   - **Change Picture**: Click this option if you want to swap the current picture for a different one. Any picture effects and animations you previously applied to the original picture will stay intact; they'll be applied to the new picture automatically. (Note: If you're working with a Storyline character and want to swap in a different character, see [this tutorial](#).)
   - **Reset Picture**: Click this option to revert to the picture's original appearance. To revert to its original size and original appearance, click the small triangle next to the **Reset Picture** option and then choose **Reset Picture & Size**. Note that **Reset Picture & Size** will also restore any areas of the picture that may have been cropped.
4. Here's what you can do with the **Picture Styles** section of the ribbon:

- **Preset picture styles**: The preset picture styles in Storyline provide you with a handy way to quickly change the appearance of your image. Click one of the thumbnails in the **Picture Styles** section to apply a style. Or, click the small triangle in the lower-right of this section to expand the list to choose from.

- **Picture Shape**: Click this option and then select a shape to change the shape of your image. Storyline crops the image to the shape you choose.

- **Picture Border**: Click this option to apply a different border to your image. If you see a color you like in the list, you can click it to apply it to the image—the colors available are controlled by your project's design theme. To customize your own color, choose **More Outline Colors**. You can also change the border's thickness by selecting **Weight**, or choose a pattern for the border with the **Dashes** option. To remove the border, choose **No Outline**.

- **Picture Effects**: Click this option to apply a shadow, reflection, glow, or soft edges. (The colors available for the glow option are controlled by your project's design theme.)

5. Here's what you can do with the **Arrange** section of the ribbon:

- **Bring Forward**: Click this option to bring the object forward one layer on your slide. Or, to send the object to the very front layer, click the small arrow next to **Bring Forward** and then choose **Bring to Front**.

- **Send Backward**: Click this option to send the object back one layer on your slide. Or, to send the object to the very back layer, click the small arrow next to **Send Backward** and then choose **Send to Back**.

  **Tip**: In addition to the above two options, another way to change the layer order of objects is to use the timeline. Click the **Timeline** tab that appears below your slide. All the elements on your slide will be listed in the timeline, in the same order in which they're layered on your slide—in other words, the topmost items in the list are the items that are closest to the front, or top, layer of the slide. To change the layering order, just select an item on the timeline and drag it up or down in the list.

- **Align**: Use this option to align objects with one another, or to align objects with the slide itself. Click **Align** and choose either **Align to Slide** or **Align to Selected Objects**. (If you've selected just one object rather than multiple, only **Align to Slide** will be available.) Next, click **Align** again and choose one of the alignment options (left, center, right, top, middle, or bottom). Or, to space items evenly, choose **Distribute Horizontally** or **Distribute Vertically**.
• **Group**: Grouping is a handy feature that allows you to move, resize, rotate, flip, or change other attributes of several objects all at the same time—as if they were a single object. To group objects, use **Shift-Click** to select two or more objects, and then choose **Group** to group them. If you later wish to ungroup them, you can select the group and choose **Group > Ungroup**. To regroup items that were previously part of a group, choose **Group > Regroup**.

• **Rotate**: Click this option to rotate your selected object(s). Choose one of the options listed, or choose **More Rotation Options** to enter a specific rotation value. If you choose **More Rotation Options**, you’ll see the following window where you can enter a specific value in the **Rotation** field, or use the arrows to increase or decrease the value. Click **Close** when you’re done.
Here’s what you can do with the **Size** section of the ribbon:

- **Zoom Picture**: Click this option to enable a zoom icon on your image, which learners can click to see a larger view. (The zoom will work only if you’ve resized the image on your slide to be smaller than the original—for example, if you’ve inserted a 500x500 pixel image and then resized it to be 250x250, the zoom icon will allow learners to see zoom the image to its original 500x500 size.)

- **Crop**: Click this option to crop the image. Handles will appear on your image, and you can drag them to change the dimensions of your picture. Or, type the specific dimensions you want for the height and width in the fields next to the **Crop** button.

**Another way to adjust the properties**

Another way to adjust the properties on a picture, screenshot, or character is to right-click the object and choose **Format Picture** or **Size and Position**. This opens a window where you can access many of the same formatting options described above.
Drawing Shapes

One way that you can customize your slide design is by drawing your own shapes onto your course slides. Here's how to add a shape:

1. From any slide or slide master, click the Insert tab.

2. From the Shapes menu, select the shape you'd like to add.

3. Click and drag on your slide canvas to add the shape to your slide.

4. The initial fill color and line color of your shape (and also the text color, if you choose to add text to it) are determined by the design theme you're using for your course. (More about design themes here.) You can change the look of your shape, though, by selecting the object and using the tools on the Format tab to apply any formatting effects that you like. Or, right-click the shape and choose Format Shape or Size and Position, and use the tools provided on the window that appears.
**Note:** If you apply some formatting to a shape and then want that same formatting to be used on future shapes you add to the current course, you can right-click the shape and choose **Set As Default Shape**.

**You might also want to explore:**

- Adjusting Properties for Shapes, Captions, and Text Boxes
- Using the Format Shape or Format Picture Window
- Using the Size and Position Window
Adding Captions, Chat Clouds, and Thought Clouds

Storyline's caption shapes give you a quick and easy way to create labels, speech bubbles, and thought clouds. Here's how to add a caption shape:

1. From any slide or slide master, click the **Insert** tab.

2. From the **Caption** menu, select the caption type you'd like to add.

3. Click and drag on your slide canvas to add the caption to your slide, and, if the caption will include text, you can immediately begin typing—there's no need to insert a separate text box over the caption, since the caption shape can hold text.

4. The initial fill color, line color, text color, and font of your caption are determined by the **design theme** you're using for your course. You can change the look of your caption, though, by selecting the object and using the tools on the **Format** tab to apply any **formatting effects** that you like, or click the **Home** tab to adjust its text properties. You can also right-click the caption and choose **Format Shape** or **Size and Position**, and use the tools provided there.

   **Note:** If you apply some formatting to a caption and then want that same formatting to be used on future captions you add to the current course, you can right-click the caption and choose **Set As Default Shape**.

5. If the caption type you chose includes a pointer, you can make it point anywhere on your slide. Just click and drag the yellow handle at the end of the pointer.
You might also want to explore:

- Adjusting Properties for Shapes, Captions, and Text Boxes
- Using the Format Shape or Format Picture Window
- Using the Size and Position Window
Adding Text Boxes

Text boxes are easy to add and edit in Storyline. You can add text boxes to any slide, including Slide Masters and Feedback Masters. Here’s how to do it:

1. From any slide or slide master, click the Insert tab.

![Image of Insert tab in Storyline](image1)

2. Choose Text Box.

![Image of Text Box option in Insert panel](image2)

3. Click and drag on your slide to draw a text box the size you want.

4. Type some text in the text box. (Or, if you’ve previously copied some text to your clipboard, you can place your cursor in the text box, and then paste by pressing Ctrl+V or by right-clicking and choosing Paste.)

5. Now that you’ve got your text box on your slide, there are a bunch of things you can do to make it look the way you want:

   - **Move or resize it:** Click the textbox and drag it to somewhere else on your slide, or use the handles to resize it.
   - **Change the font or paragraph attributes:** Check out the tutorials on Customizing Text Attributes or Customizing Paragraph Attributes if you need help making the text look just like you want.
   - **Change the fill, line color, and other properties:** You can either use the Format tab on the Storyline menu to adjust the properties of your text boxes, or access similar options by right-clicking the text box and choosing Format Shape or Size and Position.
Inserting Symbols

The Symbols feature in Storyline allows you to easily add characters that aren't normally on a keyboard, such as copyright symbols, trademark symbols, paragraph marks, accented characters, and Unicode characters.

Here's how to add a symbol:

1. Create a text box, shape or caption on your slide, or select an existing one. If there's already text in the object, place your cursor within it.
2. Click the Insert tab on the Storyline ribbon.
3. Choose Symbol.
4. You can insert any symbol shown in the list by double-clicking it or by selecting it and then clicking Insert. If you don't see the symbol you want, you can:

- Browse additional symbols by choosing a different font from the Font selector in the upper-left of the window.
- Choose a different character set in the from: selector in the lower-right of the window.
- If you've chosen the Unicode (hex) character set in the from selector, you can also choose a different Subset of characters in the upper-right of the window.
- If you know the character code, you can enter it in the Character code field directly.

You might also want to explore:

Adjusting Properties for Shapes, Captions, and Text Boxes
Inserting References to Variables

The Variables feature in Storyline enables you to collect and store pieces of data that you can refer to later. One of the ways you can use variables is by displaying the value of the variable to your learners.

For example, let's say you've inserted a text variable at the beginning your course to collect a bit of text from the learner, such as their first name. Later in the course, you can insert a reference for that variable—which is really just a placeholder that tells Storyline to display the variable's value on the slide.

Here's how to add a variable reference:

1. Draw a text box on a slide, or place your cursor in some existing text.
2. Click the Insert tab on the Storyline ribbon.
3. Select Reference.
4. The References window appears, showing a list of any variables you've inserted into your course. Select the variable you want to reference, and click OK. In the following example, I'm choosing to insert the value of the variable called "Name."
When you insert a variable reference, a code appears in your text as a placeholder. It consists of the variable name, with a % sign before and after it, like the example below.

When you publish your course and your learners interact with your content, the value of the learner-entered variable will appear within your text when learners arrive at the slide that contains the reference.

You might also want to explore:

Working with Variables
Adjusting Properties for Shapes, Captions, and Text Boxes

Once you've inserted a shape, caption, or text box onto a slide in Storyline, there are several drawing tools you can use to customize it. Here's how:

1. Select the shape, caption, or text box you want to customize.
2. On the Storyline ribbon, select the Format tab.

Now use any of the following to customize the item you selected.

3. Change Shape: Click this option and then choose one of the shapes listed to switch to a different shape.
4. **Shape Styles**: The preset shape styles in Storyline provide you with a handy way to quickly change the appearance of your object. Click one of the thumbnails in the *Shape Styles* section to apply a style. You can click the small triangle at the lower-right of the thumbnails to expand the list if you need to.

![Click a thumbnail to apply a ready-made style. Click the arrow to expand the list.](image)

5. **Shape Fill**: Click this option to change the fill color of your object. Use the guidelines below.

- If you see a color you like, click on it to apply it to your object. The colors available are controlled by your project's *design theme*.
- To remove the fill from an object, choose *No Fill*.
- To fill the object with a color other than the choices shown, choose *More Fill Colors*.
• To fill the object with a picture, choose Picture and then browse to the image you want to use and click Open.
• To apply a gradient fill to your object, choose Gradient and then either choose one of the preset options or choose More Gradients.
• To apply a texture fill, choose Texture and then either choose one of the preset options or choose More Textures.

6. Shape Outline: Click this option to change the outline of your object. Use the guidelines below.

   - If you see a color you like, you can click on it to apply it to the outline of your object. The colors available are controlled by your project's design theme.
   - To remove the outline from an object, choose No Outline.
   - To format the outline with a color other than the choices shown, choose More Outline Colors.
   - To change the outline's thickness, choose Weight.
   - To change the line style to something other than a solid line, choose Dashes.
7. **Shape Effects**: Click this option to apply or change a shadow, reflection, glow, or soft edges to your object. Use the guidelines below.

- To apply a shadow, choose **Shadow** and pick from the options available.
- To apply a reflection, choose **Reflection** and pick from the options available.
- To apply a glow, choose **Glow** and then click one of the color choices. The glow colors are determined by the project's **design theme**.
- To apply soft edges, choose **Soft Edges** and pick from the options available.

8. **Bring Forward/Send Backward**: Click these options to bring the object forward or backward one layer on your slide. Or, to send the object to the very front or back, click the small arrow next to one of the choices and select **Bring to Front** or **Send to Back**.

- **Tip**: In addition to the **Bring Forward** and **Send Backward** options, another way to change the layer order of objects is to use the timeline. Click the **Timeline** tab that appears below your slide. All the elements on your slide will be listed in the timeline, in the same order in which they're layered on your slide—in other words, the topmost items in the list are the items that are closest to the front, or top, layer of the slide. To change the layering order, just select an item on the timeline and drag it up or down in the list.
9. **Align**: Use this option to align objects with one another or to align objects with the slide itself.

   - Click **Align** and choose either **Align to Slide** or **Align to Selected Objects**. (If you've selected just one object rather than multiple, only **Align to Slide** will be available.)
   - Next, click **Align** again and choose one of the alignment options (left, center, right, top, middle, or bottom). Or, to space items evenly, choose **Distribute Horizontally** or **Distribute Vertically**.

10. **Group**: Grouping is a handy feature that allows you to move, resize, rotate, flip, or change other attributes of several objects all at the same time—as if they were a single object. To group objects, use **Shift-Click** to select two or more objects, and then choose **Group** to group them. If you later wish to ungroup them, you can select the group and choose **Group > Ungroup**. To regroup items that were previously part of a group, choose **Group > Regroup**.
11. **Rotate**: Click this option to rotate your selected object(s). Choose one of the options listed, or choose **More Rotation Options** to enter a specific rotation value. If you choose **More Rotation Options**, you'll see the following window where you can enter a specific value in the **Rotation** field, or use the arrows to increase or decrease the value. Click **Close** when you're done.

![Rotation window](image)

You can enter a rotation value here

12. **Height** and **Width**: Use these fields to enter a specific height and width, in pixels, for your object. You can also quickly resize the object itself by just selecting it and dragging the handles on its bounding box.

![Size and position window](image)

You might also want to explore:

- Customizing Text Attributes
- Customizing Paragraph Attributes
- Using the Format Shape or Format Picture Window
- Using the Size and Position Window
Customizing Text Attributes

With Storyline's font tools on the Home tab, you can customize any text on your slides. The tools are available in Normal View, Slide Master View, and Feedback Master View. You can use them to customize all sorts of things, including:

- Font selection
- Text size
- Text attributes such as bold, italic, underline, shadow, strikethrough, subscript, superscript, and case
- Highlighting
- Text color

You can also use the spell-check button to check the spelling of any text boxes you've inserted throughout your project.

Tips for working with the font tools

Here are some ways you can make the font tools work harder for you:

- You can hover over any of the buttons in the Font section of the toolbar to find out its function.
- You can apply formatting to a whole text box at once, or you can select a single word or paragraph within a text box and apply formatting to just the selected part:
  - To quickly select just one word within a text box, double-click the word.
  - To select the whole paragraph, triple-click a word within the paragraph you want to select.
  - If you want to apply formatting to everything within a text box, just select the bounding box of the text box itself.
- You can select multiple text boxes on a slide and format them all at once. Just use Shift+Click or Ctrl+Click to select multiple text boxes, or click and drag around the text boxes you want to select. Then choose whatever formatting you want.
- The Grow Font and Shrink Font options are a quick way to increase or decrease the size of the text you select.

The colors available in the font color selector are determined by your course's theme colors. To change these, see the tutorial on Using Themes.
• You can easily clear any text formatting from your text and return it to its default attributes by clicking the Clear Formatting icon. It looks like a little eraser.

Use this button to clear formatting from any text

• For even more control over the look and behavior of your text, you can right-click a text box, choose Format Shape, and select the Text Box tab on the window that appears. Learn how to use the settings on the Format Shape window here.

**Keyboard shortcuts for font formatting**

To make formatting quicker, you can use the following shortcuts for common text-editing tasks:

• **Bold:** Ctrl+B
• **Italic:** Ctrl+I
• **Underline:** Ctrl+U
• **Add hyperlink:** Ctrl+K

You might also want to browse through this list of additional Keyboard Shortcuts.

**Want to apply consistent text formatting throughout your course?**

Rather than formatting every individual slide’s text, you might want to think about defining theme fonts to make your design work easier and faster. You can set up a default heading font and default body font so that all new slides inherit the same fonts. Another shortcut is to leverage master slides for some of your font formatting. For more guidance, see the tutorials on Working with Theme Fonts, Using Slide Masters, and Using Feedback Masters.
Customizing Paragraph Attributes

With Storyline’s paragraph tools on the Home tab, you can customize attributes of entire text boxes or individual paragraphs within them. The paragraph tools are available in Normal View, Slide Master View, and Feedback Master View. You can use them to do things such as:

- Apply bullets or numbering
- Increase or decrease the indent
- Increase or decrease the line spacing
- Change the way the text is justified (right, left, center, or full)
- Change a text box’s vertical alignment, text direction, and more

Tips for working with the Paragraph tools

Here are some tips for getting the most out of the Paragraph tools:

- You can hover over any paragraph formatting button to find out its function.
- If you select an entire text box and then apply formatting, the formatting will affect everything in that text box. If your text box has multiple paragraphs and you want to format just one of them, put your cursor in the paragraph you want to format, and then select your formatting options from the toolbar.
- If you want to number your paragraphs, you can select the numbering format by clicking the little arrow next to the numbering button.

Click the small arrow to choose the numbering style
• If you apply some formatting to a text box and you want to use its attributes as the default for new text boxes within the same project, just right-click the text box and choose Set As Default Text Box. Any new text boxes you create will inherit the same properties of the original.

• For even more control over the look and behavior of your text, you can click the Text Direction button or the Align Text button and then choose More Options—or, just right-click a text box, choose Format Shape, and select the Text Box tab on the window that appears. Learn how to use the settings on the Format Shape window here.

**Keyboard shortcuts for paragraph formatting**

To make formatting quicker, you can use the following shortcuts for common paragraph-editing tasks:

- **Center**: Ctrl+E
- **Left align**: Ctrl+L
- **Right align**: Ctrl+R

You might also want to browse through this list of additional Keyboard Shortcuts.

**Want to apply consistent paragraph formatting throughout your course?**

To make your design work easier and faster, you can leverage master slides for some of your paragraph formatting. For more guidance, see the tutorials on Using Slide Masters and Using Feedback Masters.
Using the Format Shape or Format Picture Window

Storyline allows you to control several aspects of an object’s appearance, including the fill, line color, line style, and shadow. If you’re working with a picture, you can also control the image attributes and color customizations. And if your object contains text, you can also control the text attributes.

These options are found on the Format Shape window (if you're working with a shape, caption, or textbox) or the Format Picture window (if you're working with a picture, screenshot, or character).

There are a few different ways to access this window:

- Select one or more objects on a slide. Then select the Format tab, and click the arrow in the lower-right corner of the Picture Styles or Shape Styles portion of the toolbar:

- Or, right-click a selected object, and then chose Format Shape or Format Picture.
• You can also reach this window from some of the formatting menus, via a “more options” choice. For example, if you select a shape, then click the **Format** tab and choose **Shape Outline > Weight**, you’ll see an option called **More Lines**, and that opens the Format Shape window.

Some of the formatting menus contain a choice for more options, which opens the Format Shape window.
When the Format window appears, you can use any of the tabs on the left side of the window to set your options.

Explore the following tutorials to learn how to use each of the options on the window.

- Fill
- Line Color
- Line Style
- Shadow
- Picture
- Text Box
Fill

This tutorial covers the Fill options on the Format Shape or Format Picture window. Here’s an overview of the other formatting options you can select on that window.

The fill options allow you to apply fills to shapes or captions that you’ve inserted on your slides. You can also apply a fill to an image, but the fill will only be visible if the image has a transparent background. Similarly, you can apply a fill to a Storyline character, but it will only affect the background area behind the character. (If you want to recolor an entire image or character, consider using the Picture options on the Format Picture window and selecting the Recolor option.)

To choose a fill, click one of the fill options listed, and then use the other fields on the window to choose the related settings.

No fill

This removes any fill from the object.
**Solid fill**

This applies a single color to the object.

You can use the Color selector to choose from among the available Theme Colors or Standard Colors. (The theme colors are controlled by your project’s design theme.)

Or, for more flexibility, choose More Colors. This opens the Colors window:

On this window, you can do any of the following:
• Click on the color you want (either a square color swatch or a color in the spectrum area).
• Or, create a custom color by entering color values in the **Hue/Sat/Lum** fields, the **Red/Green/Blue** fields, or the **Html** field.
• Or, use Storyline’s color picker to choose a custom color from anything viewable on your screen. To do that, click the eyedropper button in the lower-right of the window, hover over any area of your screen, and click to choose a color.

If the color you’ve chosen is something you want to save for easy selection later, click **Add to Custom Colors**. The color will get added to the bank of Custom Colors in the lower-left area of the window.

Click **OK** on the **Custom Colors** window once you’ve chosen a color.

Click **Close** on the **Format Shape** window to apply the color to your object.

**Gradient fill**

This applies a gradient, which is a fill containing a series of colors that blend into one another across the shape.

You can use the **Preset colors** selector to choose from several ready-made gradients, or use the other fields on the window to set up your own gradient. If you choose to set up your own, here are the fields you’ll use:

• **Type**: Choose **Linear**, **Radial**, **Rectangular**, or **Path**. (**Path** means that the path of the gradient follows the perimeter shape of the object.)
• **Direction:** If you chose anything but **Path** for the gradient type, you can use the **Direction** field to choose from one of the preset directions.

• **Angle:** If you chose **Linear** for the gradient type, this selector allows you to customize the angle of the gradient.

• **Gradient Stops:** You’ll use a gradient stop for each color you want to include in your gradient. You can add and remove gradient stops by clicking **Add** or **Remove**. For each gradient stop, choose:

  • **Stop Position:** Drag the slider or enter a percentage to indicate where you want the new color to start.
  • **Color:** Choose from the colors shown, or select **More Colors** to choose a custom color.
  • **Transparency:** Drag the slider or enter a percentage.
  • **Rotate with shape:** Mark this box to keep the gradient aligned to the object’s orientation if the object is rotated.

Click **Close** to apply your gradient to the object you chose.

**Picture or texture fill**

This applies a texture or image as a fill on the object you’ve selected.

• **Texture:** Use this selector to see the built-in texture choices available. If you see something you like, just click to apply it.

• **Insert from:** If you’d prefer to use an image of your own, rather than one of the built-in texture choices, click **File** to browse to the image you’d like to use, or click **Clipboard** to use the current contents of your clipboard as the fill.
• **Tile picture as texture**: This affects the way the image or texture gets tiled, or repeated, within your object. If you *don’t* mark this box, the image will stretch to fill your object. If you *do* mark this box, Storyline will tile multiple copies of the same image as a texture within the object. Depending on your choice, you’ll see some different options below the checkbox.

If you tile the picture as a texture, you’ll see these options:

- These shift the fill horizontally (X) or vertically (Y)
- Applies a mirror or flip to every other tile
- These scale the fill horizontally (X) or vertically (Y)
- Determines where the tiling begins

If you *don’t* tile the picture as a texture, you’ll see the following. (Higher percentages will stretch the fill away from the indicated edge; lower numbers stretch *it toward* the indicated edge. For example, if you increase the **Left** percentage, the fill will stretch rightward, away from the left edge.)

- **Transparency**: Drag the slider or enter a percentage.
- **Rotate with shape**: Mark this box to keep the fill aligned to the object’s orientation if the object is rotated.

Click **Close** to apply the picture or texture fill to the object you chose.
Pattern fill

This applies a patterned fill to the object you’ve selected.

Choose one of the patterns shown on the window, and then use the Foreground Color and Background Color selectors to choose from among the available Theme Colors or Standard Colors. (The Theme Colors are controlled by your project’s design theme.) In either selection list, if you don’t see a color you want, you can choose More Colors to specify a custom color.
"Slide background fill"

This fills the object with whatever has been applied to the slide's background. For help with customizing slide backgrounds, check out this tutorial.
Line Color

This tutorial covers the Line Color options on the Format Shape or Format Picture window. Here’s an overview of the other formatting options you can select on that window.

This is where you can control the color of the outline on the object you’ve selected. Click one of the options listed:

**No line**

This removes the line from the object.
Solid line

This applies a single color to the line. You can use the Color selector to choose from among the available Theme Colors or Standard Colors. (The theme colors are controlled by your project's design theme.)

Or, for more flexibility, choose More Colors. This opens the Colors window:

On this window, you can do any of the following:

- Click on the color you want (either a square color swatch or a color in the spectrum area).
- Or, create a custom color by entering color values in the Hue/Sat/Lum fields, the Red/Green/Blue fields, or the Html field.
• Or, use Storyline’s color picker to choose a custom color from anything viewable on your screen. To do that, click the eyedropper button in the lower-right of the window, hover over any area of your screen, and click to choose a color.

If the color you’ve chosen is something you want to save for easy selection later, click **Add to Custom Colors**. The color will get added to the bank of Custom Colors in the lower-left area of the window.

Click **OK** on the **Custom Colors** window once you’ve chosen a color.

Click **Close** on the **Line Color** window to apply the color to your object’s outline.

**Gradient line**

This applies a gradient, which is a series of colors that blend into one another across the line.

You can use the **Preset colors** selector to choose from several ready-made gradients, or use the other fields on the window to set up your own gradient. If you choose to set up your own, here are the fields you’ll use:

• **Type**: Choose Linear, Radial, Rectangular, or Path. (Path means that the path of the gradient follows the perimeter shape of the object.)
• **Direction**: If you chose anything but Path for the gradient type, you can use the **Direction** field to choose from one of the preset directions.
• **Angle**: If you chose Linear for the gradient type, this selector allows you to customize the angle of the gradient.
• **Gradient Stops**: You’ll use a gradient stop for each color you want to include in your gradient. You can add and remove gradient stops by clicking **Add** or **Remove**. For each gradient stop, choose:
  • **Stop Position**: Drag the slider or enter a percentage to indicate where you want the new color to start.
  • **Color**: Choose from the colors shown, or select **More Colors** to choose a custom color.
• Transparency: Drag the slider or enter a percentage.

Click Close to apply your gradient to the outline of the object you chose.
Line Style
This tutorial covers the Line Style options on the Format Shape or Format Picture window. Here’s an overview of the other formatting options you can select on that window.

This is where you can control the appearance of the outline on the object you’ve selected. Here are your options:

**Width**
Type a width, in pixels, or use the arrows to increase or decrease the line width.

**Compound type**
Use the selector to choose a style composed of multiple lines, if you like.

**Dash type**
Use the selector to choose a dashed line style, if you like.
**Cap type**

Use the selector to choose your preference for the line endings. **Flat** means there is no cap added to the line ending at all. **Square** and **Round** each add a cap shape. As an example, here are three lines of identical length, each with a different cap type:

![Cap types](image)

**Join type**

Use the selector to choose the style used when two lines connect with each other. As an example, here’s what each join style looks like on the corners of a square shape:

![Join styles](image)

**Arrow settings**

If you’d like your line endings to include arrowheads, use these selectors to choose the type and size.
Shadow

This tutorial covers the Shadow options on the Format Shape or Format Picture window. Here’s an overview of the other formatting options you can select on that window.

This is where you can add and customize shadows to the object you’ve selected. Here are your options:

**Presets**

Here, you can choose one of the ready-made shadow options that Storyline provides. If you choose one, you can further customize your shadow settings with the other fields on this window.
**Color**

Use the **Color** selector to choose a shadow color from among the available **Theme Colors** or **Standard Colors**. (The theme colors are controlled by your project’s [design theme](#).)

Or, for more flexibility, choose **More Colors**. This opens the **Colors** window:

On this window, you can do any of the following:

- Click on the color you want (either a square color swatch or a color in the spectrum area).
- Or, create a custom color by entering color values in the **Hue/Sat/Lum** fields, the **Red/Green/Blue** fields, or the **Html** field.
• Or, use Storyline’s color picker to choose a custom color from anything viewable on your screen. To do that, click the eyedropper button in the lower-right of the window, hover over any area of your screen, and click to choose a color.

If the color you’ve chosen is something you want to save for easy selection later, click Add to Custom Colors. The color will get added to the bank of Custom Colors in the lower-left area of the window.

Click OK on the Custom Colors window once you’ve chosen a color.

**Transparency, Size, Blur, Angle, and Distance**

For any of these options, drag the slider or enter a value in the field.
Picture

This tutorial covers the **Picture** options on the **Format Shape** or **Format Picture** window. Here’s an overview of the other formatting options you can select on that window.

The following picture options are available for images, characters, and screenshots. They’re also available for other objects (such as shapes and captions) to which you’ve applied a picture or texture as the object’s **fill**.
**Recolor**
The Recolor options allow you to quickly apply a different color, brightness, and contrast to your picture.

- **Preset:** Use this selector to alter the color of the picture. The choices you see here are complementary to your course's theme colors, which are part of your course's design theme.

- **Brightness, Contrast, and Transparency:** Click and drag the slider for any of these options, or enter a value in the corresponding field to the right of the slider, to change the picture's brightness, contrast, or transparency.
**Blend**

The **Blend** options give you even more tools for changing the color qualities of an image. To apply a color blend, first choose the color you want to use. Then, choose a blend mode, which tells Storyline how you want the color to affect the image.

- **Color**: Use this selector to choose a color from among the available **Theme Colors** or **Standard Colors**. (The theme colors are controlled by your project’s design theme.) For additional color choices, you can click **More Colors**. This opens a window where you can select or enter a custom color.

- **Mode**: Use this selector to choose the way the color affects the image you’re working with.

You’ll probably want to experiment with different combinations of colors and modes until you find the look you want to use. As an example, here’s an image in its untouched form, and with a standard green color applied as various color modes:

![Here’s the original image:](image)

Here’s the same image after applying several different color blend modes (using a standard green color):

- **Darken**
- **Linear Burn**
- **Color Dodge**
- **Soft Light**
- **Pin Light**
- **Multiply**
- **Lighten**
- **Linear Dodge**
- **Hard Light**
- **Difference**
- **Color Burn**
- **Screen**
- **Overlay**
- **Linear Light**
- **Exclusion**
Text Box

This tutorial covers the Text Box options on the Format Shape window. Here’s an overview of the Format Shape window and the other options you can select on it.

Text box options are only available on text boxes, shapes, and captions. The options will be grayed out for other objects such as images, screenshots, and characters.

![Format Shape window](image)

**Vertical alignment**

This allows you to control how high or low the text sits within the item that contains it.
**Text direction**
For any of these options, drag the slider or enter a percentage value in the field.

**Autofit**
The *Autofit* function allows you to control what happens if the text you type in a text box, shape, or caption is too big to fit within the object. You can choose one of the following options:

- **Do not Autofit**: This causes the text to overflow the object if there is too much to fit.
- **Shrink text on overflow**: This causes the font size to automatically adjust so that the text fits within the object.
- **Resize shape to fit text**: This causes the object to automatically resize to accommodate the volume of text.

**Internal margin**
These settings allow you to control the margin, or padding, within the text box, shape, or caption.

**Wrap text in shape**
Leave this box marked if you want text to wrap within the text box, shape, or caption.
Ordering, Grouping, Sizing, and Positioning Your Objects

Storyline provides lots of tools to help you order, group, ungroup, resize, and position objects on your slide. Check out the following features.

Ordering objects

If you overlap items on your slide, they'll be layered in the same order you inserted them. You can change that order by doing any of the following once you select an object:

- On the Home tab, click Arrange. Then, select Bring to Font, Send to Back, Bring Forward, or Send Backward.

- Or, on the Format tab, use the Bring Forward or Send Backward options. Click the arrow next to either option to Bring to Front or Send to Back, respectively.
• Or, use the Timeline that appears below your slide. (If the Timeline tab isn't visible, click the Timeline, States, and Notes bar at the bottom to expand it.) All the elements on your slide will be listed in the timeline, in the same order in which they're layered on your slide. Topmost items are closest to the front, or top, layer of the slide. To change the layering order, just select an item on the timeline and drag it up or down in the list.

![Timeline](image)

Click and drag an object up or down in the Timeline list to change the layer order.

• Or, right-click an object and choose Bring to Front or Send to Back.

![Context menu](image)
**Grouping objects**

Grouping is a handy feature that allows you to move, resize, rotate, flip, or change other attributes of several objects all at the same time—as if they were a single object.

To group items, you'll first need to select the items that you want to be grouped. You can do this with Shift-Click, Ctrl-Click, or by clicking and dragging a selection area around the items.

Once your items are selected, you can group them by doing any of the following:

- On the **Home** tab, click **Arrange** and choose **Group**.

- Or, on the **Format** tab, click the **Group** option and choose **Group**.
• Or, right-click the selected items and choose **Group**.

You can **ungroup** items by selecting them and doing any of the following:

- On the **Home** tab, click **Arrange** and choose **Ungroup**.
- Or, on the **Format** tab, click **Group** and choose **Ungroup**.
- Or, right-click the grouped items and choose **Group** and then **Ungroup**.
- Or, press **Ctrl+Shift+G**.

If you select an item that was previously part of a group, you can also **regroup** it to the items it was previously grouped with:

- On the **Home** tab click **Arrange** and choose **Regroup**.
- Or, on the **Format** tab, click **Group** and choose **Regroup**.
- Or, right-click the selected item and choose **Group** and then **Regroup**.

**Aligning, positioning, rotating, and sizing objects**

It's easy to position objects on your slide by just clicking and dragging them to the place where you want them to appear. But if you want more control over the way they're aligned, positioned, rotated, or sized, there are plenty of options. Select the item(s) on your slide that you want to work with, and check out these features:

**Aligning objects**

You can align your objects with one another, or with the slide itself:

1. On the **Home** tab, click **Arrange** and choose **Align**. Or, on the **Format** tab, choose **Align**.
2. Choose your alignment preference:
• **Align to Slide**, or
• **Align Selected Objects** (this choice will only be available if you've selected multiple objects rather than a single object)

3. Now choose one of the alignment options (left, center, right, top, middle, or bottom). Or, if you'd rather space the items evenly, you can instead choose **Distribute Horizontally** or **Distribute Vertically**.
Rotating objects
To rotate a selected item on your slide, you can hover over the green handle till it turns into a curved arrow, and then click and drag.

Hover over the green handle, then click & drag to rotate

Or, for more control over the exact degree of rotation, you can do this:

1. On the Home tab, choose Arrange and then Rotate. (Or, on the Format tab, choose Rotate.)
2. Choose one of the options listed, or choose More Rotation Options to enter a specific rotation value.
3. If you choose **More Rotation Options**, you'll see the following window. (Another way to get to this window is by selecting an object on your slide, right-clicking it, choosing **Size and Position**, and choosing the **Size** tab.) Enter a value in the **Rotation** field or use the arrows to increase or decrease the value. Click **Close** when you're done.

Sizing objects
To customize the size of objects on your slide, you can select the objects and drag the handles. Here are some tips on resizing if you use this approach:

- To preserve the aspect ratio while resizing, hold down your **Shift** key while dragging a corner handle.
- To resize opposite sides of an object equally, hold down your **Ctrl** key while dragging a side handle.

If you need more control over an object’s exact size, you can select the object, click the **Format** tab, and enter your preferred values in the **Height** and **Width** fields.

If you have multiple objects that you want to size equally, you can do the following:

1. Select all the objects you want to re-size.
2. On the **Home** tab, choose **Arrange** and then **Size**.
3. Choose one of the options listed.

You might also want to explore:

Using the Size and Position Window
Setting Your Grid, Guide, and Ruler Preferences
Using the Size and Position Window

Storyline’s Size and Position window allows you to control any object’s height, width, rotation, scaling, cropping, and its position on the slide. The Size and Position window is also where you can enter alternative text (often called alt text) for any object. Alt text is important for learners with visual impairments who rely on a screen reader to announce the name or description of objects on your slides.

There are a few different ways to access the Size and Position window:

- Select one or more objects on a slide. Then select the Format tab, and click the arrow in the lower-right corner of the Size portion of the toolbar:

- Or, right-click a selected object, and then choose Size and Position.
When the Size and Position window appears, click the **Size, Position, or Alt Text** tab at the left edge of the window to set your options.

**Size**

- **Height** and **Width**: In these fields, you can enter a different value, in pixels, to change the height or width of the object. If the **Lock aspect ratio** box is marked and you change an object’s height, then Storyline automatically changes the width—and vice versa—to keep the object’s proportions. Also, anytime you change an object’s height or width, the height and width percentages in the **Scale** portion of the window will change automatically.

**Tip:** Another way to quickly change an object’s height or width is to select the object, click the **Format** tab, and enter values directly in the **Size** fields on the toolbar:
• **Rotation:** Use this field to enter a rotation value, in degrees. You can enter a number or use the arrows to increase or decrease the value. A positive number rotates the object clockwise; a negative number rotates it counterclockwise. The rotation option is available on any object except movies.

**Tip:** Another way to rotate an object is to select the object, hover over the green handle till the cursor changes to a curved arrow, and then click and drag.

![Hover over the green handle, then click & drag to rotate](image)

- **Scale Height and Scale Width:** These fields give you another way to change the height or width of an object. You can enter a different percentage in either field, or use the arrows to increase or decrease the value. If the **Lock aspect ratio** box is marked, and you change the scale height, then Storyline automatically changes the scale width—and vice versa—to keep the object’s proportions. Also, anytime you change an object’s scale height or scale width, the actual pixel height and width in the top part of this window will change automatically.

- **Lock aspect ratio:** This keeps the object’s proportions (the ratio of height to width) even if you resize the object.

- **Crop from Left, Right, Top and Bottom:** These fields allow you to crop the object by a specific number of pixels. The cropping options are only available on pictures, screenshots, and characters.

**Tip:** Another way to crop is to select the object, click the **Format** tab, and click the **Crop** button on the toolbar. Then drag the black handles that appear on the edges of your object to crop it.
• **Reset**: This button allows you to reset the object to its original size.

**Position**

Although it's easy to move an object on your slide by just clicking and dragging it, sometimes you might want more control over its exact position. The **Position** fields on the **Size and Position** window allow you to specify exactly where the object appears on the slide. Use the **Horizontal** and **Vertical** fields to enter a pixel value, and then use the **From** selectors to indicate the relative location.

![Size and Position window](image)

**Alt Text**

The **Alt Text** section of the **Size and Position** window is where you can enter preferences that affect screen readers and keyboard navigation.

When a learner uses a screen reader or presses the Tab key to navigate through the items in your course, the content is read from the top-left of the player to the bottom-right. Screen readers announce each object on the slide according to the object names on the Storyline timeline. There are two ways you can customize this behavior:

- **Object is visible to accessibility tools**: You can unmark this box if you prefer that the object not be detected by screen readers nor keyboard (Tab) navigation. A common situation when you might do this is if you have objects on your slide that are purely part of the slide's aesthetic design—for example, rectangles or lines that create visual boundaries on your slide—and which don't contribute to the content's meaning.
• **Alternative text:** If you’d like screen readers to use a name or description that’s different from whatever name appears for the selected object on the Storyline timeline, enter that alternate text here.
Setting Your Grid, Guide, and Ruler Preferences

The design grid, drawing guides, and ruler in Storyline makes it easier to position and align objects on your slide. In this tutorial we’ll look at how to set your preferences for these features.

Displaying the design grid

The design grid is a series of horizontal and vertical dotted lines that display on your slide while you’re editing. The grid won’t appear in your published output; it’s only visible to you as the designer while you’re building or editing your slides. Here’s an example of what the grid looks like on a slide:

![A slide with the design grid showing](image)

There are a few different ways to make the grid visible:

- On the View tab, mark Gridlines.
- Or, press Shift+F9 on your keyboard.
- Or, select any object and, on the Home tab, choose Arrange, then Align, then View Gridlines.
- Or, with an object selected, click the Format tab, choose Align, and select View Gridlines.
- Or, right-click in your slide workspace, choose Grid and Guides, mark Display grid on screen, and click OK.

You can turn the grid off by using the same steps.
Changing your grid settings

To set your preferences for the way gridlines display, you'll use the Grid and Guides window, shown below. You can get to this window by doing any of the following:

- Select an object, click the Home tab, and choose Arrange, then Align, then Grid Settings.
- Or, select an object, click the Format tab, choose Align, and select Grid Settings.
- Or, right-click in your slide workspace, and choose Grid and Guides.
- Or, on the View tab, click the small arrow in the lower-right corner of the Show section of the ribbon.

Here are the options you can set on the Grid and Guides window:

- **Snap options**: Mark either or both of these boxes to cause objects to snap to the gridlines or snap to other objects when you rearrange things on your slide. (If you turn either of these options on, and you need to move an object without snapping it, you can hold down your keyboard’s Alt key while dragging the object. This temporarily disables snapping. When you release the Alt key, the snap function will turn back on again.)
- **Spacing**: Under Grid settings, use the Spacing field to enter a value for the grid spacing, or use the arrows to increase or decrease the value.
- **Display grid on screen**: Use this box to turn the grid on or off.
- **Display drawing guides on screen**: Drawing guides are useful line rules that you insert on your slide to help align objects. They won’t appear in your published output; they’re only visible when you’re editing your slides. The drawing guides you add to any slide will appear on other slides within the same project too. See below for more on how to add, adjust, and remove guides.
- **Display smart guides when shapes are aligned**: Smart guides are temporary visual guidelines that appear when you’re moving objects around and two objects come into alignment with each other. They disappear as soon as you release your mouse button to place the object where you want it. Mark the box if you want them to appear, or unmark the box if you don’t want to use smart guides.
- **Set as Default**: Click this button if you’ve changed the settings on the Grid and Guides window and want these settings to apply to other Storyline projects that you open.
**Drawing guides**

Drawing guides are useful line rules that you can insert on your slide to help align objects. Just like the design grid, drawing guides won't appear in your published output. They're only visible when you're building or editing your slides. You can turn drawing guides on or off in the **Grid and Guides** window shown above, using the checkbox called **Display drawing guides on screen**. Or, you can go to the **View** tab, and mark **Guides**.

When you turn drawing guides on, two centered guidelines (one horizontal and one vertical) will appear on your slide, like in this example:

- **To move a guide**: Just click and drag a guide to move it. When you do, an arrow and a small box appear, showing the number of pixels you've moved it. Positive numbers indicate a rightward or upward position (as compared to the slide's center), and negative numbers indicate leftward or downward.
• **To create a new guide**: You can add another drawing guide to your slide by holding down your Ctrl key while clicking and dragging an existing guide. The existing guide will stay put, but a new one will appear where you drag. Release your mouse button when the guide's in the position you want.

• **To remove a guide**: If you've created a drawing guide that you no longer want to use, just click and drag it on top of an existing guide, and it'll disappear.

**The Storyline ruler**

The Storyline ruler is another handy alignment tool, because it makes it easy to position drawing guides in exactly the right place. It also makes it easier to add shapes right where you want them. When you display the ruler, it appears on the top and left edges of your slide. Anytime you move your mouse or a drawing tool around on the slide, or when you change the position of a drawing guide, its movement is traced on the ruler.

The ruler displays on the top and left edges of your slide.
To turn on the ruler on or off, do either of the following:

- Go to any slide and click the **View** tab. Then mark the **Ruler** box.

![View tab with Ruler box marked]

- Or, right-click in your slide workspace and choose **Ruler**.
Applying Quick Styles

Quick styles are a handy way to quickly change an object’s fill color, font, outline, and effect. To apply a quick style, do this:

1. Select an object and choose **Quick Styles** from the **Home** tab.
2. The color choices you see will depend on the **Design Theme** you’ve chosen for your project. Hover over the quick style options available. Your object will change as you do this, to show what that quick style would look like when applied to your object.
3. Click a choice to apply a quick style to your object.

---

*You might also want to explore:*

[Adjusting Properties for Shapes, Captions, and Text Boxes](#)

[Adjusting Properties for Pictures, Screenshots, and Characters](#)
Creating a Zoom or Pan Effect

In Storyline, a **Zoom Region** allows you to magnify a specific area of your slide at any point in the slide’s duration. This is a great way to draw your learner’s attention to important content—whether it’s a specific part of an image or a video, an object, a character, a bit of text, or anything else you've inserted on your slide.

For example, suppose your slide contains an image of a machine control panel, and you want to emphasize a critical switch on the panel when the narrator describes it. Or, maybe your slide contains a video of a software demo, and you want to zero in on a particular field at a certain time. The zoom feature is great for situations like these!

The zoom feature is also a handy tool for creating a more cinematic feel in e-learning scenarios. For example, if a character in your scenario needs to make an important decision, you can use the zoom feature to zoom in on the character's face as the narrator describes what the character's thinking.

You can have as many Zoom Regions on your slide as you want, and you can even use consecutive zoom regions for a panning effect. The zoom region will always have the same aspect ratio as your slides, so that the zoomed area doesn't appear skewed or stretched.

Here's how to add and customize a Zoom Region.

1. Go to the slide where you want to insert a Zoom Region.
2. Click the **Insert** tab on the Storyline ribbon.
3. Select **Zoom Region**.
4. Storyline inserts a rectangle on your slide to represent the Zoom Region. Everything else around the Zoom Region dims temporarily, like in the picture below, to indicate you're in zoom edit mode.

5. Now you can:

   - Drag the corner handles of the Zoom Region to adjust its size.
   - Click and drag the zoom region to any place on your slide.

6. When you're done adjusting the zoom size and position, click anywhere in the grayed-out area (or anywhere off of the slide stage) to exit zoom edit mode. Your slide returns to its normal appearance and the boundary of the Zoom Region appears as a thin green outline. (This outline won't be visible to your learners—it's only there for you.)
Now you can adjust the timing of the zoom. Like any other object on your slide, the Zoom Region appears on the Storyline Timeline. It’ll always appear as the topmost item in the Timeline's list of objects. To change when the zoom starts and ends, drag the left or right boundary of the zoom within the Timeline, or drag the entire zoom item to any point on the timeline. If you need help opening or using the Timeline, check out this tutorial.

Creating a panning effect with multiple zoom regions

If you place multiple zoom regions on a slide, and then use the timeline to make one zoom begin at the same time the previous zoom ends, you’ll create cool panning effect. Here’s how to do it:

1. Insert a Zoom Region and position it on your slide where you want the zoom/pan to start.
2. Add a second Zoom Region and position it on your slide where you want the panning motion to end.
3. In Storyline’s timeline, adjust the timing of the zoom items so that the second Zoom Region starts immediately after the first.

Below is an example of how it would look on the Storyline timeline. In this example, the initial zoom starts at 1 second, then the view pans to the second zoom region at 3.5 seconds, and finally the view zooms back out at 6 seconds:

For continuous panning, you can insert even more Zoom Regions and have them appear one after the other.
Changing the zoom speed

New zoom regions that you add to your slide default to a speed of "medium," but you can adjust the speed to be faster or slower if you like. Or, you can even make the zoom instantaneous—meaning that the zoomed-in region appears immediately rather than progressing from the regular view to the zoomed view.

To change the zoom speed, right-click the zoom area on your slide and choose **Zoom Transition Speed**. Then choose one of the speed options shown:

![Zoom Transition Speed](image)

Editing or deleting a zoom region

To change the size or placement of a Zoom Region, just click its bounding area (it will appear on your slide as a thin green rectangle). Then drag the corner handles to change the size, or click and drag the entire zoom area to adjust its position.

If you have trouble seeing or selecting the Zoom Region, you can always find it in the Timeline and select it there first, so that it becomes easier to see on your slide. Any Zoom Regions you've added to your slide will always appear at the top of the list of objects in the timeline.

To delete a Zoom Region, just select it and press the delete key on your keyboard.
Inserting Slide Notes

Storyline allows you to add notes to each slide, which can be made visible in your published story. This is useful if you want to provide a transcript, supplemental information, or instructions in your course.

Adding notes

To manage notes in Storyline, you'll need to enter the notes in the Notes panel. Here's how:

1. When you're in Story View, double-click the slide you wish to edit, which will open the slide in Normal View. If you're already in Normal View, select the slide you wish to edit from the left navigation pane.
2. If the Timeline, States, and Notes panel isn't already visible below your slide, expand it by clicking the arrow in the lower right corner of the slide stage.
3. Then select the Notes tab.
4. Type the appropriate text into the Notes panel, or copy and paste text from another source. Tip: When you import a PowerPoint presentation or another Storyline story that contains slide notes, the notes from the source content will also be imported into your new story.
**Formatting notes**

You can format notes in Storyline, using many of the [text](#) and [paragraph](#) formatting options on the [Home](#) tab, such as:

- Font face
- Font size
- Bold
- Italics
- Underline
- Bullets
- Numbering
- Alignment

**Displaying Notes in your published story**

![Published example with notes](image-url)
The player for your published story can be customized to display your notes in a variety of ways. Here's how:

1. Go to the Home tab, and click the Player button.

2. The Player Properties window will open to the Features editor. To display notes in your published story, select the Notes check box.
3. By default, notes will appear as a tab in the sidebar, but, if you prefer, you can use the Up and Down arrows to move your notes to the Topbar Left or Topbar Right.

4. Click the OK button to save your changes, and then publish your story.

For more information on customizing the player, click here.
Using the Storyline Clipboard

The Storyline clipboard allows you to cut, copy, paste, and duplicate content in your course. You can also use a handy clipboard feature called the Format Painter to quickly apply attributes from one object to another. In this tutorial we’ll get acquainted with Storyline’s clipboard tools so you can speed your development time.

Cutting, copying, pasting, and duplicating entire slides or objects on them

When you’re working with slide content, either on your course slides (in Normal View) or on your slide masters (in Slide Master View or Feedback Master View), there are several things you can do with the clipboard.

1. First, select the items you want to work with:
   - To select an entire slide, click the slide thumbnail in the left column of the editing window. If you want to cut or copy multiple slides, you can use Shift+Click to select multiple consecutive slides, or use Ctrl+Click to select multiple nonconsecutive slides.
   - To select a specific item on a slide, click on that item. You can use Shift+Click or Ctrl+Click to select multiple items on the slide, or you can click and drag a bounding box around the items you want to select. You can also select objects by clicking them on the Storyline timeline. (Learn more about using the timeline [here](#).)

2. To duplicate the items you’ve selected, do any of the following.
   - Press Ctrl+D on your keyboard.
   - Or, on the Home tab, click the small arrow next to the Copy option and choose Duplicate.
3. To **cut** the selected item(s), do any of the following. When you cut an item, it'll disappear from view, but Storyline will keep it on the clipboard for pasting until you cut or copy something else.

- Press **Ctrl+X** on your keyboard.
- Or, on the **Home** tab, click the **Cut** option.
- Or, right-click the item and choose **Cut**.
4. To **copy** selected items to the Storyline clipboard, do any of the following. When you copy an item, Storyline keeps it on the clipboard for pasting until you cut or copy something else.

- Press **Ctrl+C** on your keyboard.
- Or, on the **Home** tab, click the **Copy** option.
- Or, right-click the item and choose **Copy**.

5. To **paste** the content that you've most recently cut or copied to your clipboard, do any of the following:

- Press **Ctrl+V** on your keyboard.
- Or, right-click on your slide and choose **Paste**.
- Or, click the **Paste** option on the ribbon. If an object you're pasting has some formatting related to a design theme (such as a theme color), it'll pick up the design theme from the destination where you paste it. If you want it to retain its original formatting instead, you can click the arrow at the bottom of the **Paste** option and choose **Keep Source Formatting**.
Quickly copying formatting with the Format Painter

In Normal View, Slide Master View, and Feedback Master View, the clipboard function includes a handy tool called the Format Painter. It allows you to quickly copy formatting from one object to another. This includes text formatting, as well as any attributes you've applied to images, shapes, captions, and characters. And if you've assigned any states or triggers to the item you're copying from, the Format Painter copies those too.

Here's how to use it:

1. On any slide or slide master, select the item whose formatting you want to copy.
2. Click the Format Painter (paintbrush) icon. Your cursor will change into an arrow with a paintbrush to let you know that the Format Painter is active.

3. Now click the item to which you want to apply the copied formatting.
4. The formatting gets copied and the Format Painter automatically turns off.

Want to reapply formatting to multiple items? You can double-click the Format Painter, which keeps it active until you turn it off. This way, you can continue applying the same formatting to as many items as you like. To turn the Format Painter back off again, just click the paintbrush icon on the ribbon or press Esc on your keyboard.

Using the clipboard in Story View to cut, copy, paste, and duplicate slides or scenes

The clipboard is available in Story View, too. Here's how you can use it:

1. First, select the items you want to work with:

   - To select an individual slide, click on the slide title or the slide thumbnail. You can select multiple slides by using Shift+Click to select multiple consecutive slides, or Ctrl+Click to select multiple nonconsecutive slides. When you select a slide, it'll have a yellow outline.
   - To select an entire scene, click the scene title or the gray bounding area of the scene. When you select a scene, it'll have a yellow outline.
2. To **duplicate** your selection, do either of the following.

- Press **Ctrl+D** on your keyboard.
- Or, right-click the selection and choose **Duplicate**.

3. To cut a scene or slide and place it on your clipboard:

- Click the **Cut** button on the **Home** tab.
- Or, press **Ctrl+X** on your keyboard
- Or, right-click the selected item and choose **Cut**.

4. To copy a scene or slide to your clipboard:

- Click the **Copy** button on the **Home** tab.
- Or, press **Ctrl+C** on your keyboard
- Or, right-click the selected item and choose **Copy**.

5. To paste an item from the clipboard:

- Click the **Paste** button on the **Home** tab.
- Or, press **Ctrl+V** on your keyboard.
- Or, right-click in your Story View workspace and choose **Paste**.
Inserting New Slides

Storyline provides all sorts of options for adding new content to your course via the New Slide option. Here’s how to use it to add new slides to your project:

1. If you’re in Normal View, do any of the following:
   - Click the Insert tab and choose New Slide.
   - Or, right-click in the slide thumbnails column to the left of your slide, and choose New Slide.
   - Or, press Ctrl-M on your keyboard.

2. If you’re in Story View, do any of the following:
   - Click the Home tab or the Insert tab and choose New Slide.
   - Or, right-click in the Story View workspace and choose New Slide.
   - Or, press Ctrl-M on your keyboard.
3. The **Insert Slides** window appears. Here, you can click an option from the left edge of the window.

Choose an option for the type of slide you want to insert

Here's a bit more about each of the choices, and links to the tutorials that walk you through how to use them:

- **Templates**: The Articulate community offers several templated layouts specifically designed for e-learning courses, and you can find them here. This is also where Storyline keeps copies of any course of your own that you've saved as a Storyline template. Templates are a great way to leverage and re-use existing content.

- **Basic Layouts**: The options here are based on the Slide Masters and Slide Layouts associated with the project that's currently open. Storyline comes with several default layouts you can use, but you can also customize the layouts and add new ones.

- **Quizzing**: This option allows you to insert a graded question, a survey question, or one of several freeform-style interactions (including popular options such as drag-and-drop and hotspot). You can also use this option to insert questions from an existing Question Bank or to insert a result slide that shows learners how they performed on your quiz questions.

- **Screen Recordings**: Choose this option to create and insert a video of anything on your screen. Your screen recording can be a simple movie that learners watch as part of your course, or it can be an interactive video that allows learners to try or test their knowledge by clicking specific areas or entering data.
• **Import**: Use this option to import content from an existing PowerPoint file, an Articulate Quizmaker quiz, an Articulate Engage interaction, or another Storyline project. Find more details on how to work with imported content here.

**You might also want to explore:**

*Using the Storyline Clipboard* (the clipboard allows you to duplicate or copy/paste slides from your existing ones)
Using and Creating Storyline Templates

The Templates feature in Storyline makes it super quick and easy to take advantage of ready-made slide layouts and content, or to share scenes and slides with other course developers.

Storyline comes with several templates you can take advantage of right away, but you can also save any Storyline project of your own as a template. A template includes the content of all slides and scenes within that project—in other words, all the slide objects, audio, video, animations, triggers—everything that you’ve inserted on a particular slide is reusable when you use templates.

In this tutorial, we'll look at how to apply a project template and how to save your own projects as templates.

**Using Storyline templates**

Here's how to see what templates are available in your template library, and how to apply them in your course:

1. From Normal View or Story View, click the Insert tab and choose New Slide.
2. Choose the Templates tab on the left edge of the window.
3. Use the **Template** selector at the top of the window to choose a template. The list includes some cool (and free!) templates that come with Storyline, as well as any projects of your own that you've saved as templates.

4. Once you choose a template, the slides within that template will appear in the selection area. Click the ones you want to insert in your course. You can use **Shift+Click** to select a series of consecutive slides, or use **Ctrl+Click** to select multiple nonconsecutive slides. If the template has multiple scenes, you can click the triangle next to any scene title to collapse or expand the view.

5. Use the **Insert into scene:** selector at the bottom of the window to choose how you want to insert the selected slides.
   - **Current Scene:** This adds the slides to the current scene.
   - **Same as imported template:** This adds the slides to your project, using the same scene structure as the template you're importing from.
   - **New Scene:** This creates a new scene in your project and adds the selected slides to it. If you choose this option, you'll also be able to customize the scene name. A **Scene** field appears to the left of the **Import** button where you can enter the scene name.

6. Click **Import** to add the selected content to your project, and then customize away!
How to save a project as a template

Saving a project as a template is really easy, too. This is a good way to preserve reusable content or create a boilerplate course that other e-learning developers can use as a starting point for their own courses. Here's how to save a project as a template:

1. Open the course you want to save as a template.
2. Click the Articulate button in the upper-left corner of your Storyline window.

3. Choose Save As.
4. Navigate to the location where you want to save the file.
5. Use the Save as type selector to choose Storyline Template (*.storytemplate).

Now that you've saved your .storytemplate file, you can pass the file along to other course developers if you like, or post it in the E-Learning Heroes forums for other Storyline users. Whoever wants to use the file can then follow the steps below to create content from your template. Storyline also adds a copy of the template in your template library, which is maintained in the folder called 'My Articulate Projects\Storyline Templates.'

How to use a template that someone else gives you

When another developer gives you a .storytemplate file, follow the steps below to launch it. (You only need to do it this way once—after you've launched a template the first time using the steps below, Storyline adds a copy of the file to your template library, so that you can access it easily later.)
1. Launch the file by doing any of the following:

- Double-click the file from Windows Explorer.
- Or, if the file was sent to you as an email attachment, you can double-click the attachment.
- Or, from the Storyline launch screen, under **Create a new project**, click the option **From project template**. Then navigate to the template file and select **Open**.

![Storyline launch screen with From project template option highlighted](image)

2. Storyline displays a window where you can choose which scenes or slides you want to use from that template. Use **Shift+Click** to select a series of consecutive slides, or use **Ctrl+Click** to select multiple nonconsecutive slides. If the template has multiple scenes, you can click the triangle next to any scene title to collapse or expand the view.

3. Use the **Insert into scene** selector at the bottom of the window to choose how you want to insert the selected slides:

- **Same as imported template**: This adds the slides to a new project, using the same scene structure as the template.
- **New Scene**: This creates a new scene in a new project, and adds all the selected slides to it. If you choose this option, you'll also be able to customize the scene name. A **Scene** field appears to the left of the **Import** button where you can make whatever changes you like.

4. Click **Import** to add the selected content to your project.

When you do this, Storyline inserts the selected content into your project. It also adds a copy of the template to your template library. (The default location for Storyline templates is a folder called \My Articulate Projects\Storyline Templates.) Anytime you want to reuse content from a Storyline template, you can do that easily from Storyline's **Insert** menu by following the steps at the beginning of this tutorial.
How to delete or rename templates in your template library

Storyline maintains your template files in the folder called ‘My Articulate Projects\Storyline Templates’. You can use Windows Explorer to rename or delete these files if necessary. Any changes you make will be reflected in your template library when you choose Insert > New Slide > Templates in Storyline. (Deleted templates will no longer appear there, and renamed templates will appear under the new name you’ve given them.)
When you need to add a new slide to your Storyline project, you can start with one of the Basic Layouts. These are slide layouts that are organized by theme. Here's how to insert a new slide by using the Basic Layouts available:

1. From Normal View or Story View, click the Insert tab and choose New Slide.
2. Choose the Basic Layouts tab on the left edge of the window. Storyline displays the layouts associated with any theme currently being used in your project.

On this window, Storyline displays the layouts of any theme currently being used in your project.
3. Select the slide layout you want to use for the new slide you're inserting. You can click the triangle next to any theme name to collapse or expand the view.
4. Click **Insert** to insert the new slide.

Storyline inserts the new slide in your course, using the layout you chose. If there are placeholders on the layout, you can click them to customize your slide with whatever content you like.

**How to add themes of your own to the Insert Slides window**

To add more themed slide layouts to the Basic Layout choices, you can do either of the following:

- Go to Normal View for any slide. On the **Design** tab, select one of the ready-made design themes by right-clicking the theme and choosing **Apply to all slides** or **Apply only to this slide**. Once you do, all the layouts associated with that theme will become available on the Basic Layouts section of the Insert Slides window.

- Or, create and apply a new theme within the current project, using the guidelines in this tutorial. Any layouts that you create as part of a new theme will be available in the Basic Layouts section of the Insert Slides window.

**You might also want to explore:**

*Using and Creating Storyline Templates*
Controlling a Slide’s Advance Behavior and Other Slide Properties

You can customize the properties for any slide in your story, including how the slide advances, what happens when users revisit it, and which player controls are visible.

To access slide properties, do either of the following:

- In **Story View**, select the slide(s) you wish to modify, and then use the **Slide** panel in the lower right corner to select your options.
• Or, in Normal View, click the small gear icon to the right of the base layer's name in the Slide Layers panel.

Tip: If you want to make the same property changes to multiple slides at one time, use Story View. Then use any of the following methods to select multiple slides:

• SHIFT+click to select a series of consecutive slides
• CTRL+click to select non-consecutive slides
• CTRL+A to select all slides in a particular scene (you have to click on a slide in that scene first)
• CTRL+A twice to select all slides in the entire project (you have to click on a slide first)

Then use the following options to change specific properties for the selected slide(s):

**Slide advances**

Choose whether slides will advance Automatically or By User. By default, slides will advance By User.
**When revisiting**

This property determines how objects on the slide behave if users revisit the slide later. Choose from the following options:

- **Automatically decide**: This is the default choice, and it means Storyline will decide automatically whether to resume or reset the slide when users view the slide again later. Here’s the logic: If the slide contains just simple objects and/or audio but no interactivity, Storyline *resets* the slide to the beginning of the slide’s timeline each time users view the slide. However, if the slide contains any interactive elements, such as buttons or any other object that includes a visited or selected state, Storyline *resumes* at the slide’s current state if users view the slide more than once.

- **Resume saved state**: Use this option if you *always* want the slide to remember the state it was in previously when users return to it. In other words, this allows users to pick up where they left off if they leave the slide and come back to it.

- **Reset to initial state**: Use this option if you *always* want the slide to reset to its *initial* state when users return to it. This means every time users view the slide, it will restart at the beginning of the slide’s timeline, and any interactive objects will return to their initial states.
**Results slide**

This property only pertains to quiz slides, so it won't be visible for content slides. It allows you to specify which result slide will report the score for the selected quiz slide(s). If there are no result slides to choose from, you can add one.

**Slide navigation controls**

Use the check boxes to specify whether you want Prev, Next, and/or Submit buttons to appear on the selected slide(s). By default, content slides will have Prev and Next buttons, while quiz slides will have Submit buttons.
Player features

By default, each slide will include the features that you selected for the player. However, you can customize which player features appear on each slide by selecting "Custom for this slide" from the Player features drop-down list.

Then choose from the following features:

- Menu
- Resources
- Glossary
- Notes
- Seekbar
If you change your mind, you can revert back to the player defaults by clicking **Reset**. This also causes the Prev and Next buttons to be selected for content slides, and the Submit button to be applied to quiz slides.

**Assigning default player features**

To change the default player features for your entire project:

1. Click the **Player** button on the **Home** tab.
2. When the **Features** editor opens, select the features that you want to apply to the whole project. To learn more about the various player features and how to rearrange them, [click here](#).

3. Click the **OK** button to save the changes to your player.

**You might also want to explore:**

*Adding and Editing Slide Layers*
Using the Timeline

In Storyline, use the timeline to arrange and animate objects, so they appear in the right places at the right times. Here's how:

**Opening the timeline**

If the **Timeline, States, and Notes** panel isn't already visible, here's how you can open it:

1. When you're in **Story View**, double-click the slide you wish to edit. Or, when you're in **Normal View**, select the slide you wish to edit from the left navigation pane.
2. Click the arrow in the lower right corner of the slide stage to expand the **Timeline, States and Notes** panel.
3. Select the **Timeline** tab.

**Resizing the timeline**

You can expand the Timeline panel to make it easier to work with numerous objects, or you can make the Timeline panel smaller to give yourself more room for the slide stage. Simply hover your mouse over the boundary between the Timeline panel and the slide stage. When it changes to a two-headed arrow, drag the boundary up to expand the Timeline panel, or drag the boundary down to make the Timeline panel smaller.
Rearranging objects

All the objects on your slide will be listed on the timeline, including images, shapes, audio, and video. These objects will be listed in the same order in which they are layered on the slide, with the topmost item in the list being at the front (or top) of the slide.

To change the order of objects on a slide, select an item on the timeline and drag it up or down to its new location.

Drag object up or down to change order

Hiding and unhiding objects

When there are numerous objects on a slide, you may find it useful to hide some of them, so you can focus on certain elements. To hide an object, click the eye icon that appears to the left of its name on the timeline. Click the eye icon again to unhide it.

Be aware that hidden objects will not appear in your published output, so remember to unhide them before your publish.
**Locking objects**

You can lock objects to prevent them from accidentally being moved or modified while you are working with other items on your slide. To lock an object, click the empty box to the left of its name on the timeline. A **padlock icon** will appear, which indicates that the object has been locked in place. To unlock an object, click the **padlock icon**.

**Renaming objects**

It can be very useful to give objects on your slide easily recognizable names, especially when working with Freeform Questions. To rename an object, simply double-click its current name (or right-click and select Rename), which opens an editable text field. Then type a user-friendly name for your object, and press the **Enter** key on your keyboard to save the change.
If your object names are too long to fully display on the Timeline tab, you can hover your mouse over the vertical line that divides the Timeline tab and the top of the actual timeline until a two-headed arrow appears. Then drag the dividing line to the right to widen the Timeline tab until your object names are no longer truncated.

Drag timeline tab to the right to widen it

Expanding grouped objects and multi-item quiz answers
When you group objects together, they appear as a single object on the timeline. Likewise, many of the question slides in Storyline automatically group answer choices together as a single object on the timeline.
However, you can expand the group to work with the individual elements of the group on the timeline. This is helpful if you want to rename, reorder, or animate each element in the group separately. To expand the grouped object or answer choices, click the triangle that appears to the left of the answer group on the timeline. Click the triangle again to collapse the group.

**Changing the timing of objects on your slide**

To change when an object appears on the slide, drag it left or right along the timeline.
You can also adjust the duration of an object if you want it to disappear before the end of your slide. Simply drag the right edge of that object along the timeline until you reach the point at which you want it to disappear (or animate out).

Drag the edge of an object to change duration

Additional options for managing the timing of an object can be found by right-clicking the object on the timeline and selecting one or more of the following:

- **Align to Cue Point**: moves the object along the timeline so that its starting point lines up with the Cue Point # that you select. For more information about using cue points, see [this tutorial](#).
• **Align To Playhead**: moves the object along the timeline so that its starting point lines up with the current position of the playhead (red vertical line).

• **Show Until End**: displays the object until the end of the slide
- **Show Always**: displays the object for the entire duration of the slide

- **Timing**: allows you to specify the **Start Time** and **Duration** of the object (in seconds)
Managing cue points

Cue points allow you to precisely align objects on the timeline. They’re useful for synchronizing your animations to appear at specific times. Find out more about synchronizing animations here.

You can add, delete, and move cue points on the timeline. Here’s how:

- To add a cue point, right-click anywhere in the Timeline panel and select Create Cue Point At Playhead. Or, to add cue points on-the-fly, click the Play button in the lower-left of the timeline, and then press C on your keyboard at any point where you want to insert a cue point.

- To delete a cue point, right-click the cue point marker on the timeline and select Delete Cue Point.
• To delete all cue points on a slide, right-click anywhere within the **Timeline** panel and select **Delete All Cue Points**.

• To move a cue point, drag it left or right along the timeline.

**Zooming the view of the timeline**

To get a closer look at a portion of the timeline, drag the zoom slider, which is located in the lower left corner of the timeline, to the right. To zoom out, drag the zoom slider to the left.
**Previewing your slide using the timeline controls**

You can preview a slide using the player controls in the lower left corner of the timeline:

- Click the **Play / Pause** button once to start the playhead (red vertical line) moving along the timeline.
- Click the **Play / Pause** button again to pause the playhead at its current location.
- Click the **Stop** button to end the preview and return the playhead to beginning of the timeline.

**Working with audio**

There are a couple of timeline options that pertain only to audio that you may find helpful. When you right-click an audio track in the timeline, you'll see the following options:

- **Audio Editor**: opens the Audio Editor. To learn how to use the Audio Editor, check out [this tutorial](#). (Note that you can also double-click on an audio track in the timeline to launch the Audio Editor.)
• **Export Audio**: allows you to export the selected audio clip. Browse to the location where you want to save the exported audio file, change the default name if you want to make it more specific, select the file type (MP3, WAV, or both), and click the Save button.

![Export Audio](image1)

**Working with video**

When you right-click a video in the timeline, you’ll see an option to **Edit Video**. This allows you to modify the video using the built-in **Video Editor**. You can trim, crop, adjust the volume, control brightness and contrast, and insert a logo. For more information on using the **Video Editor**, see **Editing Videos**. *(This option is not available for website videos or SWF files.)*

![Edit Video](image2)

**You may also be interested in exploring:**

• **Syncing Animations**
Inserting and Customizing Media

In Storyline, you can add a variety of media to your slides to engage your audience, including video, Flash interactions, audio, and web content. Click any of the tutorials below to learn more:

- Adding Videos
- Editing Videos
- Adjusting Video Properties
- Adding Flash Files
- Adding Sound
- Editing Sound
- Using the Sound Tools
- Adding Web Objects
- Editing Web Objects
Adding Videos

In Storyline, you can add videos from files, from websites, and from your own webcam. We will take a look at each method below.

Adding a video from a file

Storyline supports numerous video file formats. SWF, FLV, and MP4 are natively supported. Other video file formats will be automatically converted to MP4 when you insert them into Storyline.

*Note:* Videos will be automatically *synchronized* with the slide and will be controlled by the timeline (although you can choose to provide a separate playbar for your video if you like). If you want to insert an interactive SWF file that plays *independently* of the slide and which should not be controlled by the timeline, you will need to insert it using the Insert > Flash option instead. For more information, see Adding Flash Files.

Here’s how to insert a video from a file:

1. Go to the Insert tab.
2. Click the Video drop-down arrow, and select Video from File.
3. Navigate to the video you want to insert, and click the Open button.

- The following file formats are natively supported in Storyline:
  - FLV
  - MP4
  - SWF
• The following file formats will be converted to MP4 when they are imported into Storyline:
  o 3G2
  o 3GP
  o ASF
  o AVI
  o DV
  o M1V
  o M2V
  o M4V
  o MOV
  o MPE
  o MPEG
  o MPG
  o QT
  o WMV

Note: If your video placeholder in Storyline is hard to see (it could appear as a white, black, or transparent rectangle), you can right-click the placeholder, and select Set Poster Frame. Then browse to and select an image file to use as your placeholder.

Adding a video from a website

Storyline makes it easy to embed videos that are hosted on popular websites such as YouTube, Screenr, and Vimeo. Here’s how:

Note: YouTube videos will be synchronized with the slide timeline. Other website videos will play independently of the slide timeline.

1. Go to the Insert tab.
2. Click the Video drop-down arrow, and select Video from Website.
3. Paste the video embed code from the hosting website into the **Insert Video From Website** text box.

4. Click the **Insert** button.

**Recording a video from a webcam**

With Storyline, you can also record video directly from your webcam. Here’s how:

1. Go to the **Insert** tab.
2. Click the **Video** drop-down arrow, and select **Record Webcam**.
3. Before you begin recording, you can click **More device settings** if you have more than one webcam / microphone or if you want to change the video size.
And then specify the following:

- Use the **Video Device** drop-down list to select the webcam you want to use.
- Click the **Advanced** hyperlink to fine-tune your webcam properties.
- Use the **Video Size** drop-down list to select the dimensions for your video.
- Use the **Audio Device** drop-down list to select the microphone you want to use.

4. Click the red **Record** button to begin recording.
5. When you have finished recording your video, click the **Stop** button.

6. If you'd like to preview your recording before inserting it into your story, click the **Play** button.

7. If you'd like to redo your recording, click the **red X** to delete the current recording. Then you can record again.

8. When you're ready to insert the recording into your story, click **OK**.
You might also want to explore:

- Editing Videos
- Adjusting Video Properties
- Inserting and Customizing Screen Recordings
Editing Videos

You can edit videos at any time in Storyline using the built-in Video Editor. After adding a video to your story, right-click the video placeholder on your slide, and select Edit Video.

NOTES:

- SWF movies cannot be edited in Storyline. To edit SWF movies, you will need to use third-party editing software, and then import the edited files into Storyline.
- FLV movies with alpha channel transparency cannot be edited in Storyline. However, you can edit FLV movies that don’t have transparency.
- Videos that have been inserted from a website, such as Screencr or YouTube, cannot be edited in Storyline.
- Some features described below, such as adjusting brightness and contrast or inserting a logo, will not be noticeable if you click the Play button to preview your changes until you click the Save & Close button.

When the Video Editor opens, you can trim, crop, change the volume, adjust the brightness and contrast, insert a logo, and modify the encoding options. We will review each of these features below.
**Trimming a video**

If you only want to use part of a video, you can use the **Trim** feature to select just the part you want. Here’s how:

1. Click the **Trim** button on the toolbar.

2. Draggable borders will appear on the timeline below your video. Simply drag these borders to the place where you want the video to start and end.
3. As you drag the start and end points of your video, keep an eye on the **Trim Start**, **Trim End**, and **Trim Duration** values at the bottom of your screen. These will help you see exactly where the video is going to start and end and how long the trimmed version will be.

4. You can preview your trimmed video by using the **Play / Pause** and **Stop** buttons in the lower left corner of the window.

5. If you change your mind and want to revert back to the video as it was when you first opened the **Video Editor**, click the **Reset Video** button.

6. When you have finished editing your video, click the **Save & Close** button on the toolbar.
Cropping a video

The cropping tool allows you to change the width and/or the height of your video. For example, you might want to crop out something that is distracting, or you might want to control the movie's dimensions so that it fits exactly into a specific area of your slide. Here's how to crop a video:

1. Click the Crop button on the toolbar.

2. A resizable cropping window is added to your video. Simply drag the borders of the rectangle to select the portion of the video you want to keep. If you want to maintain the original aspect ratio of your video, resize the cropping window by using the corner handles.
3. As you drag the cropping window, keep an eye on the **Crop** value in the lower-right corner of your screen. This will help you to size the video to exactly the dimensions that you want.

4. If you change your mind and want to revert back to the video as it was when you first opened the **Video Editor**, click the **Reset Video** button.

5. When you have finished editing your video, click the **Save & Close** button on the toolbar.

---

**Adjusting the volume, brightness, and contrast of a video**

You can improve the quality of your video by increasing or decreasing the volume and adjusting the brightness and contrast. Here’s how:

1. To adjust the audio volume, click the **Volume** button, and use the slider to increase or decrease the percentage. You won’t be able to hear the volume adjustment until you click the **Save & Close** button and return to Storyline.
2. To adjust the brightness or contrast, use the **Brightness** and **Contrast** fields to specify a percentage. The changes will be visible immediately. (Note that changes to brightness and contrast also affect the logo for the video if you’ve added one.)

3. If you change your mind and want to revert back to the video as it was when you first opened the Video Editor, click the **Reset Video** button.

4. When you have finished editing your video, click the **Save & Close** button on the toolbar.
**Adding a logo or watermark to a video**

Storyline makes it easy to brand your videos with a logo or a watermark. Here's how:

1. Click the **Insert Logo** button on the toolbar.

![Image of Insert Logo button](image1)

2. Browse to the image you want to use as your logo or watermark, and click the **Open** button.

3. Resize the image and place it where you want it to appear on the video.

![Image of resizing and placing logo](image2)

4. If you want to apply some transparency to the image for a watermark effect, use the **Transparency** field to specify a percentage.

![Image of Transparency field](image3)
5. If you change your mind and want to remove the image, you can click the **Remove Logo** button, or you can click the **Reset Video** button to revert back to the video as it was when you first opened the **Video Editor**.

![Remove Logo button](image)

6. When you have finished editing your video, click the **Save & Close** button on the toolbar.

![Save & Close button](image)

**Note:** You won’t be able to see your logo when you preview the video in the Video Editor. However, it will display as expected when you preview or publish your overall story.
Adjusting Video Properties

To adjust the properties of an embedded video, do the following:

1. Click once on the video placeholder to select it.
2. Click the Options tab on the toolbar.

3. Then use any of the following options to change the behavior of the video.

Options

- **Preview**: Click the Preview button to view the selected video. Click the Preview button again to stop the video.

- **Video Volume**: Use this option to change the relative volume of your video. *(This option is not available for website videos.)*
  - **Low**: Lowers the volume to 50% of the original.
  - **Medium**: Sets the volume at 100%, meaning there is no change to the original volume. This is the default option.
  - **High**: Raises the volume to 150% of the original.
• **Edit Video**: Click this button if you would like to modify your video.

The built-in Video Editor will open, allowing you to trim, crop, adjust the volume, and insert a logo. Click the **Save & Close** button when you have finished editing your video. For more information on using the Video Editor, see [Editing Videos](#). *(This option is not available for website videos or SWF files.)*

• **Show video**: Determine whether you want to show the video **In slide** or **In new browser window**.
• **Play video:** How do you want the video to start playing? Choose one of the following three options. *(Note: This property will be grayed out if you choose to display your video in a new browser window—see above.)*
  - **Automatically:** The video will start playing as soon as the slide’s timeline reaches the start of the video object. For more information on working with the timeline, check out [this tutorial](#).
  - **When clicked:** Select this option if you do not want the video to start playing until users click it.
  - **From trigger:** If you would prefer to trigger the video to start playing only after a specific event has occurred, select this option. To learn more about triggers, take a look at [this tutorial](#).

![Video Timeline Options](image)

• **Show Video Controls:** Check this box if you want a separate playbar to be displayed for the video, allowing users to control the video playback. *(This option is not available for website videos other than YouTube videos.)*

![Video Controls](image)

• Arrange your video with other objects on the slide by using the **Bring Forward**, **Send Backward**, and **Align** dropdown lists.

![Movie Tools](image)
- Resize your video on the slide using the **Height** and **Width** fields to designate your desired values in pixels. The aspect ratio of your video will be maintained. Therefore, when you change one value, the other value will automatically be changed for you.

![Movie Tools](image)

**Additional right-click options**

There are also several options that you can quickly access simply by right-clicking a video placeholder:

- **Preview**: Select this option if you want to preview the video on your slide. Click anywhere outside the video to end the preview.
- **Set Poster Frame**: If you want to designate a placeholder image for your video, select **Set Poster Frame**, and then browse to and select the image you want to use.
  - This is especially useful if you have configured your video to play only when clicked, which means your poster frame is the image that will be visible until users click the video to play it.
  - If you change your mind and want to remove the poster frame, right-click the video again, and select **Remove Poster Frame**.
- **Edit Video**: Select this option if you would like to modify your video in the built-in **Video Editor**. *(This option is not available for website videos or SWF files.)*
- **Change Embed Code**: This option only pertains to website videos. Select this option if you need to modify the embed code for a video.
- **Group**: Use this option if you want to group a video with other objects on the slide. This can be useful if you want to rotate a video. Although videos can't be rotated by default, you can group them with another object, and then rotate the grouped object.
- **Bring to Front / Send to Back**: Use these options to arrange your video with other objects on the slide.
- **Rename**: This option allows you to change the default name (**Video 1**, **Video 2**, etc) assigned to videos after they are inserted into Storyline. Another way to rename videos and other objects is to use the **Timeline**.
- **Size and Position**: This is another way to specify an exact size and position for your video. To learn more about the Size and Position dialog, take a look at [this tutorial](#).
Adding Flash Files

Storyline allows you to add interactive SWF files, also known as Flash files, to your stories using the Insert > Flash option.

Note that you can also add SWF files in Storyline using the Insert > Video > Video from File option (see Adding Videos). So, how do you know which method to use when you are inserting a SWF file? It depends on whether you want the SWF file to be synchronized with your slide or if you want it to play independently of the slide. Here’s how to decide:

- If your SWF file is a movie that requires no interaction from users, you can use the Insert > Video > Video from File option, which synchronizes the video with the slide’s timeline.
- If your SWF file contains interactive elements, you will probably want to use the Insert > Flash option described below, which will play the SWF file independently of the slide.

Adding Flash files

Here’s how to add interactive SWF files as Flash objects in Storyline:

1. Go to the Insert tab.
2. Click the Flash button.
3. Navigate to the SWF file that you want to insert, and click the Open button.

Note: If your SWF placeholder is hard to see (it may appear as a white, black, or transparent rectangle), right-click the placeholder, and select Set Poster Frame. Then browse to and select an image file to use as your placeholder.

Adjusting Flash file properties

To adjust the properties of an embedded SWF file, do the following:

- Click once on the Flash placeholder to select it.
- Then click the Options tab on the toolbar.

The options that you can modify for interactive SWF (Flash) files are the same as those for videos. For a detailed explanation of each of these options, see Adjusting Video Properties.
Adding Sound

Storyline gives you three ways to add audio to your stories:

- Importing audio files
- Recording narration
- Importing slides from other content sources

We will review each method below.

**Importing audio files**

Navigate to the slide where you want to import audio, and follow these steps:

1. Go to the **Insert** tab.
2. Click the **Sound** drop-down arrow, and select **Sound from File**.
3. Navigate to the audio file you want to insert, and click the **Open** button. (Note: You can hold down the **CTRL** key to select multiple audio files. All the audio files that you select will be inserted into the same slide.)

The following file formats are supported in Storyline:

- AAC
- AIF
- AIFF
- M4A
- MP3
- OGG
- WAV
- WMA
Recording narration

Navigate to the slide where you want to record narration, and follow these steps:

1. Go to the Insert tab.
2. Click the Sound drop-down arrow, and select Record Mic.
3. The Record Microphone window will open. If you have a script that you want to use to help you as you record, click the Narration Script button, which reveals the text from the Notes panel for this slide.

Click the Narration Script button to help with recording
4. When you are ready to begin recording, click the **Record** button.

5. When you have finished recording, click the **Stop Recording** button.
6. You can review your recording by using the **Play / Pause** button and the **Rewind** button.

7. If you need to record your narration again, simply click the **Record** button to start over. If you want to delete your narration altogether, click the **Delete** button.
8. If you change your mind about recording narration and would prefer to import an audio file instead, click the **Import Audio File** button. Navigate to the audio file you want to insert, and click the **Open** button.

![Import audio file](image)

9. If you want to edit your recording, click the **Edit Audio** button to launch the **Audio Editor**. For more information on using the **Audio Editor**, review the tutorial on **Editing Sound**.

![Edit audio](image)

10. Click the **Save** button to save your audio.
Importing slides from other content sources

When you import slides into Storyline from PowerPoint, Quizmaker, or other Storyline projects, any audio resources from the external content will also be imported and available for editing.

You can also import Engage interactions into Storyline, and any audio contained in the interaction will also be published with your story. However, Engage audio cannot be edited in Storyline. To edit audio in your interactions, you'll need to open them in Engage. Click here to learn how.

You might also want to explore:

Editing Sound
Using the Sound Tools
Editing Sound

You can edit audio at any time in Storyline using the built-in Audio Editor. After adding audio to your story, use any of the following methods to launch the Audio Editor:

- Right-click the speaker icon at the lower left corner of the slide, and select Audio Editor.

If your slide contains more than one audio track and you are not sure which one to select, you can double-click each speaker icon to hear a preview of the audio track that it represents. Then single-click the speaker icon to stop the audio preview.

- Or, right-click the audio track in the timeline, and select Audio Editor.
• Or, simply double-click the audio track in the timeline to launch the Audio Editor.

We will explore each of the Audio Editor's features below.

**Previewing audio**

You can hear a preview of your audio by using the Play / Pause and Stop buttons in the lower left corner of the Audio Editor.
Or, right-click the audio waveform, and select **Play** to preview your narration.

To hear just part of the audio, use your mouse to select a portion of the waveform. Then use the **Play / Pause** and **Stop** buttons, or right-click the selection and click **Play**.
**Recording narration**

Using the **Audio Editor**, you can record additional narration for the slide, or you can replace some or all of the audio waveform with a new recording. Here’s how:

1. To record additional narration, click on the audio waveform at the point where you want to add audio. The playhead (red, vertical line) will move to the point on the audio waveform where you clicked.

   ![Click the waveform to reposition the playhead](image1)

   Or, if you want to replace some of the audio, use your mouse to select the portion of the audio waveform that you want to replace.

   ![Click & drag to select a portion of the waveform](image2)

   Or, if you want to re-record all of the audio, press **CTRL+A** to select all of the audio waveform, so that it will be overwritten in the next step.
2. Click the **Record** button in the lower left corner of the **Audio Editor**.

![Record button](image)

3. The **Record Microphone** window will open. When you are ready to begin recording, click the **Record** button.

![Record Microphone window](image)

4. When you have finished recording, click the **Stop Recording** button.

![Stop Recording button](image)
5. You can review your recording by using the **Play / Pause** button and the **Rewind** button.

6. If you need to record your narration again, simply click the **Record** button to start over. Or, if you want to delete your narration altogether, click the **Delete** button.
7. If you change your mind about recording narration and would prefer to import an audio file instead, click the **Import Audio File** button. Navigate to the audio file you want to insert, and click the **Open** button.

![Record Microphone](image.png)

8. Click the **Save** button to save your audio changes.

**Importing audio**

You can import additional narration into your waveform, or you can replace some or all of the audio waveform with a new recording. Here’s how:

1. To import additional narration, click on the audio waveform at the point where you want to add audio. The playhead (red, vertical line) will move to the point on the audio waveform where you clicked.
Or, if you want to replace some of the audio with an imported file, use your mouse to select a portion of the audio waveform.

2. Click the **Import** button on the toolbar.

3. Browse to the audio file that you want to import. Select it, and click the **Open** button.
**Exporting audio**

You can use the Audio Editor to export a copy of your audio for backup purposes or for use in another project. Here’s how:

1. Click the round Articulate button in the upper left corner of the window, and select the Export option.

![Export button in Articulate](image)

2. Browse to the location where you want to save the exported audio, and assign a File Name.
3. Use the Save as Type drop-down list to specify whether you want the exported audio file to be saved as an MP3 file, a WAV file, or Both WAV and MP3.

![Assign a File Name and File Type](image)

4. Click the Save button to complete the export process.
**Cutting, copying, and pasting audio**

**To cut or copy:**

1. Use your mouse to select a portion of the audio waveform.

2. Then do any of the following:
   - Click either **Cut** or **Copy** on the toolbar.
   - Or, right-click the selection, and choose **Cut** or **Copy**.
   - Or, press **CTRL+X** to cut or **CTRL+C** to copy.
To paste:

1. Click on the audio waveform at the point where you want to insert audio. The playhead (red, vertical line) will move to the point on the audio waveform where you clicked.

2. Then do any of the following:
   - Click the Paste button on the toolbar.
   - Or, right-click and select Paste.
   - Or, press CTRL+V to paste.
**Deleting and cropping audio**

Use your mouse to select a portion of the audio waveform that you want to either delete or crop.

To remove this portion of the audio waveform, click the **Delete** button on the toolbar. To keep the selected portion of the audio waveform and remove everything else, click the **Crop** button.

You can also right-click the selection, and use the **Delete** and **Crop** options.
**Adding silence**

You can insert silence into your audio waveform to improve phrasing. Here’s how:

1. Click on the audio waveform at the point where you want to insert silence. The playhead (red, vertical line) will move to the point on the audio waveform where you clicked.

2. Click the **Silence** button on the toolbar.

Or, right-click and select **Insert Silence**.
3. When the **Insert Silence** window appears, enter the number of seconds of silence you would like to add, or use the arrows to increase or decrease the value.

![Insert Silence Window](image)

4. Click the **OK** button.

If you would like to *replace* part of your audio waveform with silence, do the following:

1. Use your mouse to select the portion of the audio waveform that you want to replace with silence.
2. Then click the **Silence** button, or right-click and select **Silence Selection**. Unlike when you are *adding* silence (see above), you will not be asked to specify the number of seconds you wish to add. Instead, silence will simply replace the portion of the audio waveform that you selected.

**Changing the volume**

You can change the volume of your audio waveform by clicking the **Volume** button on the toolbar and using the slider to reduce or increase the volume.

![Change Volume Window](image)

If you only need to change the volume for part of the audio waveform, use your mouse to select that portion of the waveform. Then click the **Volume** button on the toolbar and use the slider to reduce or increase the volume.
**Zooming for precise editing**

The **Audio Editor** provides you with the following options for zooming to achieve more precise editing.

- The easiest way is to simply **scroll your mouse wheel** to zoom in and out.
- Another option is to use the **Zoom slider** in the lower right corner of the window. Drag the slider to the right to zoom in. Drag the slider to the left to zoom out.

You can click the **Show All** button to return to the entire audio waveform.

- Or, you can use your mouse to select just a portion of the audio waveform.
Then click the **Zoom Selection** button on the toolbar to fill the **Audio Editor** with only the selected portion of the waveform.

Click the **Show All** button to return to the entire audio waveform.

**Correcting mistakes and saving changes**

If you make a mistake or change your mind, you can use the **Undo** and **Redo** buttons in the upper left corner to correct it.

When you have finished editing your audio, click the **Save & Close** button on the toolbar.

Also, note that you can close the Audio Editor *without* saving your changes if you wish. To do so, just click the **X** in the upper right corner.
Using the Sound Tools

Storyline provides tools for working with audio on the toolbar. Click once on any speaker icon at the lower left corner of the slide to reveal the Sound Tools.
Another way to reveal the **Sound Tools** is to click once on any audio track in the **timeline**.
**Previewing audio**

Click the **Preview** button to hear the selected audio track. Click the **Preview** button again to stop the audio.

Another way to preview an audio track is to double-click the speaker icon. Click the speaker icon again to stop the audio.

**Changing the volume**

Click the **Sound Volume** drop-down list to change the relative volume of your audio track.

**Editing audio**

Click the **Audio Editor** button on the toolbar if you need to modify your audio track. To learn how to use the **Audio Editor**, check out [this tutorial](#).
Here are some additional ways to access the **Audio Editor**:

- Right-click the **speaker icon** at the lower left corner of the slide, and select **Audio Editor**.

- Or, right-click the audio track in the **timeline**, and select **Audio Editor**.

- Or, simply double-click the audio track in the timeline to launch the **Audio Editor**.
Replacing the audio track with another file

If you want to replace the selected audio track with a different audio file, click the Change Sound button on the toolbar. Then browse to the audio file you wish to use, select it, and click the Open button.

Exporting audio

You can export a copy of your audio for backup purposes or for use in another project. Here’s how:

1. Click the Export Sound button on the toolbar.
Or, right-click the speaker icon, and select **Export Sound**.

Or, right-click the audio track in the **timeline**, and select **Export Audio**.

2. Browse to the location where you want to save the exported audio, and assign a **File Name**.
3. Use the **Save as Type** drop-down list to specify whether you want the exported audio file to be saved as an **MP3** file, a **WAV** file, or **Both WAV and MP3**.

![Assign a File Name and File Type(s)](image)

4. Click the **Save** button to complete the export process.
Adding Web Objects

Storyline’s Web Object feature gives you a versatile way of leveraging web-based resources by embedding them as part of your project, whether those resources are online or stored on your local computer. Web objects are a powerful means of enhancing your courses with web-based applications, games, videos, social media, reference material, and more.

Adding web objects

1. Open your story in Storyline, and navigate to the slide where you want your web object to appear.
2. Go to the Insert tab, and select Web Object.
3. Depending on whether your web content is online or is located on your local computer, do one of the following:

- **If your web content is online**: Type the URL of the appropriate web page into the Address field.
- **If your web content is on your local computer**: Click the Browse button. Navigate to the folder that contains your web content, and click the OK button. (Note that there must be a file called `index.htm` or `index.html` in the folder that you select, and any supporting files that are necessary for your web content to function must also be in the same folder.)

4. If you want, you may click the Test Link button to make sure that your web content launches the way you expect.
5. If you want the web object to be embedded in the slide, select **Display in slide**. Otherwise, select **Display in a new browser window** if you'd rather have your web content open in a separate window. (If you choose **Display in a new browser window**, Storyline will insert a placeholder shape on your slide, which learners can click to launch the web object. See "Working with web object placeholders" later in this tutorial for details on how to customize the placeholder with a different image, if you like.)

6. Check the **Load Web Object Automatically** box if you want your web content to load without any interaction from users. Uncheck the box if you want your web content to load only when users click on it.

This option will not be available if you choose to display your web object in a new browser window. A web object that is set to open in a new window will not load until users click on the placeholder image. See "Working with web object placeholders" later in this tutorial for details on how to customize the placeholder with a different image, if you like.

7. If you choose to display your web object in a new browser window, decide how you want the new window to look.

   - Use the **Browser Controls** drop-down list to specify which controls the new window will have.
• Use the **Window Size** drop-down to select a size.

![Window Size Drop-down](image)

If you select **Custom** as the window size, **Width** and **Height** fields will appear, allowing you to specify the size in pixels.

![Custom Window Size](image)

(These options will not be available if you choose to embed your web object in the slide.)

8. Click the **OK** button when you have finished making your selections.

**Reminder:** If your web content is located on the Internet or an intranet, users will need to be able to access that location when they are viewing your published story. Otherwise, the web object will not work.

**Working with web object placeholders**

If you have chosen to display your web content in a new browser window, there will be a small icon, like a play button, in the lower right corner of the placeholder in Storyline.

![Web Object Placeholder](image)
If you have chosen to display your web content in a new browser window or if you have configured an embedded web object not to load automatically (so that users must click on it to view and interact with it), you may want to change the placeholder image that users will see until they click to view the web content. Here’s how:

1. Right-click the web object placeholder, and select Change Picture.

2. Browse to the image you want to use as your web object placeholder. Select it, and click the Open button.

If you change your mind and want to remove an image that you applied to a web object placeholder, right-click the web object placeholder, and select Reset Picture.

**You might also want to explore:**

Editing Web Objects
Editing Web Objects

In Storyline, you can adjust the properties of a web object at any time, using either of the following methods:

- Right-click the web object placeholder, scroll to Web Object, and select Edit.

- Click once on the web object placeholder, and use the Options tab on the toolbar.

Now let’s look at the details of each of these methods.
**Right-click the web object placeholder, scroll to Web Object, and select Edit**

Modify the following web object properties as desired, and then click the OK button to save your changes:

- Change the URL that appears in the **Address** field, or click the **Open Folder** button to browse to a folder on your local computer that contains html content. (If you use local html content, be sure there is a file called `index.htm` or `index.html` in the folder that you select and that any supporting files that are necessary for your web content to function are also in the same folder.)

![Insert Web Object dialog box](image)

- If you want, you may click the **Test Link** button to make sure that your web content launches the way you expect.
• If you want the web object to be embedded in the slide, select **Display in slide**. Otherwise, select **Display in a new browser window** if you’d rather have your web content open in a separate window. (If you choose **Display in a new browser window**, Storyline will insert a placeholder shape on your slide, which learners can click to launch the web object. If you want, you can change the placeholder image by right-clicking it and choosing **Change picture**.)

• Check the **Load Web Object Automatically** box if you want your web content to load without any interaction from users. Uncheck the box if you want your web content to load only when users click on it. (This option will not be available if you choose to display your web object in a new browser window. A web object that is set to open in a new window will not load until users click on the placeholder image. If you want, you can change the placeholder image by right-clicking it and choosing **Change picture**.)

• If you choose to display your web object in a new browser window, decide how you want the new window to look.
  • Use the **Browser Controls** drop-down list to specify which controls the new window will have.

  ![Browser Controls](image)

  • Use the **Window Size** drop-down list to select a size for the new window.

  ![Window Size](image)
If you select **Custom** as the window size, **Width** and **Height** fields will appear, allowing you to specify the exact size in pixels.

(These options will not be available if you choose to embed your web object in the current slide.)

- Click the **OK** button when you have finished making your selections.

**Reminder**: If your web content is located on the Internet or an intranet, users will need to be able to access that location when they are viewing your published story. Otherwise, the web object will not work.

**Click on the web object placeholder, and use the Options tab on the toolbar**

The **Options** tab allows you to adjust the following web object properties:

- **Preview**: Click the **Preview** button to view the selected web object on the slide. Click the **Preview** button again to stop the preview.

- **Open**: This button will launch the web object in your default browser.
• **Load**: How do you want your web object to launch? Choose one of the following three options from the **Load** drop-down list. (This option will not be available if you choose to display your web content in a new browser window—see the **Show** option below. A web object that is set to open in a new window will not load until users click on the placeholder image.)
  - **Automatically**: The web object will load as soon as the slide's timeline reaches the start of the web object. For more information on working with the timeline, check out [this tutorial](#).
  - **When clicked**: Select this option if you do not want the web object to load until users click it.
  - **From trigger**: If you would prefer to trigger the web object to load only after a specific event has occurred, select this option. To learn more about triggers, take a look at [this tutorial](#).

• **Show**: Determine whether you want to display your web object in slide or in new browser window.

• **Controls**: If you choose to show your web object in a new browser window (see above), the **Controls** drop-down list will become active, allowing you to specify your preferred browser control settings for the new window. (This option will not be available if your web object is configured to display in the current slide.)
• **Size:** If you choose to show your web object in a new browser window (see above), the Size drop-down list will become active, allowing you to specify a size for the new window. (This option will not be available if your web object is configured to display in the current slide.)

![Size drop-down list](image1.png)

• Arrange your web object with other objects on the slide by using the Send Backward, Bring Forward, and Align drop-down lists.

![Arrange options](image2.png)

• Resize your web object placeholder on the slide using the Height and Width fields to designate your desired values in pixels.

![Resize fields](image3.png)
**Additional right-click options for working with web objects**

Besides the two methods described above for editing web objects and adjusting their properties, there are a few options that you can quickly access simply by right-clicking the web object placeholder on the slide:

- **Web Object > Open**: This option will launch the web object in your default browser.
- **Preview**: Select this option if you want to preview your web object on the slide. (Note that you can also double-click on the web object placeholder to preview it.) Click anywhere outside of the web object to end the preview.
- **Change Picture**: If you want to specify a placeholder image for your web object, select *Change Picture*, and then browse to and select the image you want to use.
  - This is especially useful if you have configured your web object to load only when clicked or if it is set to open in a separate browser window, because the image that you select will be visible to users until they click it to load the web content.
  - If you change your mind and want to remove an image that you applied to a web object placeholder, right-click the placeholder again, and select *Reset Picture*.
- **Rename**: This option allows you to change the default name (*Web Object 1*, *Web Object 2*, etc) assigned to web objects in Storyline. Another way to rename web objects and other items is to use the *timeline*.
- **Size and Position**: This is another way to specify an exact size and position for your web object. To learn more about the Size and Position dialog, take a look at [this tutorial](#).
Inserting and Customizing Screen Recordings

Storyline gives you powerful tools for recording your computer screen and inserting the finished recording into your story in a variety of formats:

- as a video
- as a step-by-step demonstration
- as an ungraded assessment
- as a graded exam

Click each tutorial below to learn more:

- Adding Screen Recordings
- Inserting or Deleting Screen Recordings
- Editing Screen Recordings
- Exporting Screen Recordings
Adding Screen Recordings

In this tutorial, we'll explore how to record screencasts in Storyline. To actually insert a screen recording into your story, check out [this tutorial](#).

**Step 1: Launch the screen recorder**

There are several ways to launch the screen recorder in Storyline:

When you first launch Storyline and you are looking at the welcome screen, you can click the **Record Screen** option to begin a new project by recording your screen.

![Record Screen Option](articulate-studio-record-screen.png)

If you're working in an existing project, the quickest way to start a screen recording, when you're in **Story View**, is to click the **Record Screen** button on the **Home** tab.
Or, when you’re in Normal View, click the Record Screen button on the Insert tab.

![Record Screen button](image)

**Tip:** The drop-down arrow on the lower portion of the Record Screen button is used to add an existing screen recording to your story. To start a new recording, click the top portion of the Record Screen button.

Here are some other ways you can begin a new screen recording:

1. First, do any of the following:
   - Go to the Home tab, and click New Slide.
   - Go to the Insert tab, and click New Slide.
   - In Story View, you can also right-click anywhere in the workspace, and select New Slide.
   - In Normal View, you can also right-click anywhere in the left navigation panel, and select New Slide.

2. When the Insert Slides dialog appears, select the Screen Recordings tab.
3. Click the Record Your Screen button. (If this is your first recording, the Record Your Screen button will appear in the center of the window. If you have existing recordings, the Record Your Screen button is located in the upper right corner of the window.)

The Storyline window will disappear, and the screen recorder will launch (but it won’t start recording right away).

**Step 2: Select your recording options and resize / reposition the recording area**

When the screen recorder appears, the first thing you will want to do is click the gear icon on the recorder control bar to select your recording options.
Configure the following settings:

Shortcuts:
Use the following fields to assign keyboard shortcuts that you can use to stop or pause/resume your recording, or to take a screenshot. Place your cursor in each field and press the desired key. The field will update accordingly, depending on the key you press.

- Stop recording
- Pause/Resume
- Take screenshot

Sound recording:

- **Microphone**: If you want to record audio from your microphone during your screencast, select the Microphone checkbox. (Make sure your microphone is plugged in and ready to go.) Then use the Microphone drop-down list to select the microphone you want to use for recording.
- **Speakers**: Select the Speakers checkbox if you want to record system sounds, and use the Speakers drop-down list to select your desired playback device.

*Note: If you choose to insert your screen recording as step-by-step slides, any audio that you record with the screencast will not be used. Step-by-step slides display only the action-related clips of your original screencast. As a*
result, the recorded audio would not match up to the individual slides if it were included. Your audio will still be available in your original screen recording in case you also want to insert it as a video on a single slide.

Options:

- **Move new windows into recording area**: If you will be recording a software demonstration or a program that includes multiple windows, you may want to select this checkbox to ensure that each window is properly captured within the recording area.

- **System tray icon**: Select this checkbox if you want a Storyline icon to be displayed in your system tray while you are recording. If you need to record your system tray and you would prefer not to see the Storyline icon in your screencast, deselect this checkbox. **Tip**: If you choose to display the Storyline icon in your system tray, you can simply double-click it when you have finished recording in order to stop the recording process and close the recording window. Then you will be presented with options for naming, previewing, and inserting the recording into your story.

Click the OK button to save your screen recording options.

Next, resize and reposition the recording window:

- **Resize** the dashed outline of the recording area by dragging the sizing handles on the dashed outline, or use the drop-down list on the recording control bar to select preset dimensions, or choose the Select a window option to select a specific application that is currently running.

- Note that the largest screen recording size that is supported is 2046 by 2046 pixels.
- Multi-monitor recording is not supported.
- If you will be recording a web application or web page, you may use the browser of your choice. However, be aware that Internet Explorer is the best option, because it provides the richest set of data to the Windows Accessibility API, which is how Storyline collects information about your screen recording. Firefox also works very well. Google Chrome, unfortunately, reports very little information, so details will be missing from your captions and some steps could be omitted as well.
• **Reposition** the recording area by hovering over the dashed outline or over the gray **How to record** box in the center of the recording window. A four-headed arrow will appear, and you can drag the recording area to the appropriate location.

Drag the bounding box to reposition the recording area

• You can also use the microphone drop-down list to change your audio recording device, or select **No Audio** if you do not want to record audio with your screencast.

![Microphone drop-down list](image)

**Step 3: Record your screen**

Storyline allows you to record up to two hours on a single recording. When you're ready to begin recording, here's how to do it:

1. Click the red **Record** button on the recording control bar.

![Record button](image)
2. If you need to pause the recording, you can use the Pause / Resume keyboard shortcut you specified earlier, or you can click the Pause button on the recording control bar. To resume recording, use your Pause / Resume keyboard shortcut again, or click the Record button on the recording control bar.

3. If you make a mistake or wish to start over, click the trash can icon on the recording control bar to discard your current recording. Then you can click the red Record button again to start over.

4. To exit without recording, click the Cancel button on the recording control bar.

5. When you have finished recording, you can click the Stop Recording keyboard shortcut you specified earlier, or you can click the Done button on the recording control bar.
**Step 4: Name and preview your new screen recording**

When you have completed your screen recording, you will have the option to change the default name of your recording, so that you can easily identify it later. Type a name for your recording in the **Name** field that appears above the recording.

Before you actually insert the recording into your story, you can preview it by clicking the **Play / Pause** button in the lower left corner, or use the **seekbar** to jump to a specific point in the recording.

If you change your mind and want to discard the screencast, click the **Cancel** button in the lower right corner of the screen or press the **Esc** key on your keyboard. You'll be asked if you want to save the screencast for later use.

**Step 5: Insert the screen recording into your story**

Depending on the purpose of your screen recording, you can choose to insert it as a **Video on a single slide** or as a series of **Step-by-step slides**—or both. To learn more about inserting screen recordings into your story, [click here](#).

**You may also be interested in exploring:**

- Inserting or Deleting Screen Recordings
- Editing Screen Recordings
- Exporting Screen Recordings
- Adjusting Video Properties
Inserting or Deleting Screen Recordings

After recording a screencast, you're ready to insert it into your story. In this tutorial, we'll look at how to insert new and existing screen recordings as well as how to delete them.

Inserting a new screen recording

If you've just recorded a screencast and the preview window is still open, this section of the tutorial will show you how to insert it into your story. On the other hand, if you want to insert an existing screencast that you recorded previously, skip to the next section of this tutorial for instructions.

Depending on the purpose of your screen recording, you can choose to insert it as a Video on a single slide or as a series of Step-by-step slides—or both. Select either of these options, which appear to the left of the preview area of your screen recording. If you choose Step-by-step slides, use the accompanying drop-down list to select View mode steps, Try mode steps, or Test mode steps. We'll look at each of these modes in a moment.

Note: You may insert your screen recording into your story using one or more or even all of these options. However, you must insert them one at a time. If you want to insert the same screen recording into your story again using another of these four options, refer to the following section, Inserting an existing screen recording, for additional instructions.
Video on a single slide

First, let's look at the **Video on a single slide** option. This type of video is not interactive. It simply allows your users to see a process in action. If you select this option, you will also be able to decide whether or not to include your mouse in the video by checking or unchecking the **Show Mouse Cursor** box.

Then determine where the video screen recording will be inserted into your story. Use the "**Insert slides in**" drop-down list to select either **New Scene** (which is the default option) or an existing scene in your story. If you choose to insert a new scene, use the **Scene Name** field to assign a name to the new scene.

Click the **Insert** button in the lower right corner of the window to complete the process.

- **Note**: If you click the **Cancel** button before inserting your screen recording into your story at least once, the screen recording will be deleted from your project file.
After inserting a screen recording as a video, you can adjust its properties as you would with any other video in Storyline.

Step-by-step slides

Now let’s look at each of the step-by-step modes. Choose one of the following modes, and configure its corresponding options:

**Note:** When inserting a screen recording as step-by-step slides, any audio that you recorded with the screencast will not be used. Step-by-step slides display only the action-related clips of your original screencast. As a result, the recorded audio would not match up to the individual slides if it were included. Your audio will still be available in your original screen recording in case you also want to insert it as a video on a single slide.

- **View Mode Steps** allows you to insert your screen recording as a demonstration for your users. The demonstration is not interactive. It simply allows your users to see a process in action. If you select View Mode Steps, click the corresponding View Mode Options hyperlink to specify the following options:

  - Use the Language for captions drop-down list to designate which language you want to use for captions in your screen recording.
  - If you would prefer not to include captions, deselect the Add text captions checkbox.
  - If you would prefer not to display your mouse in the screen recording, deselect the Show Mouse Cursor checkbox.
  - If you would prefer not to highlight your mouse clicks in the screen recording, deselect the Indicate clicks with highlight checkbox. Each highlight is simply a semi-transparent rectangle, which helps to direct users’ attention to the area of the screen that is about to be clicked in the demonstration.

Click the OK button when you have finished modifying your options.
- **Try Mode Steps** allows you to insert your screen recording as an *ungraded assessment*, which is an opportunity for users to test their knowledge. If you select **Try Mode Steps**, click the corresponding **Try Mode Options** hyperlink to specify the following options:

![Try Mode Options](image)

- Use the **Language for captions** drop-down list to designate which language you want to use for captions in your screen recording.
- If you want to include feedback for correct responses, select the **Show correct feedback** checkbox.
- If you would prefer that your learners’ cursor *not* switch to a hand cursor when they hover their mouse over hotspots, deselect the **Show hand cursor when hovering hotspots** checkbox.
- If you would prefer not to display hint captions, deselect the **Show hint captions** checkbox. However, if you *do* want to show hint captions, use the corresponding drop-down list to specify when hint captions should appear: when users hover their mouse over hotspots, or always.

Click the **OK** button when you have finished modifying your options.
• **Test Mode Steps** allows you to insert your screen recording as a *graded exam*. If you select **Test Mode Steps**, click the corresponding **Test Mode Options** hyperlink to specify the following options:

![Test Mode Options]

- If you want to include feedback for correct responses, select the **Show correct feedback** checkbox.
- If you would prefer not to display feedback for incorrect responses, deselect the **Show incorrect feedback** checkbox.
- You can let Storyline create a result slide for you automatically by selecting the **Automatically create a result slide** checkbox, or you can deselect this checkbox if you want to add a result slide on your own later. To learn more about how to add and edit result slides, check out this [tutorial](#).
- Use the **Limit attempts to** drop-down list to specify how many times users can attempt *each step* in the process. The default option is **Unlimited**, but you can also select a number between 1 and 10.

  If you allow users to attempt each step more than once, you can display “Try Again” feedback when they fail by selecting the **Show try again feedback** checkbox. Then, if you want, you can make changes to the default “Try Again” feedback layer that Storyline creates for you. To learn more about layers, see this [tutorial](#).

Click the **OK** button when you have finished modifying your options.

Next, decide where the screen recording will be inserted into your story. Use the **Insert slides in** drop-down list to select either **New Scene** (which is the default option) or an existing scene in your story. If you choose to insert a new scene, use the **Scene Name** field to assign a name to the new scene.
Click the **Insert** button in the lower right corner of the window to complete the process.

- **Note**: If you click the **Cancel** button before inserting your screen recording into your story at least once, the screen recording will be deleted from your project file.

After inserting a step-by-step screen recording into your story, you can add, edit, and delete slides as usual, and you can modify the **captions**, **hotspots**, **data entry fields**, **feedback layers**, and **mouse movements** that Storyline automatically generated for you. You can even change the starting and ending frames for each slide in step-by-step screen recordings, using the **Action Fine Tuning** editor.
**Inserting an existing screen recording**

Storyline keeps your entire screen recording within your project and allows you to reuse it more than once in the same story. This can be beneficial if, for example, you want to insert the same screen recording as a demonstration and also as an assessment. You don't need to re-record anything. You can just insert the same screen recording twice, using different options each time.

The quickest way to add an existing screen recording to your story is to click the drop-down arrow at the bottom of the **Record Screen** button on the **Home** tab (if you're in Story View) or on the **Insert** tab (in both Story View and Normal View), and select the recording you want to insert.
Then do the following:

1. Determine how the screen recording will be inserted. Select either Video on a single slide or Step-by-step slides, and configure the corresponding options. (Refer to the section above for detailed information regarding each of these options.)

Choose to insert as a video or step-by-step slides

If you choose step-by-step slides, select a mode

2. Select the scene where you want to insert your recording using the Insert slides in drop-down list, and, if you choose to insert a new scene, assign a Scene Name to the new scene.

3. Click the Insert button in the lower right corner to insert the selected screen recording into your story.
Here are some other ways you can insert an existing screen recording:

1. First, do any of the following:
   - Go to the Home tab, and click New Slide.
   - Go to the Insert tab, and click New Slide.
   - In Story View, you can also right-click anywhere in the workspace, and select New Slide.
   - In Normal View, you can also right-click anywhere in the left navigation panel, and select New Slide.

2. When the Insert Slides dialog appears, select the Screen Recordings tab on the left.
3. Then use the Insert From drop-down list at the top of the window to select an existing screen recording.

4. Determine how the screen recording will be inserted. Select either Video on a single slide or Step-by-step slides. (Refer to the section above for detailed information regarding each of these options.)
5. Select the scene where you want to insert your recording using the Insert slides in drop-down list, and, if you choose to insert a new scene, assign a Scene Name to the new scene.
6. Click the Insert button in the lower right corner to complete the process.

Note: If you want to insert a screen recording from a different project, do either of the following:

   - Export the MP4 movie from the source project and then import it into your new story. Using this method, you will only have a video of the screen recording. You will not be able to use step-by-step slides.
   - Or, import at least one of the screen recording slides from the source project. This will pull the entire screen recording into the new story file. Then you can use it as often as you like—either as a video or as step-by-step slides.
Deleting screen recordings

If you change your mind about a screen recording and want to remove it from your project altogether, you can do that too.

To quickly delete all screen recordings that are not currently being used in your story, click the drop-down arrow at the bottom of the Record Screen button on the Home tab (if you're in Story View) or on the Insert tab (in both Story View and Normal View), and click “Delete unused recordings”. (Nifty "In Use" tags to the left of the thumbnail images will let you know, at a glance, which screencasts are currently being used somewhere in your story.)
If you want to delete a specific screen recording, click the drop-down arrow at the bottom of the Record Screen button on the Home tab (if you're in Story View) or on the Insert tab (in both Story View and Normal View), and select the recording you want to delete.

Click the Record Screen drop-down arrow and select an existing screencast.

When the screen recording window opens, click the Delete Recording hyperlink in the lower right corner.
If the screen recording that you are attempting to delete is currently being used in your story, you will receive the following warning, explaining that it cannot be deleted. In that case, you would need to delete the slide(s) that contain the screen recording first, and then delete it from your project as described above.

When you have finished managing your screen recordings, click the Cancel button in the lower right corner or the X in the upper right corner to close the window.

Here are some other ways you can delete a specific screen recording:

1. First, do any of the following:
   - Go to the Home tab, and click New Slide.
   - Go to the Insert tab, and click New Slide.
   - In Story View, you can also right-click anywhere in the workspace, and select New Slide.
   - In Normal View, you can also right-click anywhere in the left navigation panel, and select New Slide.

2. When the Insert Slides dialog appears, select the Screen Recordings tab on the left.
3. Then use the Insert From drop-down list at the top of the window to select an existing screen recording.

4. Then click the Delete Recording hyperlink in the lower right corner of the window.
5. When you have finished managing your screen recordings, click the Cancel button in the lower right corner or the X in the upper right corner to close the window.

You may also be interested in exploring:

- Adding Screen Recordings
- Editing Screen Recordings
- Exporting Screen Recordings
- Adjusting Video Properties
Editing Screen Recordings

After recording a screencast and inserting it into your story, you can edit and fine tune it. These methods will differ, depending on how you inserted the screen recording: either as a Video on a single slide or as a series of Step-by-step slides.

Video on a single slide

If you inserted a screen recording as a video on a single slide, you can adjust its properties as you would any other video in Storyline. For example, you can specify how it will play (Automatically, When clicked, or From trigger), whether it will have a separate playbar or not, and its relative volume.

Select the video placeholder on the slide, and then click the Options tab on the toolbar. To learn more about adjusting video properties, take a look at this tutorial.

You can also use the built-in video editor to trim, crop, adjust brightness and contrast, add a logo or watermark, and change quality settings. Simply right-click the video placeholder, and select Edit Video. To learn how to use the video editor, click here.
**Step-by-step slides**

After inserting a screen recording into your story as step-by-step slides, you can add, edit, and delete slides as usual, and you can modify the captions, hotspots, data entry fields, feedback layers, and mouse movements that Storyline automatically generated for you during the recording process.

You can also add objects to each slide in your step-by-step recording if you want. For example, if you need to hide a portion of the screen that appears in your recording, such as personal information or an advertisement, you may be able to cover that area with an image or a shape that matches the background color of the slide. Note that you may need to use the same image or shape on multiple slides if the portion of the screen that you want to hide spans a series of slides in your step-by-step recording.

If necessary, you can also change the starting and ending frames for each slide in a step-by-step screen recording, which can be useful if, for example, you want to edit out an unnecessary step or a mistake made while recording. To do so, you'll use the **Action Fine Tuning** editor. Here's how:

1. Navigate to the slide in your step-by-step recording that you want to modify.
2. Right-click anywhere on the slide, and select **Action Fine Tuning** from the shortcut menu that appears.

3. Then do either of the following to adjust the starting and / or ending frames for the video clip on this slide:

   - The quickest way is to drag the starting and ending markers along the timeline until you have selected the clip you want to keep.
• Or, for even greater precision, select either the Update Start Frame radio button or the Update End Frame radio button in the lower left corner, and then click the Previous Frame button or Next Frame button to move the starting or ending point along the timeline one frame at a time.

4. You can use the Play / Pause button to preview what the slide will look like with your changes.

5. If you change your mind about modifying the starting and ending frames, you can click the Reset Original Timing button in the lower right corner to undo your changes.
6. If you need to make changes to other slides while you're in the **Action Fine Tuning** editor, you can use the slide drop-down list at the top of the window or click the **Previous Slide** and **Next Slide** buttons.

![Fine tune a section of the movie clip used for your user's capture action](image)

7. When you've finished making changes to your recording, click the **OK** button to close the fine tuning editor.

**You may also be interested in exploring:**

- [Adding Screen Recordings](#)
- [Inserting or Deleting Screen Recordings](#)
- [Exporting Screen Recordings](#)
Exporting Screen Recordings

You can export a copy of your screen recordings as MP4 movies, and you can save individual frames from your screen recordings as PNG images. These functions can be helpful if you want to reuse your content in other projects.

There are two ways to export screen recordings from a Storyline project. Because they’re somewhat different, we’ll look at the details of each method below.

Method 1: Use the Insert Slides dialog

The easiest way to access the Insert Slides dialog for managing screen recordings is to click the drop-down arrow at the bottom of the Record Screen button, which is on the Home tab if you’re in Story View and on the Insert tab in both Story View and Normal View. Then select the recording you want to export.

Click the Record Screen drop-down arrow and select an existing screencast

When the screen recording that you selected opens in the Insert Slides dialog, do either of the following:

- Export movie: To export a copy of the screencast as an MP4 movie, right-click the preview area of the window, and select Export movie.
• **Save frame**: To save a frame from the screencast as a PNG image, use the play button or the seekbar to locate the frame you want to save.

Then right-click the preview area of the window, and select **Save frame**.

Here are some other ways you can access the **Insert Slides** dialog to export a screen recording:

1. First, do any of the following:
   - Go to the **Home** tab, and click **New Slide**.
   - Go to the **Insert** tab, and click **New Slide**.
   - In Story View, you can also right-click anywhere in the workspace, and select **New Slide**.
   - In Normal View, you can also right-click anywhere in the left navigation panel, and select **New Slide**.

2. When the **Insert Slides** dialog appears, select the **Screen Recordings** tab on the left.

3. Then use the **Insert From** drop-down list at the top of the window to select an existing screen recording.

4. Then do either of the following:
   - **Export movie**: To export a copy of the screencast as an MP4 movie, right-click the preview area of the window, and select **Export movie**.
   - **Save frame**: To save a frame from the screencast as a PNG image, use the play button or the seekbar to locate the frame you want to save. Then right-click the preview area of the window, and select **Save frame**.

**Method 2: Use the Action Fine Tuning editor**

The **Action Fine Tuning** editor allows you to change the starting and ending frames for each slide in step-by-step screen recordings. (To learn more about the **Action Fine Tuning** editor, check out [this tutorial](#).) However, you can also use the **Action Fine Tuning** editor to export screen recordings, and there are some additional features when using this method that are not available in the **Insert Slides** dialog (described above). Namely, when exporting a
movie, you can choose either the entire recording or a specific clip. And when saving an individual frame as an image, you can either choose to save it at the size as it appears in the project or at the size as it was originally recorded (if those sizes happen to be different).

Note that the **Action Fine Tuning** editor is only available for screen recordings that have been inserted into your story as *step-by-step slides*. This method does not apply to screen recordings that have been inserted into your story as *videos on a single slide*. To learn about the different ways a screen recording can be inserted into a story, take a look at [this tutorial](#).

To export screen recordings, navigate to any slide in your story that is part of a step-by-step screen recording, right-click the slide, and select **Action Fine Tuning**.

Then do any of the following:

- **Export movie**: To export a copy of the entire screencast as an MP4 movie, right-click the preview area of the window, and select **Export movie**.

- **Export clip**: To export only a portion of the screencast as an MP4 movie, right-click the preview area of the window, and select **Export clip**.
If you need to modify the starting and ending frames before you export the clip, simply drag the starting and ending markers along the timeline until you have selected the clip you want.

Drag the starting and ending markers along the timeline to change the selected clip

Or, for even greater precision, select either the Update Start Frame radio button or the Update End Frame radio button in the lower left corner, and then click the Previous Frame or Next Frame button to move the starting or ending point along the timeline one frame at a time.

Select the frame to be updated  

Use the Previous and Next buttons to adjust the position of the frame
• **Save frame (project size):** To save a frame from the screencast as a PNG image at the same size as it appears in your story, use the play / pause button to locate the frame you want to save. Then right-click the preview area of the window, and select **Save frame (project size).**

![Save frame (project size)](image)

• **Save frame (original size):** If your screencast was originally recorded at a different size from the way it appears in your story, you can also save a frame as a PNG image at the original size. Use the play / pause button to locate the frame you want to save. Then right-click the preview area of the window, and select **Save frame (original size).**

![Save frame (original size)](image)

**You may also be interested in exploring:**

- [Adding Screen Recordings](#)
- [Inserting or Deleting Screen Recordings](#)
- [Editing Screen Recordings](#)
Inserting and Customizing Interactivity

Storyline makes it super easy to add interactivity to your courses. Check out the following tutorials to learn about the many ways you can make your courses come alive with interactive content:

- Adding Buttons
- Adding Button Sets
- Adding Hotspots
- Adding Markers
- Adding Data Entry Fields
- Adding Scrolling Panels
- Adding Mouse Cursors
- Adding Hyperlinks
- Converting an Existing Slide to a Freeform Interaction

You might also want to explore:

- Working with States, Triggers, and Layers
- Working with Variables
Adding Buttons

Storyline includes a variety of ready-made button styles to help you quickly create inviting, professional-looking interactions in your courses. You can choose from standard push-buttons (both rectangular and oval), four styles of check boxes, and four styles of radio buttons:
**How to insert a button**

To insert a button onto a Storyline slide, follow these steps:

1. Go to a slide where you want to add a button.
2. Select the **Insert** tab.

3. Click **Button** and choose one of the styles available. Your cursor will turn into a crosshair.

4. Click and drag on your slide to insert the button.

Once your button is on your slide, you can move, resize, or format it. You can add as many buttons to your slide as you like.

**Adding text to your buttons**

To add text to a button, there’s no need to create a separate text box. Just select the button you’ve inserted, and start typing. The text becomes part of the button object itself.

You can modify the text attributes on your button in the same way that you would normally customize a text box. For example:

- To change the font and paragraph settings, select the button and use the options on the **Home** tab. See [this tutorial](#) if you need help.
- To change the text’s alignment, autofit options, and margin settings, right-click the button, choose **Format Shape**, and select the **Text Box** tab. See [this tutorial](#) if you need help.

**Making buttons work**

Once you insert one or more buttons on your slide, you can use Storyline’s interactivity tools to customize how your buttons work. Here are some of the things you can do:

- **Add a trigger**: Triggers allow you to create actions based on how your learners interact with the button. For example, let’s say you’ve inserted a push-button to your slide, and you want to reveal a slide layer when learners click the button. Or maybe you want the button to take learners to a different slide, or open a URL, or display a lightbox. Or
maybe you want to play a sound effect whenever learners hover over a button. These and many more actions can be created easily with triggers. To apply triggers to your Storyline buttons, check out this tutorial for guidance.

- **Turn your buttons into a freeform interaction**: Another way to create interactivity is to leverage your buttons as choices in an interaction or a question. You can do this by using Storyline’s versatile Convert to Freeform option, which allows you to transform any slide into an interaction, such as a multiple-choice or multiple-response activity. If you like, you can even score the question and display customized feedback once the learner uses a button to select a choice. To find out more, check out the tutorial on Converting an Existing Slide to a Freeform Interaction.

- **Turn your buttons into a button set**: If you’ve added multiple buttons to a slide and you want learners to be able to select just one of them at a time, you can turn them into a button set. Button sets allow you to make any objects behave like radio buttons—if a learner selects one button from the set, any other buttons from that set automatically become unselected. You can even have multiple button sets on a single slide, if you’d like learners to select just one option from each group of buttons. For more details, see the tutorial on Adding Button Sets.

### Formatting your buttons

It’s easy to customize the appearance of buttons with Storyline’s formatting options. Just select a button on your slide, and then click the Format tab on the ribbon. The specific options you see will depend on the button style you’re using. You’ll be able to do things like apply ready-made styles; change the fill and border color, and apply other effects.

![Format tab in Storyline](image)

Select a button you’ve inserted on your slide, and click the Format tab to see the options available. This example shows the options for radio buttons.

The colors available in the on the Format tab are controlled by your project’s design theme. You can learn how to customize the colors in your design them [here](#).

### Adding an icon to a button

When you insert a push-button on your slide, you can add an icon to it if you like. Storyline provides a library of nearly 200 different icons to choose from. Here’s how to apply them:

1. Select a push-button you’ve inserted on your slide.
2. Click the Format tab.
3. Select an icon from the **Button Icons** section of the ribbon. (Click the arrow in the lower-right corner of the panel to expand the list.)

![Button Icons panel](image)

Click the lower-right corner of the **Button Icons** panel to expand the list of icons you can choose from.
4. If you like, use the **Align Icon** to change the placement of the icon on the button:

- The **Align Left** and **Align Right** options determine whether the icon appears to the left or to the right of any text you add to the button.
- The **Center with Text** option causes the icon and button text to be aligned together as if they were grouped. Any alignment choices you apply to the button text (via the Home tab) will be applied to the icon and text together.
- The **Ignore text** option aligns the icon to the left or right edge of the button (depending on whether you chose Align Left or Align Right above), *without* regard for any additional alignment settings you apply to the button text.

5. To change the color of the icon, use the **Icon Color** selector to choose the color you want. The choices available are controlled by your project's **theme colors**. For even more flexibility, you can choose **More Icon Colors** and choose the specific color value.
**About the icon size:** When you add an icon to a button, the icon size depends on the font size you’ve applied to the button. To change the size, select the button and click the **Home** tab, and use the font size tools:

If you change your mind about using an icon, just select the button, click the **Format** tab, and choose **Remove Icon**.

**Changing the default button characteristics**

If you customize the look of a button, and you want those attributes to apply to future buttons you create within the same Storyline project, you can set your customized button as the default. Just right-click the button and choose the **Set As Default** option.

Once you do this, any new buttons you create within the same story will inherit the default button’s attributes.
About the pre-built button states

When you insert a button on your slide, it’ll come with some pre-built states, which control the look of the button when learners hover over, click on, or otherwise interact with it. The pre-built states that Storyline applies will depend on the type of button you insert.

- All buttons include a normal, hover, down, and disabled state.
- Push-buttons also include a visited state (which determines what users see after clicking on the button at least once).
- Check boxes and radio buttons also include a selected state (which determines what users see when they’ve marked a check box, clicked a radio button, or clicked on a button that’s part of a button set).

You can, of course, modify any of the pre-built states or create additional states if you like. For help with that, check out the tutorial on Adding and Editing States.
Adding Button Sets

Button sets enable you to create interactions in which a learner can select just one object at a time out of a group of objects. This is cool because it allows you to make just about any objects behave like radio buttons. The feature works great with Storyline’s ready-made buttons, as well as other objects such as pictures, screenshots, shapes, captions, characters, markers, and more.

For example, let’s say you’ve inserted three characters on your slide, and you want the learner to select one (and only one) of the three. If you turn the characters into a button set, then when a learner selects any of the three characters, any currently selected character will automatically become unselected.

You can even have multiple button sets on a single slide. Learners will be able to select one object out of each button set you create.
Here's how to turn a set of objects into a button set:

1. Select the objects by shift-clicking or by dragging a selection area around the objects you want to turn into a button set.
2. Right-click the selection and choose **Button Set**.

3. Choose either **Button set 1** (this is the default name for the first button set you create on any slide), or choose **New set** and add a name:

![Image of selecting a button set](image)

**Tip:** If you already inserted some actual **radio buttons** on your slide via the **Insert** tab, these default to being part of Button set 1—so, unless you want other objects to be part of the same button set, it's best to choose **New set** and enter whatever name you like. The name you choose is something only you will see, not your learners.
That's it! If the objects you selected don't already have a Selected state, Storyline creates one. You can see what it looks like by viewing the States panel below your slide:

Now that you've created a button set, when you preview or publish this slide, learners will only be able to select one item at a time from the objects that make up that button set.

You can have as many button sets on a single slide as you like.

**Changing the appearance of the selected state**

If you don't like the way the selected state on any object looks, you can change it. Just select the object, click the *Edit States* button in the *States* panel, choose the *Selected* state, and make your changes. For more help with customizing object states, see the tutorial on *Adding and Editing States*. 

![Diagram showing normal and selected states of an object]
**Adding or removing items in a button set**

To add another item to an existing button set, right-click the item, choose Button Set, and choose the button set you want that item to be part of.

To remove an item from a button set, right-click the item, choose Button Set, and choose (none).

**You might also want to explore:**

- Adding Buttons
- Adding and Editing States
Adding Hotspots

Hotspots are interactive shapes you can use in place of buttons when no visible fill or outline is needed. Hotspots are invisible objects that work like buttons, only without any visible states. In fact, hotspots don’t have states or the option to add or edit states.

Hotspots are especially useful when you want to provide hover triggers and on-click triggers that perform an action, such as displaying additional information or navigating to another slide. Hotspots are also very effective in drag and drop scenarios.
**Inserting a hotspot**

1. In **Normal View**, go to the **Insert** tab on the toolbar.
2. Click **Hotspot**, and select one of the shapes (**Oval**, **Rectangle**, or **Freeform**).

3. Your mouse will change to a crosshair shape, which means you can now draw a hotspot on your slide.

*When your mouse cursor becomes a crosshair, you are ready to draw a hotspot.*
A semi-transparent green shape will appear on the slide to represent your hotspot. Although it is visible in Storyline (so you can work with it), it will be invisible when you publish your story.

Resizing, rotating, and repositioning a hotspot

After you’ve drawn a hotspot on a slide, you can resize it, rotate, and reposition it. Here’s how:

- To resize a hotspot, select it, and drag any of its sizing handles.
• To rotate a hotspot, select it, and drag the green rotation handle at the top of the hotspot.

• To reposition a hotspot, select it, and, when your mouse becomes a four-headed arrow, drag the shape to the desired location on the slide.

Another way that you can resize, rotate, and reposition a hotspot is to right-click it, and select Size and Position from the shortcut menu that appears. To learn all about the Size and Position dialog, check out this tutorial.
Showing or hiding the hand cursor when hovering over a hotspot

By default, a user’s mouse will change from the typical arrow cursor to a hand cursor when they hover over a hotspot in your published story.

This is great for letting users know that there is a clickable area of the screen. But what if you don’t want the mouse to change to a hand cursor? No problem. Simply right-click the hotspot, and uncheck the option to Show hand cursor on hover.
**Adding triggers to a hotspot**

In order for a hotspot to have any functionality, you will need to assign one or more triggers to it. One trigger will always be added automatically when you draw a hotspot. Initially, it will be "unassigned". To modify the default trigger, double-click it, or select the trigger and click the **Edit** button (pencil icon).

The default trigger will be "unassigned".

To edit the default trigger, double-click it, or click the **Edit** button.

Note that you can add multiple triggers to the same hotspot. For example, you might assign a trigger to display additional information when a user *hovers* over the hotspot, and you might also add a trigger to perform an action, such as jumping to a different slide, when a user *clicks* on it. To learn how to add and manage triggers, take a look at this tutorial.

**Renaming a hotspot**

When you insert a hotspot, it'll appear in the **timeline** with a default name, such as "Hotspot 1." It's useful to give it a more intuitive name, because this makes it easier to choose the correct object when you're applying triggers or working with other features in Storyline. There are a couple of ways to rename a hotspot. One method is to right-click the hotspot, and select the **Rename** option from the shortcut menu that appears.
Or, use the [timeline](#) to rename objects, including hotspots.

![Timeline screenshot showing a hotspot named Oval Hotspot being selected.](image)

**You can also rename a hotspot by double-clicking it in the timeline**

**Deleting a hotspot**

To delete a hotspot, select it on the slide or in the timeline, and click the **Delete** key on your keyboard. **Note:** When you delete a hotspot, all triggers that are assigned to that hotspot will also be deleted.

**Things to keep in mind when working with hotspots**

- You can arrange hotspots like other objects on a slide by sending them backward or bringing them forward. However, be aware that if a hotspot is covered by other elements on the slide, the hotspot triggers will not work.
- If you have a lot of other objects on your slide, or a complex slide background, you might find it helpful to use the formatting tools in Storyline to change the hotspot's fill color, outline style, or other shape effects, to make the hotspot easier to see. These formatting changes, though, will only affect the way the hotspot looks within Storyline when you're building or editing your content. Regardless of how you format the hotspot, it'll always be invisible to the learner when you publish.
- If a hotspot has a hover trigger applied to it that causes an object to animate into the slide, that object may flicker, flash, or repeatedly animate if the object partially or wholly covers the hotspot. For more information on this issue, [click here](#).

**You might also want to explore:**

- [Converting an Existing Slide to a Freeform Interaction](#)
- [Hotspot Freeform Question Slide](#)
- [Drag and Drop Freeform Question Slide](#)
Adding Markers

Markers in Storyline offer a quick and easy way to add a hover-and-reveal or click-and-reveal effect to your course. You can place a marker anywhere on a slide, and when learners view your published output, they can hover over it or click on it to experience additional content. That additional content can include a pop-up label, descriptive text, audio, an image or movie, or a combination of all of these. You can have as many markers on a single slide as you like.

**Inserting a marker**

1. In Normal View, click the **Insert** tab and choose **Marker**.
2. From the menu that appears, choose the icon you’d like to use on your marker.

3. Your cursor changes to a crosshair shape. Click anywhere on your slide to insert the marker.

4. Once you insert the marker, a label appears where you can enter a title and descriptive text. By default, the title appears when learners hover over the marker, and the full label appears when they click it (but, if you want, you can customize this behavior, as we’ll see in a moment). When you’re finished, click anywhere outside the label to collapse it.

   - **Tip:** If you prefer to omit the marker label and include audio only, you can just leave the label blank. See “Adding sound to a marker” and “Making an audio-only marker,” later in this tutorial.
Now that you've inserted a marker on your slide, there are all sorts of things you can do to customize the way it looks and behaves. Check out the options throughout the rest of this tutorial.

**About the fonts used in the marker label**

When you insert a marker and enter some text on its label, the fonts used for the label's title and descriptive text default to your project's theme fonts. If you want to use a different font, you can change the font directly on any individual label. Or, to change all the labels in your project to the same fonts, you can customize your project's theme fonts. (Keep in mind that if you change the theme fonts, this will affect other parts of your course, such as the fonts used for body text, quiz questions, and more.)

**Resizing or repositioning a marker's label**

If you don't like the default size or location of a marker's label, you can change it so that it fits better with your slide content:

1. Select the marker on the slide. The label appears automatically.
2. Click and drag one of the resizing handles to change the label's size.
3. Click and drag any part of the label's outline to move it to a different place, relative to the marker.

**Changing the marker icon**

Storyline provides a huge library of symbols to choose from, and if you change your mind about the one you chose initially, it's easy to change:

1. Select the marker on the slide.
2. On the **Format** tab, click **Change Icon** and pick a different symbol.
Adding sound to a marker

You can add pre-recorded sound files or record your own audio right in Storyline:

1. Select the marker on the slide.
2. On the Format tab, click Sound.

3. Choose any of the following:
   - Sound from File: This allows you to import an audio clip you've pre-recorded elsewhere. Learners will hear the audio when they mouse over or hover over the marker.
   - Record Mic: This allows you to record and save the audio within the marker.
   - Options: This is where you can change your audio playback device and recording devices. You can also modify the recording volume levels. These default to the same settings as your system settings.

After you've added some audio to a marker, you'll be able to access additional tools, such as the Audio Editor, a volume adjuster, and more. To explore these options, select the marker, click the Format tab, and click Sound. For more details on using these options, see the tutorials on Editing Sound and Using the Sound Tools.
Adding a picture or video to a marker

You can also include an image or a movie within the marker's pop-up label. Here's how:

1. Select the marker on the slide.
2. On the Format tab, click Media.

3. Choose any of the following:
   - Picture from File: This allows you to insert an image that's currently stored on your computer.
   - Video from File: This allows you to insert a movie that's currently stored on your computer.
   - Video from Website: This allows you to insert a movie that's hosted on a website where embed codes are provided (such as Screenr, Vimeo, or YouTube).
   - Record Webcam: This allows you to insert a video from your webcam.

Once you've added an image or a movie to a marker, you can make adjustments or edits as needed. You'll just need to select the marker on your slide, then select the file or movie and choose the Format tab. For more guidance, check out the tutorials on Adjusting Properties for Pictures, Screenshots, and Characters; Editing Videos; and Adjusting Video Properties.
Changing a marker’s animation

By default, Storyline applies a swirl animation to new markers you add to a course. (The animation won't be visible until you preview or publish.) You can change or remove the animation like this:

1. Select the marker on the slide.
2. On the Format tab, use the Animate selector to choose a different animation style, or choose None to remove the animation.

Changing a marker’s hover/click behavior

By default, when you publish your course and learners hover over a marker, the label’s title pops up. If learners click on the marker, then the entire label pops up, revealing any descriptive text, media, or sound you’ve added.

If you want, you can change this behavior so that no clicking is necessary—when the user hovers over the marker, the entire label appears, and any sound associated with the label begins playing. To do this, just select the marker on your slide and, on the Format tab, choose Show All On Hover.

Making an audio-only marker

If you’d prefer not to display a label when the user hovers or clicks but would rather use your marker as a clickable sound button, you can do this:

1. Insert a marker as described above. When the label appears for you to enter a title and descriptive text, don't worry about entering anything.
2. With the marker selected, click the Format tab, and use the Sound button to add some audio to the marker.
3. With the marker still selected, click the Format tab, and mark the Audio Only box.

Customizing the marker’s fill, border color, and icon color

When you first insert a marker in a Storyline project, it’ll have a default blue fill color and blue outline. The icon color on your marker corresponds to the “Text/Background Light 1” color within the design them that you’re using for your course. (More about design themes here.) But it’s easy to change any of these colors for any marker—you can do it like this:

1. Select the marker on the slide.
2. On the Format tab, choose any of the ready-made Marker Styles. Or, use the Marker Fill, Marker Border, and Icon Color selectors to choose your own colors for these items.

- Note: The Marker Fill and Marker Border options behave a lot like the options for customizing the fill and outline of a shape—in fact, you can even change the marker fill to a picture, texture, or gradient if you want!
**Customizing the label's fill and border color**

In the same way that you can customize a marker's colors, you can also customize the label that goes with it. Here's how:

1. Select the marker on the slide.
2. On the **Format** tab, choose any of the ready-made label styles. Or, use the **Label Fill** and **Label Border** selectors to choose your own options for these items. The fill and border options behave a lot like the options for customizing the fill and outline of a shape.

   ![Use the Label Styles to quickly change the label's fill and border color...](image)

   ![Or, choose your own fill and border color here.](image)

*Tip:* If you customize a label's fill and border, and you want to apply the same colors to labels of other markers on the same slide, just select the marker and, on the **Format** tab, click **Apply To All**.

**Setting the default appearance of markers and labels**

If you plan on adding several markers to your project, here's a time-saving trick to help you make them all look uniform. Once you create the first marker, you can set it as the default. This way, any additional markers you add will inherit the same characteristics for the:

- Marker fill
- Marker outline
- Icon color
- Label fill
- Label border

Here's how to set the default:

1. Customize a marker's fill, outline, and icon color and the corresponding label's fill and border color.
2. Right-click the marker and choose **Set as Default Marker**.

Once you do this, any new markers you add to your project will have the same fill and colors you assigned to the original marker. In fact, Storyline remembers your default preferences even if you close your file and come back later. (Other Storyline projects, however, will be unaffected.)
Adding Data Entry Fields

Storyline’s data entry fields allow you to dynamically collect information from your users, which can then be stored in variables, manipulated with triggers, and displayed on any slide or layer using references.

In this tutorial we'll take a look at how to insert data entry fields, and how to use references to make the user-entered data appear when and where you want.
**Inserting a data entry field:**

1. In **Normal View**, go to the **Insert** tab on the toolbar.
2. Click **Data Entry**, and select either **Text Entry** or **Numeric Entry**. (In a text entry field, learners can enter any alphanumeric characters. A numeric entry field accepts only numbers, decimals, and hyphens preceding negative numbers.)

3. Click on the slide to add the field, or click and drag if you want to make the field a specific size. (You can always resize it later by selecting it and adjusting the handles just like you would for a text box.)

4. If you like, customize the prompt (instruction) text that appears inside the field.
Two things happen when you insert a Data Entry field:

- Storyline creates a variable to hold the data. It’ll be either a text variable (if you inserted a text entry field) or a number variable (if you inserted a numeric entry field). You can view all the variables in your project by clicking the Manage project variables button in the lower-right of the Triggers panel.

- Storyline also creates a trigger, which sets the value of the variable to whatever the user types in the field when the control loses focus. (To learn more about managing triggers, take a look at this tutorial.) Note: The Enter key will add line breaks (returns) to text that the user types in the field if the field is tall enough to accommodate more than a single line of text. However, if the field is only tall enough for a single line of text, the Enter key will assign the user’s text to the variable.
Renaming a data entry field:

When you insert a data entry field onto a slide, it'll appear in the timeline with a default name (Text Entry or Numeric Entry). It can be useful to give it a more intuitive name. This makes it easier to choose the correct object when you’re applying triggers or working with other features in Storyline. There are a couple of ways to rename a data entry field. You can right-click it, and select the Rename option from the shortcut menu that appears.

Or, you can use the timeline to rename objects, including data entry fields.

You can also rename a data entry field by double-clicking it in the timeline
**Changing the variable name:**

When Storyline creates the variable for your data entry field, it assigns a default name (*TextEntry* or *NumericEntry*) to the variable. (This name is separate from the name assigned to the actual data entry text field described above.) If you have multiple data entry fields in your project, you’ll likely find it easier to manage them if you give their variables easily recognizable names. Here’s how to rename a variable:

1. Click the **Manage project variables** button in the Triggers panel.
2. Select the variable you want to rename and click the **Edit** button (the icon that looks like a piece of paper with a pencil), or simply double-click the variable.

![Variable dialog](image)

**Select the variable you want to rename and click the Edit button -- or just double-click the variable**

3. When the **Variable** dialog opens, type a new name.

![Variable dialog](image)

4. Click **OK**.
**Using a variable reference to display the user-entered data somewhere in your course:**

Any data you collect with a data entry field can be displayed anywhere in your course. You just need to insert a reference to the data entry field’s variable. Here’s how:

1. Place your cursor within the text of an existing button, shape, caption, or text box.
2. On the **Insert** tab, click **Reference**.

![Reference button](image1)

3. On the **References** window, select the variable you want to reference.

![Variable list](image2)

   **Select the variable you want to reference, and click the OK button**

4. Click **OK**.
As a placeholder, Storyline inserts the variable name, flanked by percent signs, into your button, shape, caption, or text box. In your published course, this placeholder text will be replaced with whatever data your users type in the data entry field.

- **Note**: You can format the placeholder text any way you like, using the formatting options on the **Home** tab. Any formatting you apply to the placeholder text will also be applied to the actual value of the variable when it is displayed to your users during playback. To learn about the various formatting options, take a look at the **font** and **paragraph** tutorials.
Changing font formatting:

After inserting a data entry field on your slide, you can change the font formatting for the text that users will enter. Here's how:

1. Select the data entry field on your slide.
2. Go to the **Home** tab, and use any of the following **Font** formatting options:
   - Font
   - Font Size
   - Font Color
3. You can also change the horizontal alignment (left, center, right).

You can apply some additional formatting options to the *prompt (instruction) text* in the data entry field, such as bold, italics, underline, highlight color, and even bullets. However, these formatting options will not apply to the user-entered data.

And, as noted in the section above, if you choose to display the *variable reference* on a slide or layer for your users to see, you can format the placeholder text, using any of the **font** and **paragraph** options on the **Home** tab.
**Applying styles and effects to a data entry field:**

1. Select the data entry field on your slide.
2. Click the **Format** tab.
3. Now you can click on any of the ready-made **Shape Styles**, or choose your own **Shape Fill**, **Shape Outline**, and **Shape Effects** by using the options on the ribbon. For even more flexibility, click the small arrow in the lower-right corner of the **Shape Styles** section of the ribbon to access the **Format Shape** window.

The colors available on the **Format** tab are controlled by your project's design theme. You can learn how to customize the colors in your design theme [here](#).

**Deleting a data entry field:**

To delete a data entry field, simply select it, and click the **Delete** key on your keyboard. When you delete a data entry field, the variable and trigger that were automatically created with you data entry field will also be deleted.

**Using a data entry field to trigger actions or perform calculations:**

Because Storyline stores user-entered data in variables, you can use triggers and conditions to perform specific actions based upon the data that a user enters. Similarly, if you are using a **numeric** entry field, you can use triggers and conditions to make mathematical calculations based upon the value that a user enters. To learn how, check out [this tutorial](#).
Converting to a freeform text entry question:

After adding a data entry field to a slide, you can, if you wish, convert the slide to a text entry question, so that you can evaluate it as part of a quiz. To learn how, review this tutorial. It is important to note that, although you can have as many data entry fields on a slide as you want, only one data entry field per slide can be evaluated as part of a freeform text entry question.

You might also want to explore:

- Working with Variables
- Adding and Editing Triggers
- Text Entry Freeform Questions
- Adding Result Slides
Adding Scrolling Panels

Storyline's scrolling panel feature is a great tool when you want to display large images, large amounts of text, or other objects that don’t fit well within the space you want to place them. A scrolling panel allows learners to scroll vertically so that they can see whatever content you've placed inside it. Scrolling panels can contain just about any objects: pictures, screenshots, videos, shapes, captions, markers, characters, web objects, text boxes, buttons, hotspots, data entry fields, and mouse cursor objects. Pretty much the only thing they can’t contain is additional scrolling panels, or objects that originate from the placeholders on your slide master layouts.

You can have as many scrolling panels on a single slide as you like. You can also add scrolling panels to slide layers or slide master layouts if you want. (If you use a scrolling panel on a slide master layout, though, you'll only be able to add items to it when you're on the slide master layout itself—you won't be able to add items to it from individual slides.)

**To insert a scrolling panel:**

1. Go to the slide or slide master where you want to insert a scrolling panel.
2. Select the **Insert** tab, and click **Scrolling Panel**.
3. Your cursor changes to a crosshair. Click and drag on your slide to draw the scrolling panel.

- **Tip:** Some users find it helpful to draw the scrolling panel especially large at first (since that makes it easier to insert objects into it) and then drag the handles on the scrolling panel to make it smaller. Keep in mind that no scroll bars will appear unless the scrolling panel is smaller than its contents.

Once you've drawn your scrolling panel, it'll appear with a thin, dotted bounding box. Now you can drag items into the scrolling panel, and resize, move, or format the panel as you like.

**To add objects to the scrolling panel:**

1. First, insert the object onto your slide.
2. Select the inserted object and drag it over the scrolling panel, making sure your cursor is also over the scrolling panel area.
3. If your object is taller or wider than the scrolling panel, you'll notice that its sides become concealed by the boundary of the scrolling panel once it's inside. Release your mouse button to drop the object into the scrolling panel.
To resize or move the scrolling panel:

You can resize or move the scrolling panel before or after placing objects inside it. Here’s how:

1. Select the scrolling panel on your slide.
   - **Tip:** If you’re having trouble selecting the scrolling panel without selecting an object inside it, you can always open the *timeline* and select it there, rather than trying to click it on the slide.

2. To resize the scrolling panel, drag one of the resize handles to make the panel larger or smaller.

3. To move the scrolling panel, hover over it after selecting it, and when your cursor changes to a four-pointed arrow, click and drag the scrolling panel to the place you want it to be. Any objects you’ve added to the scrolling panel will move right along with it.

When your cursor looks like this, just click and drag to move the scrolling panel.
To remove an object from the scrolling panel:

1. Select an object within the scrolling panel.

   • **Tip:** If you're having trouble seeing or selecting the desired object, it might be in a part of the scroll area that's out of view. You can click and drag the slider on the right edge of the scroll panel up or down to see the panel's contents. Or, open the **timeline** and click the arrow next to the scrolling panel object. This expands the list to show what the scrolling panel contains, and you can click the object you want to work with:

   ![The arrow expands the list so you can see what's in the scrolling panel](image)

2. Once you've selected an object, just drag it away from the scrolling panel and drop it on any other part of your slide.
**Applying styles and formatting:**

By default, scrolling panels are transparent, so anything that's part of your slide background, and other objects that are behind your scrolling panel, will show through. Sometimes this can make items in the scrolling panel difficult to see or read—but no worries, because you can easily format the scrolling panel background and outline to look however you want. Here's how:

1. Select the scrolling panel.
2. Click the **Format** tab.
3. Now you can click on any of the ready-made Shape Styles, or choose your own fill color and outline color by using the options on the ribbon. For even more flexibility, you can click the small arrow in the lower-right corner of the **Shape Styles** section of the ribbon to access the Format Shape window. For guidance on how to use the formatting tools, check out the tutorial for *Adjusting Properties for Shapes, Captions, and Text Boxes*, and the tutorial on using the *Using the Format Shape Window*, since the formatting options for scrolling panels work much the same way.

---

Use the Shape Styles, or pick your own fill, outline, and effects for your scrolling panel.

Or, click here to open the Format Shape window.
Adding Mouse Cursors

A mouse cursor is an object you can use on any slide to depict a moving mouse effect. If you like, you can also include a mouse-clicking action and sound. Mouse cursors are an easy way to enhance courses that include demos of software or web-based applications.

There are two ways to add mouse cursors on your slides:

- You can insert them manually via the Insert tab on the Storyline ribbon. This is handy, for example, when you're using your own screenshots to build a software demonstration.
- You can have Storyline insert mouse cursors for you automatically as part of a screen recording. Any time you create a screen recording in Storyline and insert it as Step-By-Step slides with View Mode Steps, Storyline inserts a mouse cursor object on the appropriate slide to show mouse movements from your recording.

You can customize any mouse cursor, whether you've inserted it yourself or Storyline inserted it as part of a screen recording. For example, you can swap it for a different cursor style, customize the direction of the mouse motion, or change or remove the clicking sound or effect.

Each slide can include one mouse cursor on the base layer of the slide. It's not possible to add multiple mouse cursors to a single slide, nor is it possible to add mouse cursors to slide layers other than the base layer.
**Inserting a mouse cursor manually**

Storyline adds mouse cursor objects to your slides automatically when you insert a screen recording as Step-By-Step slides with View Mode Steps. But you can also insert a mouse cursor manually on any slide you want. Here's how:

1. Go to the slide where you want to insert a mouse cursor.
2. Click the **Insert** tab.
3. Choose the **Mouse** button.

4. Click on the style you prefer.

Storyline inserts the mouse cursor object on your slide. Now you can customize it as you like, using the options described below.

**Swapping to a different cursor style**

If you want to use a different cursor style on a mouse cursor, here's how to switch it:

1. Select the mouse cursor object on a slide. If you have trouble seeing it, you can always open the Timeline below your slide and click on the **Mouse Cursor** object:

![Mouse Cursor Object in Timeline](image)

An easy way to select your mouse cursor for editing is to find it on the timeline and click it.

2. Choose the **Format** tab.
3. Do either of the following:

- Choose one of the cursor styles available on the ribbon. (To expand the list of choices, click the small arrow in the lower-right corner of the cursor styles library.)

- Or, click the small arrow on the cursor styles to expand the list of choices, and then choose **Browse for Cursors**:

  ![Image of cursor styles]

This allows you to choose from any of the default Windows cursors available on your system, or to browse for any other file with a `.cur` or `.ani` extension.
Changing or removing the mouse clicking sound

When the mouse reaches the end of its path, it can play a single click or double-click sound, or you can omit the clicking sound if you prefer. Here's how to set your preference:

1. Select the mouse cursor on your slide.
2. Click the Format tab.
3. Choose None, Single, or Double from the Clicks section of the ribbon:

Turning off the visual click effect

By default, in your published course Storyline applies a mouse-click effect (a small animated circle) at the point when the mouse clicks. If you'd rather omit the click effect, just select the mouse cursor on your slide, click the Format tab, and unmark the box next to Show Click Effects.
Changing the mouse’s path

Here’s how you can set the direction from which the mouse cursor appears, and whether the path is curved or straight:

1. Select the mouse on the slide. If you have trouble seeing it, you can select it by using the timeline as shown in the instructions above for “Swapping to a different cursor style.” Once you select it, you’ll see the mouse path direction on your slide, represented by a black line and arrow, like this:

2. Choose the Format tab.
3. Mark the Straight Pointer Path box if you’d like the mouse path to be straight rather than curved.

4. Use the Enter From selector to choose from eight entrance points.
• **Note:** If the **Enter From** selector is grayed out, it's because the path direction is already determined by the previous slide. When you have multiple consecutive slides with mouse cursors, the end point of the first will be the beginning point of the next.

**Changing when the mouse motion begins, the speed of the motion, and speed before click**

When a slide contains a mouse cursor object, the mouse stays on screen for the duration of your slide. You can, however, use Storyline's timeline to change when the mouse motion starts and ends. (Unlike other objects, for mouse cursors, you use the timeline to control the beginning and end of the cursor's motion - not the appearance and disappearance of the cursor itself.) You can also choose to make the mouse motion slow down before the click.

Here's how to adjust when the mouse motion begins, and its speed:

1. On the timeline, select the **Mouse Cursor** object.
2. Hover over the left border of the object until your cursor changes to a double-headed arrow.
3. Click and drag the left border of the object to the point on the timeline when you want the motion to start. Drag the right border to the point when you want the motion to end. (In this way, you are also controlling the speed of the motion, since a shorter duration results in a faster motion, and a longer duration results in a slower motion.)

![Timeline with mouse cursor object highlighted]

Drag the left edge or right edge of the mouse cursor object to control when the motion starts or ends.

4. If you want the mouse cursor to slow down a little bit before the click action, mark the box next to **Reduce Speed Before Click** on the Format tab.
Hyperlinks are a great way to add interactivity to your course—they enable learners to click something on your slide and jump directly to the content they need.

If you've used hyperlinks in other tools, you're probably accustomed to thinking of them as clickable items that take learners to:

- a different part of the course,
- a web page,
- a document,
- or some other type of file.

These are the sorts of hyperlink actions we'll cover in this tutorial—but it's worth mentioning that in Storyline, hyperlinks are a type of Trigger, and they're actually just one of many types of Triggers you can create. For a deeper dive into Triggers, and how to use them for all kinds of additional interactivity, you can check out the tutorial on Adding and Editing Triggers.

**Hyperlinking to a different part of the course**

Here's how you can add a hyperlink that takes learners to a different part of your course:

1. Select the item you want to be clickable. The item you select can be a text box, a word (or a string of words) within a text box, or some other object you've inserted onto your slide, such as a picture, screenshot, shape, caption, or character.
2. Do any of the following:
• Press Ctrl+K on your keyboard.
• Or, if you're adding a hyperlink to text, right-click the text and choose Hyperlink.
• Or, click the Insert tab and choose Hyperlink.

3. The window below appears. If you’re adding a hyperlink to a string of text, you’ll see a field called **Link Text** which shows the text that you’ve selected for the hyperlink. You can change that text here if you want.

4. Use the **Action** field to select one of the following:
   - **Show layer**: This displays a different layer of the current slide. If you choose this, you'll then need to use the **Layer** field to pick the layer you want to display. For more on layers, see Adding and Editing Slide Layers.
   - **Jump to Slide**: This takes the learner to a different slide in your course. If you choose this, use the **Slide** field to pick the destination slide. (Jumping to the next slide means the learner will go to the next slide in your course, based on the slide numbering that appears in Normal View or Story View. Jumping to the previous slide means the learner will go to whichever slide they most recently viewed.)
   - **Jump to Scene**: This takes the learner to a particular scene. If you choose this, you'll then need to use the **Scene** field to pick the destination scene. (Jumping to the next scene means the learner will go to first slide of the next scene in your course, based on the scene numbering that appears in Normal View or Story View. Jumping to the previous scene means the learner will go back to the slide they were on in the most recently viewed scene.)
   - **Lightbox Slide**: This causes whatever slide you choose to appear in a lightbox over the current slide—in other words, everything else in view grows dim, and the lightbox slide appears over the dimmed course.

5. For the destination, you can choose the layer, slide, or scene you want the learner to see, or choose **Unassigned** if you want to set up the trigger now and come back later to choose the destination.
6. Leave the **When** field set to **User Clicks**.
7. If the **Object** field appears on the window, leave it set to whatever object you selected.
8. Click **OK**.
**Hyperlinking to a web page, document, or file**

To add a hyperlink that opens a web page, document, or file, do this:

1. Select the item you want to be clickable. The item you select can be a text box, a word (or a string of words) within a text box, or some other object you've inserted onto your slide, such as a picture, screenshot, shape, caption, or character.

2. Do any of the following:
   - Press **Ctrl+K** on your keyboard.
   - Or, if you're adding a hyperlink to text, right-click the text and choose **Hyperlink**.
   - Or, click the **Insert** tab and choose **Hyperlink**.

3. The window below appears. If you're adding a hyperlink to a string of text, you'll see a field called **Link Text** which shows the text that you've selected for the hyperlink. You can change that text here if you want.

4. Use the **Action** field to select **Jump to URL/File**.

5. In the **File** field, indicate the resource you want to open when the learner clicks:
   - **If it's a document or file you currently have on your hard drive**, click the ellipse (...) button to browse and select the file. Later, when you publish, Storyline will include a copy of the file itself right along with your course content. The file will be in a folder called story_content/external files. Learners will of course need to have the appropriate software in order to view the file. For example, if the resource is a Word document, learners will need to have Microsoft Word installed on the computer from which they're viewing the course. **TIP:** If you have a lot of files that you want to provide to your learner, and you want to make them available from anywhere throughout your course, you might want to instead use the Resources tab on the player. Learn more about that in [this tutorial](#).
- If it's a web page, enter the full URL. To customize the way the window opens, click the globe (Browser options) button. The following window appears, where you can choose whether the browser opens in the current browser window or a new one. You can also choose the browser controls that appear, and the window size. Click Save after you've made your choices.

![New Browser Window Properties]

- To the right of the File field on the Trigger Wizard window, you can click the green checkmark to verify that the link you've entered works properly. If your hyperlink is to a file, a window will open with the file highlighted. If your hyperlink is to a URL, the web page you selected will open in your browser.

7. If the Object: field appears on the window, leave it set to whatever object you selected.
8. Click OK.
Changing the color of hyperlinked text

If you apply a hyperlink to text, the text color changes and an underline appears. Also, when users hover over the hyperlink in your published course, a semitransparent hover color appears, in a color that matches the hyperlink color.

The hyperlink color comes from the design theme. You can modify it by doing this:

1. Click the Design tab and choose Colors.

2. The design theme you're using will be marked by a thin orange outline. If you're using a Custom theme (these appear in the top section of the list), right-click it and choose Edit. If you're using a Built-In theme, choose Create New Theme Colors (since the built-in ones can't be edited).
3. In the color theme editor, find the **Hyperlink** color and change it to whatever you like.

4. If you're creating a new set of theme colors rather than editing an existing custom theme, you can enter a name for the new color theme in the **Name** field.

5. Click **Save** to return to your course.

**Editing a hyperlink's destination**

If you apply a hyperlink and later need to change its destination, you can do that quickly via the **Triggers** panel. Find the trigger you set up previously, and click the destination (it appears in blue with an underline). Then just make whatever changes you need.
If you need to change the type of hyperlink (for example, you want to change it from a document hyperlink into a link that points to a slide in your course), select the trigger and either double-click it, or click the pencil icon (Edit the selected trigger). This pops up the trigger wizard where you can make any changes necessary.

**About previewing slides that contain hyperlinks**

If you preview a part of your course that contains hyperlink, you might find that the hyperlinks don't work as expected. To properly test hyperlinks, you'll need to publish your course and test the hyperlinks in your published output.

**You might also want to explore:**

Adding and Editing Triggers
Converting an Existing Slide to a Freeform Interaction

The **Convert to Freeform** option allows you to quickly turn any content on your slide into a freeform question or interaction. For example, you can insert some images, characters, shapes, or any other objects onto your slide and then convert them to a drag-and-drop interactivity, a graphical multiple-choice, or any of several other forms of interactions.

Here's how to do it:

1. While in Normal View, click the **Insert** tab.
2. Select **Convert to Freeform**.
3. When the following window appears, choose one of the options on the left and click **OK**.

4. A question editor appears, where you'll be able to choose the items you want to use for your question or interaction, and set your preferences for the way the question works. Different types of freeform questions have different options. For help with setting up each type of freeform question, check out the section called "Customizing the Question" in each of the following tutorials:

   - Drag and Drop
   - Pick One
   - Pick Many
   - Text Entry
   - Hotspot
   - Shortcut Key

5. Once you're finished setting up your question or interaction, click **Save & Close** to return to the Normal View of your slide.
Need to make edits later?

You can always go back and change your preferences for the way your freeform question behaves. Just go to the slide that contains the freeform question, find the Question panel in the upper-right of your slide workspace, and click the Edit button that appears there. This opens the question editor, where you can make whatever changes you like.
Changing the freeform question back to a regular slide

If you later decide you want to remove the interactivity from your slide, you can do so like this:

1. While in Normal View, click the Insert tab.
2. Select Remove Freeform from the Storyline ribbon.

3. Storyline will prompt you to make sure you really want to remove the interactivity from the slide. Click OK if you do.

Any elements you had inserted onto your slide will stay there, but the interactivity will be removed. So will any slide layers that Storyline previously created for question feedback.
Working with States, Triggers, and Layers

Storyline’s triggers make it easy to add interactivity to your course. Assigning triggers to objects is how you make things happen (jump to slide, show layer, changing state of an object). Anything interactive will have one or more triggers.

Triggers can be applied to any type of object: buttons, characters, shapes, images, text and even characters. Because it’s Storyline, you’ll never have to write a line of code.

Storyline’s Triggers Wizard makes it even easier by guiding you through the process.

1. **What** happens (actions)
2. **Where** does it happen (slide, layer, object, character, etc)
3. **When** does it happen (event)

The **Action** field is the only field that’s fixed while **Slide**, **When** and **Object** fields are contextual to the selected action. Looking closer at the default trigger, we can see that it’s set to: Jump to next slide when the user clicks Button1.

**Summary**

Anytime you want something to happen, you need to create a trigger. This includes jumping from one slide to another, changing the state of a character, showing and hiding layers, and adjusting variables. If you need an action, you need a trigger.
Adding and Editing States

Storyline allows you to add states to a variety of objects, such as images, shapes, captions, characters, and buttons. States provide different views of the same object, which can be triggered based upon the user’s interaction with your content.

**Opening the Timeline, States and Notes panel**

To manage states in Storyline, you will need to open the Timeline, States and Notes panel. Here’s how:

1. When you’re in Story View, double-click the slide you wish to edit. Or, when you’re in Normal View, select the slide you wish to edit from the left navigation pane.
2. Click the arrow in the lower right corner of the slide stage to expand the Timeline, States and Notes panel.
3. Then select the States tab.

Adding states

Images, shapes, captions, and characters have one state by default. Buttons have multiple states by default. However, you can add more states to any of these objects. Here's how:

1. Click the object on your slide to select it.
2. In the States panel, click the Edit States button.

3. Click the New State button (the icon that looks like a blank piece of paper) to create an entirely new state.
Or, click the **Duplicate State** button (the icon that looks like two pieces of paper) to create a copy of the selected state.

4. Assign a name to the new state, or use the drop-down list to choose one of the **built-in states** that Storyline provides.

5. Then click the **Add** button.

6. If you want to modify the appearance of the new state that you just added, follow the steps in the next section of this tutorial.

7. When you have finished adding and editing states, click the **Done Editing States** button.
**Editing the appearance of states**

You can change the appearance of any state, such as its text, shape, color, effects, placement, size, etc. If you are editing states for a character, you can even change the expression, pose, and perspective. Here’s how:

1. Click the object on your slide to select it.
2. In the States panel, click the **Edit States** button.

3. Select the state you wish to modify, or add a new state (see the section above). Then use the various Storyline toolbar options to make the desired changes.
4. When you have finished editing states for the selected object, click the **Done Editing States** button.

If you need to reset a state to its original appearance while you are editing it, click the **Reset State** button.

By default, other elements on the slide will dim while you are editing states for a particular object. If you prefer, you can uncheck the “**Dim background objects**” checkbox to display all elements on the slide in their normal states. An example of why this might be useful is when you need to use the color picker to match the color of another element on the slide.
To save time while you are editing states for an object, you can use the “Editing states on:” drop-down list on the far right side of the States panel to switch to and edit other objects on the same slide. As you scroll over the items in the list, Storyline marks them with an outline on the slide, so that you can easily see what you’re selecting. All your changes to all objects will be saved when you click the Done Editing States button.
**Setting the initial state of an object**

When an object has more than one state, you get to specify which state is the initial state for that object. By default, the initial state is always *Normal*. However, you can select any other state, even *Hidden*, as the initial state for an object. Here’s how:

1. Click the object on your slide to select it.
2. In the States panel, use the Initial State drop-down list to select the desired state.

   ![Initial State Selection](image)

   Note that you can select an initial state of *Hidden*, which means that the object will not appear until the user triggers its appearance by interacting with the published content. To learn about triggers, check out [this tutorial](#).

**Deleting states**

To delete a state from an object:

1. Click the object on your slide to select it.
2. In the States panel, click the Edit States button.

   ![Edit States](image)
3. Select the state you wish to delete, and then click the **Delete State** button.

4. Acknowledge the deletion by clicking **Yes**.

5. When you have finished, click the **Done Editing States** button.
**Triggering states**

To display a state in the published story based upon the user’s interaction with the content, you’ll need to add a trigger. To learn how, see [this tutorial](#).

![Trigger Wizard](image)
Adding and Editing Triggers

Storyline’s Triggers make it incredibly easy to build interactivity into your course.

Let’s take a look at our finished example.

View the published example | Download the source file

If you’re following along, I’m working in AddingTriggers_START.story.
**Adding your first trigger**

To add a trigger to an object, select one of the following options:

- Click the Create new trigger icon in the Triggers panel
- Go to Insert > Interactive Objects > Trigger

Or, if you are working with a button that you’ve inserted on your slide, you can click the **Add trigger** shortcut that appears for that button in your Triggers panel.

The **Triggers Wizard** guides you through the process:

1. Choose the action: Show Layer
2. Select the layer to show: Layer 1
3. Select when the action occurs: User clicks
4. Which object triggers the action: Button 1
5. Click OK
6. Preview your slide

Now you have an interactive button that reveals a new layer. The process will be the same for any new triggers you create:

1. **What** happens (actions)
2. **Where** does it happen (slide, layer, object, character, etc)
3. **When** does it happen (event)
**Editing triggers**

Storyline makes it really easy to edit your existing triggers.

To edit a trigger, do one of the following:

- In the Triggers panel, double-click the trigger to bring up the Trigger Wizard. Then make whatever adjustments you like.
- Or, in the Triggers panel, look for any items that are editable on-the-fly (they'll appear underlined and in blue) and make your changes directly in the Triggers panel by clicking the blue underlined text and choosing from the dropdown menu. (Common items that you can edit on-the-fly in the Triggers panel include slide layers, variable values, variable operators, and states)
Copy and pasting triggers

When you're working with a lot of triggers, you'll likely find it faster to copy and paste existing triggers to new objects. This lets you bypass some clicking because once you paste a trigger to a new object, you can often make any needed adjustments to the newly pasted trigger by working right within the Triggers panel. Here's how it works.

1. In the Triggers panel, select the trigger you just created for Button 1.
2. Copy the trigger by pressing CTRL+C or by clicking the Copy the selected trigger icon.
3. Select Button 2 in the Triggers panel (or select Button 2 on your slide).
4. Paste the trigger by pressing CTRL+V or by clicking the Paste the copied trigger to the selected object icon.
5. Update Button 2's trigger by clicking Layer 1 in the Triggers panel, and selecting Layer 2 from the dropdown menu.

Pasting triggers to multiple objects

You can also paste a trigger to multiple objects in a single click. This comes in handy when you're applying the same types of triggers to multiple objects like a tabs interaction.

For example, if you're building a tabs interactions with a bunch of tabs, you can apply the Show layer trigger to a group of selected tabs.

Here's how it works:

1. Create the first trigger.
2. Copy one of the two triggers you just created.
3. Select Button 3 and Button 4 on your slide by shift-clicking each object.
4. Press CTRL+V or click the Paste the copied trigger to the selected object icon.
5. In the Triggers panel, update the triggers for Button 3 and Button 4 to target the correct layers.

Pasting triggers to multiple objects is a huge time-saver. Just remember to update each trigger after you paste.
**Copying triggers by duplicating objects**

Another workflow for copying and pasting triggers is to duplicate an object that already contains a trigger. This is often helpful when you’ve customized the look and the feel of a button and have multiple triggers on the button.

**Download the source file**

If you’re following along, I’m working in `DuplicatingObjects_START.story`.

The project file has been started for you. It includes four slide layers and a button with two triggers. The button triggers are set to: show a layer and change the character’s state:
Instead of creating a new button and adding two triggers each time, a quicker way to work is to duplicate the button four more times. The triggers carry with the duplicated objects.

1. Select Button 1 and press CTRL+C to copy the button.
2. Press CTRL+V four times to paste four copies of the button.
3. In the Triggers panel, you can now easily update both the desired layer and character state for each button object.

With Storyline, you'll find there are many ways to achieve the same output. Understanding the multiple workflows will help you work as efficiently as possible.

You might also want to explore:

- Adding Buttons
- Adding and Editing Slide Layers
- Adding and Editing States
Adding and Editing Slide Layers

Slide layers allow you to display additional content on a slide at certain points in your course or in response to the way your learners interact with your content. Once you've added layers to a slide, you can create triggers that tell Storyline when you want a specific layer to be revealed.

To insert a slide layer:

Go to the slide where you want to insert a layer. Then do either of the following:

- Click the **Insert** tab and choose **Slide Layer**.
• Or, click the **New Layer** button in the Slide Layers panel.

The new layer appears in the Slide Layers panel, like this:
You can add as many layers to your slide as you like.

Once you add a slide layer, you can insert content on it just like you can on the slide's base layer. You can also manage the timing and duration of any object on your layer by using the layer's timeline. Just select the layer from the Layers Panel and then click the **Timeline** tab in the Timeline, States, and Notes panel.

**To rename a slide layer:**
It's always a good idea to name your slide layers, because this allows you to more easily select the right layer when you're creating triggers. To rename a slide layer:

1. Double-click the layer's name in the Slide Layers panel.
2. Type the new name.
3. Press the **Enter** key on your keyboard or click anywhere on your slide.

**To change the layer's properties:**
For each slide layer, you can customize its properties to control its behavior. Click the small gear icon to the right of the layer's name to access the Slide Layer Properties window:
The Slide Layer Properties window appears, where you can choose your options:

Visibility:

- **Hide other slide layers**: This causes other slide layers (but not the base layer) to become invisible when the current layer appears.
- **Hide objects on base layer**: This causes everything on the slide's base layer to become invisible when the current layer appears. (If you want only some objects on the base layer to become invisible when a learner visits your layer, check out the technique described later in this tutorial for hiding only selected objects on the base layer.)
- **Hide slide layer when timeline finishes**: This causes the current layer to become hidden when the layer is finished playing.
- **Allow seeking**: If your slide's player controls include a seekbar, you can set this selector to Yes if you want to make the seekbar active on your slide layer. This is handy if the layer contains video, animations, or audio that you want learners to be able to pause, rewind, or fast-forward. If you leave the option set to Automatically Decide, Storyline will allow seeking on the layer if you've marked any of the following options: Hide objects on base layer, Prevent the user from clicking on the base layer, or Pause timeline of base layer.

Base Layer:

- **Prevent the user from clicking on the base layer**: This prevents the learner from invoking any buttons, hyperlinks, or other triggers on the base layer while the current layer is visible.
- **Pause timeline of base layer**: This causes the animations, audio, and any other objects on the base layer's timeline to pause when the current layer displays. When the layer closes, the base layer's timeline will resume.
Revisits:
These options let you control how the objects on your layers behave if learners revisit the layer.

- **Automatically decide**: This is the default choice, and it means Storyline will decide for you whether to resume the layer where the user previously left off or to reset the layer to its initial state when learners view the layer a subsequent time. Here’s the logic: If the layer contains just simple objects and/or audio but no interactivity, Storyline resets the layer to the beginning of the layer’s timeline each time the learner views the layer. But if the layer contains any interactive elements, such as buttons or any other object that includes a visited or selected state, Storyline resumes the timeline where the learner left off if they come back to the layer again.
- **Resume saved state**: Use this option if you always want the layer to resume playing where the learner last left off.
- **Reset to initial state**: Use this option if you always want the layer to reset to its initial state if learners return to it. This means any time the learner views the layer subsequent times, it'll restart at the beginning of the layer’s timeline, and any interactive objects will return to their initial states.

**To hide only specific objects on the base layer:**
The layer properties described above provide an option to "hide objects on base layer." But that option hides everything on the base layer. What if you only want to hide some of the base-layer objects? You can do that, since each slide layer has its own timeline, where you can turn off any objects that would otherwise appear on the base layer.

Just go to any slide layer and click the **Timeline** tab below the slide workspace. Click the arrow next to **Base Layer Objects**. Then use the eye icon to turn off the visibility of any base-layer objects you choose:

![Click to see the list of objects on the base layer...](image)

...then use the eye icon to hide specific items from appearing

When users visit this layer, they won't see any base-layer objects you've hidden. Once they leave the layer, the objects will reappear.
**To change the layer’s transition:**

You can apply transitions to your layers just like you can on the slide’s base layer. To apply a transition, do this:

1. Select the layer from the Slide Layers panel.
2. Click the **Animations** tab.
3. Choose a transition and a speed.

For more on transitions, see [this tutorial](#).

**Rearranging your layers**

Slide layers display on top of your base layer (not behind it). What happens when you have *multiple* slide layers, and you’ve set the visibility in the Layer Properties to allow other layers to appear? They’ll appear in the same layer-order as they’re shown in the Slide Layers panel, bottom to top.

To change the layer order, you can select a layer in the **Slide Layers** panel and drag it up or down to a different position in the stack.

**Hiding, unhiding, and dimming layers**

When you have multiple layers on a slide, you may find it useful to display or hide some of them while you’re editing your slide. To display a layer, click the eye icon that appears to the left of the layer title in the **Slide Layers** panel. To make it visible again, click the eye icon again.

![Click the eye icon next to any layer to make it visible or invisible while you’re editing your slides](image)

372
By default, all layers except the one you're currently working on will display as dimmed. If you'd rather see them in full color, unmark the box called **Dim non-selected layers** in the **Slide Layers** panel.

**Duplicating layers**

You can duplicate any layer by selecting it and clicking the **Duplicate** button or by pressing **Ctrl+D** on your keyboard.
Deleting layers
You can remove a slide layer by selecting it from the Layers Panel and clicking the red X or pressing the **Delete** key on your keyboard.
Applying Animations and Slide Transitions

Storyline's animations and slide transitions are a great way to add life and meaning to your course content. When you use them thoughtfully and strategically, animations and transitions can help make your content easier to understand, more engaging, and more professional-looking. They can also help you explain a process or tell a story because you can use them to convey change or draw attention to specific information.

Check out the following tutorials to learn more about how to work with animations and transitions in your project.

- Adding Entrance and Exit Animations to an Object
- Syncing Animations
- Adding Transitions to Your Slides and Slide Layers
Adding Entrance and Exit Animations to an Object

Storyline includes a flexible library of entrance and exit animations that you can apply to pictures, shapes, captions, text, characters, movies, and any other object you've inserted onto your slides.

Entrance animations

To apply an entrance animation, do this:

1. Select an object on your slide.
2. Click the Animations tab.
3. Click the None button in the Entrance Animations section of the toolbar. Choose one of the animations available. If you see an option to choose All At Once or By First Level Paragraph, it means that the object you selected is made up of multiple items. Choose All At Once if you want all the items to animate in at the same time, or choose By First Level Paragraph if you'd like the items to animate one after the other.
4. Use the Speed dropdown to select an animation speed.

5. Use the Enter From dropdown to select the direction from which the object enters. If you see an option here for Current, this just means the object will animate in from its current location.

If you want your entrance animation to happen at a specific point during the slide duration (rather than right at the beginning of the slide), check out the tutorial on Syncing Animations.

Exit animations

If you'd like the item to also disappear from your slide at some point during the slide duration, follow the same steps as the ones above, but use the Exit Animations section of the toolbar.

Can I animate grouped items or multi-item quiz answers separately?

Yes! If you open Storyline's timeline, you'll see a little arrow next to the item representing the answer choices or the grouped objects. Click that to expand the group, and then you'll be able to animate each item individually.
For more details, see the tutorial on how to sync animations.

**Can I use animations on master slides?**

Yes! Just click the View tab in Storyline and choose Slide Master or Feedback Master. Go to the master slide layout that contains items you want to animate. Then apply entrance or exit animations, using the steps shown above. For more on slide masters, see Using Slide Masters.

**How does Storyline handle animations on slides that I import from PowerPoint?**

When you import content from PowerPoint into Storyline, the following animations are supported:

**Entrance Animations:**

- Fade In
- Fly In
- Grow and Turn
- All other Entrance animations from PowerPoint will be converted to Fade In.

**Emphasis Animations:**

- Spin emphasis animations from PowerPoint are interpreted as Spin entrance animations in Storyline.
- All other emphasis animations are removed from content that you import from PowerPoint.

**Exit Animations:**

- Fade Out
- Fly Out
- Shrink and Turn
- All other Exit animations from PowerPoint are converted to Fade Out.

**Motion Path Animations:**

- Motion path animations from PowerPoint are not supported and are removed in Storyline.

(For more helpful considerations about imported PowerPoint content, check out this knowledgebase article.)

**You might also want to explore:**

- Syncing Animations
- Using the Timeline
- Adding Transitions to Slides and Slide Layers
Syncing Animations

Storyline makes it easy to synchronize animations. After adding animations to your objects, you can open the timeline and either position objects on the timeline manually, or use cue points to synchronize them.

To change the timing of objects manually, just drag the objects left or right along the timeline to the points where you want them to appear.

You can also adjust the duration of an object if you want it to disappear before the end of your slide. Simply drag the right edge of that object along the timeline until you reach the point at which you want it to disappear (or animate out).

Drag the edge of an object to change duration
**Right-click options**

When you right-click an object on the timeline, you will also have the following additional options to help you manage the timing and duration of that object:

- **Align to Cue Point**: moves the object along the timeline so that its starting point lines up with the Cue Point # that you select. For more about how to use cue points, see *Using cue points to synchronize animations* below.
- **Align To Playhead**: moves the object along the timeline so that its starting point lines up with the current position of the playhead (red vertical line).
- **Show Until End**: displays the object until the end of the slide.
- **Show Always**: displays the object for the entire duration of the slide.
- **Timing**: allows you to specify the **Start Time** and **Duration** of the object (in seconds).

**Using the playhead to synchronize animations**

Perhaps the quickest and easiest way to synchronize animations is to use the **Align To Playhead** feature. Here's how:

1. On the slide where you want to sync animations, open the **timeline**.
2. Press the **Play / Pause** button in the lower left corner of the timeline to begin playing your audio. **Tip**: You can also press the spacebar on your keyboard to quickly play / pause audio.

![Click the Play / Pause button to start the audio playback](image)
3. When your audio reaches the point where you want an object to animate in, click the **Play / Pause** button again to pause the playback (or click the spacebar on your keyboard to pause the audio).

4. Then right-click the object on the timeline that you want to animate in, and select **Align To Playhead**.

5. Repeat steps 2-4 until you have synchronized the entire slide.
Using cue points to synchronize animations

Another way to sync animations is to use cue points. Cue points allow you to precisely align objects on the timeline.

You can add, delete, and move cue points on the timeline. Here’s how:

- To **add** a cue point, right-click anywhere in the Timeline panel and select **Create Cue Point At Playhead**. Or, to add cue points on-the-fly, click the **Play** button in the lower-left of the timeline, and then press **C** on your keyboard at any point where you want to insert a cue point.

When your cue points are in place, you can align objects with them by right-clicking an object, scrolling to **Align to Cue Point**, and selecting the appropriate **Cue Point #**.

- To **delete** a cue point, right-click the cue point marker on the timeline and select **Delete Cue Point**.
• To delete all cue points on a slide, right-click anywhere within the Timeline panel and select Delete All Cue Points.

• To move a cue point, drag it left or right along the timeline.

*Find out more about the timeline*

For more information regarding the timeline's features and how to control the duration and timing of objects, check out this tutorial.
Adding Transitions to Slides and Slide Layers

Storyline's slide transitions are a nice way to stylize your e-learning content. Storyline offers several choices for transitions and, if you want, you can even choose a different transition for each slide, or each layer within your slide.

Here's how to apply a transition:

1. Go to a slide where you want to apply a transition. Make sure the base layer of the slide is selected in the Slide Layers panel if you want to apply the transition to the slide itself. To apply a transition to a layer within the slide, select the layer from the Slide Layers panel.
2. Click the Animations tab.
3. In the section of the toolbar called Transitions to This Slide, click on a choice or use the dropdown menu to choose the transition you'd like to apply to the current slide.
4. Use the Speed dropdown to select a speed for the transition.
5. To use the same transition elsewhere, click Apply To All. If you're on the base layer of a slide, this will apply the transition to the base layer of all other slides in your project, including slide masters. If you're on a slide layer, this will apply the transition to all other layers on the current slide. (Keep in mind that you can apply different transitions to different slide layers if you like.)

Can I apply transitions to slide masters?

Yes! Just click the View tab in Storyline and choose Slide Master or Feedback Master. Go to the master slide layout to which you want to apply a transition. Then follow the same steps shown above. For more on slide masters, see Using Slide Masters.
How does Storyline handle slide transitions that I import from PowerPoint?

When you import content from PowerPoint into Storyline, the following slide transitions are supported:

- Fade
- Uncover
- Cover
- All other slide transitions from PowerPoint will be converted to Fade

You might also want to explore:

Adding Entrance and Exit Animations to an Object
Using the Timeline
Customizing Your Project Design

Storyline provides several helpful design options to make your slides look polished and professional. Explore the possibilities by checking out the following tutorials, which will help you customize your project's design:

- **Using Themes**
- **Applying a Background Design**
- **Using Slide Masters**
- **Using Feedback Masters**

**You might also want to explore:**

- **Choosing a Story Size**
- **Using and Creating Storyline Templates**
- **Using Storyline's Basic Layouts**
Using Themes

In Storyline, you can use design themes to create a consistent visual design in your course. A design theme consists of:

- **Theme colors**
- **Theme fonts**, and
- Objects you've added to a **Slide Master**.

You can apply different design themes to different slides in your course, if you like.

To view thumbnails of the available design themes, click the **Design** tab on the Storyline ribbon. You can click the arrow in the lower-right of the thumbnail area to expand the list.

The theme assigned to the current slide will be shown with an orange outline and will appear in the section of the list called **This Project**. You'll also see a section for any **Custom** themes you've created, and the **Built-In** themes that come with Storyline:
Applying and managing themes

To apply a theme to all of the slides in your course, left-click any theme thumbnail.

Or, right-click any thumbnail and choose any of the following options.

- **Apply to Matching Slides**: This applies the theme to all slides that use the same slide master as the currently selected slide. Slides that use other slide masters will remain unchanged.
- **Apply to All Slides**: This applies the theme to all slides in your course. (You can achieve the same thing by just left-clicking the theme thumbnail.)
- **Apply Only to This Slide**: This applies the theme to the currently selected slide only.
- **Delete**: This removes the theme from Storyline. (This option isn't available on any of the built-in Storyline themes, nor on any themes that are currently used in your course.)
- **Set As Default Theme**: This allows you to designate the theme as the default for new projects. If you choose this, anytime you begin a new project in Storyline, it will inherit the default theme.

Customizing the design theme

You can make changes to the current project's design theme by:

- Adding or altering items on the [slide master](#)
- Changing the [theme fonts](#)
- Changing the [theme colors](#)

Saving a custom design theme for use in other courses

If you make some changes to the design theme (including the theme colors or theme fonts), Storyline saves those customizations within the current project. If you'd like the same design theme to be available for other projects too, do this:

1. Click the [Design](#) tab.
2. Click the arrow in the lower-right of the theme thumbnail area to expand the list.
3. Choose **Save Current Theme** from the bottom of the list.

![Image of Storyline interface with Design tab selected and theme options displayed]

4. Choose a name for your theme and click **Save**.

When you open a different Storyline project and click the **Design** tab, your customized theme will appear in the thumbnails, and you can apply it to slides in your project.

*You might also want to explore:*
- Working with Theme Colors
- Working with Theme Fonts
- Using Slide Masters
- Using Feedback Masters
**Working with Theme Colors**

Storyline comes with several sets of built-in theme colors that you can apply to your course. You can also create theme colors of your own.

**Articulate Quizmaker users**: Theme colors are shared between Storyline and Quizmaker, so any customizations you make to the theme colors in Storyline will affect Quizmaker as well, and vice versa.

The theme colors you apply to your course determine the default color choices that appear when you customize items such as text, shapes, captions, outlines, and images. For example, check out the color gallery below—these are the choices you might see when you choose the fill color for a shape. The actual theme colors appear across the top of the selection window, and shades of each appear below them. However, any time you want to apply a color that's not part of the color theme, you can choose one of the **Standard Colors**, or choose **More Colors** to choose the exact color you want.

To see the Theme Colors available, click the **Design** tab on the Storyline ribbon, and then click the **Colors** dropdown.
If you've set up any custom theme colors, they'll appear at the top of the list, in a section called Custom. The Built-In color themes will appear below that. The theme colors used on the currently selected slide are shown with a thin orange outline.

In the dropdown list, you'll see a palette of eight colors for each theme.

- The first two are designed for text and backgrounds.
- The last six are designed for accent colors—for example, the default color for shapes and Quick Styles.

To see the full color palette for any theme, or to modify any of the colors, see Modifying theme colors, below.
Applying and managing Theme Colors

To apply a set of theme colors to all slides that share the same slide master as the current slide, choose the Colors dropdown from the Design tab, and left-click the colors you want to use.

Or, from the Colors dropdown, right-click a set of colors and choose any of the following options.

- **Apply to Matching Slides**: This applies the theme colors to all slides that use the same slide master as the current slide. (You can achieve the same thing by just left-clicking the theme colors from the list.)
- **Apply to All Slides**: This applies the theme colors to all slides in your course.
- **Apply Only to This Slide**: This applies the theme colors to the currently selected slide only.
- **Edit**: This brings up the color theme editor. More about that in a minute, in the section below called Modifying theme colors. (This option is only available on custom theme colors you've created, not any of the built-in theme colors.)
- **Delete**: This removes the theme colors. (This option is only available on custom theme colors you've created, not any of the built-in theme colors.)
Creating new theme colors

Here's how you can create a new set of theme colors:

1. Click the Design tab on the Storyline ribbon.
2. Select the Colors dropdown.
3. Select Create New Theme Colors from the bottom of the list.

The color theme editor appears. Here's where you can choose your preferences for your palette of colors. These choices will determine the preset colors available when you select fill colors and outline colors for objects in Storyline. Some things you should know:

- The Text/Background items are designed to help make text easily readable when applied to shapes. For example, text that you format with the darker shades is designed to be readable when placed within lighter-colored shapes.
- The series of Accent colors are the preset color choices you'll see on the Format tab when you choose an object's fill color or outline color.
- Accent 1 is the default fill color for shapes, captions, the checkmark on checkbox buttons styles 1 & 2, and the dot on radio button styles 1 & 2. (Learn more about buttons here.)
• **Hyperlink** is the color used for text to which you apply hyperlinks.
• **Control 1** is the hover color for buttons, and the hover color on answer choices for quiz questions.
• **Custom 1** is the default fill color for buttons.
• **Custom 2** is the default color for the checkmark on checkbox buttons styles 3 & 4, and the dot on radio button styles 3 & 4.

4. Find the item you want to change, and use its color selector to assign a different color.

If you don't see a color you want when you click the color selector, you can choose **More Colors** and then do any of the following when the **Colors** window appears. Click **OK** when you're done choosing a color.

• Click on the color you want (either a square color swatch or a color in the spectrum area).
• Or, create a custom color by entering color values in the **Hue/Sat/Lum** fields, or the **Red/Green/Blue** fields, or the **Html** field.
• Or, use Storyline's color picker to choose a custom color from anything viewable on your screen. To do that, click the eyedropper, hover over any area of your screen, and click to choose a color.
If the color you’ve chosen is something you want to save for easy selection later, click **Add to Custom Colors**. The color will get added to the bank of Custom Colors in the lower-left area of the window.

5. In the **Name** field, enter a name for your new Theme Colors.

![Create New Theme Colors](image)

6. Click **Save**.

Now the custom theme colors will be available in any Storyline course you build.
**Modifying theme colors**

It's easy to go back and modify any custom theme colors you've previously created. Here's how:

1. Click the **Design** tab on the Storyline ribbon.
2. Select the **Colors** dropdown.
3. Right-click the theme colors you want to modify.
4. Choose **Edit**.
5. The color theme editor appears, and you can modify any item you choose, using the same guidelines shown above for creating new theme colors.

**Note:** You might notice that the built-in theme colors can't be modified. However, you can create your own theme colors based on any of the built-in themes by doing this:

1. First apply the built-in theme colors that you want to base yours on.
2. On the **Design** tab, click the **Colors** dropdown and choose **Create New Theme Colors**. This opens up the color theme editor, and the colors will default to the ones from the built-in color theme you just applied.
3. Now just edit the colors to your liking, and save the theme colors under a new name.

**You might also want to explore:**

- Using Themes
- Working with Theme Fonts
Working with Theme Fonts

In Storyline, one of the easy ways you can quickly customize your project is by changing the theme fonts. This allows you to alter the font used for headings, body text, and the text used for quiz questions and answer choices. You can apply the theme fonts Storyline gives you, or you can set up your own theme fonts.

Articulate Quizmaker users: Theme fonts are shared between Storyline and Quizmaker, so any customizations you make to the theme fonts in Storyline will affect Quizmaker as well, and vice versa.

Each set of theme fonts consists of a heading font and a body font:

- The heading font is used for slide titles, the question text on quiz questions, and the title on marker labels.
- The body font is used for body text on your course slides, including text that you type into text boxes, captions, buttons, and shapes. It's also used for the answer choices on quiz questions and the descriptive text on marker labels.

To see the theme fonts available, click the Design tab on the Storyline ribbon, and then click the Fonts dropdown.
If you’ve set up any theme fonts, they’ll appear at the top of the list, in a section called **Custom**. The **Built-In** theme fonts will appear below that. The theme fonts used on the currently selected slide are shown in orange. For each set of fonts listed, you’ll see the name, the heading font, and the body font.
Applying and managing theme fonts

To apply a set of theme fonts to all slides, choose the Fonts dropdown from the Design tab, and left-click the theme fonts you want to use.

Or, from the Fonts dropdown, right-click a set of theme fonts and choose any of the following options:

- **Apply to Matching Slides**: This applies the theme fonts to all slides that use the same slide master as the current slide.
- **Apply to All Slides**: This applies the theme fonts to all slides in your course. (You can achieve the same thing by just left-clicking the theme font name.)
- **Edit**: This brings up the theme font editor. More about that in a minute, in the section below called Modifying theme fonts. (This option is only available on custom theme fonts you've set up, not any of the built-in theme fonts.)
- **Delete**: This removes the theme fonts. (This option is only available on custom theme fonts you've set up, not any of the built-in theme fonts.)
Creating new theme fonts

Here's how you can create a new set of theme fonts:

1. Click the Design tab on the Storyline ribbon.
2. Select the Fonts dropdown.
3. Select Create New Theme Fonts at the bottom of the list.
The theme font editor appears. When you make changes to either of the two fields on the left side of this window, the Sample window on the right side of the window will change to show your choices.

- For the **Heading font**, choose the font you'd like to use for headings. This is also the font used for question text when you are building quiz question slides.
- For the **Body font**, choose the font you'd like to use for body text. This is also the font used for answer choices when you are building quiz question slides.

4. In the **Name** field, enter a name for your new theme fonts.
5. Click **Save**.

Now the custom theme fonts will be available in any Storyline course you build.

**Modifying theme fonts**

It's easy to go back and modify any custom theme fonts you've previously created. Here's how:

1. Click the **Design** tab on the Storyline ribbon.
2. Select the **Fonts** dropdown.
3. Right-click the theme fonts you want to modify.
4. Choose **Edit**.
5. The theme font editor appears, and you can modify either font as you like, using the same guidelines shown above for creating new theme fonts.

**Note:** You might notice that the built-in theme fonts can't be modified. However, you can create your own theme fonts based on one of the built-in themes by doing this:

1. First apply the built-in theme fonts that you want to base yours on.
2. On the **Design** tab, click the **Fonts** dropdown and choose **Create New Theme Fonts**. This will open up the theme font editor, and the fonts will default to the ones from the theme fonts you just applied.
3. Now just make any changes you like and save the new theme fonts under a different name.
How do theme fonts relate to my font choices on slide masters and slide layouts?

In the same way that you can apply theme fonts to specific slides in your course, you can also apply theme fonts to a slide master layout. When you do, any slide on which you've used the affected slide layout will inherit those same theme fonts.

Anytime you apply theme fonts, though, you can always override the font assignment on the slide itself by manually customizing any individual text box.

You might also want to explore:

Using Themes
Working with Theme Colors
Applying a Background Design

The background tools in Storyline allow you to quickly change the background fill on any course slide. You can choose from several background styles that Storyline provides, or you can create and apply your own background fill. In this tutorial we'll look at both options.

**Using Storyline's ready-made backgrounds**

Storyline provides several ready-made backgrounds that you might like. The colors of the background styles available depend on the theme colors you've applied to your course. ([Learn more about theme colors here.](#))

Here's how you can apply a ready-made background style to your course:

1. Go to the slide where you want to add a background style.
2. Click the **Design** tab on the Storyline ribbon.
3. Click **Background Styles**.
4. Hover over any of the thumbnails to see how the background will affect the look of your slide.
5. To apply a background to *all slides* in your course, left-click it (or right-click and choose **Apply to All Slides**). To apply a background to *only the current slide*, right-click and choose **Apply Only to This Slide**.
**Filling the slide background with your own color, gradient, picture, texture, or pattern**

Another way to control the look of your slide’s background is to apply a background of your own, rather than use the ready-made background styles that Storyline gives you. Here’s how to do it:

1. Go to the slide where you want to add a background style.
2. Click the **Design** tab on the Storyline ribbon.
3. Choose the **Background Styles** dropdown, and click **Format Background**.
4. The **Format Background** window appears. Use the **Fill** tab to choose one of the fill options, and set your preferences in the fields that appear. If you choose to fill the background with a picture or texture fill, you'll also be able to use the **Picture** tab of this window to set some additional options.

(If you need help setting your preferences on this window, check out the tutorials on applying **shape fills** and **picture fills**, since the options work similarly.)
5. If you’d like to hide any background graphics originating from the slide master layout, you can mark the **Hide background graphics** box.

6. If you’d like to apply the same background to all slides in your course, you can click **Apply to All**.

7. If you change your mind and want to revert to the previous background you used for the slide, just click **Reset Background**.

Another way to control the look of your slide backgrounds is by creating and applying slide master layouts. You can find out more in the tutorial on [Using Slide Masters](#).
Using Slide Masters

**Slide Master** view in Storyline functions much like slide masters in PowerPoint, allowing you to design the default themes, colors, fonts, text, and objects for your content slides. Slide masters save you time by allowing you to apply the same look and feel across multiple slides rather than designing each content slide separately.

**Opening Slide Master view**

To switch to slide master view, navigate to the **View** tab on the toolbar, and select **Slide Master**.

Any slide masters you have previously set up for this story will appear in the left column. If you have not set up any slide masters yet, you will see just a default slide master.

**Creating slide masters and layouts**

A slide master in Storyline is actually a collection of slide layouts. The slide master thumbnail in the left navigation pane will appear slightly larger than all of the thumbnails of the layouts below it.

Layouts inherit all the properties of their slide master. However, you can customize each layout to display content in a specific way. For example, you might design your title slide layout differently from your standard content slide layout, and you might design your quiz slide layout in yet another way.
If you want, you can create additional slide masters in the same story. To create a new slide master, click the **Insert Slide Master** button on the toolbar, or right-click anywhere in the left navigation pane and select **Insert Slide Master**. A new slide master with several default layouts will be added at the bottom of the left navigation pane.

You can also add more layouts to each slide master. Here's how:

1. In the left navigation pane, select the slide master to which you want to add a new layout.
2. Click the **Insert Layout** button on the toolbar, or right-click in the left navigation pane and select **Insert Layout**.

A new layout will appear at the end of the list of layouts for the selected slide master. It will inherit the properties of the slide master, and it will have a **Title** text box (which you can delete or turn off if you wish).

**Managing slide masters and layouts**

You can manage your slide masters and layouts by deleting, renaming, preserving, and duplicating them. Here's how:

- **Delete**: To delete a slide master and all of its corresponding layouts, select the slide master in the left navigation pane, and click the **Delete** button on the toolbar. If you only want to delete a layout (but not its slide master), select the layout in the left navigation pane, and click the **Delete** button on the toolbar.
You can also right-click a slide master or layout in the left navigation pane, and then select either **Delete Master** or **Delete Layout**. Or, simply press the **Delete** key on your keyboard.

**Note:** You will *not* be able to delete a slide master or layout that is currently being used by one or more slides in your story.

- **Rename:** It's a good idea to give your slide masters and layouts easily recognizable names, especially if you plan to use several similar masters or layouts within the same story. This makes it easier to select and apply them later. To rename a slide master or a layout, select the slide master or layout in the left navigation pane, and click the **Rename** button on the toolbar.

Then assign the desired name, and click the **Rename** button to complete the process.

Another way to rename is to right-click the slide master or layout in the left navigation pane, and select either **Rename Master** or **Rename Layout**.
• **Preserve**: If a slide master in your story is not currently being used but you want it to remain with the project for later use, you can *preserve* it. To do so, select the slide master in the left navigation pane, and click the **Preserve** button on the toolbar.

![Preserve button](image)

You can also right-click the slide master in the left navigation pane, and select **Preserve Master**.

• **Duplicate**: If you want to create similar slide masters or layouts, you can duplicate them to streamline the process. Right-click the slide master or layout in the left navigation pane that you want to duplicate, and then select either **Duplicate Slide Master** or **Duplicate Layout**.

![Duplicate layout](image)

You can also duplicate slide masters and layouts by using the **Copy** and **Paste** buttons on the **Home** tab or on the right-click shortcut menu.
**Designing slide masters and layouts**

To design your slide masters and layouts, you can use the standard development tools on the Home, Insert, and Animations tabs as well as the following features found on the Slide Master tab on the toolbar:

- The Insert Placeholder drop-down list allows you to add one or more of the following placeholders to a layout: content, text, picture, character, movie, flash, or web object.

After adding a placeholder to a layout, you can resize it and position it where you want it on the slide. *(This option is not available for slide masters. It only pertains to layouts.)*
• The **Title** checkbox will display a title placeholder on a layout if it is checked. Conversely, uncheck the **Title** checkbox to remove the title placeholder. *(This option is not available for slide masters. It only pertains to layouts.)*

![Title checkbox](image)

• The **Themes** drop-down list allows you to apply a consistent design to your slide master(s) and layouts. A theme consists of colors, fonts, and objects you've added to the slide master.

![Themes drop-down](image)

• You can apply a theme to the **selected** slide master and all its layouts by simply clicking the desired theme in the list. If, however, you only want to apply it to the selected layout, right-click the desired theme and select **Apply Only to This Slide**.
• You can save your current design as a custom theme, which can then be used in other projects that you create or shared with other developers. To save your design as a custom theme, click the **Save Current Theme** option at the bottom of the drop-down list.

**Tip:** The default save location is `%appdata%\Articulate\Templates\Themes`, and this is where you want to save your custom theme if you want it to appear in the **Themes** drop-down list for future projects. If you want to share your custom theme with other developers, you can either choose a different save location, or you can send them a copy of the custom theme from the default location noted above.

• If you have a custom theme file from another developer or another computer that you want to use, click the **Browse for Themes** option at the bottom of the drop-down list, and select the theme file (*.athm).

• To change the default theme for new Storyline projects, right-click the desired theme, and select **Set as Default Theme**.

• To learn more about managing and applying themes, [click here](#).

• The **Colors** drop-down list allows you to apply a consistent color scheme to your slide master(s) and layouts.

  ![Image of Color Themes](image)

  • You can preview how a particular color scheme will look in your story by hovering over it.
  • You can apply a color scheme to your slide master by simply clicking it. This will apply the color scheme to the *selected* slide master. If, however, you have more than one slide master in your story, you can apply the same color scheme to *all* slide masters by right-clicking the desired color scheme and selecting **Apply to All Slide Masters**.
  • To create your own custom color scheme, click **Create New Theme Colors** at the bottom of the drop-down list.
  • To edit a custom color scheme, right-click it and select **Edit**. (Built-in color schemes cannot be edited.)
  • To delete a custom color scheme, right-click it and select **Delete**. (Built-in color schemes cannot be deleted.)
  • To learn more about color schemes, [click here](#).
The Fonts drop-down list allows you to apply a consistent font theme to your slide master(s) and layouts.

You can preview how a particular font theme will look in your story by hovering over it.

You can apply a font theme to your slide master by simply clicking it. This will apply the font theme to the selected slide master. If however, you have more than one slide master in your story, you can apply the same font theme to all slide masters by right-clicking the desired font theme and selecting Apply to All Slide Masters.

To create your own custom font theme, click Create New Theme Fonts at the bottom of the drop-down list.

To edit a custom font theme, right-click it and select Edit. (Built-in font themes cannot be edited.)

To delete a custom font theme, right-click it and select Delete. (Built-in font themes cannot be deleted.)

To learn more about font themes, [click here](#).
- The **Background Styles** drop-down list allows you to apply a consistent background to your slide master(s) and layouts.

![Background Styles Dropdown](image)

- You can preview how one of the built-in background styles will look in your story by hovering over it.
- You can apply one of the built-in background styles to the **selected** slide master and all its layouts by simply clicking it in the drop-down list. If, however, you only want to apply it to the selected layout, right-click the desired background style and select **Apply Only to This Slide**.
- To customize the background style, click **Format Background** at the bottom of the drop-down list. Or, right-click the slide master or layout that you want to modify, and select **Format Background**. Then use the **Fill** and **Picture** options to design your background style.
- If you change your mind and want to return to the original background style, click **Reset Slide Background** at the bottom of the drop-down list.
- To learn more about background styles, [click here](#).

- The **Hide Background Graphics** checkbox, when checked, allows you to hide the graphics on a layout *that have been inherited from the slide master*. When background graphics are hidden on a layout, be aware that those graphics will *not* appear in your published story for any slides that are based on that layout. (This option is not available for slide masters. It only pertains to layouts.)

![Hide Background Graphics](image)
**Closing Slide Master view**

To exit slide master view, click the **Close Master View** button on the toolbar. The changes you made to your slide masters and layouts will automatically be applied to any existing content slides if they are based on the slide masters / layouts that you modified.

---

**Applying layouts to existing slides**

There are several ways to apply different layouts to existing slides in your story.

If you're in **Normal View**, do any of the following:

- Navigate to the slide you want to change, right-click anywhere in the workspace, scroll to **Layout**, and click the desired layout.
- Select one or more slides in the left navigation pane. Then right-click the selected slide(s), scroll to **Layout**, and click the desired layout. The layout you choose will be applied to all the slides you have selected.
- Select one or more slides in the left navigation pane. Then go to the **Home** tab on the toolbar, click the **Layout** dropdown list, and click the desired layout. The layout you choose will be applied to all the slides you have selected.
You can also apply layouts in Story View. Do either of the following:

- Select one or more slides. Then right-click the selected slides, scroll to Layout, and click the desired layout. The layout you choose will be applied to all the slides you have selected.
- Select one or more slides. Then go to the Home tab on the toolbar, click the Layout drop-down list, and click the desired layout. The layout you choose will be applied to all the slides you have selected.

You might also want to explore:

- Using Feedback Masters
- Using Themes
- Working with Theme Colors
- Working with Theme Fonts
- Applying a Background Design
- Using and Creating Storyline Templates
Using Feedback Masters

The Feedback Master view in Storyline allows you to design the default themes, colors, fonts, text, and objects for your quiz feedback layers. Feedback masters save you time and give you a consistent look and feel across your feedback layers. Feedback masters function much like slide masters.

Opening Feedback Master view

To switch to Feedback Master view, navigate to the View tab on the toolbar, and select Feedback Master.

Any feedback masters you have previously set up for this story will appear in the left column. If you have not set up any feedback masters yet, you will see just a default feedback master.

Creating feedback masters and layouts

A feedback master in Storyline is actually a collection of layouts for various types of assessment feedback, including: Correct, Incorrect, Try Again, Review, and Thank You. The feedback master thumbnail in the left navigation pane will appear slightly larger than all of the thumbnails of the layouts below it.
Layouts inherit all the properties of their feedback master. However, you can customize each layout to display content in a specific way. For example, you might design your Correct feedback layout with affirmative text and images, while your Incorrect feedback layout might have placeholders for corrective content.

If you want, you can create additional feedback masters in the same story. To create a new feedback master, click the Insert Slide Master button on the toolbar, or right-click anywhere in the left navigation pane and select Insert Slide Master. A new feedback master with several default layouts will be added to the bottom of the left navigation pane.

You can also add more layouts to each feedback master. Here’s how:

1. In the left navigation pane, select the feedback master to which you want to add a new layout.
2. Click the Insert Layout button on the toolbar, or right-click in the left navigation pane and select Insert Layout.

A new layout will appear at the end of the list of layouts for the selected feedback master. It will inherit the properties of the feedback master, and it will have a feedback pop-up image and a Title text box (which you can delete or turn off if you wish).
Managing feedback masters and layouts

You can manage your feedback masters and layouts by deleting, renaming, preserving, and duplicating them. Here’s how:

- **Delete**: To delete a feedback master and all of its corresponding layouts, select the feedback master in the left navigation pane, and click the Delete button on the toolbar. If you only want to delete a layout (but not its feedback master), select the layout in the left navigation pane, and click the Delete button on the toolbar.

You can also right-click a feedback master or layout in the left navigation pane, and then select either Delete Master or Delete Layout. Or, simply press the Delete key on your keyboard.

**Note**: You will not be able to delete a feedback master or layout that is currently being used by one or more slides in your story.

- **Rename**: It’s a good idea to give your feedback masters and layouts easily recognizable names, especially if you plan to use several similar masters or layouts within the same story. This makes it easier to select and apply them later. To rename a feedback master or a layout, select the feedback master or layout in the left navigation pane, and click the Rename button on the toolbar.
Then assign the desired name, and click the **Rename** button to complete the process.

Another way to rename is to right-click the feedback master or layout in the left navigation pane, and select either **Rename Master** or **Rename Layout**.

- **Preserve**: If a feedback master in your story is not currently being used but you want it to remain with the project for later use, you can *preserve* it. To do so, select the feedback master in the left navigation pane, and click the **Preserve** button on the toolbar.

You can also right-click the feedback master in the left navigation pane, and select **Preserve Master**.
**Duplicate**: If you want to create similar feedback masters or layouts, you can duplicate them to streamline the process. Right-click the feedback master or layout in the left navigation pane that you want to duplicate, and then select either **Duplicate Slide Master** or **Duplicate Layout**.

You can also duplicate feedback masters and layouts by using the **Copy** and **Paste** buttons on the **Home** tab or on the right-click shortcut menu.
Designing feedback masters and layouts
To design your feedback masters and layouts, you can use the standard development tools on the Home, Insert, and Animations tabs as well as the following features found on the Slide Master tab on the toolbar:

- The Insert Placeholder drop-down list allows you to add one or more of the following placeholders to a layout: content, text, picture, character, movie, flash, or web object.

After adding a placeholder to a layout, you can resize it and position it where you want it on the slide. (*This option is not available for feedback masters. It only pertains to layouts.*)
• The **Title** checkbox will display a title placeholder on a layout if it is checked. Conversely, uncheck the **Title** checkbox to remove the title placeholder. (*This option is not available for feedback masters. It only pertains to layouts.*)

![Title checkbox](image)

• The **Themes** drop-down list allows you to apply a consistent design to your course. A theme consists of colors, fonts, and objects you've added to the feedback master.

![Themes drop-down list](image)

• **Note:** Although you can apply themes while you are in feedback master view, it may not *appear* that the theme has changed. This is because all the built-in themes use the same design for feedback masters.
Therefore, if you select a built-in theme while you are in feedback master view, you won't actually notice the change until you exit feedback master view.

- You can apply a theme to your course by simply clicking the desired theme in the list.
- To learn more about managing and applying themes, click here.
- The Colors drop-down list allows you to apply a consistent color scheme to your feedback master(s) and layouts.

- You can preview how a particular color scheme will look in your story by hovering over it.
- You can apply a color scheme to your feedback master by simply clicking it. This will apply the color scheme to the selected feedback master. If, however, you have more than one feedback master in your story, you can apply the same color scheme to all feedback masters by right-clicking the desired color scheme and selecting Apply to All Slide Masters.
- To create your own custom color scheme, click Create New Theme Colors at the bottom of the drop-down list.
- To edit a custom color scheme, right-click it and select Edit. (Built-in color schemes cannot be edited.)
- To delete a custom color scheme, right-click it and select Delete. (Built-in color schemes cannot be deleted.)
- To learn more about color schemes, click here.
• The Fonts drop-down list allows you to apply a consistent font theme to your slide master(s) and layouts.

• You can preview how a particular font theme will look in your story by hovering over it.
• You can apply a font theme to your feedback master by simply clicking it. This will apply the font theme to the selected feedback master. If however, you have more than one feedback master in your story, you can apply the same font theme to all feedback masters by right-clicking the desired font theme and selecting Apply to All Slide Masters.
• To create your own custom font theme, click Create New Theme Fonts at the bottom of the drop-down list.
• To edit a custom font theme, right-click it and select Edit. (Built-in font themes cannot be edited.)
• To delete a custom font theme, right-click it and select Delete. (Built-in font themes cannot be deleted.)
• To learn more about font themes, click here.
• The **Background Styles** drop-down list allows you to apply a consistent background to your feedback master(s) and layouts.

![Background Styles dropdown list](image1.png)

• You can preview how one of the built-in background styles will look in your story by hovering over it.

• You can apply one of the built-in background styles to the selected feedback master and all its layouts by simply clicking it in the drop-down list. If, however, you only want to apply it to the selected layout, right-click the desired background style and select **Apply Only to This Slide**.

• To customize the background style, click **Format Background** at the bottom of the drop-down list. Or, right-click the feedback master or layout that you want to modify, and select **Format Background**. Then use the **Fill** and **Picture** options to design your background style.

• If you change your mind and want to return to the original background style, click **Reset Slide Background** at the bottom of the drop-down list.

• To learn more about background styles, [click here](#).

• The **Hide Background Graphics** checkbox, when checked, allows you to hide the graphics on a layout *that have been inherited from the feedback master*. When background graphics are hidden on a layout, be aware that those graphics will *not* appear in your published story for any slides that are based on that layout. (This option is not available for feedback masters. It only pertains to layouts.)

![Hide Background Graphics](image2.png)
**Closing Feedback Master view**

To exit feedback master view, click the **Close Master View** button on the toolbar. The changes you made to your feedback masters and layouts will automatically be applied to your existing quiz slides.

**Applying layouts to existing feedback layers**

Here's how you can apply different layouts to existing feedback layers in your story:

1. First, navigate to the quiz slide you want to edit.
2. Select one of the feedback layers (Correct, Incorrect, Review, etc.) in the **Slide Layers** panel in the lower right corner of the window.

3. Then do any of the following:
   - Right-click anywhere on the slide, scroll to **Layout**, and click the desired feedback layout.
   - Or, right-click the slide thumbnail in the left navigation pane, scroll to **Layout**, and click the desired feedback layout.
• Or, go to the **Home** tab on the toolbar, click the **Layout** drop-down list, and click the desired feedback layout.

---

**You might also want to explore:**

- [Using Slide Masters](#)
- [Using Themes](#)
- [Working with Theme Colors](#)
- [Working with Theme Fonts](#)
- [Applying a Background Design](#)
- [Using and Creating Storyline Templates](#)
Working with Variables

Storyline makes working with variables easy. Using the Trigger Wizard, you can quickly set up your project variables without writing a line of code.

Variables are a way to remember information—such as a learner’s name or numeric input—and then present dynamic content based on that information. They’re also a great way to add conditional interactivity to your course.

Variables can only hold one piece of data at a time. A good example is to think of a slide that asks a learner for their first name. The variable can accept any text-based entry for the name, but it can only hold one learner’s name at a time. Each time a learner enters a new name, the variable is updated with the most recent entry.

Types of Variables

In Storyline, there are three types of variables:

1. Text
2. Number
3. True/False

Text variables hold text-based values. Common examples include a learner’s name, personalized feedback to a scenario and customized certificates at the end of the course.

Number variables hold numeric values. Common examples include a learner’s score, number of attempts on a question and weighted quiz scores.

True/false variable are often referred to as boolean variables. Unlike text and numeric variables, they can have one of two states: on or off. Some common examples include custom Play and Pause buttons that toggle based on user input, a course acknowledgement button that, when clicked, enables the learner to complete the course.

Three-step process for working with variables:

1. Name the variable - create and name your variable
2. Select the type of variable - select the type of variable data you want to work with
3. Select the value - what is the starting value of your data (text, numeric or true/false)
**Variables vs. States**

Variables are different from States. States can only hold information for the current slide, while variables can hold data across slides, scenes—even the entire project.

Use variables when you want to:

- Remember a learner's name
- Count the number of times a button was clicked
- Combine scores from one quiz with another

Use states and triggers to track:

- Which objects on a slide are clicked

**You might also want to explore:**

- Adding True/False Variables
- Adding Text Variables
- Adding Number Variables
Adding True/False Variables
The true/false variable works just like it sounds: values can either be true or false. Some examples of where you’d use a true/false variable are:

- Scene or slide completion: Adjust variable Section1 to true when user completes Slide 10.
- Compliance acknowledgement: Adjust variable Agree to True when user clicks Submit button.

Let's take a look at a simple example using two buttons.

**View the published example | Download the source file**

If you're following along, I'm working in TrueFalse_START.story.

**Step 1: Create a new project variable**
We have two buttons on the slide, but we only need a single variable to evaluate.

1. In the Triggers panel, click Manage project variables to create a new variable
2. Click the Create a new variable icon
3. Name your variable: Agree
4. Set the variable type to True/False
5. Set the value to False
Step 2: Insert a reference to the variable

This is not necessary, but it's a big help when working with variables. By inserting a reference to the variable, we can verify the variable is working the way we expect it to work. We'll delete the reference at the end of the project, but keep the reference for testing both the variable and the buttons.

1. Insert a text box on the slide by going to Insert > Text > Text Box and clicking once on your slide
2. Go back to the Insert tab this time go to Text > Reference. This brings up your project variables. There's only one variable so it will automatically be selected.
3. Click OK to close the window and insert the variable reference.
4. With the variable reference selected, increase its font size to something large, like 36

Let's preview our work. Click F12 or Preview to preview the slide.

![Variable Reference](image)

Nothing much happens, but we can see the variable reference returned a false message. That's the default value we assigned when we created the variable. Next, we'll add some triggers to our buttons.
**Step 3: Assign button triggers to adjust the variable**

At this point, you've created the True/False variable, but it's not useful until we assign a trigger to evaluate it. In the Trigger panel, click the Create a new trigger icon.

1. **Action**: select Adjust variable
2. **Variable**: select Agree
3. **Operator**: keep the current setting
4. **Value**: change to Value and then select True
5. **When**: keep current setting
6. **Object**: keep current setting
7. Click OK

Now that our first True trigger is set, we can copy and paste it for the False button.

1. In the Triggers panel, select the trigger you just created
2. Click the **Copy selected trigger** icon to copy the trigger
3. On your slide, click the False button once to select it
4. Return to the triggers panel and click the **Paste the copied trigger to the selected object** icon. This pastes the True button’s triggers to the False button. You now only need to modify the False button’s triggers
5. For the False button’s trigger, select the true value and select False from the menu

Preview your project and test your buttons.
Adding Text Variables

One of the most common examples for text variables is used to capture a learner's name and then reference that name during and at the end of the course—often in the form of a course completion certificate.

View the published example | Download the source file

Begin by previewing the final, published example. On the first slide, you're asked for your name. Type your name and click the Next button. On the second slide, the name you entered appears in the certificate. Pretty cool, right? Let's take a closer look at how we put this together.
Step 1: Insert a new text entry field

1. Go to Insert > Data Entry > Text Entry
2. Place your cursor over the name tag. Then click and drag to create a text entry box.
3. Center the text by clicking the Paragraph style

You just created your first variable. Take a look at the Triggers panel and you'll see a new trigger along with a variable. Storyline created a variable named TextEntry for us when we inserted the text entry field. This variable can be used at any point in our project to reference the text-based value.

You just created a new variable named “TextEntry”
Let's edit our variable name to give it something more specific to how we're using it.

**Step 2: Edit the variable name**

1. In the Triggers panel, click the X in the bottom right corner. This opens the Project Variables window.
2. Double click the TextEntry name.
3. In the Variable window, type a new name: FirstName.
4. Leave Value blank and click OK.

Take a look in the Triggers panel. You'll see that Storyline has updated our trigger to reference the updated variable name. That's it for creating and editing variables. At this point, we've created a variable that will accept text-based data from our learner. But storing data is only half the fun--we can also retrieve the data.

**Step 3: Insert a reference to the variable**

Now that our variable is set and ready to take data, we need a way to retrieve and display that data. To display the data, we insert a reference to the variable.

1. Select the second slide "1.2 Congratulations."
2. Go to Insert > Text Box and drag out a text box in the middle of the certificate.
3. Next, go to Insert > Reference to bring up the variable references. The FirstName variable is selected because it's the only variable.
4. Click OK to insert a reference on the slide.
The formatting for reference variables is always the same:

\[
\% \text{ VariableName } \% \\
\]

**Step 4: Format the reference variable using the font tools**

Finally, we can apply some basic formatting to our reference variable to align it with the rest of our slide design.

1. Select the reference variable text box
2. Increase the font size to 28
3. Change the font style to Georgia
4. Center the text using

Preview your project by pressing F12

Now try clicking the Previous button to return to the first slide. Enter a new name and click Next. Storyline automatically updates the variable with the latest value. That's because variables can only hold one piece of data at a time.
Adding Number Variables

When you need to capture and track numeric values such as learner scores, number of attempts, or object prices, number variables can be a great solution.

In this simple example, you'll work with numeric variables to assign weighted scores to multiple choices. This is common when you have scenarios where the answer choices are all correct, but each choice is worth a different amount. You can then evaluate the choices and provide feedback based on their choices. The best part? You'll never have to write a line of code--Storyline manages everything through the Trigger Wizard.
Let's take a look at what we're going to build.

The first slide is a decision slide. Each chat box is worth a number of points: 10, 5, or 1. When you click Submit, you'll branch to a slide based on the chat cloud you selected.

If you're following along, I'm in NumericVariable_START.story.
Step 1: Create a numeric variable

We only need one variable in this example. Variables can hold any type of data, but they can only hold one piece of data at a time. Points will be assigned based on the learner's selection.

1. Click the Manage project variables icon (it's the small X at the lower right of the Triggers panel).
2. When the Variables window appears, click the Create a new variable icon (the icon looks like a blank piece of paper).
3. Type Choice for the Name.
4. Select Number for the variable Type.
5. Leave the value blank.
6. Click OK.
Step 2: Create a new trigger to assign a point value to Choice 1

Next, we'll set up a trigger to dynamically assign points to our Choice variable. For this example, we'll assign 10 points for the best choice, 5 points for the next best choice and 1 point for the worst choice. The chat captions have been placed in descending order to make it easier to follow.

1. On slide 1.1, click the first chat caption ("Refer the employee to Human Resources") to select it.
2. Create a new trigger by clicking the Create a new trigger icon (it's the icon at the bottom of the trigger panel that looks like a blank piece of paper).
3. On the Trigger Wizard, choose the options as shown below. Basically, you're telling Storyline to change the number variable called "Choice" to a value of 10 when the learner clicks the chat caption.

![Trigger Wizard](image)

Each time the learner clicks the first chat box, the variable Choice will have a point value of 10. Let's add the point values for the next two chat boxes.
**Step 3: Create a new trigger to assign a point value to Choice 2**

Now that we've created the first trigger, we'll copy the trigger to the second chat caption, and adjust the value to 5.

1. In the Triggers panel, select the trigger you just added.
2. Click the **Copy trigger** icon to copy the trigger.

![Click the copy trigger icon]

3. Now select the middle chat caption on your slide ("Ask the employee to discuss his feelings"). Then, on the Triggers panel, click the **Paste trigger** icon to paste the trigger to the caption.
4. On the new trigger in the Triggers panel, click the value shown in blue (it should say 10.00) and change it to 5.00.

Now, if you double-click the trigger assigned to the second chat caption, it should look like this:
Step 4: Create a new trigger to assign a point value to Choice 3

In this step, we copy the trigger once more, this time pasting it to the third chat caption.

1. In the Triggers panel, select the trigger you just added.
2. Click the **Copy trigger** icon to copy the trigger.
3. Select the third chat caption on your slide (“Ignore the behavior and hope it doesn't happen again”).
4. Click the **Paste trigger** icon to paste the trigger.
5. On the new trigger in the Triggers panel, change the value from 5.00 to 1.00.

Step 5: Verify the triggers are adjusting the variable correctly

This next step is more of a best practices step. We'll add a temporary variable reference on our slide to verify that the value is being assigned correctly. (It never hurts to verify that things are working right before moving on!)

1. On the **Insert** tab, choose **Text Box** and insert a text box at the top of your slide
2. Go back to the **Insert** tab and select **Reference**.
3. In the Reference window, select **Choice** and click **OK**.

This inserts a reference to our variable, Choice. When you're building or editing your slide, Storyline shows variable references as a placeholder, with percent signs on either side. When you preview or publish, this placeholder will be replaced with the actual variable value. Each time the variable value changes, the reference will change to show the new value.

Preview your slide. When you click each chat box, you should see a different value in the text box at the top of your slide. Now that you know things are working fine, you could delete the text box or turn off its visibility in the slide's timeline so that it doesn't appear in your final output.

Step 6: Evaluate the variable and branch to the appropriate slide

Now that our variable is set up, we can add some triggers to a Submit button to branch our learner to a slide based on their selected choice. Here's how:

1. Select the blue Submit button on the slide.
2. Click the **Create a new trigger** button in the Triggers panel.
3. Set **Action** to **Jump to slide**.
4. For **Slide**, select 1.2 Choice-1.
5. Click **Show Conditions** to open the Conditions panel.

Here's where we evaluate the value of our variable. The trigger is set to jump to another slide, but we want to set up a condition that tells Storyline to jump to the selected slide *only* if the variable (Choice) has a specific value.

1. Click the green plus sign to add a condition.
2. In the **If** field, select **Choice** from the menu.
3. Set the **Operator** to **==Equal to**.
4. Set **Type** to **Value**.
5. Enter 10 for **Value** and click **OK**.
That sets up our first condition. Because we have three choices and three slides, we will want to add two more triggers with conditions to evaluate the other two point values.

1. In the Triggers panel, copy and paste the trigger you just created for the Submit button.
2. On the new trigger, change the slide to Slide 1.3 Choice-2.
3. Click 10.00 to change the value to 5.00. You don't need to open the Trigger Wizard each time to update these values.

![Triggers panel showing triggers for slide transitions]

And finally, let's add one more trigger to evaluate the final choice value:

1. In the Triggers panel, copy and paste the trigger you just created for the submit button
2. On the new trigger, change the slide to Slide 1.4 Choice-3
3. Click 5.00 to update the value to 1.00.

Notice what's happened in the slide thumbnails pane at the left of your slide workspace? Now that you've added some triggers, the thumbnails have rearranged themselves to reflect the different possibilities for the way a learner might branch from the first slide. The thumbnails should look like this:

![Slide thumbnails showing different possible paths]

Now, preview the entire scene. Select a caption and click the blue Submit button, and you'll branch to one of the three feedback slides.
Building a Simple Counter

Let's look at working with number variables to add and subtract values from number variables. This is really easy to do in Storyline. Check out the final example:

View the published example | Download the source file

If you're following along, I'm working in Counter_START.story.

**Step 1: Create the number variable:**

1. In the Trigger panel, click the Manage project variables icon
2. Click the Create new variable icon

![Create a new variable](image)

3. **Name**: Counter
4. **Type**: Number
5. **Value**: 0

![Variable settings](image)

6. Click **OK**

Now that our variable is created, the next step is to create a trigger that increases or decreases the variable's value.

**Step 2: Add the trigger**

In this step, we'll set up a trigger to increase our variable by +1 each time the user clicks a button.

1. Insert a new button on your slide
2. Create a new trigger for the button (Trigger panel > Create a new trigger)
3. **Action**: Adjust variable
4. **Variable**: Counter
5. **Operator**: +Add
6. **Value**: Value 1
7. **When**: User clicks
8. **Object**: Button 1
9. Click OK

We have our variable set up and a trigger that increases the value. But how do we know this is working? We can insert a reference to the variable on our slide that will dynamically update when we click the button.

**Step 3: Insert the variable reference**

1. Go to Insert > Text > Text Box and click once on your slide to create an active text box.
2. With the text box selected, go back to Insert > Text > Reference
3. Select Counter and click OK

Preview your project and click the button. Each time you click, the variable reference updates by a value of 1.
**Step 4: Subtract from the value**

Want to see things go in the opposite direction? Add another trigger to subtract from the Counter variable. Since we already have the first button and trigger created, we can duplicate it and modify the trigger.

1. Duplicate the first button by pressing CTRL-D
2. Double click its trigger in the Trigger panel
3. Change the Operator to -Subtract
4. Leave the Value set to 1
5. Click OK

Preview your movie.

You can add any value to increase, subtract, divide or multiply the values.
Evaluating Text Variables

Storyline makes it easy to present dynamic content based on a learner's choices. In this example, we'll work with timeline triggers to branch learners to specific slides based on their earlier choices. Take a look at what we're going to build:

View the published example | Download the source file

When you first look at it, you might think that the button triggers are showing the layers. While that's certainly possible, that's not how this example works. The button triggers are actually adjusting a variable to "true" or "false" while a timeline trigger listens for that variable to change. Based on the variable, the course will branch to one of two slides. It's really cool.

If you're following along, I'm working in EvaluateVariable_START.story.
Step 1: Create the project variable

1. In the triggers panel, click the Manage project variables icon
2. Create a new variable
   - Name: Agree
   - Type: Text
   - Value: (blank)
3. Click OK

Step 2: Insert a variable reference on the slide

1. Go to Insert > Text > Text box and click once on the slide to create an active text box
2. Go back to Insert > Text > Reference to bring up the project variables
3. Select the variable you created and click OK
**Step 3: Add button triggers to adjust the variable**

1. Select the green button and add a new trigger
2. **Action:** Adjust variable
3. **Variable:** Agree
4. **Operator:** = Assignment
5. **Value:** Value, Agree
6. **When:** User clicks
7. **Object:** Agree button
8. Click OK

**Duplicate the button trigger**

1. In the Triggers panel, copy and paste the trigger to duplicate it
2. Change the value to: Disagree
3. Change the Object to: Disagree button
4. Click OK

![Trigger settings for “Disagree” button](image)
Step 4: Add a timeline trigger to evaluate which button is clicked

Here’s where things come together. The button triggers adjusted the variable so now we can evaluate which button is clicked and give our learners the appropriate content.

Create a new trigger

- Action: Jump to slide
- Slide: 1.2 Agree
- When: User clicks
- Object: Continue button

Show conditions:
Agree == Equal to Agree

Duplicate the trigger and update for a disagree value.

1. Select the trigger you just created and copy paste it
2. Change the targeted slide to 1.3 Disagree
3. Change the Agree value to Disagree
4. Preview your project

Because Storyline's variables are persistent, you can evaluate variables at any time during a project.
The intuitive and powerful quizzing features in Storyline provide you with all sorts of options for creating assessments, surveys, and interactions—as well as displaying feedback and results to let learners know how they performed.

Explore the following tutorials to find out how to add different forms of quiz content to your course:

- **Graded questions and survey questions**: Choose from 20 different predefined question types for fast and easy quiz-building.
- **Freeform questions**: These allow you to build your own questions or interactions out of just about any object you've added to your quiz slides—the ultimate in flexible authoring! Choose from five different question types, including drag and drop, hotspot, and more.
- **Questions from a question bank**: Question banks provide a simple way to create sets of questions and randomize the order in which they display. You can even choose to display just a subset of the questions if you like.
- **Result slides**: Storyline's result slide options allow you to compile results from any quiz questions you choose, and then display performance data to your learners. You can even opt to show an aggregate score from multiple quizzes if you like.
Adding Graded Questions and Survey Questions

Storyline allows you to quickly add all sorts of question types to your course. In this tutorial, we'll take a look at how to create a new quiz question or survey question, using one of Storyline’s ready-made question types. If you’d like more flexibility to create your own interactive questions by converting objects on your slide into answer choices, you should also explore the Freeform Question options.

Step 1: Enter your question and answer choices

1. Do any one of the following:
   - Click the Home tab on the Storyline ribbon and select New Slide.
   - Or, click the Insert tab on the Storyline ribbon and select New Slide.
   - Or, in Story View, right-click anywhere in the workspace and choose New Slide.
   - Or, in Normal View, right-click the workspace in the slide thumbnails area at the left and choose New Slide.

2. When the Insert Slides window appears, select the Quizzing tab from the left edge.
3. Decide whether your question should be a **Graded** question or a **Survey** question, and click one of those tabs at the top of the window. (A graded question has a correct and incorrect answer, and users are scored based on their response. A survey question, on the other hand, has no right or wrong answer, so it isn't scored at all.)

![Choose Graded or Survey](image)

4. Storyline shows the thumbnails for each question type available. The question types depend on whether you're adding a graded question or survey question. Click any thumbnail to explore the choices—the panel at the right edge of the window shows a description of whatever question type you click.

- **Note:** If you want more flexibility than what the standard question types offer, you can instead build a **Freeform** question in Storyline. This allows you to create questions or interactions out of your own shapes, images, textboxes, and more. See the tutorial on [Converting an Existing Slide to a Freeform Interaction](#).

5. Once you find the question type you want to use, click **Insert**.
6. The Form View of the question editor appears. Enter the question and answer choices, and if the question is a graded question, indicate which answer is correct. Here’s a Multiple Choice example—your screen will look a little different if you’re working with a different question type:

7. For some question types, you can choose to shuffle the answer choices. Use the Shuffle dropdown on the toolbar to turn shuffling on or off.
Step 2: Enter the score (graded questions only)

1. If you’re building a graded question, choose one of the following from the **Score** selector on the toolbar. (For survey questions, the **Score** selector isn’t available, since there’s no right or wrong answer).

   - **By Question**: This is the default, and it allows you to assign points to the correct and incorrect answer.
   - **By Choice**: This allows you to set up a different score for each individual answer choice. This option is only available for Multiple Choice and Word Bank questions.

2. Now click in the **Points** column of the question editor, and enter the score values you want to grant for the possible response. The location of the **Points** column depends on which option you chose for **Score**.

   - If you’re scoring By Question, assign the points here.
   - If you’re scoring By Answer, assign the points here.
Step 3: Make the question required or optional (survey questions only)

If you’re building a survey question, use the Require selector on the toolbar to choose User may skip or User must answer. (For graded questions, the Require selector isn’t available, since graded questions require an answer.)

Step 4: Choose your options for feedback and branching

In Storyline, you can show your learners feedback after they answer a question—and you can also branch learners to different parts of your course, based on their answers. Here’s how:

1. Choose one of the following from the Feedback selector on the toolbar:
   
   - **By Question**: This allows you to set up question-based feedback and branching. For a graded question, you can show different feedback for a correct vs. incorrect answer. For a survey question, there’s just one feedback message for the question overall.
   
   - **By Choice**: This allows you to set up different feedback for each individual answer choice. This option is only available on some question types, such as Multiple Choice, Word Bank, Pick One, and Which Word.
   
   - **None**: Choose this if you don’t want any feedback to display and you don’t need to branch the learner to a different place in the course based on how they answer.

2. If you opt to display feedback, you can edit the feedback text in the Feedback area of the question editor. (This appears at the bottom of the question editor if you chose Feedback By Question, or next to each answer choice if you chose Feedback By Choice.) Or, when you return to the Normal View of your side, you can make the changes to the feedback layers that Storyline creates for you. (Learn more about slide layers.) If you want to change the visual design of the feedback layers throughout your course, check out the tutorial on Working with Feedback Masters.
3. For graded questions, you can also include **Post-Quiz Review** feedback. This feedback appears during the quiz review, if you provide your learners with a **Result Slide** that includes a "Review Quiz" option. In the **Post-Quiz Review** field at the bottom of the question editor, enter the review feedback you want learners to see.

4. Now let's talk about branching. By default, Storyline will take the learner to the next slide in your course once they answer your question. But if you want to take them somewhere else in the course, you can do that. Click any **More** button in the **Feedback** area, and then use the **Branch to the following** selector to choose the destination:
Step 5: Choose the number of attempts (graded questions only)

By default, Storyline gives learners one attempt at your question. But if they answer incorrectly, you can give them the opportunity to retry. Use the Attempts selector to choose the number of attempts, or set it to Unlimited if you want learners to keep trying the question till they get it right. (The Attempts selector doesn't appear on survey questions, since those don't have a right or wrong answer.)

Some things to keep in mind:

- If you allow multiple tries, Storyline adds a "Try Again" section to the Feedback area on the question editor. This is the feedback that’ll appear if a learner answers incorrectly. You can make changes to the feedback here on the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the to the “Try Again” slide layer that Storyline creates for you. (Learn more about slide layers.)
- If you want the “Try Again” messages throughout your course to look a certain way, you can make changes to the Try Again Feedback layout. For more details, check out the tutorial on Using Feedback Masters.

Step 6: Add media or sound if you like

The Media and Sound icons on the question editor’s toolbar are handy if you want to add pictures, movies, or audio to your question slide. But you can add those things just as easily later, when you return to Normal View.

To add other things to your slide (such as screenshots, shapes, captions, characters, web objects, zoom regions, and more), you'll need to return to Normal View first.
Step 7: Return to the Normal View of your slide

Click Save & Close to close the question editor and go to the Normal View of your slide. Here, you can enhance your slide content with any of the other Storyline tools (such as animations, transitions, triggers, or the Timeline)—just like you would with a content slide.

If you chose to provide feedback on this question, or if you chose to include a post-quiz review message, you'll see separate layers for each of these in the Slide Layers panel, and you can edit those layers if you like.

What about a quiz result slide?

You can display quiz results at any point in your course by using a result slide. When you create a results slide, you can tell Storyline which questions in your course you want it to use for calculating the results.

If you've already added a result slide in your course, you can assign the current question to it like this: with your question slide In Normal View, find the Question panel at the right edge of the slide workspace. Use the Result slide selector to choose the result slide to which you want to connect this question.
**How do I edit my quiz question later?**

If you need to make changes to your quiz question later, you can go to your quiz slide and edit the content directly on the slide itself. Or, if you need to change other things about the question that aren't visible on the slide (such as the scoring, number of attempts, or how feedback is handled), just click the Edit button in the Question panel that appears to the upper-right of the slide workspace. That brings up the Form View of the question editor where you can make whatever changes you need. Click Save & Close when you're done.

**You might also want to explore:**

- Adding Result Slides
- Adding Freeform Quiz Questions
- Using Question Banks
- Using Feedback Masters
Adding Freeform Quiz Questions

Storyline's freeform quizzing tools make it fun and easy to turn the objects on any slide into an engaging assessment activity. Explore the tutorials below to find out how to quickly build the following types of interactions:

- Drag and Drop
- Pick One
- Pick Many
- Text Entry
- Hotspot
- Shortcut Key
Drag and Drop

A Freeform Drag and Drop question allows you to add interactivity to objects on the slide by designating drag items and drop targets. Drag and drop interactions can be used as graded or ungraded assessments.

**Step 1: Insert a Drag and Drop freeform question**

There are a couple of ways you can create a Freeform Drag and Drop question slide. If you already have some objects on your slide that you want to use as a Drag and Drop question, you can convert it by using the steps in this tutorial.

Or, you can create the slide from scratch by following these steps:

1. Do any one of the following:
   - Select the Home tab, and click New Slide.
   - Or, select the Insert tab, and click New Slide.
   - Or, in Story View, right-click anywhere in the workspace and choose New Slide.
   - Or, in Normal (slide) View, right-click anywhere in the left navigation pane and choose New Slide.

2. When the Insert Slides window appears, select the Quizzing tab from the left edge.
3. Select the **Freeform** tab at the top of the window, and click the **Drag and Drop** thumbnail.

4. Click the **Insert** button.

5. Next, you'll need to add objects to your slides so that you can use them as your drag items and drop targets. Storyline will let you know this by displaying a message in the **Question** panel that says "To edit the question, this slide needs at least two compatible shapes." You can use the **Insert** tab on the Storyline menu to add objects to your slide. Check out the tutorials [here](#) if you need help inserting content.
6. Once you’ve added some objects to your slide, click the Edit Drag and Drop button in the Question panel. This opens the question editor, where you can customize your question.

Step 2: Identify drag items and drop targets

When the Drag and Drop question editor appears, identify the objects that you want to use as drag items and drop targets. Here’s how:

1. Put your cursor in the Drag Item column, and use the drop-down selector to identify the objects on your slide that you want users to be able to drag. As you scroll over the items in the list, Storyline marks them with an outline on the slide, so that you can easily see what you’re selecting.
2. Then put your cursor in the **Drop Target** column, and use the drop-down selector to identify the objects on your slide where you want users to deposit the corresponding drag items you identified in the previous step. As before, Storyline will mark each item on the slide with an outline as you scroll over them, so you can easily see what you're selecting.

3. Use the **Shuffle** drop-down list on the toolbar to turn shuffling on or off. Shuffling causes the drag items to appear in a random order.

Here are some things to bear in mind as you select drag items and drop targets:

- Each drag item can be matched to only one drop target.
- However, each drop target can be assigned to more than one drag item (i.e., you can drop multiple items into the same target).
• If you want an object on the slide to be draggable even if it isn't part of the correct response (a decoy drag item), select that object in the Drag Item column, and select None in the Drop Target column.

On the other hand, if you want an object to function as an incorrect drop target (a decoy drop target), select that object in the Drop Target column, and select None in the Drag Item column.
• If you need to remove a drag item / drop target combination, click anywhere on that row to select it, and then click the Delete button below the lower right corner of the list area.

Step 3: Select drag item options

On the right side of the Drag and Drop question editor, there are several options that you can select to change the behavior of your drag and drop scenario:

• **Return items to start point if dropped outside**: Select this checkbox if you want to force drag items to snap back to their original locations when users drop them outside of any targets or when users drop them on the wrong targets. Then use the corresponding drop-down list to select “any drop target” or “a correct drop target”.

• **Tip**: If you want some items to snap back to their original locations while other items on the same slide do not return to their original locations, go ahead and select this option, and click the Save & Close button on the toolbar to exit the question editor. Then, right-click each of the objects on the slide that you do not want to return to their starting position, scroll to Drag and Drop, and uncheck Drag Return. These objects will remain on the slide wherever users happen to drop them.
- **Reveal drag items one at a time**: Select this checkbox if you want drag items to only appear one at a time after the previous drag item has been dropped on a target. Then click the *ellipsis* (...) button to determine in which order the drag items will appear.

- **Snap dropped items to drop target**: Select this checkbox if you want drag items to snap to drop targets as users arrange them on the slide. Then use the corresponding drop-down list to select the manner in which items will be tiled or stacked.
• **Allow only one item in each drop target**: Select this checkbox if you want to restrict the number of drag items that can be dropped on a particular target to only one item. If users drag another item onto an occupied drop target, then the first item will be pushed out of the drop target and replaced with the new item.

• **Delay item drop states until interaction is submitted**: If you use different **Drop Correct** and **Drop Incorrect** states for drag items, you may not want these state changes to appear until after users submit the question. Otherwise, users will know whether they got the question right or wrong even before they click the **Submit** button. To delay the drop states from appearing until after users submit the question, select this checkbox. If, however, you would prefer to give users immediate feedback upon dropping items onto targets, do not mark this checkbox. (To learn more about states, take a look at [this tutorial](#).)
Step 4: Enter the score

1. Choose one of the following from the Score selector on the toolbar:

   - **By Question**: This is the default, and it allows you to assign points to the correct and incorrect answer.
   - **None**: This omits any scoring info from the question. It also removes the need for correct/incorrect feedback. Storyline creates a single feedback message (which you can of course edit) rather than having separate correct/incorrect feedback messages.

2. If you chose **By Question** for the Scoring option, now enter values in the Points area of the question editor.
Step 5: Make the question required or optional (unscored questions only)

If you are building an unscored question, use the Require selector on the toolbar to choose User may skip or User must answer. (For graded questions, the Require selector isn’t available, since graded questions require an answer.)

Step 6: Choose your options for feedback and branching

In Storyline, you can show your learners feedback after they answer a question—and you can also branch learners to different parts of your course, based on their answers. Here’s how:

1. Choose one of the following from the Feedback selector on the toolbar:
   - By Question: This allows you to set up question-based feedback and branching. For a graded question, you can show different feedback for a correct vs. incorrect answer. For an unscored question, there’s just one feedback message for the question overall.
   - None: Choose this if you don’t want any feedback to display and if you don’t need to branch the learner to a different place in the course based on how they answer.

2. If you opt to display feedback, you can edit the feedback text in the Feedback area of the question editor, which appears at the bottom of the question editor (if you chose Feedback By Question), or next to each answer choice (if you chose Feedback By Choice). Or, when you return to the Normal View of your slide, you can make the changes to the feedback layers that Storyline creates for you. To learn more about Layers, see this tutorial. To change the visual design of your feedback layers, check out this tutorial.

3. For graded questions, you can also include Post-Quiz Review feedback. This feedback appears during the quiz review if you provide your learners with a Result Slide that includes a "Review Quiz" option. In the Post-Quiz Review field at the bottom of the question editor, enter the review feedback you want learners to see.
4. Now let’s talk about branching. By default, Storyline will take the learner to the next slide in your course once they answer your question. But if you want to take them somewhere else in the course, you can do that. Click any **More** button in the **Feedback** area, and use the **Branch to the following** selector to choose the destination.
Step 7: Assign the number of attempts (graded questions only)

By default, Storyline gives learners one attempt at your question. But if they answer incorrectly, you can give them the opportunity to retry. Use the Attempts selector to choose the number of attempts, or set it to Unlimited if you want learners to keep trying the question till they get it right. (The Attempts selector doesn't appear on unscored questions, since those don't have a right or wrong answer.)

Some things to keep in mind:

• If you allow multiple tries, Storyline adds a “Try Again” section to the Feedback area on the question editor. This is the feedback that'll appear if a learner answers incorrectly. You can make changes to the feedback here on the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the to the “Try Again” slide layer that Storyline creates for you. To learn more about layers, see this tutorial.

• If you want the “Try Again” messages throughout your course to look a certain way, you can make changes to the Try Again feedback layout. For more details, check out this tutorial.

Step 8: Return to the Normal View of your slide

When you're done setting your options on the question editor, click Save & Close. This closes the question editor and returns you to the Normal View of the slide.

If you chose to provide feedback on this question, or if you chose to include a post-quiz review message, you'll see separate layers for each of these in the Slide Layers panel, and you can edit those layers if you like.
This is also where you can customize the default Selected state that Storyline has applied to your answer choices. Find out more about editing States [here](#).

**Step 9: Assign a result slide**

You can display quiz results at any point in your course by using a results slide. When you create a results slide, you can tell Storyline which questions in your course you want it to use for calculating the results. Find out more about how to create a results slide [here](#).

If you've already added a result slide in your course, you can assign the current question to it like this: in Normal View, find the **Question** panel at the right edge of the slide workspace. Use the **Results slide** selector to choose the results slide to which you want to connect this question.

![Image of assigning a result slide](image)

**How do I edit my question later?**

If you need to make changes to your question later, you can go to your question slide and edit the content directly on the slide. If you need to change other things about the question that aren't visible on the slide (such as the scoring, number of attempts, or how feedback is handled), just click the **Edit Drag and Drop** button in the **Question** panel that appears to the right of the slide workspace. This opens the question editor where you can make whatever changes you need. Click **Save & Close** when you're done.

**You might also want to explore:**

- [Adding Result Slides](#)
- [Adding Graded Questions and Survey Questions](#)
- [Using Question Banks](#)
- [Using Feedback Masters](#)
- [Adding and Editing States](#)
Pick One

A Freeform Pick One question behaves a lot like a multiple-choice question, only instead of using just text as your answer choices, you can use just about any kind of object—such as a picture, character, shape, caption, button, or screenshot. In this tutorial, we'll look at how to create a Freeform Pick One question.

Step 1: Create the question slide

There are a few ways you can create a Freeform Pick One question slide. If you already have some objects on your slide that you want to use as a Pick One question, you can convert it by using the steps in this tutorial.

Or, you can create the slide from scratch by following these steps:

1. Do any of the following:
   - Click the Insert tab on the Storyline ribbon and select New Slide.
   - Or, in Story View, right-click anywhere in the workspace and choose New Slide.
   - Or, in Normal View, right-click the workspace in the slide thumbnails area and choose New Slide.

2. The Insert Slides window appears. Select the Quizzing tab from the left edge.
3. At the top of the window, select **Freeform**, and click the **Pick One** thumbnail.

4. Click **Insert**.

5. Next, you'll need to add objects to your slides so that you can use them as your answer choices. Storyline will let you know this by displaying a message in the **Question** panel that says "To edit the question, this slide needs at least two compatible shapes." You can use the **Insert** tab on the Storyline menu to add objects to your slide. Check out the tutorials [here](#) if you need help inserting content.
6. Once you've added some objects to your slide, click **Edit Pick One** in the question panel. This opens the question editor, where you can customize your question.
Step 2: Identify the answer choices

When the Pick One question editor appears, identify the objects you want to use as answer choices, like this:

1. Put your cursor in the Choice column and use the selector to identify the objects on your slide that you want to turn into answer choices. As you scroll over the items in the list, Storyline marks them with an outline on the slide, so that you can easily see what you’re selecting.

On any object that you designate as an answer choice, Storyline automatically creates a Selected state. This adds a slight colored glow to the object when learners click on it, so your learners can easily distinguish between selected and unselected items. You can customize the Selected state to look however you like. Find out more about editing states in this tutorial.
2. In the **Correct** column, mark the item that represents the correct answer.

   - **Note:** If there isn't really a correct or incorrect answer, and you want this to be an unscored activity, don't worry about marking a correct answer for now. We'll see how to remove the **Correct** column and turn off scoring in a minute.

3. Use the **Shuffle** selector on the toolbar to turn answer-shuffling on or off. Shuffling causes the answer choices to appear in a random order.
**Step 3: Enter the score**

1. Choose one of the following from the **Score** selector on the toolbar:

   - **By Question**: This is the default, and it allows you to assign points to the correct and incorrect answer.
   - **By Choice**: This allows you to set up a different score for each answer choice.
   - **None**: This omits any scoring info from the question. It also removes the need for correct/incorrect answer choices and correct/incorrect feedback.

2. If you chose **By Question** or **By Choice** for the **Scoring** option, now enter values in the **Points** area of the question editor.

The Points fields will be in the Feedback and Branching area, or next to each answer choice, depending on whether you chose to score **By Question** or **By Choice**.
Step 4: Make the question required or optional (unscored questions only)

If you’re building an unscored question, use the Require selector on the toolbar to choose User may skip or User must answer. (For graded questions, the Require selector isn’t available, since graded questions require an answer.)

Step 5: Choose your options for feedback and branching

In Storyline, you can show your learners feedback after they answer a question—and you can also branch learners to different parts of your course, based on their answers. Here’s how:

1. Choose one of the following from the Feedback selector on the toolbar:

   - **By Question**: This allows you to set up question-based feedback and branching. For a graded question, you can show different feedback for a correct vs. incorrect answer. For an unscored question, there’s just one feedback message for the question overall.
   - **By Choice**: This allows you to set up different feedback for each individual answer choice.
   - **None**: Choose this if you don’t want any feedback to display, and you don’t need to branch the learner to a different place in the course based on how they answer.

2. If you display feedback, you can edit the feedback text in the Feedback area of the question editor, which appears at the bottom of the question editor (if you chose Feedback By Question), or next to each answer choice (if you chose Feedback By Choice). Or, when you return to the Normal View of your slide, you can make
the changes to the feedback layers that Storyline creates for you. To learn more about Layers, see this tutorial. To change the visual design of your feedback layers, check out the tutorial on Using Feedback Masters.

3. For graded questions, you can also include Post-Quiz Review feedback. This feedback appears during the quiz review, if you provide your learners with a Result Slide that includes a "Review Quiz" option. In the Post-Quiz Review field at the bottom of the question editor, enter the review feedback you want learners to see.

4. Now let's talk about branching. By default, Storyline will take the learner to the next slide in your course once they answer your question. But if you want to take them somewhere else in the course, you can do that. Click any More button that appears to the right of the Feedback field, and then use the Branch to the following selector to choose the destination.
Step 6: Choose the number of attempts (graded questions only)

By default, Storyline gives learners one attempt at your question. But if they answer incorrectly, you can give them the opportunity to retry. Use the Attempts selector to choose the number of attempts, or set it to Unlimited if you want learners to keep trying the question till they get it right. (The Attempts selector doesn’t appear on unscored questions, since those don’t have a right or wrong answer.)

Some things to keep in mind:

- If you allow multiple tries, Storyline adds a “Try Again” section to the Feedback area on the question editor. This is the feedback that’ll appear if a learner answers incorrectly. You can make changes to the feedback here on the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the the “Try Again” slide layer that Storyline creates for you. (Learn more about slide layers.)

- If you want the “Try Again” messages throughout your course to look a certain way, you can make changes to the Try Again Feedback layout. For more details, check out this tutorial.

Returning to the Normal View of your slide

When you’re done setting your options on the question editor, click Save & Close. This closes the question editor and returns you to the Normal View of the slide.

If you chose to provide feedback on this question, or if you chose to include a post-quiz review message, you’ll see separate layers for each of these in the Slide Layers panel, and you can edit those layers now if you like.

This is also where you can customize the default Selected state that Storyline has applied to your answer choices. More about editing States here.
What about a quiz result slide?

You can display quiz results at any point in your course by using a results slide. When you create a results slide, you can tell Storyline which questions in your course you want it to use for calculating the results. Find out more about how to create a result slide in the Adding Result Slides tutorial.

If you've already added a result slide in your course, you can assign the current question to it like this: in the Question panel at the upper-right of the slide workspace, use the Result slide selector to choose the result slide to which you want to connect this question.

How do I edit my question later?

If you need to make changes to your question later, you can go to your question slide and edit the content directly on the slide. If you need to change other things about the question that aren't visible on the slide (such as the scoring, number of attempts, or how feedback is handled), just click the Edit Pick One button in the Question panel that appears to the right of the slide workspace. This opens the question editor, where you can make whatever changes you need. Click Save & Close when you're done.

You might also want to explore:

- Adding Result Slides
- Adding Graded Questions and Survey Questions
- Using Question Banks
- Using Feedback Masters
- Adding and Editing States
Pick Many

A Freeform Pick Many question behaves a lot like a multiple-response question, only instead of using just text as your answer choices, you can use just about any kind of object—such as a picture, character, shape, caption, button, or screenshot. In this tutorial, we'll look at how to create a Freeform Pick Many question.

**Step 1: Create the question slide**

There are a few ways you can create a Freeform Pick Many question slide. If you already have some objects on your slide that you want to use as a Pick Many question, you can convert it by using the steps in this tutorial.

Or, you can create the slide from scratch by following these steps:

1. Do any of the following:
   - Click the Insert tab on the Storyline ribbon and select New Slide.
   - Or, in Story View, right-click anywhere in the workspace and choose New Slide.
   - Or, in Normal View, right-click the workspace in the slide thumbnails area and choose New Slide.

2. The Insert Slides window appears. Select the Quizzing tab from the left edge.
3. At the top of the window, select **Freeform**, and click the **Pick Many** thumbnail.

4. Click **Insert**.

5. Next, you'll need to add objects to your slides so that you can use them as your answer choices. Storyline will let you know this by displaying a message in the **Question** panel that says "To edit the question, this slide needs at least two compatible shapes." You can use the **Insert** tab on the Storyline menu to add objects to your slide. Check out the tutorials **here** if you need help inserting content.
6. Once you’ve added some objects to your slide, click **Edit Pick Many** in the question panel. This opens the question editor, where you can customize your question.
Step 2: Identify the answer choices

When the Pick Many question editor appears, identify the objects you want to use as answer choices, like this:

1. Place your cursor in the Choice column and use the selector to identify the objects on your slide that you want to turn into answer choices. As you scroll over the items in the list, Storyline marks them with an outline on the slide, so that you can easily see what you're selecting.

On any object that you designate as an answer choice, Storyline automatically creates a Selected state. This adds a slight colored glow to the object when learners click on it, so your learners can easily distinguish between selected and unselected items. You can customize the Selected state to look however you like. Find out more about editing states in this tutorial.
2. In the **Correct** column, mark the items that represent the correct answer. Since this is a Pick Many question, you can mark multiple correct responses.

- **Note:** If the question doesn't really have correct or incorrect answers, and you want this to be an unscored activity, don't worry about marking anything correct for now. We'll see how to remove the **Correct** column and turn off scoring in a minute.

3. Use the **Shuffle** selector on the toolbar to turn answer-shuffling on or off. Shuffling causes the answer choices to appear in a random order.
Step 3: Enter the score

1. Choose one of the following from the Score selector on the toolbar:

   - **By Question**: This is the default, and it allows you to assign points to the correct and incorrect answer.
   - **None**: This omits any scoring info from the question. It also removes the need for correct/incorrect answer choices and correct/incorrect feedback.

2. If you chose **By Question** for the Scoring option, now enter values in the Points area of the question editor.

Step 4: Make the question required or optional (unscored questions only)

If you’re building an unscored question, use the Require selector on the toolbar to choose **User may skip** or **User must answer**. (For graded questions, the Require selector isn’t available, since graded questions require an answer.)
Step 5: Choose your options for feedback and branching

In Storyline, you can show your learners feedback after they answer a question—and you can also branch learners to different parts of your course, based on their answers. Here’s how:

1. Choose one of the following from the Feedback selector on the toolbar:

   - **By Question**: This allows you to set up question-based feedback and branching. For a graded question, you can show different feedback for a correct vs. incorrect answer. For an unscored question, there’s just one feedback message for the question overall.
   - **None**: Choose this if you don’t want any feedback to display, and you don’t need to branch the learner to a different place in the course based on how they answer.

2. If you display feedback, you can edit the feedback text in the Feedback area at the bottom of the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the feedback layers that Storyline creates for you. To learn more about Layers, see this tutorial. To change the visual design of your feedback layers, check out this tutorial.

3. For graded questions, you can also include Post-Quiz Review feedback. This feedback appears during the quiz review, if you provide your learners with a Result Slide that includes a "Review Quiz” option. In the Post-Quiz Review field at the bottom of the question editor, enter the review feedback you want learners to see.
4. Now let’s talk about branching. By default, Storyline will take the learner to the next slide in your course once they answer your question. But if you want to take them somewhere else in the course, you can do that. Click any More button that appears to the right of the Feedback field, and then use the Branch to the following selector to choose the destination.
**Step 6: Choose the number of attempts (graded questions only)**

By default, Storyline gives learners one attempt at your question. But if they answer incorrectly, you can give them the opportunity to retry. Use the **Attempts** selector to choose the number of attempts, or set it to **Unlimited** if you want learners to keep trying the question till they get it right. (The **Attempts** selector doesn't appear on unscored questions, since those don't have a right or wrong answer.)

![Screenshot of Storyline interface showing the Attempts selector](image)

Some things to keep in mind:

- If you allow multiple tries, Storyline adds a "Try Again" section to the **Feedback** area on the question editor. This is the feedback that'll appear if a learner answers incorrectly. You can make changes to the feedback here on the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the to the "Try Again" slide layer that Storyline creates for you. ([Learn more about slide layers.](#))
- If you want the "Try Again" messages throughout your course to look a certain way, you can make changes to the Try Again Feedback layout. For more details, check out [this tutorial](#).

**Returning to the Normal View of your slide**

When you're done setting your options on the question editor, click **Save & Close**. Storyline will return you to the Normal View of the slide. If you chose to provide feedback on this question, or if you chose to include a post-quiz review message, you'll see separate layers for each of these in the Slide Layers pane, and you can edit those layers if you like.
What about a quiz result slide?

You can display quiz results at any point in your course by using a results slide. When you create a results slide, you can tell Storyline which questions in your course you want it to use for calculating the results. Find out more about how to create a result slide [here](#).

If you've already added a result slide in your course, you can assign the current question to it like this: In the **Question** panel at the upper-right of the slide workspace, use the **Result slide** selector to choose the result slide to which you want to connect this question.

How do I edit my question later?

If you need to make changes to your question later, you can go to your question slide and edit the content directly on the slide. If you need to change other things about the question that aren't visible on the slide (such as the scoring, number of attempts, or how feedback is handled), just click the **Edit Pick Many** button in the **Question** panel that appears to the right of the slide workspace. This opens the question editor, where you can make whatever changes you need. Click **Save & Close** when you're done.

You might also want to explore:

- Adding Result Slides
- Adding Graded Questions and Survey Questions
- Using Question Banks
- Using Feedback Masters
- Adding and Editing States
Text Entry

A Freeform Text Entry question allows you to design your own fill-in-the-blank question. In this tutorial, we'll explore how to create a new Text Entry question from scratch.

Note: Even though you can use the Insert tab to add multiple text entry fields to your slide, be aware that only one designated text entry field will be evaluated. If you need your course to evaluate multiple text entry fields, check out this approach instead.

Step 1: Insert a Text Entry freeform question

1. Do any one of the following:
   - Select the Home tab, and click New Slide.
   - Or, select the Insert tab, and click New Slide.
   - Or, in Story View, right-click anywhere in the workspace and choose New Slide.
   - Or, in Normal (slide) View, right-click anywhere in the left navigation pane and choose New Slide.

2. When the Insert Slides window appears, select the Quizzing tab from the left edge.
3. Select the **Freeform** tab at the top of the window, and click the **Text Entry** thumbnail.

4. Click the **Insert** button.

A new slide will be added to your story, and the **Text Entry** question editor will automatically open where you can define the acceptable answers.
Step 2: Define acceptable answers

Type the acceptable answers for the text entry question into the answer grid. And if the acceptable answers are case-sensitive, be sure to mark the **Answers are case sensitive** check box in the lower right corner of the window.

**Tip**: If you convert an existing slide with **data entry fields** into a freeform **Text Entry** question, use the **Field To Evaluate** drop-down list to select the existing text entry field that you want to grade or on which you want to provide feedback. Only one text entry field per slide can be evaluated.
**Step 3: Specify how the text entry question will be submitted**

Your users can click the built-in Submit button on your player, which is the default navigation feature for quizzing slides, to submit their text entry response for evaluation. However, if you are not using the built-in Submit button on your player, or if you want to provide alternative methods for submitting responses, you can configure one or both of the following:

- **Submit Keys**: Use the Submit Keys field below the answer grid to designate which key or combination of keys will actually submit users’ answers for evaluation.
  
  - Simply click in the Submit Keys field and press the key or combination of keys that you wish to use.
  - If you change your mind, you can either press the correct key(s), which will update the Submit Keys field accordingly, or you can click the Clear Submit Keys button, which looks like a red X, to clear the field altogether.
  - **Note**: The Enter key will always submit a text entry field for evaluation, so you won’t need to specify it here.

- **Submit Button**: If you would like to provide your own button or hotspot on the slide that users can click to submit their answer, use the Submit Button drop-down list to select New Button or New Hotspot. If you already have one or more buttons or hotspots on the slide, they will also appear in the drop-down list, which means you can even select an existing button or hotspot to submit users’ answers. And, if you change your mind, you can select No Button from the drop-down list.
**Step 4: Enter the score**

1. Choose one of the following from the **Score** selector on the toolbar:
   - **By Question**: This is the default, and it allows you to assign points to the correct answer.
   - **None**: This omits any scoring info from the question. It also removes the need for acceptable answers and correct/incorrect feedback. Storyline creates a single feedback message (which you can of course edit) rather than having separate correct/incorrect feedback messages.

2. If you chose **By Question** for the **Scoring** option, now enter values in the **Points** area of the question editor (lower right corner).

**Step 5: Make the question required or optional (unscored questions only)**

If you are building an unscored question, use the **Require** selector on the toolbar to choose **User may skip** or **User must answer**. (For graded questions, the **Require** selector isn’t available, since graded questions require an answer.)
Step 6: Choose feedback and branching options

1. In Storyline, you can show your learners feedback after they answer a question—and you can also branch learners to different parts of your course, based on their answers. Choose one of the following from the Feedback selector on the toolbar:

   - **By Question**: This allows you to set up question-based feedback and branching. For a graded question, you can show different feedback for a correct vs. incorrect answer. For an unscored question, there's just one feedback message for the question overall.
   
   - **None**: Choose this if you don't want any feedback to display and if you don't need to branch the learner to a different place in the course based on how they answer.

2. If you opt to display feedback, you can edit the feedback text in the Feedback area of the question editor, which appears at the bottom of the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the feedback layers that Storyline creates for you. To learn more about layers, see this tutorial. To change the visual design of your feedback layers, check out this tutorial.

3. For graded questions, you can also include Post-Quiz Review feedback. This feedback appears during the quiz review, if you provide your learners with a Result Slide that includes a "Review Quiz" option. In the Post-Quiz Review field at the bottom of the question editor, enter the review feedback you want learners to see.
4. Now let's talk about branching. By default, Storyline will take the learner to the next slide in your course once they answer your question. But if you want to take them somewhere else in the course, you can do that. Click any More button in the Feedback area, and use the Branch to the following selector to choose the destination.
Step 7: Assign the number of attempts (graded questions only)

By default, Storyline gives learners one attempt at your question. But if they answer incorrectly, you can give them the opportunity to retry. Use the Attempts selector to choose the number of attempts, or set it to Unlimited if you want learners to keep trying the question till they get it right. (The Attempts selector doesn’t appear on unscored questions, since those don’t have a right or wrong answer.)

Some things to keep in mind:

- If you allow multiple tries, Storyline adds a “Try Again” section to the Feedback area on the question editor. This is the feedback that’ll appear if a learner answers incorrectly. You can make changes to the feedback here on the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the “Try Again” slide layer that Storyline creates for you. To learn more about layers, see this tutorial.
- If you want the “Try Again” messages throughout your course to look a certain way, you can make changes to the Try Again feedback layout. For more details, check out this tutorial.

Step 8: Return to the Normal View of your slide

When you’re done setting your options on the question editor, click Save & Close. This closes the question editor and returns you to the Normal View of the slide.

If you chose to provide feedback on this question, or if you chose to include a post-quiz review message, you’ll see separate layers for each of these in the Slide Layers panel, and you can edit those layers if you like.
**Step 9: Assign a result slide**

You can display quiz results at any point in your course by using a results slide. When you create a results slide, you can tell Storyline which questions in your course you want it to use for calculating the results. Find out more about how to create a result slide [here](#).

If you've *already* added a result slide in your course, you can assign the current question to it like this: in Normal View, find the **Question** panel at the right edge of the slide workspace. Use the **Results slide** selector to choose the results slide to which you want to connect this question.

![Results slide selector](image)

**How do I edit my question later?**

If you need to make changes to your question later, you can go to your question slide and edit the content directly on the slide. If you need to change other things about the question that aren’t visible on the slide (such as the scoring, number of attempts, or how feedback is handled), just click the **Edit Text Entry Interaction** button in the **Question** panel that appears to the right of the slide workspace. This opens the question editor where you can make whatever changes you need. Click **Save & Close** when you're done.

**You might also want to explore:**

- Adding Result Slides
- Adding Graded Questions and Survey Questions
- Using Question Banks
- Using Feedback Masters
- Adding and Editing States
Hotspot

A **Freeform Hotspot** question allows you to define one or more hotspots on a slide and provide feedback based on the user's interaction with them.

In this tutorial, we’ll look at how to create a hotspot question from scratch. However, you may find it easier to create a hotspot question from an existing slide. To learn how to convert an existing slide into a freeform hotspot question, take a look at [this tutorial](#).

**Step 1: Insert a Hotspot freeform question**

1. Do any one of the following:
   - Select the **Home** tab, and click **New Slide**.
   - Or, select the **Insert** tab, and click **New Slide**.
   - Or, in Story View, right-click anywhere in the workspace and choose **New Slide**.
   - Or, in Normal (slide) View, right-click anywhere in the left navigation pane and choose **New Slide**.

2. When the **Insert Slides** window appears, select the **Quizzing** tab from the left edge.
3. Select the **Freeform** tab at the top of the window, and click the **Hotspot** thumbnail.

4. Click the **Insert** button.

A new slide will be added to your story, and the **Hotspot** question editor will automatically open where you can add an image and define one or more hotspots.
**Step 2: Add an image and define hotspots**

First, you'll want to add an image to your new slide on which you will define hotspots. Click the Choose Image button below the slide preview area, select the image you want to use, and click the Open button.

Then add one or more hotspots to your slide. Here’s how:

1. Click the Add Hotspot drop-down list below the slide preview area, and select Add Oval, Add Rectangle, or Add Freeform.

2. Draw your hotspot in the slide preview area.
• **Tip:** If you are adding your first hotspot, you can also click either the *oval* hyperlink or the *rectangle* hyperlink in the hotspot list on the right side of the window, which will automatically add an oval or rectangle to the slide preview area for you.

3. If you want to add more hotspots, repeat steps 1 and 2.

Here are some things to keep in mind when constructing a hotspot question:

- You must have at least one hotspot. You can add more hotspots if you want, but only one is required.
- If you are building a hotspot question that will be graded (scored), the first hotspot that you draw will be green, which indicates that it is the *correct* response. If you draw any additional hotspots, they will be red, which indicates that they are *incorrect* responses. You will be able to change which hotspot is the correct one at any time after you add at least two hotspots (see below).

- There can be only one *correct* hotspot in a graded question.
- On the other hand, if you are building a hotspot question that will be unscored, all the hotspots will be green, since there are no wrong answers for an unscored question.
After adding hotspots to your question, you can further customize and manage them, using the following options:

- You can resize hotspots by dragging the sizing handles.

- You can rearrange hotspots by dragging them with your mouse (which changes to a 4-headed arrow) to the desired locations on the slide.

- You can rename hotspots by clicking in the text field and typing over the default name (Hotspot 1, Hotspot 2, etc). Though your learners won't see this text, the names make it easier to identify or select objects when you’re working with other Storyline features, such as the timeline or triggers.
• If you have more than one hotspot and you are building a graded (scored) question, you can specify which hotspot is the correct response by selecting the appropriate radio button in the hotspot list on the right side of the window. The red and green color coding of the hotspots in the slide preview area will change accordingly.

• If you need to delete a hotspot, select that hotspot in the slide preview area or in the hotspot list, and then click the Delete button below the slide preview area or click the Delete key on your keyboard.
Step 3: Specify how the hotspot question will be submitted

Use the Submit drop-down list on the toolbar to specify which of the following four methods will indicate that a user has completed the hotspot question and submitted it for evaluation:

- By Player Button
- On Click
- On Double Click
- On Right Click

The default option, By Player Button, means that users must click the built-in Submit button on your course's player for the question to be evaluated. However, if you want users' responses to be evaluated as soon as they click on a hotspot, select one of the other three options.

Step 4: Enter the score

1. Choose one of the following from the Score selector on the toolbar:

   - By Question: This is the default, and it allows you to assign points to the correct and incorrect answer.
   - By Choice: This allows you to set up a different score for each answer choice.
   - None: This omits any scoring info from the question. It also removes the need for correct/incorrect answer choices and correct/incorrect feedback.
2. If you chose **By Question** or **By Choice** for the **Scoring** option, now enter values in the **Points** area of the question editor.

The Points fields will be in the Feedback and Branching area or next to each answer choice, depending on whether you chose to score **By Question** or **By Choice**.

**Step 5: Make the question required or optional (unscored questions only)**

If you’re building an unscored question, use the **Require** selector on the toolbar to choose **User may skip** or **User must answer**. (For graded questions, the **Require** selector isn’t available, since graded questions require an answer.)
Step 6: Choose your options for feedback and branching

In Storyline, you can show your learners feedback after they answer a question—and you can also branch learners to different parts of your course, based on their answers. Here’s how:

1. Choose one of the following from the **Feedback** selector on the toolbar:

   - **By Question**: This allows you to set up question-based feedback and branching. For a graded question, you can show different feedback for a correct vs. incorrect answer. For an unscored question, there’s just one feedback message for the question overall.
   - **By Choice**: This allows you to set up different feedback for each individual answer choice.
   - **None**: Choose this if you don’t want any feedback to display and you don’t need to branch the learner to a different place in the course based on how they answer.

2. If you display feedback, you can edit the feedback text in the **Feedback** area of the question editor, which appears at the bottom of the question editor (if you chose Feedback By Question), or next to each answer choice (if you chose Feedback By Choice). Or, when you return to the Normal View of your slide, you can make the changes to the feedback layers that Storyline creates for you. To learn more about layers, see this tutorial. To change the visual design of your feedback layers, check out this tutorial.

3. For graded questions, you can also include **Post-Quiz Review** feedback. This feedback appears during the quiz review if you provide your learners with a **Result Slide** that includes a “Review Quiz” option. In the **Post-Quiz Review** field at the bottom of the question editor, enter the review feedback you want learners to see.
4. Now let’s talk about branching. By default, Storyline will take the learner to the next slide in your course once they answer your question. But if you want to take them somewhere else in the course, you can do that. Click any More button that appears to the right of the Feedback field, and then use the Branch to the following selector to choose the destination.

![Image of branching interface in Storyline]

1. Click any “More” button to add branching to your question.

2. Then choose your branching here.
Step 7: Choose the number of attempts (graded questions only)

By default, Storyline gives learners one attempt at your question. But if they answer incorrectly, you can give them the opportunity to retry. Use the Attempts selector to choose the number of attempts, or set it to Unlimited if you want learners to keep trying the question till they get it right. (The Attempts selector doesn’t appear on unscored questions, since those don’t have a right or wrong answer.)

![Image of the Attempts selector in Storyline]

Some things to keep in mind:

- If you allow multiple tries, Storyline adds a “Try Again” section to the Feedback area on the question editor. This is the feedback that’ll appear if a learner answers incorrectly. You can make changes to the feedback here on the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the to the “Try Again” slide layer that Storyline creates for you. To learn more about layers, see this tutorial.
- If you want the “Try Again” messages throughout your course to look a certain way, you can make changes to the Try Again feedback layout. For more details, check out this tutorial.

Step 8: Return to the Normal View of your slide

When you’re done setting your options on the question editor, click Save & Close. This closes the question editor and returns you to the Normal View of the slide.

![Image of the Save & Close button in Storyline]

If you chose to provide feedback on this question, or if you chose to include a post-quiz review message, you’ll see separate layers for each of these in the Slide Layers panel, and you can edit those layers if you like.
**Step 9: Assign a result slide**

You can display quiz results at any point in your course by using a results slide. When you create a results slide, you can tell Storyline which questions in your course you want it to use for calculating the results. Find out more about how to create a results slide [here](#).

If you've already added a result slide in your course, you can assign the current question to it like this: in Normal View, find the Question panel at the right edge of the slide workspace. Use the Results slide selector to choose the results slide to which you want to connect this question.

![Results slide selector](image)

**How do I edit my question later?**

If you need to make changes to your question later, you can go to your question slide and edit the content directly on the slide. If you need to change other things about the question that aren't visible on the slide (such as the scoring, number of attempts, or how feedback is handled), just click the Edit Hotspot button in the Question panel that appears to the right of the slide workspace. This opens the question editor where you can make whatever changes you need. Click Save & Close when you're done.

**You might also want to explore:**

- Adding Result Slides
- Adding Graded Questions and Survey Questions
- Using Question Banks
- Using Feedback Masters
- Adding and Editing States
Shortcut Key

A Shortcut Key question allows users to answer by pressing a key or combination of keys on their keyboard. In this tutorial, we’ll look at how to create a shortcut key question.

**Step 1: Create a slide and convert it to a freeform question**

To create a shortcut key question, you must first add a non-question slide to your project. You can start with one of the basic layouts, a template, a screen recording that you’ve inserted as step-by-step slides (Try mode or Test mode), or a slide imported from PowerPoint. Be sure to add a text box or caption to your slide with instructions for your users or the question that you want them to answer as demonstrated in the following image:

![Image of a slide with instructions]

After designing the slide to look the way you want, do the following:

1. Go to the Insert tab, and click Convert to Freeform.
2. Select **Shortcut Key**, and click the **OK** button.

The Shortcut Keys question editor will automatically open, where you can specify the correct response.

**Step 2: Define the correct key or combination of keys**

When the Shortcut Keys question editor opens, select the **Key or Key Combination** field, and press the key or combination of keys for the correct response.

*Be sure to thoroughly test your shortcut key questions in your published output. If you select keys or key combinations that are common shortcuts in browsers (ALT+D, CTRL+T, etc), you may experience unexpected behavior.*
**Step 3: Enter the score**

1. Choose one of the following from the **Score** selector on the toolbar:

   - **By Question**: This is the default, and it allows you to assign points to the correct and incorrect answer.
   - **None**: This omits any scoring info from the question. It also removes the need for correct/incorrect feedback. Storyline creates a single feedback message (which you can of course edit) rather than having separate correct/incorrect feedback messages.

2. If you chose **By Question** for the **Scoring** option, now enter values in the **Points** area of the question editor.
**Step 4: Make the question required or optional (unscored questions only)**

If you are building an unscored question, use the Require selector on the toolbar to choose **User may skip** or **User must answer**. (For graded questions, the Require selector isn’t available, since graded questions require an answer.)

![Image of Require selector](image)

**Step 5: Choose your options for feedback and branching**

In Storyline, you can show your learners feedback after they answer a question—and you can also branch learners to different parts of your course based on their answers. Here’s how:

1. Choose one of the following from the Feedback selector on the toolbar:
   - **By Question**: This allows you to set up question-based feedback and branching. For a graded question, you can show different feedback for a correct vs. incorrect answer. For an unscored question, there’s just one feedback message for the question overall.
   - **None**: Choose this if you don’t want any feedback to display and if you don’t need to branch the learner to a different place in the course based on how they answer.

![Image of Feedback selector](image)

2. If you opt to display feedback, you can edit the feedback text in the Feedback area of the question editor, which appears at the bottom of the question editor (if you chose Feedback By Question). Or, when you return to the Normal View of your slide, you can make the changes to the feedback layers that Storyline creates for you. To learn more about layers, see [this tutorial](link). To change the visual design of your feedback layers, check out [this tutorial](link).

3. For graded questions, you can also include **Post-Quiz Review** feedback. This feedback appears during the quiz review, if you provide your learners with a Result Slide that includes a "Review Quiz" option. In the Post-Quiz Review field at the bottom of the question editor, enter the review feedback you want learners to see.
4. Now let's talk about branching. By default, Storyline will take the learner to the next slide in your course once they answer your question. But if you want to take them somewhere else in the course, you can do that. Click any **More** button in the **Feedback** area, and use the **Branch to the following** selector to choose the destination.
**Step 6: Assign the number of attempts (graded questions only)**

By default, Storyline gives learners one attempt at your question. But if they answer incorrectly, you can give them the opportunity to retry. Use the **Attempts** selector to choose the number of attempts, or set it to **Unlimited** if you want learners to keep trying the question till they get it right. (The **Attempts** selector doesn't appear on unscored questions, since those don't have a right or wrong answer.)

Some things to keep in mind:

- If you allow multiple tries, Storyline adds a “Try Again” section to the **Feedback** area on the question editor. This is the feedback that’ll appear if a learner answers incorrectly. You can make changes to the feedback here on the question editor. Or, when you return to the Normal View of your slide, you can make the changes to the to the “Try Again” slide layer that Storyline creates for you. To learn more about layers, see this tutorial.
- If you want the “Try Again” messages throughout your course to look a certain way, you can make changes to the Try Again feedback layout. For more details, check out this tutorial.

**Step 7: Return to the Normal View of your slide**

When you're done setting your options on the question editor, click **Save & Close**. This closes the question editor and returns you to the Normal View of the slide.

If you chose to provide feedback on this question, or if you chose to include a post-quiz review message, you'll see separate layers for each of these in the Slide Layers panel, and you can edit those layers if you like.
**Step 8: Assign a result slide**

You can display quiz results at any point in your course by using a results slide. When you create a results slide, you can tell Storyline which questions in your course you want it to use for calculating the results. Find out more about how to create a results slide [here](#).

If you've already added a result slide in your course, you can assign the current question to it like this: in Normal View, find the **Question** panel at the right edge of the slide workspace. Use the **Results slide** selector to choose the results slide to which you want to connect this question.

![Image](#)

**How do I edit my question later?**

If you need to make changes to your question later, you can go to your question slide and edit the content directly on the slide. If you need to change other things about the question that aren't visible on the slide (such as the scoring, number of attempts, or how feedback is handled), just click the **Edit Shortcut Keys** button in the **Question** panel that appears to the right of the slide workspace. This opens the question editor where you can make whatever changes you need. Click **Save & Close** when you're done.

**You might also want to explore:**

- Adding Result Slides
- Using Storyline's Basic Layouts
- Using and Creating Storyline Templates
- Adding Graded Questions and Survey Questions
- Using Question Banks
- Adding Screen Recordings
- Importing from PowerPoint
- Using Feedback Masters
Using Question Banks

Use question banks to manage groups of questions in a Storyline project. Question banks make it easy to assemble, use, and even reuse questions.

Although question banks are generally used for storing question slides, you aren't limited to question slides. You can add content slides as well.

Slides in a question bank will not be visible to your users in the published content unless you draw them into the story. When you draw slides from a question bank into your story, you can choose to display all of them or just a subset. You can also randomize the questions if you prefer.

Question banks are file-specific, meaning they only pertain to the story in which they're located. However, like any other slides in your story, question bank slides can be imported into a different story if you want to reuse them.

To learn how to create question banks and how to draw from them, take a look at these tutorials:

- Creating and Editing Question Banks
- Drawing from Question Banks
Creating and Editing Question Banks

In this tutorial, we'll explore how to create, edit (populate), and manage question banks.

Creating question banks

By default, one question bank will always exist in a story. Initially it'll be empty until you add or import questions to it. You can create as many additional question banks as you like, using the steps below. To learn how to edit the default question bank, called Question Bank 1, see the section in this tutorial called Editing question banks.

Here's how to create a new question bank:

1. In Story View, select the Home tab.
2. Click the Question Banks button, and do any one of the following:

- Select Create Question Bank.
- Or, select Manage Question Banks, and then click the “Create a new question bank” button.
- Or, select Manage Question Banks, and then click the “Duplicate the selected question bank” button.

An empty question bank will open. The next section of this tutorial will describe how to populate it with slides.
Editing question banks

When you edit a question bank, you can add, delete, and rearrange slides. You’ll also be able to open individual slides in Normal View for editing.

Opening a question bank for editing:

First, you will need to open the question bank that you want to edit (if you haven’t already done so). There are several ways to open a question bank, but here’s the quickest and easiest method:

1. In Story View, go to the Home tab.
2. Click the Question Banks button, and select the name of the question bank that you want to edit.
You can also open a question bank for editing using either of the following ways:

- In **Story View**, go to the **Home** tab. Click the **Question Banks** button, and select **Manage Question Banks**. Then select the question bank that you want to open, and click the "**Edit the selected question bank**" button (the pencil icon). (For more information on managing question banks, see the last section in this tutorial.)

- Or, open the **Insert Slides** dialog, and select the **Quizzing** tab on the left. Then select the **Draw From Bank** tab at the top of the window. Select the question bank that you want to edit from the **Question Bank** drop-down list, and click the **Edit question bank** hyperlink.
Using the Home tab to edit a question bank:

When you have opened a question bank, use the following toolbar options on the Home tab to edit and populate the question bank:

- The Cut, Copy, and Paste buttons can be used to duplicate or rearrange questions within your question bank. They can also be used to move or copy questions from scenes in your story into your question bank and vice versa.

- Graded Question allows you to create a new graded question in the question bank.

- Survey Question allows you to create a new survey question in the question bank.
• **New Slide** allows you to **insert new content slides or question slides** from a variety of sources, including Storyline templates, basic slide layouts, quiz templates, and even other Articulate programs. (If you want to include screen recordings in your question bank, you can do that by importing a screen recording from a scene in your story. New screen recordings cannot be created directly in question banks. See the next option for information on how to import slides into question banks.)

• **Import Questions** allows you to import slides into the open question bank from scenes in your story or from other question banks in the same story.

When the **Import Questions** dialog opens, select the slides that you want to import in the following manner:

1. Use the **Import from** drop-down list to specify whether you want to import slides from scenes in the **Story** or from other **Question Banks**.
2. Use the corresponding **Import** drop-down list to specify whether the imported slides will be *copied* into the open question bank or whether they will be *moved* from their current location into your question bank.

3. Select the slides that you want to import by marking the appropriate check boxes to the left of each slide thumbnail. You can also click the **Include All** check box to the right of any scene or question bank to quickly select all the slides in that particular scene or question bank.

4. Then click the **OK** button to complete the import process.
• The **Question Banks** drop-down list allows you to edit and manage other questions banks or to create new question banks. (See the next section in this tutorial for information on managing question banks.)

  ![Question Banks](image1.png)

• **Edit Question** allows you to edit the selected question or content slide in **Normal View**.

  ![Edit Question](image2.png)

When you’re in Normal View, you can edit the content directly on the slide. If you need to change other things about a question that aren’t visible on the slide (such as the scoring, number of attempts, or how feedback is handled), just click the **Edit** button in the **Question** panel that appears to the right of the slide workspace (like the example in the image below). This opens the question editor, where you can make whatever changes you need.

  ![Edit Drag and Drop](image3.png)
• **Delete Question** allows you to delete the selected question or content slide.

![Delete Question](image)

• The **Move Question** drop-down list allows you to move the selected question or content slide **Up** or **Down** in the question bank. (Note that you can also rearrange questions by dragging them up or down the question bank with your mouse.)

![Move Question](image)

• The **Lock Question** drop-down list allows you to lock the selected question or content slide in a specific location, which affects how they will be shuffled (if you choose to randomize the questions when you draw them into your story). You can lock a slide **To Question Above / Below** or **To Top / Bottom of Group**. You can also choose to **Remove Lock** if you change your mind.

![Lock Question](image)
Using the right-click menu to edit a question bank:

You can also access many of the same features described above by right-clicking any slide in your question bank and selecting them from the shortcut menu that appears:

Using the Triggers panel to edit a question bank:

You also have access to the Triggers panel on the right side of the screen where you can quickly add, edit, delete, and rearrange triggers for the selected slide. To learn more about managing triggers, check out this tutorial.
Managing question banks

The Question Bank Manager allows you to create, edit, duplicate, delete, and rename question banks. Here’s how to access the Question Bank Manager:

1. In Story View, go to the Home tab.
2. Click the Question Banks button, and select Manage Question Banks.

When the Question Bank Manager opens, you can perform any of the following management tasks:

- **Create** a new question bank by clicking the “Create a new question bank” button (the icon that looks like a blank piece of paper) in the lower left corner. A new question bank will be added to your list of question banks, and the name of the question bank will be editable. Type the name you want for your new question bank, and then click anywhere on the list of question banks to save the change (or press the Enter key on your keyboard to save the change and immediately open the question bank for editing).
• Edit an existing question bank by clicking the “Edit the selected question bank” button (the pencil icon). Refer to the section above for editing options, such as adding, editing, deleting, moving, and locking questions. Tip: You can also double-click on the name of any question bank in the list to open it for editing.

• Duplicate an existing question bank by clicking the “Duplicate the selected question bank” button (the icon that looks like two windows).

• Rename an existing question bank by clicking the “Rename the selected question bank” button (the “ab” icon).

• Delete an existing question bank by clicking the “Delete the selected question bank” button (the red X).

You might also want to explore:

• Drawing from Question Banks
• Adding Graded Questions and Survey Questions
• Adding Freeform Quiz Questions
• Adding Result Slides
Drawing from Question Banks

After you've created and populated at least one question bank in your project, you can draw questions from the bank into any scene in your story. This is called a question draw. In this tutorial, we'll look at how to add and edit question draws in Storyline.

Note: You can create multiple question draws from the same question bank if you wish, which means you can use the same questions more than once in the same story.

Drawing from question banks

First, select the scene where you want to add a question draw, or create a new scene. Then do either of the following to begin a new question draw:

- In Story View, go to the Home tab, click the Question Banks drop-down list, and then select New Draw from Question Bank.

- Or, open the Insert Slides dialog, and select the Quizzing tab on the left. Then select the Draw From Bank tab at the top of the window.
Then specify the following parameters for your new question draw:

- Use the **Question Bank** drop-down list to select the bank from which you want to draw your questions.

  ![Question Bank](image1)

  If you need to modify the questions in the question bank first, click the **Edit Question Bank** hyperlink next to the **Question Bank** drop-down list. Refer to **this tutorial** for question bank options, such as adding, editing, deleting, moving, and locking questions.

  ![Edit Question Bank](image2)
• If you want the questions to display in a random order in the published story, select the **Draw Questions Randomly** check box.

• If you choose to randomize your questions, you can also use the **Include** drop-down list to specify how many questions you want to include in this particular draw. (This option will not be available unless you randomize your questions.)
• Use the **Include In Shuffle** column to specify, for each question, whether the question will be **Randomly** displayed (which is the default option), **Never** displayed, or **Always** displayed.

![Include In Shuffle column](image)

• Use the **Lock Question** button at the bottom of the window to lock the selected question or content slide in a specific location. This affects how the questions will be shuffled (if you choose to randomize the questions when you draw them into your story). You can lock a slide **To Question Above / Below** or **To Top / Bottom of Group**. You can also choose to **Remove Lock** if you change your mind.

![Lock Question button](image)
• The **Move Question** button at the bottom of the window allows you to move the selected question or content slide **Up** or **Down** in the question bank. (Note that you can also rearrange questions by dragging them up or down the list with your mouse.)

When you have finished making your selections, click the **Insert** button to complete the question draw. When you draw questions from a question bank into your story, there will be a placeholder slide in your story that looks like this:
And the placeholder thumbnail image for a question draw looks like this:

![Placeholder thumbnail image for a question draw](image)

**Editing a question draw**

If you need to change the parameters for an existing question draw, such as randomization, how many questions will be included, how they will be shuffled, or the order in which they will appear, click the *top half* of the placeholder slide where it says, "Click to view the slide draw".

![Click to view the slide draw](image)

![Click to view the question bank](image)
• **Tip:** You can also change the parameters for an existing question draw when you are in Story View by right-clicking the placeholder thumbnail and selecting **Edit** from the shortcut menu that appears.

On the other hand, if you need to edit the source question bank from which the questions will be drawn (by adding, editing, deleting, moving, or locking questions), click the **bottom half** of the slide where it says, “**Click to view the question bank**”. Refer to [this tutorial](#) for question bank options, such as adding, editing, deleting, moving, and locking questions.
You might also want to explore:

- Creating and Editing Question Banks
- Adding Graded Questions and Survey Questions
- Adding Freeform Quiz Questions
- Adding Result Slides
Adding Result Slides

In Storyline, result slides allow you to easily communicate to your users about how they performed on any combination of quiz questions you’ve included in your course. You can report on all questions in your course or, if you prefer, just a subset of questions.

Storyline also allows you to use multiple result slides in the same course (although only one result slide can be tracked in Articulate Online or another LMS). You can even combine scores from multiple result slides to create a final result slide with a consolidated score.

In this tutorial, we'll look at how to create result slides.

Step 1: Create a result slide

1. Do any one of the following:
   - Select the Home tab, and click New Slide.
   - Or, select the Insert tab, and click New Slide.
   - Or, in Story View, right-click anywhere in the workspace and choose New Slide.
   - Or, in Normal View, right-click anywhere in the left navigation pane and choose New Slide.

2. When the Insert Slides window appears, select the Quizzing tab from the left edge.
3. Select the Result Slides tab at the top of the window, and then click the thumbnail image for the type of result slide you want to create.

![Image showing various result slide options in Storyline](image)

The choice you make determines the default items that get included on your result slide. Keep in mind, though, that you'll still be able to customize the slide with more or fewer items if you like. Here's what Storyline gives you as a starting point for each type of result slide:

- **Graded Result Slide**: Includes the user’s score, the passing score, and a button that allows users to review the questions. On separate layers of the slide, Storyline also includes a message about whether the user passed or failed. When your users view the result slide, the appropriate layer appears, depending on their score. You can customize the failure and success messages by editing the appropriate slide layer.
- **Survey Result Slide**: Includes a button that allows the user to review the questions and a “thank you” message for completing the survey.
- **Blank Result Slide**: Includes a button that allows the user to review the questions.

4. Click the Insert button.

The Result Slide Properties window will appear, where you can select the questions you want to track, define the passing score (if applicable), set up a timer, and choose other options for your result slide.
Step 2: Select the questions to be tracked

1. On the Results tab, use the Calculate results for drop-down list to choose one of the following:

   - **Selected Questions**: This option allows you to choose the individual question slides or question draws you want Storyline to use when tabulating results.
   - **Selected Results Slides**: This option allows you to combine more than one result slide into a single cumulative result.

2. Then use the list box to select either the questions or result slides that you want to track. Simply mark the check boxes next to the slides you want to include in the results. If there are no question slides in your course yet, that’s okay—you can still create your result slide now and come back later to choose the slides you want to associate with it.
Tip: If you decide to create your result slide first and associate questions with it later, you can do any of the following to add questions to an existing result slide:

- Navigate to the result slide in your project file, click the Edit Result Slide button in the Question panel on the right side of the slide workspace, and then check the boxes for the question you want to add.
- Or, navigate to a question slide in your project file that you want to add to the result slide, and use the Results Slide drop-down list in the Question panel on the right side of the slide workspace to select the existing result slide.
- Or, switch to Story View, select all the question slides that you want to associate with the result slide, and then use the Results Slide drop-down in the Slide panel in the lower right corner of the window to select the existing result slide.

**Step 3: Define the passing score (for graded questions)**

If you are tracking graded questions, you can adjust the Passing Score field to whatever percentage you like.

Similarly, if you are combining other result slides into a single result, you can specify either of the following:

- **User must pass each quiz**: Each result slide in your course represents a quiz. Select this option if your users must pass each individual quiz to receive an overall passing result. In this scenario, if a user fails any single quiz in the course, then they fail the entire course.
- **Combine points from each quiz**: Select this option if you want the scores from the selected result slides to be added together and re-evaluated as a single score. Then assign the appropriate Passing Score percentage. In this scenario, a user could fail one or more of the individual quizzes in the course and still pass the overall course as long as their cumulative score exceeds the passing score assigned here.
Step 4: Enable the timer (optional)

To apply a time limit to your quiz, do the following:

1. Since the timer does not apply to result slides, be sure that the Calculate results for drop-down list at the top of the window is set to Selected Questions.
2. At the bottom of the window, mark the check box next to End quiz after, and then choose the number of minutes you want to allow.

3. Use the Start timer selector to tell Storyline when you want the timer to begin. With first question means the timer starts when users arrive at the first quiz question associated with this result slide. With first slide means the timer starts as soon as users launch your course.

4. Use the Timer format selector to specify how you want the timer to appear to your users. Select from the following:
   - Elapsed out of total
   - Do not show time
   - Elapsed
   - Remaining
**Step 5: Choose options**

To specify additional options, such as reviewing, printing, and retry features, select the **Options** tab on the left side of the window, and mark the check boxes for any or all of the following:

- **Show user’s score**: If you mark this, Storyline includes a placeholder on your slide that will display both the percentage the learner achieved as well as the number of points they earned.
  - **Tip**: Storyline uses variables to keep track of the learner’s percentage and points earned. You can use these variables elsewhere in your course if you want, and you can also create variables of your own. Find out more about variables [here](#).

- **Show passing score**: If you mark this, Storyline includes a placeholder on your slide that will display both the passing percentage and the number of points required to pass.

- **Allow user to review quiz**: This causes a **Review Quiz** button to appear on your slide, which allows users to go back and review the answers they submitted for the questions. If you also want notations to appear during the review to indicate whether answers were right or wrong, mark the box next to **Show correct/incorrect responses when reviewing**.

- **Allow user to print results**: Mark this box if you want a **Print Results** button to appear on the slide. If you do this, you can also mark the box that follows, which causes Storyline to prompt the users for a name before printing. If you do that, Storyline will add the user’s name to the header of the printed report.

- **Allow user to retry quiz**: Mark this box if you want a **Retry Quiz** button to appear on the slide, giving users unlimited attempts to take the quiz.
  - **Tip**: If you want to limit the number of attempts, take a look at [this tutorial](#).
How do I edit my result slide later?

If you need to make changes to your result slide later, you can go to your result slide and edit the content and design directly on the slide. If you need to change other things about the result slide that aren't visible on the slide (such as which questions are being tracked, the passing score, timer, or other options), just click the Edit Result Slide button in the Question panel that appears to the right of the slide workspace. This opens the Result Slide Properties dialog where you can make whatever changes you need. Click the OK button when you're done.
Limiting Quiz Attempts

If you want to allow users to take a quiz more than once in your Storyline project, enable the Retry Quiz button on the result slide for the quiz. This'll give your users an unlimited number of attempts to take the quiz. But what if you want to limit the number attempts? You can do that, too, by using a variable to track the number of attempts. Here's one way you can accomplish this:

1. First, enable the Retry Quiz button on the result slide. Click here to learn how.
2. Then add a **number variable** to your course to track the number of attempts, and set the initial value to zero (0). For the sake of this tutorial, we'll refer to this variable as the *Attempts* variable.

![Variable dialog box](image)

3. On the result slide, add a trigger to the **Retry Quiz** button that adds a value of 1 to the *Attempts* variable when a user clicks it, and move the trigger up so it's the first trigger listed for the **Retry Quiz** button. To learn how to add and manage triggers, [click here](#).
4. Now, add a slide trigger to the result slide that'll change the state of the Retry Quiz button to Disabled when the timeline starts if the Attempts variable is equal to the maximum number of retries that you want to allow. If you need help understanding how to add conditions to a trigger, see this tutorial.

That's it! If you want to make the Disabled state of the Retry Quiz button more descriptive or noticeable, you can edit the state to change the color of the button or even change the text to “No more attempts” or something similar. To learn more about editing states, review this tutorial.
Submitting Answers All at Once

By default, question slides in Storyline will have a Submit button, meaning that each answer will be submitted one at a time for evaluation, and feedback will be displayed immediately after each slide (if you have feedback enabled). But what if you'd rather have all the answers submitted at the same time at the end of the quiz? No problem. You can do that, too. You'll need to change the navigation controls for your question slides to Prev and Next buttons rather than the default Submit button. Here's how:

If your quiz slides are in a question bank...

1. If your quiz slides are in a question bank, open the question bank for editing. The quickest and easiest method is to go to the Home tab when you are in Story View. Then click the Question Banks button, and select the name of the question bank that you want to edit.
2. When the question bank editor opens, select the first slide in the list, and then use the **Slide** panel in the lower right corner to **uncheck** the **Submit** box and to **check** the **Prev** and **Next** boxes.

3. Select the next slide in your question bank, and repeat step 2 until the navigation controls have been changed for all the slides in your question bank.
If your quiz slides are not in a question bank...

1. If your quiz slides are not in a question bank, switch to Story View.
2. Select all your quiz slides (except result slides). You can use SHIFT+Click to select consecutive slides or CTRL+Click to select non-consecutive slides.
3. Then use the Slide panel in the lower right corner to uncheck the Submit box and to check the Prev and Next boxes. This will change the navigation controls for all the selected slides at the same time.

What happens if users skip questions without answering?

When you use the Prev and Next navigation buttons rather than the default Submit button for question slides, it is easy for users to skip questions without answering them. If they reach the result slide without answering all the questions, be aware that this will impact the tabulated results.

Therefore, if you want users to answer all the questions, you may also want to review this tutorial, which describes how you can ask users to confirm that they have answered all the questions and are ready to submit their answers before they get to the result slide.

You might also want to explore:

- Using Question Banks
- Controlling a Slide's Advance Behavior and Other Slide Properties
- Adding Result Slides
- Limiting Quiz Attempts
- Confirming That Users Are Ready to Submit Their Answers
Confirming That Users Are Ready to Submit Their Answers

You may want to ask your users to confirm that they've answered all the questions in a quiz before they proceed to the result slide, especially if you've configured the quiz to submit answers all at once. Otherwise, if they leave any questions unanswered, the scoring will not be accurate on the result slide.

Here’s one way you can confirm that users have answered all the questions and are ready to submit their answers for evaluation:

1. **Add a new slide** between the last question in your quiz and the result slide. You can use one of the basic layouts for this slide.

2. **Add a button** called Review (or something similar), and **add a trigger** to the button that jumps to the first slide in the quiz.
3. Add another button called *Submit*, and add a trigger to the button that jumps to the result slide.

4. **Add a text box** to the slide, and provide instructions for users to:
   
   - Click the *Review* button if they skipped any questions or want to review their answers before submitting them.
   - Click the *Submit* button when they're ready to submit their answers for evaluation and proceed to the result slide.
Importing Content from Other Sources
Storyline makes it super easy to leverage existing content by importing from PowerPoint, Quizmaker, Engage, and even other Storyline projects. Click the tutorials at the right to learn how.
Importing from PowerPoint

You can import PowerPoint presentations into Storyline to leverage your existing content and take advantage of the rich feature set that Storyline offers. Here's how:

Note: Importing PowerPoint content into Storyline is not an exact one-to-one conversion. As a result, text may look a bit different. And although most features in PowerPoint and Articulate Presenter are supported in Storyline, some are not. Click here for details.

1. If you're getting ready to start a new project, you can click the Import PowerPoint option on the welcome screen, and then proceed to step 2 below.

Or, at any time, click the round Articulate button in the upper left corner, scroll to Import, and select PowerPoint. Then proceed to step 2 below.
Otherwise, start by opening the import dialog by doing any one of the following:

- Go to the Home tab, click New Slide, select the Import tab, and click the PowerPoint option.
- Go to the Insert tab, click New Slide, select the Import tab, and click the PowerPoint option.
- In Story View, right-click anywhere in the workspace, select New Slide, select the Import tab, and click the PowerPoint option.
- In Normal View, right-click anywhere in the left navigation pane, select New Slide, select the Import tab, and click the PowerPoint option.

2. Then browse to and select the PowerPoint file that contains the slides you want to import, and click the Open button.

   • **Note**: If you're importing a PowerPoint file that includes Articulate Presenter resources (such as audio), be sure that the PPTA file is located in the same folder as the PowerPoint file. Otherwise, Storyline will be able to import only the PowerPoint slides but not the corresponding Articulate Presenter resources. (Articulate Presenter does not need to be installed to import PowerPoint / Presenter content.)

3. If you opened the wrong PowerPoint file or want to select a different PowerPoint file, click the ellipsis (...) button in the upper right corner to browse for another file.
4. Storyline will display thumbnail images for all the slides in the presentation. Select the slides you want to import:

- By default, all slides will be selected and imported unless you specify otherwise. You can tell which slides are "selected" by their yellow outline.
- To select or deselect a specific slide, simply click it, and the yellow outline will either appear or disappear to indicate its status.
• You can also use the Select All and None hyperlinks in the upper right corner to quickly select all the slides or to deselect all the slides at once.

5. Use the Insert into scene drop-down list at the bottom of the window to specify where you want the PowerPoint slides to be inserted in your story. You can insert them into a new scene, which is the default option, or you can choose an existing scene. If you choose to insert a new scene, use the Scene field to assign a name to the new scene.

6. Click the Import button to complete the process.

• Note: If your presentation includes Quizmaker quizzes or Engage interactions and you encounter an error message that one or more of them could not be found, review this article to find out how to correct it.
Importing from Articulate Quizmaker

You can import existing Quizmaker quizzes into Storyline. Here’s how:

*Note: Articulate Quizmaker does not need to be installed to import quizzes into Storyline.*

**Importing Quizmaker quizzes**

1. If you are getting ready to start a new project, you can click the Import Quizmaker option on the welcome screen, and then proceed to step 2 below.

Or, at any time, you can click the round Articulate button in the upper left corner, scroll to Import, and select Quizmaker. Then proceed to step 2 below.
Otherwise, start by opening the import dialog by doing any one of the following:

- Go to the Home tab, click New Slide, select the Import tab, and click the Quizmaker option.
- Go to the Insert tab, click New Slide, select the Import tab, and click the Quizmaker option.
- In Story View, right-click anywhere in the workspace, select New Slide, select the Import tab, and click the Quizmaker option.
- In Normal View, right-click anywhere in the left navigation pane, select New Slide, select the Import tab, and click the Quizmaker option.

2. Then browse to and select the Quizmaker quiz that you want to import, and click the Open button.
3. If you opened the wrong Quizmaker quiz or want to select a different quiz, click the ellipsis (...) button in the upper right corner to browse for another file.
4. Storyline will display thumbnail images for all the slides in your quiz, divided into sections based upon the question groups to which they belong. Select the slides you want to import:

- By default, all slides will be selected and imported unless you specify otherwise. You can tell which slides are "selected" by their yellow outline.
- To select or deselect a specific slide, simply click it, and the yellow outline will either appear or disappear to indicate its status.

Slides that are "selected" for import have a yellow outline.

Simply click a slide to select or deselect it.
• You can also use the **Select All** and **None** hyperlinks in the upper right corner to quickly select all the slides or to deselect all the slides at once.

• To select or deselect an entire *question group* and all the slides that it contains, simply click the question group name. The question group name and all the slides in that question group will either be highlighted in yellow to indicate that they have been selected to be imported, or the yellow highlighting will disappear to indicate that they will not be imported.

  **Click the question group name to select or deselect the entire question group**

  ![Selected and Not selected](image)

• To make navigation a little easier, you can also collapse and expand question groups by clicking the triangle to the left of each question group name. (Note that collapsing and expanding question groups does not impact whether they will be imported or not.)
5. Use the **Insert into scene** drop-down list at the bottom of the window to specify where you want the Quizmaker quiz to be inserted in your story. You can insert it into a new scene, which is the default option, or you can choose an existing scene. If you choose to insert a new scene, use the **Scene** field to assign a name to the new scene.

![Insert into scene dropdown](image)

6. Click the **Import** button to complete the process.

**Note:** Question groups that are set to randomize in Quizmaker will be imported into Storyline as **question banks**. Question groups that are not set to randomize in Quizmaker will be imported into Storyline as normal slides in the selected scene.
**Editing questions**

After importing a quiz into Storyline, you can edit any question by navigating to the appropriate slide and then clicking the **Edit** button in the **Question** panel on the right side of the screen.

The editing interface will be familiar to Quizmaker users, since it is very similar. To learn more about the question editor, including scoring, number of attempts, feedback, branching, and adding media, check out this tutorial. When you've finished editing the question, click the **Save & Close** button to return to Normal View.
**Assigning result slides and adjusting slide properties**

When you import a Quizmaker quiz into Storyline, the result slide from the quiz will automatically be imported as well, and each of your imported questions will be associated with that result slide in Storyline.

- **Tip:** After importing a Quizmaker quiz into Storyline, you'll need to edit the imported *result slide* to ensure that it includes all the options you want. The pass and fail result slides from Quizmaker get consolidated into a single result slide in Storyline, so some settings will *not* be selected in Storyline regardless of what is selected in Quizmaker, such as the options to display the user's score and the passing score.

Note that Storyline also supports multiple result slides in the same story, so you can change the result slide that is associated with each question at any time.

You can assign *individual* questions to a particular result slide when you're in **Normal View** by using the **Results Slide** drop-down list in the **Question** panel on the right side of the screen. You can assign each question to any of your existing result slides, or select **None** if you do not want this question to be included in any result slides.

For more information on creating and editing result slides, see [this tutorial](#).
You can also assign *multiple* question slides to the same result slide all at once by switching to Story View, selecting the question slides you want to modify, and then using the Slide panel in the lower right corner of the window to adjust the properties for all the selected slides at the same time.

To learn more about adjusting slide properties, including result slides, take a look at this tutorial.

**Modifying feedback layers**

Storyline uses slide layers to provide feedback for each question. There are various types of feedback that you can provide your users, such as Correct, Incorrect, Try Again, Review, and Thank You.

Storyline will automatically generate some feedback layers for you, but you can add, edit, and delete them whenever you want. Just navigate to the question you want to modify, and then use the Slide Layers panel on the lower right side of the screen to manage your feedback layers.
• To modify an existing feedback layer, simply click the layer you want to edit, and then use the toolbar features to edit it as desired.

  • **Tip**: If you would prefer to edit the feedback master instead of each feedback layer individually, go to the View menu, and select **Feedback Master**. To learn more about managing feedback masters and how to assign them to your question feedback layers, review [this tutorial](#).

• To add a new feedback layer to a question slide, click the **New Layer** button (the icon that looks like a blank piece of paper) at the bottom of the **Slide Layers** panel.

Go to the **Home** tab, click the **Layout** button, and assign the feedback layout that you want to use.
To delete a feedback layer, click the layer you want to delete in the Slide Layers panel, and click the Delete button at the bottom of the panel.

You might also want to explore:

- Adding Graded Questions and Survey Questions
- Adding Result Slides
- Controlling a Slide’s Advance Behavior and Other Slide Properties
- Adding and Editing Slide Layers
- Using Feedback Masters
- Using Question Banks
Importing from Articulate Engage

Storyline’s powerful features allow you to create highly interactive content. However, you can also take advantage of your existing Articulate Engage interactions by importing them into Storyline. Here’s how:

**Importing Engage interactions**

1. At any time, you can click the round Articulate button in the upper left corner, scroll to Import, and select Engage. Then proceed to step 2 below.

   ![Articulate Engage Import Dialogue](image)

Otherwise, start by opening the import dialog by doing any one of the following:

- Go to the Home tab, click New Slide, select the Import tab, and click the Engage option.
- Go to the Insert tab, click New Slide, select the Import tab, and click the Engage option.
- In Story View, right-click anywhere in the workspace, select New Slide, select the Import tab, and click the Engage option.
- In Normal View, right-click anywhere in the left navigation pane, select New Slide, select the Import tab, and click the Engage option.
2. Browse to and select the Engage interaction that you want to import, and click the Open button.

3. If you opened the wrong Engage interaction or want to select a different interaction, click the ellipsis (...) button in the upper right corner to browse for another file.

4. Use the Insert into scene drop-down list at the bottom of the window to specify where you want the Engage interaction to be inserted in your story. You can insert it into a new scene, which is the default option, or you can choose an existing scene. If you choose to insert a new scene, use the Scene field to assign a name to the new scene.

5. Click the Import button to complete the process.

**Things to consider when importing Engage interactions into Storyline:**

- To import Engage interactions into Storyline, you must have Articulate Engage '09 installed on your computer and activated with a valid serial number.
- When you import an Engage interaction into Storyline, a copy of your original interaction (.intr) file actually gets stored in the Storyline project file. This means that you can transfer your story file to another computer or another developer and still edit the Engage interaction (as long as the other computer also has the Articulate Engage program installed and activated with a valid serial number).
- Storyline imports Engage interactions as web objects, meaning they'll play as standalone interactions that are embedded into your story. As a result, if the resume feature is enabled in an interaction, users will encounter a resume prompt when they revisit the interaction slide in your course. If you want to disable this resume prompt, you’ll need to uncheck the resume option in Engage. Check out [this article](#) for more information.
- Engage interactions are not supported in HTML5 output or the Articulate Mobile Player app for iPad.
**Editing Engage interactions**

To edit an Engage interaction that has already been imported into Storyline, open your story, and navigate to the slide that contains your interaction. Click once on the interaction placeholder to reveal the Options tab on the toolbar. Click the Options tab, and use the following features to edit your interaction and to adjust its properties:

- **Preview**: Click the Preview button to view the selected interaction on the slide. Click the Preview button again to stop the preview.

- **Open**: This button will launch the interaction in your default browser.

- **Edit in Engage**: Click the Edit in Engage button if you have Articulate Engage installed on your computer and you want to open the source interaction in Engage for editing.
  - Because a copy of the original interaction (.intr) file gets stored in your story file, you won't need to keep the external Engage file with your Storyline project. It also means that if you make changes to the external Engage interaction file (outside of Storyline), the changes will *not* be reflected in your story.
  - When you have finished editing your interaction in Engage, click the Save and Return to Storyline button.
- **Load**: How do you want your interaction to launch? Choose one of the following three options from the Load drop-down list. (This option will not be available if you choose to display your interaction in a new browser window – see the Show option below. An interaction that is set to open in a new window will not load until users click on the placeholder image.)
  - **Automatically**: The interaction will load as soon as the slide’s timeline reaches the start of the interaction object. For more information on working with the timeline, check out [this tutorial](#).
  - **When clicked**: Select this option if you do not want the interaction to load until users click it.
  - **From trigger**: If you would prefer to trigger the interaction to load only after a specific event has occurred, select this option. To learn more about triggers, take a look at [this tutorial](#).

- **Show**: Determine whether you want to display your interaction **in slide** or **in new browser window**.

- **Controls**: If you choose to show your interaction in a new browser window (see above), the Controls drop-down list will become active, allowing you to specify your preferred browser control settings for the new window. (This option will not be available if your interaction is configured to display in the current slide.)
• **Size**: If you choose to show your interaction in a new browser window (see above), the *Size* drop-down list will become active, allowing you to specify a size for the new window. (This option will not be available if your interaction is configured to display in the current slide.)

![Size drop-down list](image)

• **Show 'Next Slide' Button**: Use this drop-down list to determine when the *Next Slide* button will appear in your interaction, which allows users to advance to the next slide in your course: *Never*, *Always*, or *When complete*.

![Next Slide Button drop-down list](image)

• **Button Label**: If you choose to display the *Next Slide* button (see above), use the *Button Label* field to specify the text you want to appear on the button in your published story. This is where you would, for example, translate "Next Slide" into another language if you were developing a course for an audience that doesn't read English.

![Button Label field](image)

• Arrange your interaction with other objects on the slide by using the *Send Backward*, *Bring Forward*, and *Align* drop-down lists.
• Resize your interaction placeholder on the slide using the **Height** and **Width** fields to designate your desired values in pixels.

**Right-click options for working with Engage interactions**

There are several options that you can quickly access when working with Engage interactions simply by right-clicking the interaction placeholder on the slide:

- **Web Object > Edit**: This option will display the *Edit Web Object* dialog, which allows you to adjust some of the properties described above, such as whether the interaction will display in the slide or in a new browser window and whether it will load automatically or when users click it. **Note**: Do not change the file path displayed in the **Address** field, or the link to your interaction may become broken.

- **Web Object > Open**: This option will launch the interaction in your default browser.

- **Preview**: Select this option if you want to preview your interaction on the slide. (Note that you can also double-click on the interaction placeholder to preview it.) Click anywhere outside of the interaction placeholder to end the preview.

- **Reset Picture**: Your interaction placeholder will automatically use the first frame of the interaction as its placeholder image. However, if you want to remove the placeholder image, select **Reset Picture**.
  - After resetting (removing) the placeholder image, if you want to use a different image for the placeholder, right-click the interaction again and select **Change Picture**. Then browse to and select the image you want to use.
  - This is especially useful if you have configured your interaction to load only when clicked or if it is set to open in a separate browser window, because the image that you select will be visible to users until they click it to load the interaction.
• **Rename**: This option allows you to change the default name (*Engage Interaction 1, Engage Interaction 2*, etc) assigned to interaction placeholders in Storyline. Another way to rename objects is to use the timeline. **Note**: Changing the name of the interaction placeholder does not affect the title of the Engage interaction that your users will see in the published course.

• **Size and Position**: This is another way to specify an exact size and position for your web object. To learn more about the Size and Position dialog, take a look at this tutorial.

**Deleting Engage interactions**

To delete an Engage interaction from your story, simply click on the interaction placeholder to select it, and then press the **Delete** key on your keyboard.
Importing from Another Storyline Project

To import scenes or slides from another Storyline project:

1. Click the round Articulate button in the upper left corner, scroll to Import, and select Storyline. Then proceed to step 2 below.

Or, open the import dialog by doing any one of the following:

- Go to the Home tab, click New Slide, select the Import tab, and click the Storyline option.
- Go to the Insert tab, click New Slide, select the Import tab, and click the Storyline option.
- In Story View, right-click anywhere in the workspace, select New Slide, select the Import tab, and click the Storyline option.
- In Normal View, right-click anywhere in the left navigation pane, select New Slide, select the Import tab, and click the Storyline option.
2. Then browse to and select the Storyline file that contains the slides you want to import, and click the **Open** button.

3. If you opened the wrong Storyline file or want to select a different Storyline file, click the **ellipsis (…) button** in the upper right corner to browse for another file.

4. Storyline will display thumbnail images for all the slides in the story, divided into sections based upon the scenes to which they belong. Select the slides you want to import:

   - **Effective Meetings 101**
     - Please sign in
     - Intro
     - Don't like meetings?...
     - Our company's mee...
     - Start with the end i...
     - Involve the whole g...
     - Stay on track.
     - Create a plan for fol...

   - **Let's Review**
     - Which items do you...
     - Which facilitator will...
     - Wrap-Up

   - By default, all slides will be selected and imported unless you specify otherwise. You can tell which slides are "selected" by their yellow outline.
• To select or deselect a specific slide, simply click it, and the yellow outline will either appear or disappear to indicate its status.

Slides that are "selected" for import have a yellow outline

Simply click a slide to select or deselect it

• You can also use the Select All and None hyperlinks in the upper right corner to quickly select all the slides or to deselect all the slides at once.
• To select or deselect an entire scene and all the slides that it contains, simply click the scene name. The scene name and all the slides in that scene will either be highlighted in yellow to indicate that they have been selected to be imported, or the yellow highlighting will disappear to indicate that they will not be imported.

Click the scene name to select or deselect the entire scene

• To make navigation a little easier, you can also collapse and expand scenes by clicking the triangle to the left of each scene name. (Note that collapsing and expanding scenes does not impact whether they will be imported or not.)

5. Use the Insert into scene drop-down list at the bottom of the window to specify where you want the new slides to be inserted in your story:

• The default option, Same as imported project, will create a new scene for each corresponding scene that you import and will name each scene with the same name that it had in the original story.
• If you select New Scene, use the Scene field to assign a name to the new scene.
• You can also import all the selected scenes and slides into the currently selected scene in your story by choosing **Current Scene**.

6. Click the **Import** button to complete the process.
Customizing the Storyline Player

In Storyline, we use the term "player" to mean the interface that appears around the perimeter of your slides. It can include all sorts of things, such as a clickable menu, a seekbar, slide notes, a glossary, a button for supplemental course resources, player controls such as a forward button and back button, and more. You can even customize the player with specific colors. Or, for a completely chromeless look, you can make the player invisible—which is a nice option if you plan to build all the course navigation buttons on your own, using objects and triggers on your slides.

It's easy to use Storyline's Player Properties to make the player look exactly the way you want. Here are just a few examples of how different players can change the way a course looks:
This one includes player controls, a menu, several tabs on the sidebar, and additional content placed on the top bar.

This one’s much simpler. It includes just a thin black line around the slide perimeter. The items at the bottom are actually not part of the player – they’re buttons built on the slide itself.

This one features some simple player controls and a custom font that matches the slide content.
You can access the settings related to the player by clicking the **Home** tab on the Storyline ribbon and then selecting **Player**.

The Player Properties window appears, where you can customize just about any facet of the player and its features, or switch to a different player if you choose. The following tutorials will show you how:

- **Choosing Player Features**
- **Customizing the Player Menu**
- **Attaching Resources to the Player**
- **Adding a Glossary to the Player**
- **Changing the Player Colors and Font**
- **Changing the Player’s Text Labels**
- **Changing the Browser Settings and Player Size**
- **Changing the Player’s Resume Behavior**
- **Enabling Right-to-Left Language Support**
- **Saving Your Player or Switching to a Different One**
Choosing Player Features

The **Features** available in Storyline’s Player Properties window allow you to choose exactly which features and controls you include on your course player. To customize your player features, click the **Home** tab on the Storyline ribbon, and then click **Player**.
When the Player Properties window appears, the **Features** button will already be selected, and you can begin setting your preferences. As you make changes to the options on the left side of the window, keep an eye on the **Preview** area in the right side of the window. It'll change to reflect your choices.
Choosing the player tabs

Player tabs allow you to offer additional content to supplement your course. The player tabs appear along the top edge of the player in your published output—you can place them in a sidebar, or on the left or right top bar above your slide.

In the Player Tabs area of the Player Properties window, mark the checkbox next to the tab(s) you want to include. Storyline provides the four ready-made tabs listed below, but you can create additional tabs if you like. (More on that in a minute.)

- **Menu**: Mark this box if you want to display a menu on your player. The menu can include your scene titles, slide titles, and any other text you want to add. ([Learn more about customizing the menu.](#))
- **Resources**: Mark this box if you want to provide learners with resources related to your course. You can include file attachments, links to websites, or a combination of both. ([Learn how to add resources to the player.](#))
- **Glossary**: Mark this box if you want to include a glossary on your course's player. ([Learn how to add terms to the glossary.](#))
- **Notes**: Mark this box if you want learners to be able to view slide notes on your player. ([Learn how to add notes.](#))

In this section, mark any items you want to include as tabs on your player.
**Rearranging player tabs**

You can place your player tabs in three different areas of the player:

- Sidebar
- Topbar Left
- Topbar Right

You can have multiple tabs in each location. To move a tab from one location to another:

1. Select the tab name in the **Player Tabs** area of the Player Properties window.
2. Click either of the arrow buttons below the list of tabs until the tab is in the location where you want it to be.
For example, if my options looked like what you see below, and I wanted to move my Menu tab from the Sidebar to the Topbar Right area, I'd select the Menu and click the up arrow once.

If you choose not to display any tabs in the Sidebar of the player, the sidebar won't appear in your course at all. Storyline will adjust the width of your published output accordingly—you can see what it'll look like by checking out the Preview area on the right side of the Player Properties window.

**Note:** Only the four built-in tabs (Menu, Resources, Glossary, and Notes) can be moved to the sidebar. If you've added tabs of your own, these can only be placed in the Topbar Left or Topbar Right.

**Displaying different tabs for different slides**

If you enable any of the four built-in Storyline tabs (Menu, Resources, Glossary, or Notes), by default these will appear for all slides in your course. But if you want to show the tabs only when learners are viewing certain slides that's okay—you can do that. To learn how, check out this tutorial on slide properties.
Adding more tabs to your player

Besides the four ready-made tabs that come with Storyline, you can also add tabs of your own. These tabs can contain any additional slide content that you want, or you can assign any other trigger action to them. Here's how to add a tab:

1. Click the **Add** button (the icon that looks like a blank piece of paper) below the list of player tabs.

![Image of Add button and Trigger Wizard window]

2. The Trigger Wizard window appears. Type a name for the tab in the **Name** field.
3. Use the **Align** field to choose where to place the tab. You can choose **Topbar Left** or **Topbar Right**.
4. Use the **Action** field, along with the fields that follow it, to tell Storyline how to respond when learners click the tab. This is called a **Trigger**. (For example, if you want a certain slide to appear in a lightbox when the learner clicks the tab, you would choose **Lightbox slide** as the trigger action, and then choose the slide you want to lightbox.) You can also include **Conditions** that determine the circumstances under which the trigger occurs. To learn more about triggers and conditions, check out [this tutorial](#).
5. When you're finished entering the Trigger information for your new tab, click **OK**.
Editing tabs

If you’ve added any tabs of your own, you can edit their names or behavior. Just select a tab name in the Player Tabs pane of the Player Properties manager and click the pencil icon. This pops up the Trigger Wizard window, where you can change the tab’s name, location, and trigger action.

Note: The behavior of the built-in player tabs (Menu, Resources, Glossary, and Notes) can’t be edited. You can, however, change these tabs’ names by editing the player’s Text Labels.
**Removing tabs**

You can exclude a tab from appearing on your player by unmarking the checkbox to the right of the tab name. If you do this, the tab will no longer be visible in your course when you publish, but it *does* stay within your Player Properties options in case you ever want to turn it back on again.

If you want to *permanently delete* a tab from your player, you can select the tab and click the red X below the list of tabs. Only tabs that you've added to your player can be deleted. You won't be able to delete any of Storyline's four preset tabs (Menu, Resources, Glossary, or Notes).

![Player Properties - EffectiveMeetingsPlayer](image)

Unmark a checkbox to exclude a tab from appearing on the player....

...or select the tab name & click the red X to remove the tab permanently.
Choosing sidebar behavior and the course title

In the Features area of the window, you can turn the course title on or off, and you can choose where to put the sidebar, if you're using one.

- **Title**: Mark this checkbox if you want the course title to appear in the top left area of the player. The title defaults to the name of your Storyline file, but you can use a different title by editing the text in this field (if you do that, it won’t change the name of your actual Storyline file; it'll only change the title that displays on the player.) You can also remove the title altogether if you prefer, by unmarking the box.

- **Sidebar**: If you've chosen to include any player tabs in your sidebar, or if you've added a logo to the sidebar (which we'll cover below), you can use this selector to choose where the sidebar appears. The default location is **On Left**, but you can change it to **On Right** if you prefer.

Choosing a logo and player controls

The Controls area of the window is where you choose player controls and add a logo to the player, if you like. Here are your options:

- **Volume**: If this box is marked, a volume control will appear on your player, to the lower-left of your slide.

- **Search**: Mark this box to include a search field on the Menu tab of your player. Learners can use this to search for content within your slides or slide notes. Keep in mind that because the Search field is part of the Menu tab, it'll only appear in your published course if you've marked **Menu** in the Player Tabs area of the Player Properties window.

- **Seekbar**: Mark this box to include a seekbar on your player. The seekbar will automatically include a play/pause button and a replay button.

- **Logo**: Mark this box to add a logo to the topmost area of the player's sidebar. Use the Click to add a logo link and then select the image you want to use. For best results, use an image that is a maximum of 200 pixels wide and 220
pixels high. If your image doesn't fit within those dimensions, Storyline will scale it to fit.

**Note:** When you add a logo to your sidebar, Storyline includes a border and slight shadow on it. If you want to change or remove either of these, no problem—you can customize their colors (or make them transparent) by modifying your player's color scheme.

**What about navigation controls, like a Prev and Next button?**

You might have noticed that the **Controls** listed on the Player Properties window don't include slide navigation controls, such as Prev (previous) and Next buttons, or a Submit button for quiz slides. That's because you can customize these for individual slides or scenes by using the Slide Properties pane. **This tutorial** covers how to customize the Slide Properties.

**Saving your changes to the player**

If you click OK on the Player Properties window and then save your project by clicking the **Save** button above the Storyline ribbon, Storyline saves your player customizations within your project. It's a good practice, though, to save your player separately, because this allows you to apply the same player customizations to other projects if you like.

To save your player, click the **Current Player** button on the Player Properties window and choose **Save**. Enter a name for the player if you're prompted, and click **OK**.

For more details about using the **Current Player** options, see the tutorial called **Saving Your Player or Switching to a Different One**.
Customizing the Player Menu

The **Menu** options on the Player Properties window allow you to control how the player menu appears in your published course. Keep in mind, though, that in order for the menu to show up in your course, you need to select it in the **Player Tabs** area on the **Features** section of the Player Properties window. Learn more about that [here](#).

To customize your player menu, first click the **Home** tab on the Storyline ribbon, and then click **Player**.
When the Player Properties window appears, click the **Menu** button. As you make changes to the options on the left side of the window, keep an eye on the **Preview** area in the right side of the window. It'll change to reflect your choices.

As you make changes to the options on the left side of the window...

...the preview here changes.
Changing a scene title or slide title

The titles you see on the menu default to the scene titles and slide titles that you assigned to your slides in Story View (or in the slide thumbnail list in Normal View). You can adjust the text here in the Player Properties manager if you like. Any changes you make will not affect the titles you see in Story View or Normal View when you're working on your course, nor will the changes affect any actual text you've entered on the slides themselves.

To change a scene title or slide title on the menu, double-click a title and enter a new name. Then press Enter on your keyboard.
**Rearranging items on your menu**

If you'd like the menu items to appear in a different order, you can select any item and drag it to a new place in the list. Or, select an item and then click the up arrow or down arrow below the **Menu** pane to move that item.

**Note:** Rearranging your menu items does *not* change the slide's trigger behavior or the viewing order of the slides themselves; it only changes the sequence in which items are listed in the menu.

![Image of menu pane with arrows for moving items up or down](image)

**Changing the indent level of items on your menu and applying auto-collapse**

Another way to control the look of your menu is with indent levels. Indents create a more hierarchical, tiered look to your slide titles. Indent levels can also make it easier for users to see at a glance the contents of each section in your presentation. You can even control when and how the levels expand and collapse in the menu as users move through your course. Here’s how to change the indent level:

1. Select a title in the **Menu** pane.
2. Click the right arrow to increase the indent or the left arrow to decrease the indent.

You may only increase a title's indent one level deeper than the title above it.
When you publish your course, a small triangle appears next to any title that has sub-levels beneath it. Learners can click on the triangle to collapse or expand any level. Want the levels to automatically collapse when the learner’s finished with a section? Do this:

1. Click the gear icon (the **Additional Options** button) at the lower-right of the **Menu** pane.
2. In the window that appears, mark the box next to **Auto-collapse menu as learner progresses**.
3. Click **OK**.
Tip: To display any level as initially collapsed in your published output, click the small triangle next to the title here in the menu editor. When a published course is first launched, the collapsed and expanded levels will appear exactly the way they do in the menu editor.

Collapse levels in the editor if you want them to be initially collapsed in the published output.
Removing items from the menu

Want to remove a title from the menu? No problem—just select the scene or slide, and then click the Delete Heading button below the menu. Any scenes or slides you hide from the menu will still be part of your course; it's just that their titles won't appear in the menu any more.

If you delete a title that has items below it which are at a greater indent level, Storyline will also give you the option of keeping or removing that title's children.

Inserting titles from the project

At any time, you can click the Insert From Project button (the open folder icon) to insert headings from the scenes or slides in your course. This is an easy way to restore titles that you previously removed from the menu.
**Resetting your menu to reflect the slide titles in your course**

If you make some changes to your menu and then decide that you want to reset the menu back to what it was originally (reflecting the original slide titles of your course), you can click the **Reset From Story** button:

![Reset From Story button](image)

**Adding new items to the menu**

There might be times when you want to insert additional titles in your menu to help visually organize the menu. For example, you might want to add section titles. You can do this by clicking the **New Heading** button (the icon that looks like a blank piece of paper) and then typing the title you want to use. From there, you can use the up or down arrow keys below the **Menu** pane to move the heading wherever you want it to appear in the list.

![Adding new heading](image)
Including slide titles from question banks

If your course includes a draw from a question bank, it'll appear in the menu as a single title, called "Draw from [question bank name]." You can edit, move, or delete the title (just as you can for any other slide). If you prefer to show each slide title from the question bank draw, rather than just a single title, here's how to do it:

1. Click the gear icon next to the title that represents your question draw.
2. Mark the Show Slide Draw Contents box.

When you publish your course, each slide title from the question bank draw will appear as a separate item in the menu.

Note that you can display all the slides individually from a question draw in the menu as described above, but you won't be able to show some of the individual slide titles from a question draw while hiding others.
Wrapping long titles or adding a tooltip

If some of your slide titles are too long to display in the width of the menu, you can wrap the text, or you can cause a tooltip to show the full title when learners hover over it. Here's how:

1. Click the gear icon (the Additional Options button) at the lower-right of the Menu pane.
2. When the Additional Options window appears, mark the box next to Wrap long menu item titles if you want the text to wrap.
3. Mark the box next to Show tooltip on hover to cause a tooltip to appear when learners hover over long titles.
4. Click OK when you're done.
Adding or removing automatic numbering

By default, Storyline automatically numbers the scene and slide titles in your menu, according to the numbering that appears in Story View and Normal View. If you want to keep the numbers from appearing in your menu, you can do this:

1. Click the gear icon (the Additional Options button) at the lower-right of the Menu pane.
2. When the Additional Options window appears, mark the box next to Number entries in the menu automatically.
3. Click OK.
Changing the navigation method

When you first begin a Storyline project, the navigation method defaults to Free—meaning that users can view your slides in any order. In some cases, if you're building a linear course and want learners to move through your content one slide at a time, you might want to switch to Locked or Restricted navigation. This prevents learners from using the menu to jump to other slides. Here's how to switch, and how to decide which navigation method to choose:

1. Click the gear icon (the Additional Options button) at the lower-right of the Menu pane.

2. When the Additional Options window appears, use the Navigation Restriction selector to choose one of the following:

   - **Free**: This allows learners to click on the titles in the course's menu to navigate to any part of the course at any time. They can view whatever slides they wish, in any order.
   - **Restricted**: This means learners can view the current slide and any slide they've previously viewed, but they can't use the menu to jump ahead or skip over slides.
   - **Locked**: This means learners can only view the slides in the order you've designed. They can't use the menu to jump ahead or skip over slides, nor can they use it to skip back to any previously viewed slides.

3. Click OK when you're done.
Keep in mind that if you use Locked or Restricted navigation, this only affects your learners' ability to click on menu items to navigate. If your slides include a Previous or Next button, users will still be able to click those to move forward and backward in your course at will. To prevent that, there are a few things you can do:

- One approach is to remove the Previous and/or Next buttons from specific slides by changing the Slide Properties. Then, either make the slide advance automatically (which you can also do in the Slide Properties), or create your own Previous and/or Next buttons and use the Timeline to delay the buttons' appearance until the slide is finished playing.
- Another approach is to add a condition to the Next button's trigger, so that the button works only if a specific condition is met (such as the slide timeline ending). For more on how to add conditions to your triggers, see this tutorial.

**Saving your changes to the player**

If you click OK on the Player Properties window and then save your project by clicking the Save button above the Storyline ribbon, Storyline saves your player customizations within your project. It's a good practice, though, to save your player separately, because this allows you to apply the same player customizations to other projects if you like.

To save your player, click the Current Player button on the Player Properties window and choose Save. Enter a name for the player if you're prompted, and click OK.

![Current Player button](image)

**Displaying the menu only for certain slides**

If you enable any of the four built-in Storyline tabs (Menu, Resources, Glossary, or Notes), by default these will appear for all slides in your course. But if you want to show some of these tabs only when learners are viewing certain slides that's okay—you can do that. To learn how, check out the Slide Properties tutorial.

**Changing the name of the Menu**

Want to use something other than the word "menu" for your menu tab? No problem—you can change that. The tab name comes from your player's Text Labels. If you need help editing the text labels, see this tutorial.
Attaching Resources to the Player

The **Resources** feature in Storyline allows you to bake additional content into your course via a tab on your player. The cool thing about that is users can get to these resources anytime they need to. This is great if you want to give learners the chance to view reference information, job aids, related websites, or any other helpful info. Another common way to use this feature is to provide learners with a printable copy of their slides and/or a transcript of the slide notes.

The resources you include can be file attachments, links to websites, or a combination of both. Keep in mind, though, that in order for the **Resources** tab to show up in your course, you need to select it in the **Player Tabs** area on the **Features** editor. Learn more about that **here**.

To add resources to your player, first click the **Home** tab on the Storyline ribbon, and then click **Player**.
When the Player Properties window appears, click the Resources button:

**Entering a description for the Resources tab**

In the Description field, type the text you want users to see at the top of your list of resources:

Text you enter here will appear at the top of your resource list when you publish.
**Adding resources**

Here’s how to add resources to your player:

1. Click the **Add** button (the icon that looks like a blank piece of paper) at the bottom of the **Resources** window. Or, if this is the first resource you’ve added to this player, you can just click anywhere in the **Resources** window.

2. When the **Add Resource** window appears, enter a **Title** for the resource you’re adding. This is the text that users will see when they browse your list of resources.

3. Next, select either **URL** or **File**, depending on the kind of resource you’re adding. Then do the following:

   - If you chose **URL**, enter the web address in the field provided. You can also click the **Test** button to make sure the URL opens as you expect. Later, when you publish your course, learners will be able to click on the resource name to access the URL you chose. Learners will need to be connected to the internet in order for this to work.
   - If you chose **File**, click **Browse** and select the file you want to attach. Then click **Save**. Later, when you publish, Storyline will bundle a copy of the file itself right along with your course content. The file will be included in the **story_content** folder of your published output. Learners will need to have the appropriate software in order to view the file. For example, if the resource is a Word document, learners will need to have Microsoft Word installed on the computer from which they’re viewing the course.

4. When you’re finished adding the resource, click **Save**.

Storyline adds the item to your resource list, along with an icon next to the title to indicate the type of resource. You can keep adding more resources in the same way.
**Editing, rearranging, or deleting resources**

The buttons at the bottom of the **Resources** window allow you to add new resources and to edit, rearrange, or delete the ones you've already added:
Re-using the same resources in other projects

When you add resources to a course, these items are saved within your project, not within your player. (This means that if you save your player and apply the player to other projects, the resources won't be applied with it.)

If you want to re-use the same set of resources in another project, an easy way to do that is to save your project as a Storyline template. Then, when you're ready to begin a new project, use that template as your starting point by choosing From project template on the Storyline launch screen. When you repurpose content this way, the player customizations on the template (including any Resources you've added) become part of the new project. If you later add, delete, or change any of the resources, those changes won't automatically carry over to other projects in which you've used the same resources. You'll need to make the same changes in each project.

Displaying the Resources only for certain slides

If you enable any of the four built-in Storyline tabs (Menu, Resources, Glossary, or Notes), by default these will appear for all slides in your course. But if you want to show the tabs only when learners are viewing certain slides, that's okay—you can do that. To learn how, check out the tutorial on Slide Properties.

Changing the name of the Resources tab

Don't like the word "resources"? That's okay—you can change it! The tab name comes from your player's Text Labels. If you need help editing the text labels, check out this tutorial.
The **Glossary** feature in Storyline allows you to easily add a set of terms and definitions to your course. Learners can access the glossary by clicking a tab on your player. Keep in mind, though, that in order for the **Glossary** tab to show up in your course, you need to select it in the **Player Tabs** area on the **Features** editor. Learn more about that [here](#).

To add a glossary to your player, first click the **Home** tab on the Storyline ribbon, and then click **Player**.

When the Player Properties window appears, click the **Glossary** button:
Adding terms & definitions to your glossary

Here's how to add entries to your player's glossary:

1. Click the Add button (the icon that looks like a blank piece of paper) at the bottom of the Glossary window. Or, if this is the first glossary term you've added to this player, you can just click anywhere in the Glossary window.

![Image of Add button](image)

2. When the Glossary Term window appears, enter a Term and a Definition in the fields provided.

![Image of Glossary Term window](image)

3. Click Save when you're done.

Storyline adds the item to your glossary, and you can keep adding more terms and definitions in the same way. As you add terms, Storyline alphabetizes them automatically.
**Editing or deleting glossary terms**

The buttons at the bottom of the **Glossary** window allow you to add new glossary terms and to edit or delete the ones you've already added:
Re-using a glossary in other projects

When you add a glossary to a course, these items are saved within your project, not within your player. (This means that if you save your player and apply the player to other projects, the glossary won’t be applied with it.)

If you want to re-use the same glossary in another project, an easy way to do that is to save your project as a Storyline template. Then, when you’re ready to begin a new project, use that template as your starting point by choosing From project template on the Storyline launch screen. When you repurpose content this way, the player customizations on the template (including any Glossary you’ve added) become part of the new project. If you later add, delete, or change any of the glossary terms, those changes won’t automatically carry over to other projects in which you’ve used the same template. You’ll need to make the same changes in each project.

Displaying the Glossary only for certain slides

If you enable any of the four built-in Storyline tabs (Menu, Resources, Glossary, or Notes), by default these will appear for all slides in your course. But if you want to show the tabs only when learners are viewing certain slides, that’s okay—you can do that. To learn how, check out this tutorial.

Changing the name of the Glossary tab

Not crazy about the word “glossary” for your tab? Don’t worry—you can change that. The tab name comes from your player’s Text Labels. If you need help editing the text labels, check out this tutorial.
Changing the Player Colors and Font

One of the ways you can customize the look of your course is by changing the colors or fonts on your player. This comes in handy when you want your player to complement the design elements in your course content, or when you need to match an organization's corporate colors or font standards.

To change your player's colors or fonts, you'll first need to open the Player Properties window. Click the Home tab on the Storyline ribbon, and then click Player:

When the Player Properties window appears, click Colors & Effects:
Now you can use any of the following options to adjust the player colors or font. Click OK on the Player Properties window when you're done.

**Switching to a different player color scheme**

The **Color Scheme** selector shows the name of the color scheme you're currently using. The preview area on the right half of the window shows what your player would look like if it were published with that color scheme. You can see how different color schemes would look by choosing a different option from the **Color Scheme** selector, or other options from the left half of the window. If you find a color scheme you like, after you select it you can click OK in the lower-right corner of the window to save that color scheme to your player. Next time you publish this project, that's the color scheme Storyline will use.

*When you change the color scheme here, or change other options on this window, the preview here reflects your choice.*

**Customizing a color scheme**

If you want to get very specific about the colors used for any particular element of the player, or you want to apply custom colors that aren't available on any of the ready-made color schemes, it's easy to customize your own color scheme. Here's how to do it:
1. Click **Advanced Color Editing**. Some additional options will appear on the window.

![Advanced Color Editing](image)

2. Use the **Edit item** selector to choose which part of the player you want to change. Need some help identifying which item is used for which part of the player? **Here's a quick-reference diagram.**

3. Now use the **Color** selector(s) to choose a new color. If you see both a **Top color** and a **Bottom color** selector, this means the color for the item you chose is a gradient comprised of two colors, and you can make a selection for each.

   **Note:** The color selector shows several options from your project's **Theme Colors** as well as several Standard Color choices. If you don't see a color you want to use, you can choose **More Colors** to open a window where you can choose a specific color value.

![Color Selection](image)
If you choose **More Colors**, a window opens where you can do one of the following to pick your color:

- Click on the color you want (either a square color swatch or a color in the spectrum area).
- Or, create a custom color by entering color values in the **Hue/Sat/Lum** fields, the **Red/Green/Blue** fields, or the **Html** field.
- Or, use Storyline's color picker to choose a custom color from anything viewable on your screen. To do that, click the eyedropper button in the lower-right of the window, hover over any area of your screen, and click to choose a color.

![Colors Window](image1)

If the color you've chosen is something you want to save for easy selection later, click **Add to Custom Colors**. The color will get added to the bank of Custom Colors in the lower-left area of the window.

Click **OK** on the Colors window when you're done.

4. If you want to apply a transparency to the item you're modifying, you can enter the value in the **Transparency** field.
**Resetting a modified color scheme**

Anytime you make changes to a color scheme, the name in the Color Scheme field changes to include the word "(modified)" after the scheme name. If you've made some changes and want to revert back to the colors you previously used, click the Reset button:

![Image of the Player Properties window showing the Color Scheme field with a modified color scheme highlighted and the Reset button circled.]

**Saving your customized color schemes**

If you close the Player Properties window after modifying a color scheme, the modified scheme will become part of your project, but it won't be available to other projects unless you save it. To save your color scheme, just click the Save button and give it a name. Then click OK.

![Image of the Player Properties window showing the Save button and a new color scheme dialog box. The new color scheme dialog box is opened, showing the name field with the name "EffectiveMeetingsColorScheme" entered.]
Once you save a new color scheme, Storyline adds it to the selections in the **Color Scheme** selector for any other course you build. The color scheme file gets stored in the following directory, depending on your version of Windows:

- **Windows Vista / 7:**
  C:\Users\%username%\AppData\Roaming\Articulate\Shared\2.0\Frames\StoryFrame\ColorSchemes

- **Windows XP:**
  C:\Documents and Settings\%username%\Application Data\Articulate\Shared\2.0\Frames\StoryFrame\ColorSchemes

**Deleting a color scheme**

To remove a color scheme, select it from the **Color scheme** selector and then click the red X. The deleted scheme will no longer appear in the **Color scheme** selector. If a color scheme you delete was previously applied to another course, though, it won't be removed from that course - it'll just be within the project file itself.

**Changing the course’s background color**

The **Page background** refers to the color that appears behind the player when learners view your published content. Depending on their browser size and the size of your published course, learners may see this color around the perimeter of your player. If you've made the **base** portion of your player fully or partially transparent, the page background color will be visible there too.

Use the **Page background** selector to choose a color. The choices consist of a color palette that comes from your course’s **Theme Colors** as well as some **Standard Colors**. If you don't see a color you like, you can choose **More Colors** and use the **Colors** window as explained above.
**Customizing the player font**

The player font is what Storyline uses on player features that contain text—such as tabs, buttons, menu items, prompts, and the search window. You can use the **Player Font** selector to choose a different font. Just like other options you change on the player, any new selection you make in this field will show up in the Preview area on the right half of the window.
**Saving your changes to the player**

If you click OK on the Player Properties window and then save your project by clicking the **Save** button above the Storyline ribbon, Storyline saves your player customizations within your project. It's a good practice, though, to save your player separately, because this allows you to apply the same player customizations to other projects if you like.

To save your player, click the **Current Player** button on the Player Properties window and choose **Save**. Enter a name for the player if you're prompted, and click **OK**.

For more details about using the **Current Player** options, see the tutorial called **Saving Your Player or Switching to a Different One**.

**You might also want to explore:**

*Storyline Player Colors*
Changing the Player's Text Labels

Storyline enables you to customize the default text used in messages and controls used on your project’s player. You can even switch your player's text labels to a completely different language if you want.

To customize your player's text labels, you'll first need to open the text labels via the Player Properties window. Click the Home tab on the Storyline ribbon, and then click Player.

When the Player Properties window appears, click Text Labels:

From here, you can customize individual text labels, switch all labels on your player to a different language, or switch to a previously saved set of text labels.
Customizing the individual text labels on your player

On the left side of the window, Storyline displays a list of all the text labels you can edit. For any item you want to change, just type your preferred text in the Custom Text column.

If you'd like to send all the text labels to someone else to translate or modify, you can download this spreadsheet, which contains a complete list.
**Saving your customized text labels**

If you click **OK** after changing some text labels, the changes become part of the current course's player. If you want those same text labels to be available for use in *other* courses you build in Storyline, do this:

1. From the Text Labels section of the Player Properties window, click the **Save** button to the right of the **Language** selector.
2. Choose a name for your new set of text labels and click **Save**.

This saves your text labels in Storyline's default location. You can choose a different location if you like—for example, maybe you'd prefer to save the labels to your desktop so that you can easily locate them later, if you need to share them with a colleague or copy them to a different computer. However, if you choose a location other than the default, the saved text labels won't appear in the **Language** selector in other courses you build. You would need to use the **Load** button (the folder icon to the right of the **Language** selector) to browse for the labels if you want to re-use them in another project.
Changing your player to a different language (or to a customized set of text labels you previously saved)

To switch to a completely different language, or to a customized set of text labels you previously saved, you can use the Language selector on the Player Properties window to choose the set of text labels you want to use. Storyline provides several language options in the Built In section of the list; the Custom section of the list contains text labels you've created and saved yourself.

If you previously saved a set of text labels and you're not seeing it in the list, it probably means you saved the text labels in a location other than the default, which is why Storyline isn't displaying them in the list. You can click the Load button (the folder icon to the right of the Language selector) to browse for the text labels and open them from wherever you saved them.
Saving your changes to the player

If you click OK on the Player Properties window and then save your project by clicking the Save button above the Storyline ribbon, Storyline saves your player customizations within your project. It’s a good practice, though, to save your player separately, because this allows you to apply the same player customizations to other projects if you like.

To save your player, click the Current Player button on the Player Properties window and choose Save. Enter a name for the player if you’re prompted, and click OK.

For more details about using the Current Player options, see the tutorial called Saving Your Player or Switching to a Different One.
In Storyline, you can control several aspects of the browser and player behavior in your launched course, including:

- The size of the browser window in which the course displays,
- Whether the course stays locked at the same size you created it, or if learners can scale the course up or down by adjusting the size of their browser window, and
- Whether the course launches in a new window, and if so, the characteristics of that window.

To set your options for these things, you'll need to open the Player Properties window. First, click the Home tab on the Storyline ribbon, and then click Player.
When the Player Properties window appears, click Other.

Now set your preferences, using the guidelines below.

**Choosing the browser size**

Use the Browser Size selector to choose one of the options available:

- **Display at user's current browser size**: With this option, when the course launches, it'll display in a browser window at whatever size the learner's browser is currently set to.
- **Resize browser to optimal size**: If you choose this option, when the course launches it'll automatically resize the learner's browser to match the course's optimal size. The optimal size is whatever you've chosen as the story size, plus any additional height or width to accommodate the course player. Depending on the features and controls you've included on your player, the player can add between 20 and 260 pixels to the width of your course, and between 20 and 118 pixels to the height. If you need help understanding the features and controls available on your player, check out this tutorial.
- **Resize browser to fill screen**: If you choose this option, when the course launches, it'll automatically resize the learner's browser to fill the whole screen.
Choosing the player size

Use the Player size selector to choose one of the options available:

• Scale player to fill browser window: This causes your published course to fill the user's browser window.
• Lock player at optimal size: This locks the published course at its optimal size—and even if learners resize their browser window, the course itself will stay at the optimal size. The optimal size is whatever you've chosen as the story size, plus any additional height or width to accommodate the course player. Depending on the features and controls you've included on your player, the player can add between 20 and 260 pixels to the width of your course, and between 20 and 118 pixels to the height. If you need help understanding the features and controls available on your player, check out this tutorial.

Launching the course in a new window

If you'd like your course to launch in a new browser window via a launch page, mark Launch player in a new window. Then choose your options from the additional options that follow:
• **Display window with no browser controls:** If you mark this, the new window in which your course displays will have no browser controls—it'll only display the address bar, which won't be editable. If you leave this box **unmarked**, the new browser window will have the usual controls that the learner uses on his or her browser.

Here's a course published with browser controls: ![Course with browser controls](image1)

...and the same course published without browser controls: ![Course without browser controls](image2)

• **Allow user to resize browser:** Mark this if you want your learners to be able to resize the browser window in which your course launches.
Saving your changes to the player

If you click OK on the Player Properties window and then save your project by clicking the Save button above the Storyline ribbon, Storyline saves your player customizations within your project. It's a good practice, though, to save your player separately, because this allows you to apply the same player customizations to other projects if you like.

To save your player, click the Current Player button on the Player Properties window and choose Save. Enter a name for the player if you're prompted, and click OK.

For more details about using the Current Player options, see the tutorial called Saving Your Player or Switching to a Different One.
Changing the Player’s Resume Behavior

If the same learner launches your course more than once, the Resume feature in Storyline determines how the course behaves on subsequent visits.

- You can start the course fresh every time,
- Or, you can automatically place learners where they were the last time they visited the course,
- Or, you can display a prompt that allows the learner to choose.

The resume behavior is part of the player you apply to your course. To customize the resume behavior, you'll need to open the Player Properties window. First, click the Home tab on the Storyline ribbon, and then click Player.

When the Player Properties window appears, click Other.

Find the Resume section of the window, and set your preference by using the On story restart selector:
• **Always**: This causes your course to automatically open at the place where the learner left off last time. Users won't see a prompt; the resume just happens automatically.

• **Never**: This causes your course to always open at the beginning of the course, regardless of whether the learner already completed part of the course previously. Users won't see a prompt.

• **Prompt**: If the learner previously viewed any slides beyond the initial slide, this option causes the course to display a prompt, asking the learner if they want to pick up where they left off. The prompt will look something like this:

```
Resume

Would you like to resume where you left off?

Yes  No
```

If you choose **Always** or **Prompt**, you can choose to have your LMS manage the resume data if it's able. When the box labeled **When running in LMS, ignore Flash cookie** is marked, if you upload your published course to an LMS that supports resume data, the course will use the LMS bookmark rather than the Flash cookie that would normally be used. If you upload your course to an LMS that does not provide a resume bookmark, the course will use the Flash cookie as usual.

**Changing the wording on the resume prompt**

If you've enabled a resume prompt and you want to customize what it says, that's easy to change. The text comes from your player's **Text Labels**, which you can customize from the Player Properties window. If you need help editing the text labels, check out [this tutorial](#).
**Saving your changes to the player**

If you click **OK** on the Player Properties window and then save your project by clicking the **Save** button above the Storyline ribbon, Storyline saves your player customizations within your project. It’s a good practice, though, to save your player separately, because this allows you to apply the same player customizations to other projects if you like.

To save your player, click the **Current Player** button on the Player Properties window and choose **Save**. Enter a name for the player if you’re prompted, and click **OK**.

For more details about using the **Current Player** options, see the tutorial called **Saving Your Player or Switching to a Different One**.
Enabling Right-to-Left Language Support

Text on your Storyline player defaults to being displayed in a left-to-right orientation. If you're using a right-to-left language, such as Hebrew or Arabic, you can enable right-to-left language support by making a small change to your course's player. First, make sure you're using a font that supports non-Western text, such as Arial Unicode MS. Then, follow these steps:

Click the **Home** tab on the Storyline ribbon, and then click **Player**.

When the Player Properties window appears, click **Other**.

Find the **Text is read from** section of the window, and set your preference by using the selector:
If you're using a sidebar on your player

If your course player includes a sidebar where you display a menu, glossary, resources, or slide notes, you might also be interested to know that you can switch the sidebar's location so that it displays on the right side of your player instead of the left. To make this change, click the Features button at the top of the Player Properties window and change the Sidebar selector to On Right.
Saving your changes to the player

If you click OK on the Player Properties window and then save your project by clicking the Save button above the Storyline ribbon, Storyline saves your player customizations within your project. It's a good practice, though, to save your player separately, because this allows you to apply the same player customizations to other projects if you like.

To save your player, click the Current Player button on the Player Properties window and choose Save. Enter a name for the player if you're prompted, and click OK.

For more details about using the Current Player options, see the tutorial called Saving Your Player or Switching to a Different One.

Enabling right-to-left direction on your slide text

For any slide text that you want to display in a right-to-left language on your slide, make sure the Right-to-Left Text Direction button is selected when you enter or edit the text. You'll find this button on the Home tab of the ribbon, but it will only appear if you have a right-to-left keyboard input language installed on your computer:
Saving Your Player or Switching to a Different One

In Storyline, when you make changes to a course's player, those changes get saved within your course's project file. But Storyline also allows you to save the player on its own. This enables you to apply the same player to other courses you build, or to share the player with other course developers.

In this tutorial, we'll take a look at how to save a player, how to apply a previously saved player to a project, and how to import, export, and delete players.

**Opening the Player Properties window**

First you'll need to open the Player Properties window: click the Home tab on the Storyline ribbon, and then click Player:

![Player Properties window](image)

**Saving your player**

To save your player, click the Current Player button on the Player Properties window:

![Player Properties window with Save button highlighted](image)

Then choose either of the following:

- **Save**: Use this to save the player under its current name. If you haven't saved the player before, it doesn't have a name yet, so Storyline will ask you to enter one. Enter a name and click OK.
• **Save As:** This saves a copy of the current player under a new name, which Storyline will prompt you to enter. This is a good option when you've customized a player and then want to make additional variations of the same player.

Be sure to click the **OK** button to close the Player Properties window when you have finished working with your player configuration. If you click the **X** in the upper right corner of the window instead of clicking **OK**, your changes, including the **Save** action, will be canceled. In other words, the **X** in the upper right corner functions in the same manner as the **Cancel** button.

Once you save a Storyline player, it’s stored as an .xml file on your hard drive, and it gets added to the list of available players you can apply to any course (see the next section of this tutorial for info on how to switch your course to a player you’ve previously saved). The location where the .xml file is stored depends on which version of Windows you’re using:

- **Windows Vista / 7:**
  C:Users\%username%\AppData\Roaming\Articulate\Shared\2.0\Players

- **Windows XP:**
  C:\Documents and Settings\%username%\Application Data\Articulate\Shared\2.0\Players

**Applying a player that you previously saved**

Once you use the **Save** or **Save As** options to save a player, you can apply that same player to other courses you build. To do that, click **Current Player** on the Player Properties window, and choose **Open**.

![Image of Player Properties window](image)

Scroll through the list to find the player you want to use, and then click it to apply it to the current course.

The default Storyline Player will always appear at the top of the list. Any player whose name is followed by "(on disk)" has been saved to your hard drive. A player name followed by "(in project)" is stored within the current project itself, and hasn’t yet been saved under its own name.
Sharing a player with a colleague or moving it to a different computer (exporting a player)

If you want to share a player with a colleague, or transfer the player to a different computer, you can easily export the player’s .xml file. That same file can then be imported by any other Storyline user who wants to use it. Here’s how to export:

1. On the Player Properties manager, click **Current Player** and choose **Export**.

![Player Properties manager with Export button highlighted]

2. Browse to the location where you want to save the player.
3. Enter the name you want to give the exported player (it defaults to the player name you've used in Storyline, but you can enter a different name if you want).
4. Click **Save**.

Now you can give the file to a colleague, or use it on another computer. For instructions on how to import the file, see the next section of this tutorial.
Using a player someone has shared with you (importing a player)

If someone gives or sends you an .xml file for a Storyline player, you can import it to your current project like this:

1. On the Player Properties window, click **Current Player** and choose **Import**.

2. Navigate to the .xml file for the player you want to import. Select it and click **Open**.
3. This applies the player to your project. If you'd like to also save the player so that it's available for other Storyline projects you work on, use the steps we covered earlier for saving your player.

Deleting a player from your hard drive

If you no longer need a player you've previously saved, you can delete it like this:

1. On the Player Properties window, click **Current Player** and choose **Open**.
2. Scroll through the list and find the player you want to delete. Click it to apply it to the current course.
3. Click **Current Player** again, and this time choose **Delete**. Respond **Yes** at the confirmation prompt.
This deletes the player and reverts your course back to the default Storyline player. If any other courses you've built happen to use the player you deleted, that player will still remain saved within the course; it'll just be saved within the project rather than as a separate player file.

**Want to undo the changes you’ve made to a player?**

Let's say you've saved a player, and then made some additional modifications, but haven't yet re-saved the player. Although the additional modifications will stay within the course, they're saved "in project"—meaning they're not saved to the actual player file yet. If you click the **Current Player** button on the Player Properties window, you might see something like this:

![Current Player Button](image)

If you want to revert back to the previously saved version of the player, you just need to click **Current Player** and choose **Reset**.

![Reset Button](image)
Previewing and Publishing Your Project

Storyline provides a wide range of publishing formats (including publishing for iPad and HTML5), as well as the option to preview your content prior to publishing. Use the following tutorials to get acquainted with Storyline's preview and publish features:

- Previewing Your Project
- Publishing a Project for Web
- Publishing a Project for Articulate Online
- Publishing a Project for LMS
- Publishing a Project for CD or Another Local Source
- Publishing a Project for Word
- Publishing a Project for iPad or HTML5

![Image of Storyline's preview and publish features](image.png)
**Previewing Your Project**

Previewing is a great way to see the changes you've made to your content without publishing your project. You can preview from Story View or from Normal View.

To preview your entire project, you can do any of the following:

- Press **F12** on your keyboard.
- Or, from any tab on the Storyline ribbon, click the **Preview** button.
- Or, in the lower-right corner of your Storyline window, click the icon to the left of the zoom percentage.

Or, to preview just a portion of your project, do any of the following:

- Press **Ctrl+F12** on your keyboard to preview the current slide.
- Or, press **Shift+F12** on your keyboard to preview the current scene.
- Or, find the **Preview** button on the Storyline ribbon, click the small arrow on it, and then choose to preview the current slide, the current scene, or the whole project:

**Options on the Preview window**

When the Preview window appears, you can use the buttons on the Preview toolbar to do any of the following:
• **Close Preview:** This closes the Preview window and takes you back to wherever you were prior to previewing.

• **Select:** This allows you to choose a different slide in your course to preview.

• **Replay:** Click this button to replay the preview selection again. Or, you can click the arrow on this button and replay just the current slide, the current scene, or the entire project.

• **Edit Slide:** This takes you to Normal View of the slide you’re currently previewing.

You can also use the buttons in the lower-right corner to close the Preview window and go to either Story View or to the Normal View of the slide you’re currently previewing:

---

**Items that aren’t available during Preview**

Though most content displays during Preview just like it would in the published output, there are a few items that are unavailable during Preview. They are:

• **Web objects**

• **Videos** that you insert from websites such as Screenr, YouTube or Vimeo

• Content that you import from Articulate Engage
Publishing a Project for Web

If you want learners to be able to access your course via the Internet or an intranet, and if you don’t need to track their completion or progress, then web publishing is for you. (If you do need tracking capabilities, you’d want to instead publish to Articulate Online or an LMS.)

In this tutorial, we’ll take a look at how to use Storyline’s web publishing option to turn your project into web-ready content:

**Step 1: Enter Title, Description, and Folder Location**

1. On the **Home** tab of the Storyline ribbon, click the **Publish** button. (Or, from any other tab on the ribbon, you can click the small triangle under the **Preview** button, and then choose **Publish**.)

2. When the Publish window appears, click the **Web** tab.
3. Check the text that appears in the **Title** field, and customize it if you like. This text defaults to the name of your Storyline file. If you change it, it'll change the title text that Storyline uses in the following places (but it won't change your actual file name):

- The folder that Storyline creates to contain your published output. For example, if the **Title** field contains the words **MSDS Course**, Storyline creates a new folder on your hard drive called **MSDS Course Output** when you publish.
- The browser title bar, when learners view your published course in a browser window.
- The top bar of your course player, if you've opted to include the title as one of the **player features**.
- If you publish your content for use with the Articulate Mobile Player, the course title is also used on the HTML launch page from which learners can add the course to their player. Once they do that, the title is added to the list of course names in the mobile player library.

4. In the **Description** field, you can enter some descriptive text about your course if you like. If learners view your course on an iPad with the Articulate Mobile Player, your description text appears below the course thumbnail in the mobile player library.

5. In the **Folder** field, indicate the place on your computer where you want Storyline to create your published output. You can click the ellipsis button (...) to browse to a specific location. Storyline will create a new folder in that spot, with all the files needed to play your course.

- **Important!** Always publish to a local drive on your computer. Publishing to a network drive or a USB drive can create problems with your published output. After you publish your course to a local folder, you can move the output to a web server and test it.
Step 2: Enter additional project info for the Articulate Mobile Player (optional)

If you plan to allow learners to view your content on an iPad with the Articulate Mobile Player, you can optionally add or customize some additional information by clicking the ellipsis button (...) next to the Title field on the Publish window. The following Project Info window appears:

1. The Title and Description are the same as what you entered on the Publish window; you can change the text here if you like.
2. The thumbnail below the Title field is what will appear for this course when learners browse courses in their mobile player library. By default, Storyline uses an image of the first slide in your course, but you can use a different slide for the thumbnail if you want. Just click the blue slide title text, and choose the slide you want to use.
3. The **Duration** lets learners know approximately how long the course will take. In the Articulate Mobile Player, this value appears below the course thumbnail. You can have Storyline **Calculate Automatically**, or you can choose **Custom** and enter the duration you want learners to see.

4. The **Author** field allows you to identify the course author, if you like. The author name appears below the course thumbnail in the Articulate Mobile Player library.

5. The remaining fields on this window (**Keywords**, **Email**, **Website**, **Date**, **Version**, and **Identifier**) aren't currently used in your published output; these will be used in a future version.

When you’re finished customizing the fields on this window, click **OK** to return to the Publish window.

**Step 3: Choose HTML5 and/or mobile publishing (optional)**

If some or all of your learners will access your content with an iPad or some other mobile device that doesn't support Flash, you can use the following options on the Publish window to make your course viewable in HTML5, the Articulate Mobile Player, or both. If you do this, be sure to also check out the info here so that your content looks and behaves the way you expect when viewed in a non-Flash environment.

- **Include HTML5 output**: This prepares your course so that it's viewable as HTML5 content if a learner doesn't have the Flash player and they view your course in an HTML5-compatible browser. Keep in mind that not all browsers handle HTML5 content equally. **This article** identifies which browsers your learners should use if they need to view your course as HTML5 content.

- **Use Articulate Mobile Player on iPad**: This prepares your course so that learners receive the best possible viewing experience on an iPad. Users view the content through Articulate’s free mobile player app, which they'll be prompted to install the first time they attempt to use their iPad to view a Storyline-published course. To find out why the Articulate Mobile Player provides a richer learning experience than viewing content as HTML5, check out **this article**.

- **Allow downloading for offline viewing**: Mark this box to give your learners the option of downloading your course to their Articulate Mobile Player. Once learners download the course, they can view it at any time, even if they don't have internet access, and even if you remove the course from the location where you've hosted it. The course stays in your learners' mobile player library until they remove it. (For this reason, you might not want to mark this option if you don't want learners to be able to access the course indefinitely, at any time, or if you plan to update the course and are concerned about learners viewing previously downloaded content that becomes obsolete.)
**Step 4: Check player properties and quality settings**

The **Properties** section of the Publish window allows you to make any last-minute changes to your course player, or to change the compression settings Storyline uses when publishing.

1. The **Player** field shows the name of the player that Storyline will use when you publish. (The player is the interface that users see when they view your course, and it can include things like player controls, resources, a glossary, a menu, and other features.) Click the player name if you'd like to make some final adjustments to your player or switch to a different player. If you need help choosing your player settings, see the tutorials on [Customizing the Storyline Player](#).

2. The **Quality** field allows you to control the compression settings Storyline uses for any audio, video, and pictures you've added to your course. The settings here default to whatever you used the last time you published a Storyline project. To change the quality settings, click the blue text and change any of the fields as noted below; then click **OK**.

   - Choose **Standard** if you want to use the default settings. If you mark this option, the values on the window revert back to their defaults (video quality of 5, audio bitrate of 48kbps, and image quality of 80%).
   - Choose **Custom** if you want to define your own quality settings. Then click and drag the slider on any of the three values to change the compression. Using higher values means higher-quality output, but also larger file sizes (which means longer download times). Lower values mean smaller file sizes and faster download times, but the visual and audio quality will be lower as well.

![Publish Quality](Image)
Step 5: Publish!

When you're finished making changes to the options on the Publish window, just click the Publish button.

Storyline creates your published output in the location you specified. When publishing is complete, you'll see the following pop-up, and you can choose whichever option suits you:

- **View Story:** This launches your course in your web browser so you can take a look at your output. **Important note about viewing your published content:** Since your files have been prepared for deployment over the web, in some situations you might encounter unexpected behavior if you try to view the presentation from a local drive (such as your computer's hard drive). When publishing for web, it's always best to upload your published output to its final destination and test it there, rather than testing it from a local source.
- **Email:** This opens up a new email message with a zipped file of your published output attached. This might be helpful if you need to share your course with an SME or other reviewers, or if you need to send it to someone who will place it in the location from which it'll be deployed. If your audience is larger than just a few, though, it's usually better to move your files to a web server instead, and send your audience the link to player.html (the file which launches your course). This way, you're less likely to logjam your email system with attachments, your recipients won't need to fuss with saving and unzipping your file, and you won't have to resend revised files to a slew of people every time you update the course.
- **FTP:** This pops up a window where you can enter your FTP credentials and transfer your output to your website.
- **ZIP:** This creates a zipped file of your output in the location you specified on the Publish window.
- **Open Folder:** This opens a file viewer where you can see the files Storyline just created. There will be a story_content folder, a file called story.swf, a meta.xml file containing some project info, and a file called story.html (which is the file that launches your course). If you've opted to include HTML5 output and/or make your course viewable on the Articulate Mobile Player, there will also be some additional files to support these options. When you move your files to a web server, you'll need to send your users a link to story.html so they can view your course. Depending on the device and browser learners use, they'll automatically get directed to the appropriate format. (See below for more info on that.)

What do I do with my files once I've published?

Now that you've published, it's time to move your web-ready course to your website or server, give it a test run, and then send your users a link to the story.html file so they can access your course.

If you chose to publish for HTML5 and/or the Articulate Mobile Player

When learners open the course via story.html, they'll automatically see the right type of content based on the device and browser they're using:

- They'll see the Flash content if their browser supports it.
- If they're using an iPad, and if you chose the Articulate Mobile Player option when you published, they'll see a launch page that allows them to view the course in the Articulate Mobile Player. (And if they don't have the player installed on their iPad yet, they'll see an option to install it.)
- If they're using an iPad and you didn't choose the Articulate Mobile Player option when you published, but you did choose HTML5, they'll see the HTML5 output.
- If they're using some other non-Flash compatible browser and you chose to publish for HTML5, they'll see the HTML5 output.
Publishing a Project for Articulate Online

Storyline's publishing options make it easy to publish and upload your course to Articulate Online, all at once. Here's how to do it:

**Step 1: Enter the Title and Description**

1. On the **Home** tab of the Storyline ribbon, click the **Publish** button. (Or, from any other tab on the ribbon, you can click the small triangle under the **Preview** button, and then choose **Publish**.)

2. When the Publish window appears, select **Articulate Online**.
3. Check the text that appears in the **Title** field, and customize it if you like. This text defaults to the name of your Storyline file. If you change it, it'll change the title text that Storyline uses in the following places (but it won't change your actual file name):

- The title of your content as it appears in Articulate Online’s content list.
- The browser title bar, when learners view your published course in a browser window.
- The top bar of your course player, if you’ve opted to include the title as one of the [player features](#).
- If you publish your content for use with the Articulate Mobile Player, the course title is also used on the HTML launch page from which learners can add the course to their player. Once they do that, the title is added to the list of course names in the mobile player library.

4. In the **Description** field, you can enter some descriptive text about your course if you like. If you enter a description, it’ll be used in the following places:

- When you manage your content in Articulate Online, the description will appear along with the course title.
- The description will appear to learners who access your content through Articulate Online’s user portal, if you choose to enable that. (You can learn more about the user portal and other options for giving users access to your content in [this online tutorial](#).)
- If you publish your content for use with the Articulate Mobile Player, the description is also used on the HTML launch page from which learners can add the course to their player. Once they do that, the description text appears below the course thumbnail in the mobile player library.
**Step 2: Enter additional project info for the Articulate Mobile Player (optional)**

If you plan to allow learners to view your content on an iPad with the Articulate Mobile Player, you can optionally add or customize some additional information by clicking the ellipsis button (…) next to the Title field on the Publish window. The following Project Info window appears.

1. The **Title** and **Description** are the same as what you entered on the Publish window; you can change the text here if you like.
2. The thumbnail below the **Title** field is what will appear for this course when learners browse courses in their mobile player library. By default, Storyline uses an image of the first slide in your course, but you can use a different slide for the thumbnail if you want. Just click the blue slide title text, and choose the slide you want to use.
3. The **Author** field allows you to identify the course author, if you like. The author name appears below the course thumbnail in the Articulate Mobile Player library.

4. The **Duration** lets learners know approximately how long the course will take. In the Articulate Mobile Player, this value appears below the course thumbnail. You can have Storyline **Calculate automatically**, or you can choose **Custom** and enter the duration you want learners to see.

5. The remaining fields on this window (**Keywords, Email, Website, Date, Version, and Identifier**) aren't currently used in your published output; these will be used in a future version.

When you're finished customizing the fields on this window, click **OK** to return to the Publish window.

**Step 3: Choose HTML5 and/or mobile publishing (optional)**

If some or all of your learners will access your content with an iPad or some other mobile device that doesn't support Flash, you can use the following options on the Publish window to make your course viewable in HTML5, the Articulate Mobile Player, or both. If you do this, be sure to also check out the info here so that your content looks and behaves the way you expect when viewed in a non-Flash environment.

- **Include HTML5 output**: This prepares your course so that it's viewable as HTML5 content if a learner doesn't have the Flash player and they view your course in an HTML5-compatible browser. Keep in mind that not all browsers handle HTML5 content equally. [This article](#) identifies which browsers your learners should use if they need to view your course as HTML5 content.

- **Use Articulate Mobile Player on iPad**: This prepares your course so that learners receive the best possible viewing experience on an iPad. **(IMPORTANT: If you need to track and report on learners' progress or results, you'll need to publish your content with Storyline Update 1 or later. If you republish and reupload a course that you previously published to Articulate Online, the newly published course will replace the previous one—and any existing data will stay intact—as long as you keep the Title field the same.)** If you do mark this option, users may view the content through the free Articulate Mobile Player, which they'll be prompted to install the first time they attempt to use their iPad to view a Storyline-published course.

- **Allow downloading for offline viewing**: This checkbox box is currently ignored when you publish to Articulate Online, since learners will need to be online in order for the course to send tracking data to your account. (A future version of the Articulate Mobile Player may support offline viewing, and if so, at that time this setting will be honored for courses you previously published.)
**Step 4: Check player properties and quality settings**

The **Properties** section of the Publish window is where you can make any last-minute changes to your course player or change the compression settings Storyline uses when publishing.

1. The **Player** field shows the name of the player that Storyline will use when you publish. (The player is the interface that users see when they view your course, and it can include things like player controls, resources, a glossary, a menu, and other features.) Click the player name if you'd like to make some final adjustments to your player or switch to a different player. If you need help choosing your player settings, see the tutorials [here](#).

2. The **Quality** field allows you to control the compression settings Storyline uses for any audio, video, and pictures you've added to your course. The settings here default to whatever you used the last time you published a Storyline project. To change the quality settings, click the blue text and change any of the fields as noted below; then click **OK**.

   - Choose **Standard** if you want to use the default settings. If you mark this option, the values on the window revert back to their defaults (video quality of 5, audio bitrate of 48kbps, and image quality of 80%).
   - Choose **Custom** if you want to define your own quality settings. Then click and drag the slider on any of the three values to change the compression. Using higher values means higher-quality output, but also larger file sizes (which means longer download times). Lower values mean smaller file sizes and faster download times, but the visual and audio quality will be lower as well.
**Step 5: Choose your tracking and reporting preferences**

In the **Properties** section of the Publish window, click the **Tracking** field to open the following window, where you can choose your options for the way Articulate Online tracks and reports on your learners’ progress:

![Reporting and Tracking Options](image)

1. **Report status to AO** allows you to choose the wording that Articulate Online uses in reports when expressing learners’ status. Use the selector to choose one of the four options available.

2. **Communicate resume data** allows you to choose how Articulate Online handles resume data if you’ve enabled the [resume feature](#) on your player.

   - **On Course Complete**: With this option, the course communicates resume data when the learner closes the browser window in which they’re viewing your course, or when they reach the completion threshold that you choose in the Tracking section (explained below).
   
   - **After Every Slide**: With this option, the course sends resume data each time the learner advances to another slide in your course. If you choose this option, *and* if you’ve enabled the [resume feature](#) on your player, then learners who experience an internet disruption while taking your course will still be able to pick up where they left off, without losing their progress, when they relaunch the course. Keep in mind that because this option results in frequent communication between your course and Articulate Online, it does increase network traffic, which can become significant if you roll out your course to many learners at the same time.
3. In the **Tracking** section of the window, choose one of the following:

- **Track using number of slides viewed:** With this option, you can specify how many slides learners need to view in order to complete the course.
- **Track using quiz result:** This option appears if your course includes a quiz result slide. Select this if you want to track learners based on their quiz results. If your course has multiple quizzes, you'll need to pick just one result slide to use for tracking.

4. Click **OK** when you're finished setting up your tracking and reporting preferences.

**Step 6: Enter your Articulate Online credentials and publish**

1. For your **Account information**, enter your Articulate Online credentials. Type your **Account URL**, your **E-mail** address, and your **Password**. (You'll need to be an administrator or publisher on your account in order to publish content.) If you want Storyline to remember your password for the next time you publish, you can mark **Save my password**.
2. Click **Publish**.

Your content gets published and uploaded to Articulate Online, all at once. How fast this happens depends on the size of your course and also how fast your connection speed is. When the **Publish Successful** window appears, you can click **Manage Content** to open Articulate Online and manage the course you just uploaded, or work with any other content you’ve published to your account.

![Publish Successful](image)

**Can you publish locally first, and then upload later?**

Yes. For example, if a corporate firewall prohibits you from publishing automatically to Articulate Online, you can publish the content locally and then manually upload to Articulate Online via your browser. To find out how to manually upload published content to Articulate Online, check out [this online tutorial](#).
If you chose to publish for HTML5 and/or the Articulate Mobile Player

When you give learners access to your content and they launch your course, they'll automatically see the right type of content based on the device and browser they're using:

- They'll see the Flash content if their browser supports it.
- If they're using an iPad, and if you chose the Articulate Mobile Player option when you published, they'll see a launch page that allows them to view the course in the Articulate Mobile Player. (And if they don't have the player installed on their iPad yet, they'll see an option to install it.)
- If they're using an iPad and you didn't choose the mobile player option when you published, but you did choose HTML5, they'll see the HTML5 output.
- If they're using some other non-Flash compatible browser and you chose to publish for HTML5, they'll see the HTML5 output.
Publishing a Project for LMS

If your organization or client uses a learning management system (LMS) to deploy e-learning content, then when you publish your Storyline content, you'll want to use the LMS option.

Here are the steps you need to know:

**Step 1: Enter Title, Description, and Folder Location**

1. On the **Home** tab of the Storyline ribbon, click the **Publish** button. (Or, from any other tab on the ribbon, you can click the small triangle under the **Preview** button, and then choose **Publish**.)

2. When the Publish window appears, click the **LMS** tab.
3. Check the text that appears in the **Title** field, and customize it if you like. This text defaults to the name of your Storyline file. If you change it, it'll change the title text that Storyline uses in the following places (but it won't change your actual file name):

- The folder that Storyline creates to contain your published output. For example, if the **Title** field contains the words **MSDS Course**, Storyline creates a new folder on your hard drive called **MSDS Course Output** when you publish.
- The browser title bar, when learners view your published course in a browser window.
- The top bar of your course player, if you've opted to include the title as one of the **player features**.
- Any screen in your LMS interface that contains titles of content items.
- If you publish your content for use with the Articulate Mobile Player, the course title is also used on the HTML launch page from which learners can add the course to their player. Once they do that, the title is added to the list of course names in the mobile player library.

4. In the **Description** field, you can enter some descriptive text about your course if you like. Depending on your LMS, this descriptive text may appear along with the course name in certain screens within your LMS environment.

5. In the **Folder** field, indicate the place on your computer where you want Storyline to create your published output. You can click the ellipsis button (...) to browse to a specific location. Storyline will create a new folder in that spot, with all the files needed to play your course.

- **Important!** Always publish to a local drive on your computer. Publishing to a network drive or a USB drive can create problems with your published output. After you publish your course to a local folder, you can upload the output to your LMS to test it.

**Step 2: Enter additional project info for the Articulate Mobile Player (optional)**

If you plan to allow learners to view your content on an iPad with the Articulate Mobile Player, you can optionally add or customize some additional information by clicking the ellipsis button (...) next to the **Title** field on the Publish window. The following Project Info window appears.

Please note these important facts about mobile output:

- Tracking in the Articulate Mobile Player is only supported in learning management systems that support the **Tin Can API** specification.
- If your LMS does not yet support the Tin Can API and you need to track and report on learners’ results, learners will need to view your course in a browser that supports Flash or HTML5, so that the course can communicate results to your LMS.
- If your LMS doesn’t support the Tin Can API but you don’t need tracking, you might still be able to deploy your Storyline content via your LMS for viewing on the Articulate Mobile Player. However, not all LMSs allow content to be viewed on a mobile app, so you’ll need to test this with your own LMS to confirm.
1. The **Title** and **Description** are the same as what you entered on the Publish window; you can change the text here if you like.

2. The thumbnail below the **Title** field is what will appear for this course when learners browse courses in their mobile player library. By default, Storyline uses an image of the first slide in your course, but you can use a different slide for the thumbnail if you want. Just click the blue slide title text, and choose the slide you want to use.

3. The **Author** field allows you to identify the course author, if you like. The author name appears below the course thumbnail in the Articulate Mobile Player library.

4. The **Duration** lets learners know approximately how long the course will take. In the Articulate Mobile Player, this value appears below the course thumbnail. You can have Storyline **Calculate automatically**, or you can choose **Custom** and enter the duration you want learners to see.
5. The **Identifier** field is a unique string of characters assigned by Storyline, and your LMS uses it to identify your content. If you're republishing a course that's already in your LMS and you plan to re-upload to your LMS, be sure not to change the value in this field.

6. The remaining fields on this window (**Keywords, Email, Website, Date, and Version**) aren't currently used in your published output; these will be used in a future version.

When you're finished customizing the fields on this window, click **OK** to return to the Publish window.

**Step 3: Choose HTML5 and/or mobile publishing (optional)**

If some or all of your learners will access your content with an iPad or some other mobile device that doesn't support Flash, you can use the following options on the Publish window to make your course viewable in HTML5, the Articulate Mobile Player, or both. If you do this, be sure to also check out the info here so that your content looks and behaves the way you expect when viewed in a non-Flash environment.

- **Include HTML5 output**: This prepares your course so that it's viewable as HTML5 content if a learner doesn't have the Flash player and they view your course in an HTML5-compatible browser. Keep in mind that not all browsers handle HTML5 content equally. [This article](#) identifies which browsers your learners should use if they need to view your course as HTML5 content.

- **Use Articulate Mobile Player on iPad**: This prepares your course so that learners receive the best possible viewing experience on an iPad. If you mark this option, users may view the content through the free Articulate Mobile Player, which they'll be prompted to install the first time they attempt to use their iPad to view a Storyline-published course. *Important*: Tracking in the Articulate Mobile Player is only supported in learning management systems that support the Tin Can API specification. If tracking and reporting is crucial, but your LMS does not support the Tin Can API, do not mark this option. If your LMS doesn't support the Tin Can API but you don't need tracking, you might still be able to deploy your Storyline content via your LMS for viewing on the Articulate Mobile Player. You'll need to test this with your own LMS to confirm, since not all LMSs allow content to be viewed on a mobile app.

- **Allow downloading for offline viewing**: This box allows you to give learners the option of downloading your course to their Articulate Mobile Player so that they may view it offline later. However, currently the Articulate Mobile player only supports tracking while online, so learners who attempt to view a course while offline will be prompted to reconnect.
Step 4: Check player properties and quality settings

The **Properties** section of the Publish window is where you can make any last-minute changes to your course player or change the compression settings Storyline uses when publishing.

1. The **Player** field shows the name of the player that Storyline will use when you publish. (The player is the interface that users see when they view your course, and it can include things like player controls, resources, a glossary, a menu, and other features.) Click the player name if you’d like to make some final adjustments to your player or switch to a different player. If you need help choosing your player settings, see the tutorials [here](#).

2. The **Quality** field allows you to control the compression settings Storyline uses for any audio, video, and pictures you’ve added to your course. The settings here default to whatever you used the last time you published a Storyline project. To change the quality settings, click the blue text and change any of the fields as noted below; then click **OK**.

- Choose **Standard** if you want to use the default settings. If you mark this option, the values on the window revert back to their defaults (video quality of 5, audio bitrate of 48kbps, and image quality of 80%).
- Choose **Custom** if you want to define your own quality settings. Then click and drag the slider on any of the three values to change the compression. Using higher values means higher-quality output, but also larger file sizes (which means longer download times). Lower values mean smaller file sizes and faster download times, but the visual and audio quality will be lower as well.

![Publish Quality](image-url)
**Step 5: Choose your tracking and reporting preferences**

In the **Properties** section of the Publish window, click the **Tracking** field to open the following window, where you can choose your options for the way your LMS tracks and reports on your learners' progress:

![Reporting and Tracking Options](image)

1. Click the **Reporting** tab on the left edge of the window, and use the **LMS** selector to choose the standard to which you'd like to publish (ask your LMS administrator if you're not sure).

![LMS Selector](image)

2. Complete the fields in the section called **LMS Course Information** and the section called **LMS Lesson SCORM Information** if it appears. (Again, ask your LMS administrator if you need help). Some important notes about the fields on this window:

   • If you've chosen Tin Can API as your reporting specification, you'll see a field called **Launch URL**. Use this to enter the full URL of the .story.html file for your course if you plan to host the content on a server that's separate from your LMS. Typically you'd host your content on a server separate from your LMS if your LMS supports the Tin Can API but hasn't yet allowed private content authorization for mobile apps. Find out more [here](#) and [here](#).
• The Identifier field is a unique string of characters assigned by Storyline, and your LMS uses it to identify your content. If you're republishing a course that's already in your LMS and you plan to re-upload to your LMS, be sure *not* to change the value in this field.

3. If the window includes a section called LMS Reporting, use the selector to choose the wording you'd like to use when expressing learners' status with regard to this course.

4. Now click the Tracking tab on the left edge of the window and choose one of the following options:

   - **Track using number of slides viewed:** With this option, your LMS will determine whether a learner has passed or completed your course by monitoring the number of slides the learner has viewed. Use the selector to choose a number.
   - **Track using quiz result:** This option appears if your course includes a quiz result slide. Select this if you want your LMS to track learners' status based on their quiz results. If your course has multiple quizzes, you'll need to pick just one result slide to use for tracking. For more about result slides, see this tutorial. *(Note: If you are using the Tin Can API, the quiz you select here is used to report the overall course score, but individual quiz questions and other quiz result slides will also be reported.)*

5. Click OK when you're finished setting up your tracking and reporting preferences.
Step 6: Publish!

When you're finished choosing your options on the Publish window, just click the Publish button.

Storyline creates your published output in the location you specified. When publishing is complete, you'll see the following pop-up, and you can choose whichever option suits you:

- **View Project:** This launches your course in your web browser so you can take a look at your output. **If you want to test your published course, though, it's best not to do it this way.** Since your published output was created specifically for use with an LMS, you should instead upload your course to your LMS and test it from there, to make sure it behaves as expected in the environment where you plan to use it.
- **Email:** This opens up a new email message with a zipped file of your published output attached. This might be helpful if your LMS administrator will upload your course for you, and you need to send him or her the published output for upload.
- **FTP:** This pops up a window where you can enter your FTP credentials and transfer your output to a website (which isn't something you'd typically do if you've published for LMS).
- **ZIP:** This creates a zipped file of your output in the location you specified on the Publish window. **For LMS users, this is the most common choice,** because then you can easily upload your entire zipped course to your LMS.
- **Open Folder:** This opens a file viewer where you can see the files Storyline just created. There will be several folders and files which are needed to play your course. **If your LMS requires that you identify a single launch file once you've uploaded your content, the file to point to is index_lms.html.**

What do I do with my files once I've published?

Now that you've published, it's time to upload your content to your learning management system. The steps for this are slightly different for each LMS. Ask your LMS administrator if you need help with the specifics of uploading, launching, or tracking your course.
**If you chose to publish for HTML5 and/or the Articulate Mobile Player**

When learners launch your course, they'll automatically see the right type of content based on the device and browser they're using:

- They'll see the Flash content if their browser supports it.
- If they're using an iPad, and if you chose the Articulate Mobile Player option when you published, they'll see a launch page that allows them to view the course in the Articulate Mobile Player. (And if they don't have the player installed on their iPad yet, they'll see an option to install it.)
- If they're using an iPad and you *didn't* choose the mobile player option when you published, but you *did* choose HTML5, they'll see the HTML5 output.
- If they're using some *other* non-Flash compatible browser and you chose to publish for HTML5, they'll see the HTML5 output.
Publishing a Project for CD or Another Local Source

Storyline includes an easy way to publish your e-learning content for local use—such as if you need to deploy your course from a CD, DVD, or standalone computer. Here's how to do it:

**Step 1: Enter Title, Description, and Folder Location**

1. On the **Home** tab of the Storyline ribbon, click the **Publish** button. (Or, from any other tab on the ribbon, you can click the small triangle under the **Preview** button, and then choose **Publish**.)

2. When the Publish window appears, select **CD**.
3. Check the text that appears in the **Title** field, and customize it if you like. This text defaults to the name of your Storyline file. If you change it, it'll change the title text that Storyline uses in the following places (but it won't change your actual file name):

- The folder that Storyline creates to contain your published output. For example, if the **Title** field contains the words *MSDS Course*, Storyline creates a new folder on your hard drive called **MSDS Course Output** when you publish.
- The browser title bar, when learners view your published course in a browser window.
- The top bar of your course player, if you've opted to include the title as one of the **player features**.

4. The ellipsis button (…) next to the **Title** field allows you to open an additional window where you can enter some optional project information if you like. However, this information is really only used if you later republish your course for Web and some or all of your learners view the course on an iPad with the Articulate Mobile Player. If that's not your situation, you don't need to worry about entering anything in these fields. For more details on how the additional project info is used, see the tutorial on **Publishing a Project for Web**.

5. The **Description** field, you can enter some descriptive text about your course if you like. (When you publish for CD or other local source, any text you enter here won't be visible to your learners, but it'll be saved as part of your project and you'll be able to see and edit it here if you return to the Publish window later. The description is visible to learners if you republish for a different destination, such as Web, Articulate Online, or LMS.

6. In the **Folder** field, indicate the place on your computer where you want Storyline to create your published output. You can click the ellipsis button (…) to browse to a specific location. Storyline will create a new folder in that spot, with all the files needed to play your course.

- **Important!** Always publish to a local drive on your computer. Publishing to a network drive or a USB drive can create problems with your published output. After you publish your course to a local folder, you can burn it to a CD or DVD, or move it to some other local destination.
Step 2: Check player properties and quality settings

The Properties section of the Publish window allows you to make any last-minute changes to your course player, or to change the compression settings Storyline uses when publishing.

1. The Player field shows the name of the player that Storyline will use when you publish. (The player is the interface that users see when they view your course, and it can include things like player controls, resources, a glossary, a menu, and other features.) Click the player name if you’d like to make some final adjustments to your player or switch to a different player. If you need help choosing your player settings, see the tutorials on Customizing the Storyline Player.

2. The Quality field allows you to control the compression settings Storyline uses for any audio, video, and pictures you’ve added to your course. The settings here default to whatever you used the last time you published a Storyline project. To change the quality settings, click the blue text and change any of the fields as noted below; then click OK.

- Choose Standard if you want to use the default settings. If you mark this option, the values on the window revert back to their defaults (video quality of 5, audio bitrate of 48kbps, and image quality of 80%).
- Choose Custom if you want to define your own quality settings. Then click and drag the slider on any of the three values to change the compression. Using higher values means higher-quality output, but also larger file sizes (which means longer download times). Lower values mean smaller file sizes and faster download times, but the visual and audio quality will be lower as well.
Step 3: Publish!

When you're finished making changes to the options on the Publish window, just click the Publish button.

Storyline creates your published output in the location you specified. When publishing is complete, you'll see the following pop-up, and you can choose whichever option suits you:

- **View Project:** This launches your course in your web browser so you can take a look at your output.
- **Email:** This opens up a new email message with a zipped file of your published output attached. This might be helpful if you need to share your course with an SME or other reviewers, or if you need to send it to someone who will place it in the location from which it'll be deployed.
- **FTP:** This pops up a window where you can enter your FTP credentials and transfer your output to your website. This probably isn't something you'd need or want to do, though, since you've chosen to publish for CD, which optimizes your content for local deployment instead of online deployment.
- **ZIP:** This creates a zipped file of your output in the location you specified on the Publish window.
- **Open Folder:** This opens a file viewer where you can see the files Storyline just created. There will be several folders and files, and the file that launches your course is called Launch_Story.exe. There's also an autorun file, which causes your presentation to launch automatically if learners insert a CD or DVD containing your published output.

What do I do with my files once I've published?

Now that you've published, you can burn the files to a CD or DVD, or copy them to whatever local destination from which you plan to deploy your course.

- **Note:** If you burn your course to a DVD, it must be played in a computer DVD drive. It will not function in a DVD player on a TV.
Publishing a Project for Word

Storyline includes an option to publish your project to Microsoft Word. This can be a nice tool for situations when you want to provide learners with a printable copy of your content or if you want to give a copy of your content to a reviewer or a translator.

Here’s how to publish your project to Word:

**Step 1: Enter Title, Description, and Folder Location**

1. On the **Home** tab of the Storyline ribbon, click the **Publish** button. (Or, from any other tab on the ribbon, you can click the small triangle under the **Preview** button, and then choose **Publish**.)

2. When the Publish window appears, click the **Word** tab.
3. Check the text that appears in the **Title** field, and customize it if you like. This text defaults to the name of your Storyline file. If you change it, it will change the title text that Storyline places at the top of your Word document when you publish (but it won’t change your actual file name).

4. The ellipsis button (…) next to the **Title** field allows you to open an additional window where you can enter some optional project information if you like. However, this information is really only used if you later republish your course and some or all of your learners view it on an iPad with the Articulate Mobile Player. If that’s not your situation, you don’t need to worry about entering anything in these fields. For more details on how the additional project info is used, see the tutorial on [Publishing a Project for Web](#).

5. The **Description** field, you can enter some descriptive text about your course if you like. This text won’t appear in your Word document, but it’s used in your published output if you later republish for a different format ([Web](#), [Articulate Online](#), [LMS](#), or [CD](#)).

6. In the **Folder** field, indicate the place on your computer where you want Storyline to create your published output. You can click the ellipsis button (…) to browse to a specific location. When you publish, Storyline will create a new folder in that spot, and it will contain your Word document.

**Step 2: Choose the document properties**

The **Properties** section of the Publish window is where you can choose some formatting options for your Word document:

1. **Show Layers**: When you publish to Word, your Word doc will include a screenshot of each slide’s base layer. If you want your document to also include a screenshot of the other layers associated with each slide, mark this box. When you publish, the layer screenshots will appear right after the associated base layer.

2. **Show slide notes**: If you’ve entered text in the **slide notes** pane for any slides, you can include the notes in your Word document by marking this box. When you publish, the notes text will appear right below the screenshot of each slide’s base layer.
3. **Screen shot size**: Choose **Medium** or **Large** to specify how big you want your slides' screenshots to appear in your document. Below is a look at the relative difference in size. This shows the same slide published to a Word doc as a medium screenshot and as a large screenshot:
**Step 3: Publish!**

When you're finished setting your options on the Publish window, just click the **Publish** button. Storyline creates your Word document in the folder you specified. When you see the following pop-up, you can choose whichever option suits you:

- **View Document**: This opens your Word document in Microsoft Word so that you can take a look and make any edits you like.
- **Email**: This opens up a new email message with a zipped copy of your Word document attached. This might be helpful if you need to share your content with an SME or other reviewer, or if your course contains quiz or survey questions that you want to send to a learner who prefers to complete them with pen and paper.
- **FTP**: This pops up a window where you can enter your FTP credentials and transfer your output to your website.
- **ZIP**: This creates a zipped file of your output in the location you specified on the Publish window.
- **Open Folder**: This opens a file viewer where you can see the file Storyline just created, so that you can move, rename, or copy it.
Publishing a Project for iPad or HTML5

Storyline makes it easy to deploy your content to learners who use iPads and mobile devices that don’t support Flash.

**Publishing courses for mobile devices and iPad**

If you choose **Web, Articulate Online**, or **LMS** when publishing your Storyline content, you’ll see several options on the Publish window. You can choose **Include HTML5 output** to let learners view content on mobile devices that don’t support Flash. You can also choose **Use Articulate Mobile Player on iPad** to let learners view content on iPad using Articulate Mobile Player, a free app that gives learners the richest viewing experience on an iPad. Anyone can [download it for free from the iTunes App Store](https://apps.apple.com/app/ articulate-mobile-player/id565211475).

Below we answer some common questions course developers ask about publishing for iPad and mobile devices (HTML5). If you’re not sure which option you should choose (HTML5 or Articulate Mobile Player) or need other step-by-step guidance on publishing, read our tutorials on publishing for **Web, Articulate Online**, or **LMS**.

**If I publish for iPad or HTML5, will my course look and behave like it does when I publish Flash output?**

While many of the features in your course will look and behave exactly the same, some may not. Before you design for mobile, [review this article](https://www.articulate.com/online-help/learners-can-view-your-course-on-mobile-devices/) to find out how mobile deployment may impact your course.

**Once I publish for iPad or HTML5, how do learners view my course?**

After you publish from Storyline and upload your content to a web server, you just give learners a link to the *story.html* file. They’ll see the right format for the browser or device they’re using. [See this article for details on how this happens](https://www.articulate.com/online-help/learners-can-view-your-course-on-mobile-devices/).
**Do learners need to be connected to the internet to view my course on an iPad?**

Initially, learners must be connected to the internet to view your course on an iPad. However, you can allow learners to download your course for offline viewing once they’ve added it to their library. [Here’s an article that explains how to set this option when you publish.](#)

If you need tracking and reporting capabilities, your learners will need to be connected to the internet at the time they view your course—otherwise, your course won’t be able to communicate data to your LMS or to Articulate Online, whichever you’re using. (For more details, see “How can I track and report on learner progress if I publish for iPad or HTML5,” below.)

**How do learners remove a course from their Articulate Mobile Player library?**

Swipe the course title to the right or left, just like in the Mail App. A delete button appears to the right of the course title, and learners can tap the button to remove the course.

**How can I publish content so that it will work on an iPhone?**

Include HTML5 output when publishing so that learners can use mobile Safari on their iPhones to view content. For more information, [see this article.](#)

**What publishing option should I choose if my learners use Android devices?**

When you direct learners to the `story.html` file in your published course, they’ll automatically view the best output for their device and browser. Most Android devices support Flash, so learners will have the best experience by viewing the Flash version of your course. If they’re using a browser that doesn’t support Flash and if you included HTML5 output when you published, they’ll see the HTML5 version instead. [See this article for details on how this works.](#)

**How can I track and report on mobile learners' progress?**

To track your learners who view your iPad or HTML5 content, you’ll need to do any one of the following:

- **Deploy your course from Articulate Online:** Articulate Online fully supports tracking users who view your course with the Articulate Mobile Player on an iPad. When you publish, choose Articulate Online as your publish option, and mark the checkbox to “Use Articulate Mobile Player on iPad.” [Find out more about publishing to Articulate Online here.](#)

- **Deploy your course from an LMS which supports the Tin Can API:** Tin Can is a communication specification which allows learning management systems to receive tracking data from mobile apps. When you publish, choose LMS as your publish option, and mark the checkbox to “Use Articulate Mobile Player on iPad.” (If your LMS provider doesn’t yet support Tin Can API, we recommend that you urge them to do so.) [Find out more about publishing for LMS here.](#)

- **Deploy your course as HTML5 content, and have learners access it from your LMS with a browser that supports HTML5:** This is a good option if you’re using an LMS which does not support Tin Can API and if learners will use an iPad or other device which doesn’t support Flash. When you publish, choose LMS as your publish option, and mark the checkbox to “Include HTML5 output.” [Find out more about publishing for LMS here.](#)

For more information, see:

- [Viewing and tracking Storyline content in an LMS](#)
- [Viewing and tracking Storyline content in Articulate Online](#)
I don't need to support tracking. Can I still use the Articulate Mobile Player in my LMS even if it doesn't support Tin Can API?

It depends. If your LMS doesn't require a login, your learners might be able to use the Articulate Mobile Player. If your LMS requires a login, learners might not be able to use the Articulate Mobile Player, because browsers cannot pass security credentials to iPad apps unless the LMS supports Tin Can API. You'll need to test your published output in your particular LMS environment if you plan to allow viewing in Articulate Mobile Player.
Helpful Storyline Tools and Options

Besides super-easy course authoring, Storyline provides several tools and options to enhance your productivity and make your work easier. Check out the following tutorials for how to take advantage of these features:

- Setting the Zoom
- Spelling Preferences, Proxy Settings, and Other Options
- Using the Find/Replace Feature
- Keyboard Shortcuts
- Translating Storyline Content
Setting the Zoom

The **Zoom** features in Storyline make it easy to get a big-picture or close-up view of your course content while you're building or editing your course. This tutorial shows several ways to change the zoom.

**Tip:** Because of the way text is rendered when you're editing your slides, if you work at a zoom percentage other than 100%, it's possible that the text spacing or wrapping might end up looking slightly different when you publish. If you find that happening, change your zoom back to 100%, adjust your slide content to look the way you want, and then republish.

Here are some ways to adjust the zoom in Storyline:

- **Ctrl-mouse wheel:** This is probably the easiest and quickest way to zoom in and out. Hold down your Ctrl key and scroll your mouse wheel. Scroll forward to zoom in, or backward to zoom out.
- **Zoom slider:** In the lower-right corner of your screen, you'll see a zoom slider. Drag to the right to zoom in, or to the left to zoom out.

- **Zoom percentage:** Next to the zoom slider in the lower-right corner of your screen, you'll see a zoom percentage. You can click the percentage to bring up the zoom window, where you can change the zoom to whatever you like. You can also access this window by clicking the **View** tab and choosing the **Zoom** button.
- **Fit to window:** To the right of the zoom slider in the lower-right corner of your screen, you'll see a small rectangular button with arrows. Click that to make everything fit in the viewable area of your Storyline window.

  ![Click the rectangular icon to fit your content within the window's current size](image)

  Or, click the **View** tab and select **Fit to Window**.
Spelling Preferences, Proxy Settings, and Other Options

Storyline allows you to choose your preferences related to spelling and several system options. In this tutorial, we'll take a look at how to access and change these options.

Opening the Storyline Options window

First, you'll need to open the Options window by doing this:

1. Click the Articulate button in the upper-left corner of the Storyline window.
2. Click Storyline Options.

The Storyline Options window appears, where you can set or change the following options.
General Options

Use the top section of the window to indicate your preferences for general Storyline options:

- **Check for updates at startup**: If you leave this box checked and if you're connected to the internet when you launch Storyline, the program will automatically check to see if updates are available.

- **Enable publishing for manual upload to Articulate Online**: If you use Articulate Online, normally you'll publish and upload your content all at the same time. But if you'd like the option of publishing locally first, and then manually uploading your content, you can mark this box. For more details on manually uploading content to Articulate Online, check out [this online tutorial](#).

- **Reset "Don't show again prompts"**: For some actions, such as when you delete a slide or scene, Storyline displays a confirmation prompt along with a checkbox that says "Don't show again" or "Don't ask again." If you mark that checkbox, Storyline will no longer display the confirmation prompt when you perform that action. To reset your preferences so that Storyline once again displays all confirmations, click Reset "Don't show again prompts."
**Spelling Options**

On the Storyline Options window, click **Spelling Options** to set your preferences for the Storyline spell checker and dictionary. Keep in mind that preferences you set here will also affect Articulate Quizmaker and Articulate Engage, if you have those products installed. (If you have Articulate Presenter installed, the spelling options here will not affect it, since Presenter uses the spelling options from within Microsoft Office).

- **Hide spelling errors**: Hides the wavy red lines that normally appear under misspelled words while you're editing your slides. (But if you run a spell-check, the misspelled words will still be caught.) If you choose to leave the wavy red lines visible, you can right-click on any misspelled word for a list of suggested spellings.
- **Ignore words in UPPERCASE**: Words with all capital letters won't get spell-checked.
- **Ignore words with numbers**: Words that contain numbers won't get spell-checked.
- **Ignore Internet and file addresses**: Website URLs, file names and paths, and syntax like mailto:biz@articulate.com won't get spell-checked.
- **Ignore capitalized words**: Words with initial capital letters won't get spell-checked.
- **Ignore words with mixed case**: Words that contain both uppercase and lowercase letters won't get spell-checked.
- **Ignore HTML markups**: Words with HTML tags—such as `<Strong></Strong>`—won't get spell-checked.
- **Allow accented words**: Words with accented letters won't get spell-checked.
- **Report doubled words**: Instances of two words appearing one after the other will get flagged during spell-check.
- **Suggest split words**: If a misspelled word appears to be two separate words, Storyline might suggest an appropriate correction during spell-check.
- **Phonetic suggestions**: During spell-check, if a misspelled word resembles the phonetic spelling of an actual word, Storyline will provide suggested corrections.
• **Typographical suggestions:** During spell-check, Storyline will provide suggested corrections that are typographically similar to the misspelled word. (For example, if you type "potatoe" the words "potatoes" or "potato" will be suggested.)

• **Case sensitive:** Enables Storyline to distinguish words based on the case patterns of their letters.

• **Auto-correct:** Enables Storyline to dynamically correct misspellings as you type. If you mark this box, you can also click the auto-correct **Options** button to customize the auto-correct dictionary. See the "Auto-Correct Options" section of this tutorial for more details.

If you change your mind about any of the options you've marked or unmarked on this window, you can switch back to the default settings by clicking **Restore Defaults**.
**Dictionary Options**

From the **Spelling Options** window shown above, you can use the **Dictionary** settings to switch Storyline's spell checker to a different language, or to manage your custom spell-check dictionaries.

Use the **Main Dictionary language** selector to choose the dictionary you want to use for spell checking. Click **Custom Dictionaries** to add, modify, or remove a custom dictionary. A custom dictionary is a way to supplement your main dictionary with additional words that you don't need Storyline to flag during spell-checking, such as names, industry-specific or technical words, or alternative spellings.
Managing custom dictionaries

If you click **Custom Dictionaries** on the **Spelling Options** window, the window below appears, where you can do the following:

- **Modify a dictionary**: Select a dictionary and click **Modify**. A window appears where you can add or remove words from your custom dictionary. To add a word, type it in the **Word** field and click **Add**. To remove a word, select it from the list and click **Delete**. Click **OK** when you’re done making changes.

- **Change the default dictionary**: To use a different custom dictionary by default, choose a dictionary from the list on the **Custom Dictionaries** window and click **Change Default**.
• **Create a new dictionary:** Click New. Type a name for your new dictionary in the File name field. Click Save. The new dictionary will now be in your dictionary list, and you can add words to it as needed.

• **Add a dictionary that already exists on your computer:** This option is for cases when you’ve obtained a .dic file from someone else and you have the file on your computer but it doesn’t appear in the Dictionary list. Click Add, navigate to the .dic file you’d like to use, and select it. Click Open. The dictionary will now be in your dictionary list, and you can modify it as needed.

• **Remove a dictionary:** Select a dictionary you want to remove. Click Remove. This doesn’t remove the .dic file from your hard drive, but it does remove it from your dictionary list in Storyline and other Articulate programs.

### Auto-Correct Options

The auto-correct options allow you to set your preferences for the way Storyline automatically corrects common misspellings. You can reach these options either by clicking the Options button on the Spelling Options window shown earlier in this tutorial, or by clicking **Auto-Correct Options** on the Storyline Options window, as shown below.

When the **AutoCorrect** window appears, you can turn the auto-correct feature on or off by marking or unmarking the **Replace text as you type** box.
If auto-correct is on, then any time you’re editing text on a Storyline slide and you type a word that’s listed in the left-hand column, Storyline will replace it with the corresponding text from the right-hand column. Here’s how you can customize the auto-correct behavior:

- **To change the text Storyline uses for the correction**: Select a word in the left-hand column. In the **With** field, type the text you want Storyline to replace it with. Then click **Replace**.

- **To remove a word from the auto-correct list**: Select the word you want to remove and click **Delete**.

- **To add a word to the auto-correct list**: In the **Replace** field, type the word you want to add. In the **With** field, type the word you want it replaced with. Then click **Add**.
Click OK when you’re done managing your auto-correct list.

**Proxy Settings**

On the Storyline Options window, there’s also a section for Proxy Settings. These options are for Articulate Online users who may need to use a proxy server in order to publish their course to an Articulate Online account.

In most cases, leaving the default option selected (Use Internet Explorer proxy settings) will work just fine, but if your organization uses a proxy server, you can select Use proxy server and enter the Address and Port. Check with your IT department if you’re unsure about whether you need to do this or if you don’t know the address and port information.
Using the Find/Replace Feature

Storyline's find/replace feature allows you to quickly search your project for specific text, such as a word, phrase, or other string of characters. You can also use this feature to replace text—for example, if you've used a certain word throughout your course and now need to change that word to something else.

**How to search for specific text**

1. On your keyboard, press **Ctrl+F**. (Or, when you're in Normal View, click the Find Text button on the Home tab.)
2. The Find window appears.

![Find window](image)

3. In the Find what field, enter the text you want to search for. Or, use the arrow on the right edge of this field to select from search strings you've used previously.
4. To search for text that contains the same combination of upper- and lower-case characters as the text in the Find what field, mark the Match case checkbox. Otherwise, Storyline will find all occurrences of the text, regardless of case.
5. To search only for complete words, mark the Find whole words only checkbox. For example, a search for "art" will find only occurrences of the word "art," not other words that contain the same characters, such as "articulate" or "artistic." (This option won't be available if you've entered more than one word in the Find what field.)
6. Click Find Next.
7. Storyline takes you to the first occurrence it finds. You can now click Close to close the window, or, if you want to find additional occurrences, you can keep clicking Find Next until you see a message indicating that Storyline has finished searching your project.

![Message](image)
How to search for and replace specific text

1. On your keyboard, press Ctrl+F. (Or, when you're in Normal View, click the Find Text button on the Home tab.)
2. When the Find window appears, click Replace.

3. In the Find what field, enter the text you want to replace.
4. In the Replace with field, enter the new text you want to use instead.
5. To search for text that contains the same combination of upper- and lower-case characters as the text in the Find what field, mark the Match case checkbox. Otherwise, Storyline will find all occurrences of the text regardless of case.
6. To search only for complete words, mark the Find whole words only checkbox. For example, a search for "art" will find only occurrences of the word "art," not other words that contain the same characters, such as "articulate" or "artistic." (This option won't be available if you've entered more than one word in the Find what field.)
7. Click Find Next.
8. Storyline takes you to the first occurrence it finds. Now you can do any of the following:
   - Click Find Next to leave the text as is, without replacing it.
   - Click Close if you're finished and you want to close the window.
   - Click Replace to replace only the occurrence that Storyline has found. Storyline will make the change and immediately take you to the next occurrence
   - Click Replace All to automatically replace all occurrences of your search text with the replacement text you've entered.

If you search your whole project until Storyline finds no more occurrences of your search text, you'll see a message saying so. If you chose to Replace All occurrences, the message will also indicate how many replacements Storyline made:
### Keyboard Shortcuts

Here's a list of keyboard shortcuts to help you become even more productive when working in Storyline:

<table>
<thead>
<tr>
<th>KEY(S)</th>
<th>FUNCTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help</td>
</tr>
<tr>
<td>F2</td>
<td>Selects all text within a shape after its bounding box has been clicked</td>
</tr>
<tr>
<td>F3</td>
<td>Normal view</td>
</tr>
<tr>
<td>F4</td>
<td>Slide master</td>
</tr>
<tr>
<td>F5</td>
<td>Feedback master</td>
</tr>
<tr>
<td>F7</td>
<td>Spell check</td>
</tr>
<tr>
<td>F10</td>
<td>Publish</td>
</tr>
<tr>
<td>F12</td>
<td>Preview entire project</td>
</tr>
<tr>
<td>Shift+F9</td>
<td>Show / Hide Gridlines</td>
</tr>
<tr>
<td>Shift+F12</td>
<td>Preview current scene</td>
</tr>
<tr>
<td>Shift+drag</td>
<td>If moving an object, movement is constrained to straight lines. If resizing an object, size maintains aspect ratio.</td>
</tr>
<tr>
<td>Alt+drag</td>
<td>Move or resize an object with tighter control in 1 pixel increments</td>
</tr>
<tr>
<td>Ctrl+drag</td>
<td>If moving an object, a copy of the object will be created in the new location. If resizing an object, it will be proportionally resized from opposite directions simultaneously.</td>
</tr>
<tr>
<td>Ctrl+A</td>
<td>Select all [Click here for details on how Ctrl+A works in Storyline.]</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Bold</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>Duplicate object</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Center align text</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Find</td>
</tr>
<tr>
<td>KEY(S)</td>
<td>FUNCTION</td>
</tr>
<tr>
<td>----------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Group objects</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Italicize</td>
</tr>
<tr>
<td>Ctrl+J</td>
<td>Insert picture</td>
</tr>
<tr>
<td>Ctrl+K</td>
<td>Add trigger to selected object</td>
</tr>
<tr>
<td>Ctrl+L</td>
<td>Left align text</td>
</tr>
<tr>
<td>Ctrl+M</td>
<td>Insert slide</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>New project</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Open project</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Right align text</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save project</td>
</tr>
<tr>
<td>Ctrl+T</td>
<td>Insert text box</td>
</tr>
<tr>
<td>Ctrl+U</td>
<td>Underline</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>Close tab</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl+Enter</td>
<td>Opens Format Shape dialog</td>
</tr>
<tr>
<td>Ctrl+F12</td>
<td>Previews current slide</td>
</tr>
<tr>
<td>Ctrl+Mouse Wheel</td>
<td>Zoom in / out</td>
</tr>
<tr>
<td>Ctrl+Arrow</td>
<td>Moves selected object 1 pixel in the direction of the arrow</td>
</tr>
<tr>
<td>Ctrl+Shift+Arrow</td>
<td>Resizes the selected object by 1 pixel (up/down arrows increase/decrease the object height; right/left arrows increase/decrease the object width)</td>
</tr>
<tr>
<td>KEY(S)</td>
<td>FUNCTION</td>
</tr>
<tr>
<td>----------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ctrl+Shift+G</td>
<td>Ungroup objects</td>
</tr>
<tr>
<td>Ctrl+Shift+Enter</td>
<td>Opens Size and Position dialog</td>
</tr>
<tr>
<td>C</td>
<td>Adds a cue point if you press the key while playing the slide from the timeline</td>
</tr>
<tr>
<td>Spacebar</td>
<td>Pauses/plays the timeline once you click the play button on the timeline</td>
</tr>
</tbody>
</table>

**Creating your own keyboard shortcuts**

You can also create your own keyboard shortcuts by adding features that you use frequently to the Quick Access Toolbar. To do so, right-click the button for any Storyline feature, and select **Add to Quick Access Toolbar**.

Then, to launch any of the buttons on the Quick Access Toolbar via a keyboard shortcut, press and hold the **ALT** key on your keyboard and then press the number key that matches the button you want to launch. For example, the first button on the Quick Access Toolbar is "1", the second button is "2", etc.
Translating Storyline Content

Do you need to deploy a course in multiple languages? Storyline's translation feature can help with that. Here's how:

**Export the original text**

First, export a copy of the text from your Storyline project:

1. Click the round Articulate button in the upper left corner, scroll to Translation, and select Export.
2. Browse to the location where you'd like to save the exported text.
3. Assign a File name to your exported document.
4. Use the Save as type drop-down list to select one of the following formats for your exported document:
   - **Word Document (*.doc)**: If you'll be translating the text manually, this is probably your best option.
   - **Word Document with Reference Column (*.doc)**: This is the same document as above with an additional column, so you can always see the text in its original language for reference purposes.
   - **XML Localization Interchange File Format (*.xliff)**: If you'll be using a translation service or computer program, you may find that this file format is more useful.
5. Click the Save button.

**Translate the exported text**

After exporting the text from your Storyline project, use the resulting Word document or XML file to translate it into other languages. You can translate it manually, line-by-line, or you might use a translation service or computer...
program. If you’ll be translating the text manually, you’ll probably want to use a Word document format. Here are some important things to remember:

- Only modify text in the column called “Translate this column.” Leave all other text unchanged.
- If you change the text formatting in any way (font, size, color, style, alignment, etc), those changes will also be reflected in your project when you import the file back into Storyline.

If you’ll be using a translation service or computer program, you may find that the XML (*.xliff) file is more useful.

**Import the translated text**

When the translation is complete, import the Word document or XML file back into your Storyline course:

1. Create a copy of your original Storyline project file to hold the new language.
2. Open the new project file in Storyline.
3. Click the round Articulate button in the upper left corner, scroll to Translation, and select Import.
4. Browse to the Word document or XML file that contains the translated text, select it, and click the Open button.
5. When you see the Congratulations message, click OK.

**Localize the Storyline player**

While Storyline’s translation feature allows you to modify the slide content, you may also want to customize the player text labels. Text labels allow you to localize buttons, tabs, messages, and other player elements for different languages.